<!doctype html><html class="no-js" lang="en-us"><head><meta charset="utf-8">
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">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</script><title>Fdisk Command in Linux (Create Disk Partitions) | Linuxize</title><meta content="IE=edge" http-equiv="X-UA-Compatible"><meta content="width=device-width,initial-scale=1,shrink-to-fit=no" name="viewport"><meta content="Linuxize" name="apple-mobile-web-app-title"><meta content="Linuxize" name="application-name"><meta content="#2271ff" name="theme-color"><meta content="#2271ff" name="msapplication-TileColor"><meta content="fdisk is a menu driven command-line utility that allows you to create and manipulate partition tables on a hard disk." name="description"><meta content="unsafe-url" name="referrer"><link href="https://linuxize.com/post/fdisk-command-in-linux/" rel="canonical"><meta content="index, follow" name="robots"><meta content="Fdisk Command in Linux (Create Disk Partitions)" property="og:title"><meta content="fdisk is a menu driven command-line utility that allows you to create and manipulate partition tables on a hard disk." property="og:description"><meta content="article" property="og:type"><meta content="/post/fdisk-command-in-linux/" property="og:url"><meta content="https://linuxize.com/post/fdisk-command-in-linux/featured.jpg" property="og:image"><meta content="http://" property="og:image:secure"><meta content="fdisk is a menu driven command-line utility that allows you to create and manipulate partition tables on a hard disk." property="og:image:alt"><meta content="2020-05-19T20:51:34+01:00" property="article:published_time"><meta content="2020-05-19T20:51:34+01:00" property="article:modified_time"><meta content="en" property="og:locale"><meta content="post" property="article:section"><meta content="https://www.facebook.com/linuxize" property="article:publisher"><meta content="fdisk" property="article:tag"><meta content="terminal" property="article:tag"><meta content="fdisk,terminal" name="news_keywords"><meta content="summary_large_image" name="twitter:card"><meta content="https://linuxize.com/post/fdisk-command-in-linux/featured.jpg" name="twitter:image"><meta content="Fdisk Command in Linux (Create Disk Partitions)" name="twitter:title"><meta content="fdisk is a menu driven command-line utility that allows you to create and manipulate partition tables on a hard disk." name="twitter:description"><meta content="@linuxize" name="twitter:site"><link href="/favicons/apple-touch-icon.png" rel="apple-touch-icon" sizes="180x180"><link href="/favicons/favicon-32x32.png" rel="icon" sizes="32x32" type="image/png"><link href="/favicons/favicon-16x16.png" rel="icon" sizes="16x16" type="image/png"><link href="/favicons/safari-pinned-tab.svg" rel="mask-icon" color="#2271ff"><link href="//fonts.gstatic.com" rel="preconnect" crossorigin=""><link href="//fonts.googleapis.com" rel="preconnect" crossorigin=""><link href="//www.googletagmanager.com" rel="preconnect" crossorigin=""><link href="//www.google-analytics.com" rel="preconnect" crossorigin=""><link href="//pagead2.googlesyndication.com" rel="preconnect" crossorigin=""><link href="https://fonts.googleapis.com/css?family=Hind:400,500,600,700|Roboto+Mono:400,400i,700,700i|Roboto:400,400i,500,700,700i&display=swap" rel="stylesheet"><script type="application/ld+json">{
  "@context": "http://schema.org",
  "@type": "BlogPosting",
  "headline": "Fdisk Command in Linux (Create Disk Partitions)",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https:\/\/linuxize.com\/post\/fdisk-command-in-linux\/"
  },"image": {
     "@type": "ImageObject",
     "url": "https:\/\/linuxize.com\/post\/fdisk-command-in-linux\/featured.jpg",
     "width":  1000 ,
     "height":  530 
    },"keywords": "fdisk, terminal",
  "wordcount":  1307 ,
  "url": "https:\/\/linuxize.com\/post\/fdisk-command-in-linux\/",
  "datePublished": "2020-05-19T20:51:34+01:00",
  "dateModified": "2020-05-19T20:51:34+01:00",
  "publisher": {
    "@type": "Organization","logo": {
    "@type": "imageObject",
      "url": "https:\/\/linuxize.com\/assets\/linuxize-card.png"
    },"name": "Linuxize"
  },

  "author": {
    "@type": "Person",
    "name": "Linuxize"
  },
  "description": "fdisk is a menu driven command-line utility that allows you to create and manipulate partition tables on a hard disk."
}</script><script src="/js/dfp.js" async></script><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-P827G6S');</script><script src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js" async data-ad-client="ca-pub-9439755881064125"></script><link href="/css/app.105da3570413f4af7e0e.css" rel="stylesheet"><meta content="#2271ff" name="theme-color"><link href="/manifest.128dc4ca8d47b9db75ffbc72b588021a.json" rel="manifest">
<script data-ezscrex="false" data-cfasync="false" type="text/javascript">window.google_analytics_uacct = "UA-124335151-13";</script>
<script data-ezscrex="false" data-cfasync="false" type="text/javascript">
var _gaq = _gaq || [];
_gaq.push(['e._setAccount', 'UA-124335151-13']);
_gaq.push(['f._setAccount', 'UA-38339005-1']);
_gaq.push(['e._setDomainName', 'linuxize.com']);
_gaq.push(['f._setDomainName', 'linuxize.com']);
_gaq.push(['e._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['e._setCustomVar',2,'t','126',3]);
_gaq.push(['e._setCustomVar',3,'rid','0',2]);
_gaq.push(['e._setCustomVar',4,'bra','mod44',3]);
_gaq.push(['e._setAllowAnchor',true]);
_gaq.push(['e._setSiteSpeedSampleRate', 10]);
_gaq.push(['f._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['f._setCustomVar',2,'domain','linuxize.com',3]);
_gaq.push(['f._setSiteSpeedSampleRate', 20]);
_gaq.push(['e._trackPageview']);
_gaq.push(['f._trackPageview']);


(function() {
 var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
 ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
 var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
})();
</script>
<script type="text/javascript">var ezouid = "1";</script><base href="https://linuxize.com/post/fdisk-command-in-linux/"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 93605;
var ezdomain = 'linuxize.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":93605,"engaged_time_visit":0,"ezcache_level":1,"forensiq_score":-1,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"8954455f-79c4-46b9-6949-32f7191a8223","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_time_orig":8,"serverid":"184.72.116.137:18109","state":"VA","t_epoch":1590030299,"template_id":126,"time_on_site_visit":0,"url":"https://linuxize.com/post/fdisk-command-in-linux/","user_id":0,"word_count":1501,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script><script data-ezscrex='false' data-cfasync='false' type="text/javascript" src="/detroitchicago/rochester.js?cb=188-0&v=8" async></script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl() {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_93605=" + new Date().getTime() + "|8954455f-79c4-46b9-6949-32f7191a8223|false; " + expires, 3);
}
function attach_ezolpl() {
    if(window.attachEvent) {
        window.attachEvent('onload', create_ezolpl);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl();
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl;
        }
    }
}
attach_ezolpl();
</script></head><body class="font-sans kind-page leading-normal section-post type-post"><div class="flex flex-col min-h-screen main-wrap"><header class="w-full dark:border-gray-900 border-b border-gray-400 fixed header linuxize-shadow px-6 z-50" id="header"><nav class="w-full mx-auto flex items-center h-12 justify-start md:h-16"><a href="/" class="flex items-center block dark:text-gray-200 flex-shrink-0 logo mr-6 no-underline text-black" aria-label="Linuxize.com"><svg aria-hidden="true" class="md:h-8 fill-current h-6 md:w-8 mr-2 w-6" role="img"><use xlink:href="/svg/sprite.svg#logo"></use></svg> <span class="font-medium hidden md:block text-md tracking-tight">Linuxize</span></a><div class="flex -mb-px flex-1 min-w-0 text-sm"><a href="/tags/ubuntu/" class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 hidden md:block mr-4 no-underline text-gray-800"><span class="inline-block font-bold md:py-4 md:py-6 py-3">Ubuntu </span></a><a href="/tags/centos/" class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 hidden md:block mr-4 no-underline text-gray-800"><span class="inline-block font-bold md:py-4 md:py-6 py-3">Centos </span></a><a href="/tags/debian/" class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 hidden md:block mr-4 no-underline text-gray-800"><span class="inline-block font-bold md:py-4 md:py-6 py-3">Debian </span></a><a href="/tags/terminal/" class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 hidden md:block mr-4 no-underline text-gray-800"><span class="inline-block font-bold md:py-4 md:py-6 py-3">Commands </span></a><a href="/series/" class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 hidden md:block mr-4 no-underline text-gray-800"><span class="inline-block font-bold md:py-4 md:py-6 py-3">Series </span></a><a href="https://www.buymeacoffee.com/8swZOSU6I" class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 hidden md:block mr-4 no-underline text-gray-800 mr-0"><span class="inline-block font-bold md:py-4 md:py-6 py-3">Donate</span></a></div><div class="flex justify-end"><button class="block h-6" id="btn-search" aria-label="Search"><svg aria-hidden="true" class="dark:text-gray-300 inline-block fill-current h-6 w-6 text-gray-900" role="img"><use xlink:href="/svg/sprite.svg#search"></use></svg></button> <button class="ml-2 mode-toggle" id="mode-toggle"><div class="mode-toggle-icons"><svg aria-hidden="true" class="dark:text-gray-300 inline-block fill-current h-6 w-6 text-gray-900" role="img"><use xlink:href="/svg/sprite.svg#moon"></use></svg> <svg aria-hidden="true" class="dark:text-gray-300 inline-block fill-current h-6 w-6 text-gray-900" role="img"><use xlink:href="/svg/sprite.svg#sun"></use></svg></div></button></div></nav></header><main class="w-full flex-grow flex-shrink-0 pb-8 pt-16 sm:pt-24 main"><article class="relative single-post"><div class="w-full mx-auto px-6 post-width"><div class="relative mb-4 post-header xl:mb-8 z-40"><h1 class="font-semibold leading-none lg:text-3xl mb-2 text-2xl xxl:text-4xl">Fdisk Command in Linux (Create Disk Partitions)</h1><div class="flex flex-col dark:text-gray-300 font-medium md:flex-row text-gray-700 text-xs"><div class="inline-flex flex-row"><p class="font-medium text-xs leading-normal rounded-sm"><span>Posted </span><time class="" datetime="2020-05-19T20:51:34+01:00">May 19, 2020</time></p><span class="inline-block mx-2">•</span><p>7 min read</p></div></div></div><div class="lg:flex"><div class="w-full lg:max-h-full lg:overflow-visible lg:static min-h-screen"><div class="flex"><div class="w-full pb-8"><div class="flex flex-col xl:flex-relative xl:flex-row"><aside class="w-full block hidden sidebar2 xxl:block" id="sidebar2"><script src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js" async></script><div class="w-full flex justify-center content-center"><div class="w-full relative"><ins class="block hidden adsbygoogle mx-autosidebar2-as xl:block" data-ad-client="ca-pub-9439755881064125" data-ad-format="horizontal,rectangle" data-ad-slot="4501323511" data-full-width-responsive="true"></ins></div></div><script>(adsbygoogle = window.adsbygoogle || []).push({});</script><div class="w-full flex justify-center content-center"><div class="w-full relative"><div id="bsa-block"></div></div></div><div class="w-full -mt-12 flex-col hidden justify-between pb-4 pt-12 sticky top-16 xl:flex"><div class="bg-gray-200 dark:bg-gray-900 mb-6 p-4 pb-2 overflow-auto table-of-contents toc"><p class="font-medium text-xs mb-3 mb-3 text-gray-800 tracking-tight uppercase xxl:text-sm dark:text-gray-200">Contents</p><div class="relative overflow-hidden"><div class="lg:max-h-toc overflow-y-auto scrollbar-thumb-gray scrollbar-thumb-rounded scrollbar-track-gray-lighter scrollbar-w-2 scrolling-touch"><nav id="TableOfContents"><ul><li><a href="#list-partitions">List Partitions</a></li><li><a href="#creating-partition-table">Creating Partition Table</a></li><li><a href="#activating-the-partitions">Activating the Partitions</a></li><li><a href="#conclusion">Conclusion</a></li></ul></nav></div></div><div class="flex border-gray-400 border-t dark:border-gray-900 items-center justify-content mb-3 mr-2 pt-4 tracking-tight"><p class="font-medium text-xs mr-4 uppercase xxl:text-sm">Share:</p><section class="w-full mx-auto"><nav class="flex flex-wrap"><a href="https://twitter.com/share?text=Fdisk%20Command%20in%20Linux%20%28Create%20Disk%20Partitions%29&url=https%3a%2f%2flinuxize.com%2fpost%2ffdisk-command-in-linux%2f" class="mr-3 h-6 w-6" rel="noopener" target="_blank"><svg aria-hidden="true" class="dark:text-gray-300 inline-block fill-current h-6 w-6 hover:text-blue-600 text-gray-600" role="img"><use xlink:href="/svg/sprite.svg#twitter"></use></svg> </a><a href="https://www.facebook.com/sharer/sharer.php?caption=Fdisk%20Command%20in%20Linux%20%28Create%20Disk%20Partitions%29&u=https%3a%2f%2flinuxize.com%2fpost%2ffdisk-command-in-linux%2f" class="mr-3 h-6 w-6" rel="noopener" target="_blank"><svg aria-hidden="true" class="dark:text-gray-300 inline-block fill-current h-6 w-6 hover:text-blue-600 text-gray-600" role="img"><use xlink:href="/svg/sprite.svg#facebook"></use></svg> </a><a href="https://pinterest.com/pin/create/button/?url=https%3a%2f%2flinuxize.com%2fpost%2ffdisk-command-in-linux%2f&media=https%3a%2f%2flinuxize.com%2fpost%2ffdisk-command-in-linux%2ffeatured.jpg&description=Fdisk%20Command%20in%20Linux%20%28Create%20Disk%20Partitions%29" class="mr-3 h-6 w-6" rel="noopener" target="_blank"><svg aria-hidden="true" class="dark:text-gray-300 inline-block fill-current h-6 w-6 hover:text-blue-600 text-gray-600" role="img"><use xlink:href="/svg/sprite.svg#pinterest"></use></svg> </a><a href="mailto:?subject=Fdisk%20Command%20in%20Linux%20%28Create%20Disk%20Partitions%29&body=Check%20out%20this%20article:%0A%0Ahttps%3a%2f%2flinuxize.com%2fpost%2ffdisk-command-in-linux%2f" class="h-6 w-6" rel="noopener" target="_blank"><svg aria-hidden="true" class="dark:text-gray-300 inline-block fill-current h-6 w-6 hover:text-blue-600 text-gray-600" role="img"><use xlink:href="/svg/sprite.svg#email"></use></svg></a></nav></section></div></div></div></aside><section class="w-full mx-auto lg:ml-0 lg:mr-auto lg:pr-6 min-w-0 xl:mx-0 xl:w-full xxl:px-6"><figure class="relative -mx-6 lg:mx-0 mb-6"><div class="w-full mx-auto my-0 block relative"><div class="block" style="padding-bottom:53%"></div><div class="w-full h-full absolute inset-0 m-auto overflow-hidden bg-gray-200"><img alt="" class="w-full h-full absolute inset-0 m-auto lazy lazyload" src="data:image/gif;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAYAAAAfFcSJAAAADUlEQVR42mP8+PXHfwAJnAPfCuZXlQAAAABJRU5ErkJggg==" data-sizes="auto" data-src="/post/fdisk-command-in-linux/featured_huc9db77d400abad9a3c9959c3a5afbcc1_20542_600x0_resize_q95_box.jpg" data-srcset="
              /post/fdisk-command-in-linux/featured_huc9db77d400abad9a3c9959c3a5afbcc1_20542_600x0_resize_q95_box.jpg 600w,
              /post/fdisk-command-in-linux/featured.jpg 1000w
            "><noscript><img alt="" class="w-full h-full absolute inset-0 m-auto" src="/post/fdisk-command-in-linux/featured.jpg"></noscript></div></div></figure><div class="markdown"><p>The first thing you need to do after installing a new SSD or hard disk is to partition it. A drive needs to have at least one partition before you can format it and store files on it.</p><p>In Linux, there are several tools that you can use to create partitions, with <code>fdisk</code> being the most commonly used one.</p><p>In this article, we will talk about the <code>fdisk</code> command.</p><p><code>fdisk</code> is a menu-driven command-line utility that allows you to create and manipulate partition tables on a hard disk.</p><p>Be aware that <code>fdisk</code> is a dangerous tool and should be used with extreme caution. Only root or users with <a href="https://linuxize.com/post/sudo-command-in-linux/"><code>sudo</code></a> privileges can manipulate the partition tables.</p><h2 id="list-partitions">List Partitions <a href="#list-partitions" class="headline-link" aria-hidden="true">#</a></h2><p>To list the partition table of a device, invoke the <code>fdisk</code> command with the <code>-l</code> option, followed by the device name. For example to list the <code>/dev/sda</code> partition table and partitions you would run:</p><pre class="terminal"><code class="terminal-line" prefix="$">fdisk -l /dev/sda</code></pre><p>When no device is given as an argument, <code>fdisk</code> will print partition tables of all devices listed in the <code>/proc/partitions</code> file:</p><pre class="terminal"><code class="terminal-line" prefix="$">fdisk -l</code></pre><pre><code class="language-output" data-lang="output">Disk /dev/nvme0n1: 232.91 GiB, 250059350016 bytes, 488397168 sectors
Disk model: Samsung SSD 960 EVO 250GB               
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 6907D1B3-B3AB-7E43-AD20-0707A656A1B5

Device            Start       End   Sectors   Size Type
/dev/nvme0n1p1     2048   1050623   1048576   512M EFI System
/dev/nvme0n1p2  1050624  34605055  33554432    16G Linux swap
/dev/nvme0n1p3 34605056 488397134 453792079 216.4G Linux filesystem


Disk /dev/sda: 465.78 GiB, 500107862016 bytes, 976773168 sectors
Disk model: WDC WD5000AAKS-0
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x0001cca3

Device     Boot Start       End   Sectors   Size Id Type
/dev/sda1        2048 976771071 976769024 465.8G 83 Linux
</code></pre><p>The output above shows the current partition tables of all devices that are attached to your system. Generally, SATA device names follow the pattern <code>/dev/sd[a-z]</code>, while NVMe device names have the following pattern <code>/dev/nvme[1-9]n[1-9]</code>.</p><h2 id="creating-partition-table">Creating Partition Table <a href="#creating-partition-table" class="headline-link" aria-hidden="true">#</a></h2><p>To start partitioning the drive, run <code>fdisk</code> with the device name. In this example we’ll work on <code>/dev/sdb</code>:</p><pre class="terminal"><code class="terminal-line" prefix="$">fdisk /dev/sdb</code></pre><p>The command prompt will change, and the <code>fdisk</code> dialogue where you can type in commands will open:</p><pre><code class="language-prompt" data-lang="prompt">Welcome to fdisk (util-linux 2.34).
Changes will remain in memory only, until you decide to write them.
Be careful before using the write command.

Command (m for help):
</code></pre><div class="my-6 bg-yellow-100 border-l-4 border-yellow-400 dark:bg-gray-800 dark:border-0 dark:text-yellow-200 note p-6"><div class="flex"><div class="w-full text-sm font-sans">Changes you make to the partition table won’t take effect until you write them with the <code>w</code> command. You can exit the <code>fdisk</code> dialogue without saving the changes using the <code>q</code> command.</div></div></div><p>To get a list of all available commands enter <code>m</code>:</p><pre class="terminal"><code class="terminal-line" prefix="Command (m for help)">m</code></pre><figure class="relative"><div class="w-full mx-auto my-0 block relative"><div class="block" style="padding-bottom:91.88571428571429%"></div><div class="w-full h-full absolute inset-0 m-auto overflow-hidden text-center"><img alt="" class="lazyload" src="data:image/gif;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAYAAAAfFcSJAAAADUlEQVR42mP8+PXHfwAJnAPfCuZXlQAAAABJRU5ErkJggg==" data-sizes="auto" data-src="/post/fdisk-command-in-linux/fdisk-commands_hu3469665baa3effbebd88035f5c0ce412_64622_600x0_resize_q75_box.jpg" data-srcset="
              /post/fdisk-command-in-linux/fdisk-commands_hu3469665baa3effbebd88035f5c0ce412_64622_600x0_resize_q75_box.jpg 600w,
              /post/fdisk-command-in-linux/fdisk-commands.jpg 875w
            " data-action="zoom"><noscript><img alt="" class="w-full h-full absolute inset-0 m-auto" src="/post/fdisk-command-in-linux/fdisk-commands.jpg"></noscript></div></div></figure><p>If you are partitioning a new drive, before starting to create partitions first, you need to create a partition table. Skip this step if the device already has a partition table and you want to keep it.</p><p><code>fdisk</code> supports several partitioning schemes. MBR and GPT are the two most popular partition scheme standards, that store the partitioning information on a drive in a different way. GPT is a newer standard allowing and has many advantages over MBR. The main points to consider when choosing what partitioning standard to use:</p><ul><li>Use MBR to boot the disk in legacy BIOS mode.</li><li>Use GPT to boot the disk in UEFI mode.</li><li>The MBR standard supports creating a disk partition up to 2 TiB. If you have a disk of 2 TiB or larger, use GPT.</li><li>MBR has a limit of 4 primary partitions. If you need more partitions, one of the primary partitions can be set as an extended partition and hold additional logical partitions. With GPT, you can have up to 128 partitions. GPT doesn’t support extended or logical partitions.</li></ul><p>In this example, we will use a GPT partition table.</p><p>Enter <code>g</code> to create a new empty GPT partition table:</p><pre class="terminal"><code class="terminal-line" prefix="Command (m for help)">g</code></pre><p>The output will look something like this:</p><pre><code class="language-output" data-lang="output">Created a new GPT disklabel (GUID: 4649EE36-3013-214E-961C-51A9187A7503).
</code></pre><p>The next step is to create the new partitions.</p><p>We will create two partitions. The first one with a size of 100 GiB and the second one will take the rest of the disk space.</p><p>Run the <code>n</code> command to create a new partition:</p><pre class="terminal"><code class="terminal-line" prefix="Command (m for help)">n</code></pre><p>You’ll be prompted to enter the partition number. Hit “Enter” to use the default value (<code>1</code>):</p><pre><code class="language-prompt" data-lang="prompt">Partition number (1-128, default 1):
</code></pre><p>Next, the command will ask you to specify the first sector. Generally it is always recommended to use the default values for the first value. Hit “Enter” to use the default value (<code>2048</code>):</p><pre><code class="language-prompt" data-lang="prompt">First sector (2048-500118158, default 2048):
</code></pre><p>On the next prompt, you’ll need to enter the last sector. You can use an absolute value for the last sector or relative value to the start sector, using the + symbol following by the partition size. The size can be specified in kibibytes (K), mebibytes (M), gibibytes (G), tebibytes (T), or pebibytes (P).</p><p>Enter <code>+100G</code> to set the partition size to 100 GiB:</p><pre><code class="language-prompt" data-lang="prompt">Last sector, +/-sectors or +/-size{K,M,G,T,P} (2048-500118158, default 500118158): +100G
</code></pre><pre><code class="language-output" data-lang="output">Created a new partition 1 of type 'Linux filesystem' and of size 100 GiB.
</code></pre><p>By default, the type of the new partition is set to “Linux filesystem”, which should be fine for most cases. If you want to change the type, press <code>l</code> to get a list of partition types and then press <code>t</code> to change the type.</p><p>Let’s create the second partition that will take the rest of the disk space:</p><pre class="terminal"><code class="terminal-line" prefix="Command (m for help)">n</code></pre><p>Use the default values for the partition number, first and last sectors. This will create a partition that will use all available space on the disk.</p><pre><code class="language-prompt" data-lang="prompt">Partition number (2-128, default 2): 
First sector (209717248-625142414, default 209717248): 
Last sector, +/-sectors or +/-size{K,M,G,T,P} (209717248-625142414, default 625142414): 
</code></pre><p>Once done creating partitions, use the <code>p</code> command to display the new partition table:</p><pre class="terminal"><code class="terminal-line" prefix="Command (m for help)">p</code></pre><pre><code class="language-output" data-lang="output">Disk /dev/sdb: 298.9 GiB, 320072933376 bytes, 625142448 sectors
Disk model: nal USB 3.0     
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: F8365250-AF58-F74E-B592-D56E3A5DEED1

Device         Start       End   Sectors   Size Type
/dev/sdb1       2048 209717247 209715200   100G Linux filesystem
/dev/sdb2  209717248 625142414 415425167 198.1G Linux filesystem
</code></pre><div class="my-6 bg-yellow-100 border-l-4 border-yellow-400 dark:bg-gray-800 dark:border-0 dark:text-yellow-200 note p-6"><div class="flex"><div class="w-full text-sm font-sans">If you want to delete a partition, use the <code>d</code> command.</div></div></div><p>Save the changes by running the <code>w</code> command:</p><pre class="terminal"><code class="terminal-line" prefix="Command (m for help)">p</code></pre><p>The command will write the table to disk and exit the <code>fdisk</code> menu.</p><pre><code class="language-output" data-lang="output">The partition table has been altered.
Calling ioctl() to re-read partition table.
Syncing disks.
</code></pre><p>The kernel will read the device partition table without the need to reboot the system.</p><h2 id="activating-the-partitions">Activating the Partitions <a href="#activating-the-partitions" class="headline-link" aria-hidden="true">#</a></h2><p>Now that the partitions have been created, the next step is to format the partitions and mount them to the system’s directory tree.</p><p>We’ll format both partitions to ext4:</p><pre class="terminal"><code class="terminal-line" prefix="$">sudo mkfs.ext4 -F /dev/sdb1</code><code class="terminal-line" prefix="$">sudo mkfs.ext4 -F /dev/sdb2</code></pre><pre><code class="language-output" data-lang="output">mke2fs 1.45.5 (07-Jan-2020)
Creating filesystem with 51928145 4k blocks and 12984320 inodes
Filesystem UUID: 63a3457e-c3a1-43f4-a0e6-01a7dbe7dfed
Superblock backups stored on blocks: 
	32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208, 
	4096000, 7962624, 11239424, 20480000, 23887872

Allocating group tables: done                            
Writing inode tables: done                            
Creating journal (262144 blocks): done
Writing superblocks and filesystem accounting information: done   
</code></pre><p>In this example, will mount the partitions to <code>/mnt/audio</code> and <code>/mnt/video</code> directories.</p><p>Create the mount points with <a href="https://linuxize.com/post/how-to-create-directories-in-linux-with-the-mkdir-command/"><code>mkdir</code></a>:</p><pre class="terminal"><code class="terminal-line" prefix="$">sudo mkdir -p /mnt/audio /mnt/video </code></pre><p><a href="https://linuxize.com/post/how-to-mount-and-unmount-file-systems-in-linux/">Mount</a> the new partition:</p><pre class="terminal"><code class="terminal-line" prefix="$">sudo mount /dev/sdb1 /mnt/audio</code><code class="terminal-line" prefix="$">sudo mount /dev/sdb2 /mnt/video </code></pre><p>Partitions will stay mounted until you unmount it or <a href="https://linuxize.com/post/linux-shutdown-command/">shutdown</a> the machine. To automatically mount a partition when your Linux system starts up, define the mount in the <code>/etc/fstab</code> file.</p><p>That’s it! You can now use the new partitions to store your files.</p><h2 id="conclusion">Conclusion <a href="#conclusion" class="headline-link" aria-hidden="true">#</a></h2><p><code>fdisk</code> is a command-line tool for creating partition schemes. For more information about the <code>fdisk</code> command, type <code>man fdisk</code> in your terminal.</p><p>If you have any questions or feedback, feel free to leave a comment.</p><div class="flex flex-wrap my-6"><a href="/tags/fdisk/" class="font-medium text-sm bg-indigo-700 hover:bg-indigo-800 mr-2 mt-2 px-4 py-2 rounded text-white tracking-wide">fdisk</a> <a href="/tags/terminal/" class="font-medium text-sm bg-indigo-700 hover:bg-indigo-800 mr-2 mt-2 px-4 py-2 rounded text-white tracking-wide">terminal</a></div></div></section></div></div></div></div><div class="w-full absolute hidden -mb-16 flex-grow lg:-mb-0 lg:block lg:pt-0 lg:static sidebar top-16 z-40" id="sidebar"><div class="bg-gray-200 dark:bg-gray-900 mb-6 p-4 pb-2 related-content"><p class="dark:text-gray-300 font-medium text-gray-800 mb-3 mb-3 text-xs tracking-tight uppercase xxl:text-sm">Related Tutorials</p><ul class="border-gray-400 dark:border-gray-800 border-t mb-0 mt-4 pt-3"><li class="flex border-gray-400 border-b dark:border-gray-800 mb-2 pb-2"><a href="https://linuxize.com/post/grep-multiple-patterns/" class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 font-medium text-gray-700 text-sm">How to Grep for Multiple Strings and Patterns</a></li><li class="flex border-gray-400 border-b dark:border-gray-800 mb-2 pb-2"><a href="https://linuxize.com/post/bashrc-vs-bash-profile/" class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 font-medium text-gray-700 text-sm">.bashrc vs .bash_profile</a></li><li class="flex border-gray-400 border-b dark:border-gray-800 mb-2 pb-2"><a href="https://linuxize.com/post/how-to-set-or-change-timezone-on-ubuntu-20-04/" class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 font-medium text-gray-700 text-sm">How To Set or Change Timezone on Ubuntu 20.04</a></li><li class="flex border-gray-400 border-b dark:border-gray-800 mb-2 pb-2"><a href="https://linuxize.com/post/how-to-delete-group-in-linux/" class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 font-medium text-gray-700 text-sm">How to Delete Group in Linux (groupdel Command)</a></li><li class="flex border-gray-400 border-b dark:border-gray-800 mb-2 pb-2"><a href="https://linuxize.com/post/at-command-in-linux/" class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 font-medium text-gray-700 text-sm">At Command in Linux</a></li><li class="flex border-gray-400 border-b dark:border-gray-800 mb-2 pb-2"><a href="https://linuxize.com/post/awk-command/" class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 font-medium text-gray-700 text-sm">Awk Command in Linux with Examples</a></li><li class="flex border-gray-400 border-b dark:border-gray-800 mb-2 pb-2"><a href="https://linuxize.com/post/how-to-add-and-delete-users-on-centos-8/" class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 font-medium text-gray-700 text-sm">How to Add and Delete Users on CentOS 8</a></li></ul></div><div class="flex flex-col -mt-12 lg:block lg:relative lg:sticky lg:top-16 pt-12"><div class="sideblock"><div class="hidden affiliate mb-5"><a href="https://www.serverhunter.com/landing/?ad=linuxize&utm_source=linuxize&utm_medium=cpc&utm_campaign=sidebar&utm_content=adblock" class="server-hunter" rel="noreferrer noopener" target="_blank" id="serverhunter_link"></a></div><div class="hidden affiliate"><a href="https://www.vultr.com/?ref=8389060-6G" class="vultr" rel="noreferrer noopener" target="_blank" id="vultr"></a></div><script src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js" async></script><div class="w-full flex justify-center content-center"><div class="w-full relative"><ins class="block mx-auto adsbygoogle" data-ad-client="ca-pub-9439755881064125" data-ad-format="auto" data-ad-slot="7027266996" data-full-width-responsive="true"></ins></div></div><script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></div></div></div></div></article><div class="px-6"><section class="w-full mx-auto border-gray-200 border-t dark:border-gray-900 mt-8 pt-8 max-w-article"><div class="p-8 dark:bg-gray-900 sm:py-8 bg-orange-100"><p class="dark:text-gray-300 lg:text-base max-w-md mx-auto my-0 sm:text-base text-center text-orange-800 text-sm">If you like our content, please consider buying us a coffee.<br>Thank you for your support!</p><div class="w-full mx-auto flex items-center flex-col max-w-sm sm:flex-row justify-center mt-6"><a href="https://www.buymeacoffee.com/8swZOSU6I" class="font-medium px-4 py-2 rounded bg-orange-500 hover:bg-orange-600 inline-flex items-center text-orange-100" rel="noopener" target="_blank"><svg aria-hidden="true" class="inline-block fill-current h-6 w-6 text-gray-900" role="img"><use xlink:href="/svg/sprite.svg#bmc"></use></svg> <span class="font-medium text-xs ml-2 uppercase">Buy me a coffee</span></a></div></div></section><section class="w-full mx-auto border-gray-200 border-t dark:border-gray-900 mt-8 pt-8 max-w-article"><div class="bg-gray-200 dark:bg-gray-900 p-8 sm:py-8"><p class="lg:text-base max-w-md mx-auto my-0 sm:text-base text-center text-sm">Sign up to our newsletter and get our latest tutorials and news straight to your mailbox.</p><form action="https://linuxize.us17.list-manage.com/subscribe/post?u=35cd4cd9d021c25c3dd7cabfd&id=9cfa4c89de" class="pt-8" id="mc-embedded-subscribe-form" method="post" name="mc-embedded-subscribe-form" novalidate><div class="w-full mx-auto flex items-center flex-col max-w-sm sm:flex-row justify-between mb-2"><input class="w-full block bg-white appearance-none border hover:border-gray-700 mb-3 px-4 py-3 rounded sm:mb-0 text-gray-800" name="EMAIL" aria-label="email" placeholder="Your email..." type="email"> <input class="hidden" name="b_35cd4cd9d021c25c3dd7cabfd_9cfa4c89de" tabindex="-1"> <button class="w-full px-4 py-3 rounded bg-indigo-700 hover:bg-indigo-800 sm:ml-4 sm:w-auto text-white tracking-wide" name="subscribe" type="submit"><span class="text-center">Subscribe</span></button></div><p class="w-full mx-auto my-0 max-w-sm text-sm">We’ll never share your email address or spam you.</p></form></div></section><section class="w-full mx-auto border-gray-200 border-t dark:border-gray-900 mt-8 pt-8 max-w-5xl"><div class="flex flex-wrap -mx-4"><a href="https://linuxize.com/post/grep-multiple-patterns/" class="w-full flex md:mb-0 md:w-1/3 overflow-hidden px-4 mb-8"><div class="w-full h-full flex flex-col"><p class="dark:text-gray-300 text-xs text-gray-700 font-normal uppercase">May 13, 2020</p><h2 class="dark:text-gray-300 font-medium text-gray-800 flex-grow mb-2 md:mb-4 text-lg">How to Grep for Multiple Strings and Patterns</h2><div><figure class="relative"><div class="w-full mx-auto my-0 block relative"><div class="block" style="padding-bottom:53%"></div><div class="w-full h-full absolute inset-0 m-auto overflow-hidden bg-gray-200"><img alt="" class="w-full h-full absolute inset-0 m-auto lazy lazyload" src="data:image/gif;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAYAAAAfFcSJAAAADUlEQVR42mP8+PXHfwAJnAPfCuZXlQAAAABJRU5ErkJggg==" data-sizes="auto" data-src="/post/grep-multiple-patterns/featured_hu1d5e55dcf56ebd1c0db3a19edde6217a_32124_600x0_resize_q95_box.jpg" data-srcset="
              /post/grep-multiple-patterns/featured_hu1d5e55dcf56ebd1c0db3a19edde6217a_32124_600x0_resize_q95_box.jpg 600w,
              /post/grep-multiple-patterns/featured.jpg 1000w
            "><noscript><img alt="" class="w-full h-full absolute inset-0 m-auto" src="/post/grep-multiple-patterns/featured.jpg"></noscript></div></div></figure></div></div></a><a href="https://linuxize.com/post/bashrc-vs-bash-profile/" class="w-full flex md:mb-0 md:w-1/3 overflow-hidden px-4 mb-8"><div class="w-full h-full flex flex-col"><p class="dark:text-gray-300 text-xs text-gray-700 font-normal uppercase">May 10, 2020</p><h2 class="dark:text-gray-300 font-medium text-gray-800 flex-grow mb-2 md:mb-4 text-lg">.bashrc vs .bash_profile</h2><div><figure class="relative"><div class="w-full mx-auto my-0 block relative"><div class="block" style="padding-bottom:53%"></div><div class="w-full h-full absolute inset-0 m-auto overflow-hidden bg-gray-200"><img alt="" class="w-full h-full absolute inset-0 m-auto lazy lazyload" src="data:image/gif;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAYAAAAfFcSJAAAADUlEQVR42mP8+PXHfwAJnAPfCuZXlQAAAABJRU5ErkJggg==" data-sizes="auto" data-src="/post/bashrc-vs-bash-profile/featured_hueb4f3e4d47680768d837c2014c5335f8_29864_600x0_resize_q95_box.jpg" data-srcset="
              /post/bashrc-vs-bash-profile/featured_hueb4f3e4d47680768d837c2014c5335f8_29864_600x0_resize_q95_box.jpg 600w,
              /post/bashrc-vs-bash-profile/featured.jpg 1000w
            "><noscript><img alt="" class="w-full h-full absolute inset-0 m-auto" src="/post/bashrc-vs-bash-profile/featured.jpg"></noscript></div></div></figure></div></div></a><a href="https://linuxize.com/post/how-to-set-or-change-timezone-on-ubuntu-20-04/" class="w-full flex md:mb-0 md:w-1/3 overflow-hidden px-4 mb-0"><div class="w-full h-full flex flex-col"><p class="dark:text-gray-300 text-xs text-gray-700 font-normal uppercase">May 6, 2020</p><h2 class="dark:text-gray-300 font-medium text-gray-800 flex-grow mb-2 md:mb-4 text-lg">How To Set or Change Timezone on Ubuntu 20.04</h2><div><figure class="relative"><div class="w-full mx-auto my-0 block relative"><div class="block" style="padding-bottom:53%"></div><div class="w-full h-full absolute inset-0 m-auto overflow-hidden bg-gray-200"><img alt="" class="w-full h-full absolute inset-0 m-auto lazy lazyload" src="data:image/gif;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAYAAAAfFcSJAAAADUlEQVR42mP8+PXHfwAJnAPfCuZXlQAAAABJRU5ErkJggg==" data-sizes="auto" data-src="/post/how-to-set-or-change-timezone-on-ubuntu-20-04/featured_huf4422b2da9c738e2d7a3bddbf51ded27_31572_600x0_resize_q95_box.jpg" data-srcset="
              /post/how-to-set-or-change-timezone-on-ubuntu-20-04/featured_huf4422b2da9c738e2d7a3bddbf51ded27_31572_600x0_resize_q95_box.jpg 600w,
              /post/how-to-set-or-change-timezone-on-ubuntu-20-04/featured.jpg 1000w
            "><noscript><img alt="" class="w-full h-full absolute inset-0 m-auto" src="/post/how-to-set-or-change-timezone-on-ubuntu-20-04/featured.jpg"></noscript></div></div></figure></div></div></a></div></section><section class="w-full mx-auto relative border-gray-200 border-t dark:border-gray-900 max-w-3xl mt-8 pt-16 py-8"><a href="https://linuxize.com/post/fdisk-command-in-linux/#disqus_thread" class="w-full block bg-gray-200 dark:bg-gray-900 disqus-comment-count disqus-load md:py-8 py-4 text-center" title="Show comments for post">Write a comment</a><div id="disqus_thread"></div><noscript>Please enable JavaScript to view the <a href="https://disqus.com/?ref_noscript">comments powered by Disqus.</a></noscript></section></div></main><section class="w-full absolute inset-0 bg-white block h-screen hidden search z-100" id="search-box"><div class="flex flex-col min-h-screen"><header class="w-full mx-auto flex items-center h-12 justify-end px-6 sm:h-16 z-10"><a href="#" class="block h-6 sm:h-8" id="btn-search-close"><svg aria-hidden="true" class="inline-block fill-current h-6 w-6 text-gray-900 sm:h-8 sm:w-8" role="img"><use xlink:href="/svg/sprite.svg#close"></use></svg> <small class="block text-center sm:w-8 w-6">ESC</small></a></header><div class="w-full px-6 flex-grow flex-shrink-0 pb-8 pt-16 sm:pt-24"><div class="flex flex-col mx-auto max-w-screen-xl mb-4 mb-8"><div class="searchbox-container" id="searchbox"></div><div class="search-results" id="search-results"></div><div id="hits"></div><div id="stats"></div><footer class="mt-6"><a href="https://github.com/algolia/instantsearch.js/" rel="noopener noreferrer" target="_blank" tabindex="-1"><svg aria-hidden="true" class="inline-block fill-current search-algolia-logo text-gray-700" role="img"><use xlink:href="/svg/sprite.svg#search-by-algolia"></use></svg></a></footer></div></div></div></section><footer class="w-full px-6 bg-gray-100 dark:bg-gray-900"><div class="w-full mx-auto flex items-center justify-center flex-wrap lg:justify-between lg:text-left max-w-screen-xl py-8 text-center"><div class="w-full text-sm lg:mb-0 lg:w-1/2 mb-2"><div class="w-full block lg:flex lg:items-center lg:w-auto"><div class="lg:flex-grow"><span class="dark:text-gray-300 text-gray-800 mb-2 block lg:inline-block lg:mb-0 lg:mr-8">© 2020 Linuxize.com</span> <a href="/privacy-policy/" class="dark:text-gray-300 dark-hover:text-gray-100 no-underline mr-4 footer-menu-item hover:text-gray-800 inline-block lg:mt-0 text-gray-900">Privacy Policy </a><a href="/terms-of-service/" class="dark:text-gray-300 dark-hover:text-gray-100 no-underline mr-4 footer-menu-item hover:text-gray-800 inline-block lg:mt-0 text-gray-900">Terms </a><a href="/contact/" class="dark:text-gray-300 dark-hover:text-gray-100 no-underline footer-menu-item hover:text-gray-800 inline-block lg:mt-0 text-gray-900 mr-0">Contact</a></div></div></div><div class="w-full flex justify-center lg:justify-end lg:w-1/2"><a href="https://twitter.com/linuxize" class="block h-6 mr-2" aria-label="Twitter"><svg aria-hidden="true" class="dark:text-gray-300 inline-block fill-current h-6 w-6 text-gray-900" role="img"><use xlink:href="/svg/sprite.svg#twitter"></use></svg> </a><a href="https://www.facebook.com/linuxize/" class="block h-6 mr-2" aria-label="Facebook"><svg aria-hidden="true" class="dark:text-gray-300 inline-block fill-current h-6 w-6 text-gray-900" role="img"><use xlink:href="/svg/sprite.svg#facebook"></use></svg> </a><a href="/index.xml" class="block h-6" aria-label="RSS"><svg aria-hidden="true" class="dark:text-gray-300 inline-block fill-current h-6 w-6 text-gray-900" role="img"><use xlink:href="/svg/sprite.svg#rss"></use></svg></a></div></div></footer></div><script src="https://cdn.jsdelivr.net/npm/algoliasearch@4.0.0/dist/algoliasearch-lite.umd.js" crossorigin="anonymous" integrity="sha256-MfeKq2Aw9VAkaE9Caes2NOxQf6vUa8Av0JqcUXUGkd0="></script><script src="https://cdn.jsdelivr.net/npm/instantsearch.js@4.2.0/dist/instantsearch.production.min.js" crossorigin="anonymous" integrity="sha256-B+gqnZmUVBAmEIiecyayAjKMHpQjJhlNMly7YIxbdfw="></script><script src="/js/1.9aee595d9d362699c0f1.js"></script><script src="/js/app.105da3570413f4af7e0e.js"></script><script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('edmonton.php', '/detroitchicago/edmonton.webp?a=a&cb=0&shcb=32', true, [], true, false, false, false);
__ez.queue.addFile('jellyfish.php', '/porpoiseant/jellyfish.webp?a=a&cb=0&shcb=32', false, [], true, false, false, false);
</script>

<script>var _audins_dom="linuxize_com",_audins_did=93605;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=188-0");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.linuxize_com,DomainId.93605" border="0" height="1" width="1" alt="Quantcast"/></div></noscript><noscript><img src="https://sb.scorecardresearch.com/p?c1=2&c2=20015427&cv=2.0&cj=1"/></noscript>
<script type='text/javascript' data-cfasync='false'></script></body></html>