<!doctype html><html class=no-js lang=en-us><head><title>How To Install and Configure Redis on Debian 9 | Linuxize</title><meta charset=utf-8><meta content="IE=edge" http-equiv=X-UA-Compatible><meta content="width=device-width,initial-scale=1,shrink-to-fit=no" name=viewport><meta content=Linuxize name=apple-mobile-web-app-title><meta content=Linuxize name=application-name><meta content=#2271ff name=theme-color><meta content=#2271ff name=msapplication-TileColor><meta content="Redis is an open-source in-memory key-value data store. It can be used as a database, cache and message broker and supports various data structures such as Strings, Hashes, Lists, Sets, etc. This tutorial explains how to install and configure Redis on a Debian 9 server." name=description><meta content=unsafe-url name=referrer><link href=https://linuxize.com/post/how-to-install-and-configure-redis-on-debian-9/ rel=canonical><meta content="index, follow" name=robots><meta content="Hugo 0.51" name=generator><meta content="How To Install and Configure Redis on Debian 9" property=og:title><meta content="Redis is an open-source in-memory key-value data store. It can be used as a database, cache and message broker and supports various data structures such as Strings, Hashes, Lists, Sets, etc. This tutorial explains how to install and configure Redis on a Debian 9 server." property=og:description><meta content=article property=og:type><meta content=/post/how-to-install-and-configure-redis-on-debian-9/ property=og:url><meta content=https://linuxize.com/post/how-to-install-and-configure-redis-on-debian-9/featured.jpg property=og:image><meta content="Redis is an open-source in-memory key-value data store. It can be used as a database, cache and message broker and supports various data structures such as Strings, Hashes, Lists, Sets, etc. This tutorial explains how to install and configure Redis on a Debian 9 server." property=og:image:alt><meta content=2018-12-05T00:21:42+01:00 property=article:published_time><meta content=2018-12-05T00:21:42+01:00 property=article:modified_time><meta content=en property=og:locale><meta content=post property=article:section><meta content=https://www.facebook.com/linuxize property=article:publisher><meta content=redis property=article:tag><meta content=debian property=article:tag><meta content=redis,debian name=news_keywords><meta content=summary_large_image name=twitter:card><meta content=https://linuxize.com/post/how-to-install-and-configure-redis-on-debian-9/featured.jpg name=twitter:image><meta content="How To Install and Configure Redis on Debian 9" name=twitter:title><meta content="Redis is an open-source in-memory key-value data store. It can be used as a database, cache and message broker and supports various data structures such as Strings, Hashes, Lists, Sets, etc. This tutorial explains how to install and configure Redis on a Debian 9 server." name=twitter:description><meta content=@linuxize name=twitter:site><link href=/favicons/apple-touch-icon.png rel=apple-touch-icon sizes=180x180><link href=/favicons/favicon-32x32.png rel=icon sizes=32x32 type=image/png><link href=/favicons/favicon-16x16.png rel=icon sizes=16x16 type=image/png><link href=/favicons/safari-pinned-tab.svg rel=mask-icon color=#2271ff><script type=application/ld+json>{
  "@context": "http://schema.org",
  "@type": "BlogPosting",
  "headline": "How To Install and Configure Redis on Debian 9",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://linuxize.com/post/how-to-install-and-configure-redis-on-debian-9/"
  },"image": {
     "@type": "ImageObject",
     "url": "https://linuxize.com/post/how-to-install-and-configure-redis-on-debian-9/featured.jpg",
     "width": 1000,
     "height": 530
    },"keywords": "redis, debian",
  "wordcount": 553,
  "url": "https://linuxize.com/post/how-to-install-and-configure-redis-on-debian-9/",
  "datePublished": "2018-12-05T00:21:42+01:00",
  "dateModified": "2018-12-05T00:21:42+01:00",
  "publisher": {
    "@type": "Organization","logo": {
    "@type": "imageObject",
      "url": "https://linuxize.com/assets/linuxize-card.png"
    },"name": "Linuxize"
  },

  "author": {
    "@type": "Person",
    "name": "Linuxize"
  },
  "description": "Redis is an open-source in-memory key-value data store. It can be used as a database, cache and message broker and supports various data structures such as Strings, Hashes, Lists, Sets, etc. This tutorial explains how to install and configure Redis on a Debian 9 server."
}</script><script src=/js/ads.js></script><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-P827G6S');</script><script src=https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js async></script><script>(adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-9439755881064125",
          enable_page_level_ads: true
     });</script><meta content=#2271ff name=theme-color><link href=/manifest.79f739767e479131c04f7216cce1c084.json rel=manifest><link href="https://fonts.googleapis.com/css?family=IBM+Plex+Sans:300,400,400i,500,700%7CIBM+Plex+Serif:300,400,400i,600,600i" rel=stylesheet><link href=/css/app.b7053e1607f74b413ca7.css rel=stylesheet></head><body class="font-sans kind-page leading-normal section-post text-black type-post"><div class="flex flex-col min-h-screen main-wrap"><header class="w-full px-6 z-10 bg-white border-b border-grey-light fixed linuxize-shadow" id=header><nav class="w-full mx-auto flex items-center h-12 sm:h-16 justify-start"><a href=/ class="flex items-center block flex-no-shrink mr-6 no-underline text-black" aria-label=Linuxize.com><svg aria-hidden=true class="h-6 w-6 fill-current sm:h-8 sm:w-8 mr-2"><use xlink:href=#logo></use><title>Linuxize</title></svg> <span class="font-medium tracking-tight hidden sm:block text-xl">Linuxize</span></a><div class="flex -mb-px flex-1 min-w-0 text-sm"><a href=/tags/ubuntu/ class="hover:text-grey-darkest hidden mr-4 no-underline sm:block text-grey-darker"><span class="inline-block font-bold md:py-6 py-3 sm:py-4">Ubuntu </span></a><a href=/tags/centos/ class="hover:text-grey-darkest hidden mr-4 no-underline sm:block text-grey-darker"><span class="inline-block font-bold md:py-6 py-3 sm:py-4">Centos </span></a><a href=/tags/debian/ class="hover:text-grey-darkest hidden mr-4 no-underline sm:block text-grey-darker"><span class="inline-block font-bold md:py-6 py-3 sm:py-4">Debian </span></a><a href=/tags/terminal/ class="hover:text-grey-darkest hidden mr-4 no-underline sm:block text-grey-darker"><span class="inline-block font-bold md:py-6 py-3 sm:py-4">Linux Commands </span></a><a href=/series/ class="hover:text-grey-darkest hidden mr-4 no-underline sm:block text-grey-darker mr-0"><span class="inline-block font-bold md:py-6 py-3 sm:py-4">Series</span></a></div><div class="flex justify-end"><button class="h-6 block sm:h-8" aria-label=Search id=btn-search><svg aria-hidden=true class="h-6 w-6 fill-current inline-block text-grey-darkest sm:h-8 sm:w-8"><use xlink:href=#search></use><title>Search</title></svg></button></div></nav></header><main class="w-full px-6 flex-grow flex-no-shrink pb-8 pt-16 sm:pt-24 main"><article class="relative single-post"><div class="w-full mx-auto max-w-screen-2xl"><div class=lg:flex><div class="w-full lg:static lg:max-h-full lg:overflow-visible min-h-screen"><div class=flex><div class="w-full pb-8"><div class="mx-auto lg:ml-0 lg:mr-auto lg:pr-6 xl:mx-0 max-w-lg mb-6 xl:max-w-full xl:pr-8"><div class="flex mb-2 flex-col font-medium md:flex-row text-xs uppercase"><div class=inline-flex><time class="" datetime=2018-12-05T00:21:42+01:00>December 5, 2018 </time><span class=mx-2>•</span><p>Read in 3 minutes</p></div><span class="hidden md:block mx-2">|</span><p class="font-medium text-xs leading-normal rounded-sm uppercase">last updated  <time class="" datetime=2018-12-05T00:21:42+01:00>December 5, 2018</time></p></div><div class=post-header><h1 class="font-bold leading-none lg:text-3xl mb-4 text-2xl text-black xl:mb-8 xxl:text-4xl">How To Install and Configure Redis on Debian 9</h1></div></div><div class="flex flex-col xl:flex-relative xl:flex-row"><aside class="w-full block lg:hidden xl:block" id=sidebar2><div class="w-full flex justify-center content-center"><div class="w-full relative"><ins class="mx-auto adsbygoogle hidden mb-6 sidebar2-as xl:block" data-ad-client=ca-pub-9439755881064125 data-ad-format=horizontal,rectangle data-ad-slot=4501323511 style=display:block data-full-width-responsive=true></ins></div></div><div class="hidden flex-col justify-between xl:flex distro-versions"><div class="mb-6 p-4 pb-2 toc bg-blue"><p class="font-medium text-xs mb-3 tracking-tight uppercase xxl:text-sm text-white">This tutorial is also available for</p><div class="w-full distro-versions flex-wrap inline-flex items-center mb-4"><a href=/post/how-to-install-and-configure-redis-on-centos-7/ class="w-full mb-2 bg-blue-dark capitalize font-medium hover:bg-blue-darkest leading-normal px-3 py-1 rounded-sm text-center text-white text-xs xxl:mr-2 xxl:text-sm">centos 7 </a><a href=/post/how-to-install-and-configure-redis-on-ubuntu-18-04/ class="w-full mb-2 bg-blue-dark capitalize font-medium hover:bg-blue-darkest leading-normal px-3 py-1 rounded-sm text-center text-white text-xs xxl:mr-2 xxl:text-sm">ubuntu 18.04</a></div></div></div><div class="hidden flex-col justify-between xl:flex -mt-12 pb-4 pt-12 sticky top-16"><div class="mb-6 p-4 pb-2 toc bg-grey-lighter table-of-contents"><p class="font-medium text-xs mb-3 mb-3 tracking-tight uppercase xxl:text-sm text-grey-darker">Contents</p><nav id=TableOfContents><ul><li><ul><li><a href=#prerequisites>Prerequisites</a></li><li><a href=#installing-redis-on-debian>Installing Redis on Debian</a></li><li><a href=#configure-redis-remote-access>Configure Redis Remote Access</a></li><li><a href=#conclusion>Conclusion</a></li></ul></li></ul></nav><p class="font-medium text-xs mb-3 mb-3 tracking-tight uppercase xxl:text-sm border-grey-light border-t mt-4 pt-4">Share</p><section class="w-full mx-auto"><nav class="flex flex-wrap"><a href="https://twitter.com/share?text=How%20To%20Install%20and%20Configure%20Redis%20on%20Debian%209&url=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-install-and-configure-redis-on-debian-9%2f" class="h-6 w-6 mb-4 mr-3" rel=noopener target=_blank><svg aria-hidden=true class="h-6 w-6 fill-current inline-block hover:text-blue text-gray-light"><use xlink:href=#twitter></use><title>Share on Twitter</title></svg> </a><a href="https://www.facebook.com/sharer/sharer.php?caption=How%20To%20Install%20and%20Configure%20Redis%20on%20Debian%209&u=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-install-and-configure-redis-on-debian-9%2f" class="h-6 w-6 mb-4 mr-3" rel=noopener target=_blank><svg aria-hidden=true class="h-6 w-6 fill-current inline-block hover:text-blue text-gray-light"><use xlink:href=#facebook></use><title>Share on Facebook</title></svg> </a><a href="https://pinterest.com/pin/create/button/?url=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-install-and-configure-redis-on-debian-9%2f&media=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-install-and-configure-redis-on-debian-9%2ffeatured.jpg&description=How%20To%20Install%20and%20Configure%20Redis%20on%20Debian%209" class="h-6 w-6 mb-4 mr-3" rel=noopener target=_blank><svg aria-hidden=true class="h-6 w-6 fill-current inline-block hover:text-blue text-gray-light"><use xlink:href=#pinterest></use><title>Share on Pinterest</title></svg> </a><a href="https://plus.google.com/share?url=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-install-and-configure-redis-on-debian-9%2f" class="h-6 w-6 mb-4 mr-3" rel=noopener target=_blank><svg aria-hidden=true class="h-6 w-6 fill-current inline-block hover:text-blue text-gray-light"><use xlink:href=#gplus></use><title>Share on Google Plus</title></svg> </a><a href="https://news.ycombinator.com/submitlink?t=How%20To%20Install%20and%20Configure%20Redis%20on%20Debian%209&u=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-install-and-configure-redis-on-debian-9%2f" class="h-6 w-6 mb-4 mr-3" rel=noopener target=_blank><svg aria-hidden=true class="h-6 w-6 fill-current inline-block hover:text-blue text-gray-light"><use xlink:href=#hacker-news></use><title>Submit to Hacker News</title></svg> </a><a href="/cdn-cgi/l/email-protection#536c202631393630276e1b3c24766163073c7661631a3d2027323f3f766163323d37766163103c3d353a342621367661630136373a207661633c3d7661631736313a323d7661636a75313c372a6e103b3630387661633c2627766163273b3a207661633221273a303f36697663127663123b272723207660327661357661353f3a3d262b3a29367d303c3e766135233c20277661353b3c247e273c7e3a3d2027323f3f7e323d377e303c3d353a342621367e2136373a207e3c3d7e3736313a323d7e6a766135" class="h-6 w-6 mb-4" rel=noopener target=_blank><svg aria-hidden=true class="h-6 w-6 fill-current inline-block hover:text-blue text-gray-light"><use xlink:href=#email></use><title>Share with Email</title></svg></a></nav></section></div></div></aside><section class="w-full mx-auto lg:ml-0 lg:mr-auto lg:pr-6 min-w-0 xl:mx-0 xl:px-8 xl:w-full"><figure class="relative -mx-6 lg:mx-0 mb-6"><div class="bg-center bg-cover" style=background-image:url(/post/how-to-install-and-configure-redis-on-debian-9/featured.jpg);padding-top:46.7%></div></figure><div class=markdown><p>Redis is an open-source in-memory key-value data store. It can be used as a database, cache and message broker and supports various data structures such as Strings, Hashes, Lists, Sets, etc. Redis provides high availability via Redis Sentinel including monitoring, notifications Automatic failover. It also provides automatic partitioning across multiple Redis nodes with Redis Cluster.</p><p>This tutorial explains how to install and configure Redis on a Debian 9 server.</p><h2 id=prerequisites>Prerequisites</h2><p>Before starting with the tutorial, make sure you are logged in as a <a href=/post/how-to-create-a-sudo-user-on-debian/ >user with sudo privileges</a>.</p><h2 id=installing-redis-on-debian>Installing Redis on Debian</h2><p>Redis package is included in the default Debian 9 repositories. The installation is pretty straightforward, just follow the steps below:</p><ol><li><p>Start by updating the apt packages list by issuing the following command:</p><div class=highlight><pre class=chroma><code class=language-console-bash data-lang=console-bash>sudo apt update</code></pre></div></li><li><p>Install Redis by typing:</p><div class=highlight><pre class=chroma><code class=language-console-bash data-lang=console-bash>sudo apt install redis-server</code></pre></div></li><li><p>When the installation is complete, Redis service will start automatically. You can check the status of the service by typing:</p><div class=highlight><pre class=chroma><code class=language-console-bash data-lang=console-bash>sudo systemctl status redis-server</code></pre></div><p>You should see something like this:</p><div class=highlight><pre class=chroma><code class=language-output data-lang=output>● redis-server.service - Advanced key-value store
Loaded: loaded (/lib/systemd/system/redis-server.service; enabled; vendor preset: enabled)
Active: active (running) since Wed 2018-12-05 08:54:49 PST; 4min 52s ago
    Docs: http://redis.io/documentation,
        man:redis-server(1)
Main PID: 1569 (redis-server)
CGroup: /system.slice/redis-server.service
        └─1569 /usr/bin/redis-server 127.0.0.1:6379</code></pre></div></li></ol><div class="my-6 bg-yellow-lightest border-l-4 border-yellow-light note p-6 text-yellow-darkest"><div class=flex><div class="w-full text-sm font-sans"><p>Redis service will fail to start if IPv6 is disabled on your server.</p></div></div></div><p>At this point Redis is installed and running on your Debian 9 server and you can start using it.</p><h2 id=configure-redis-remote-access>Configure Redis Remote Access</h2><p>By default, Redis cannot be accessed from a remote location. You can connect to the Redis server only from 127.0.0.1 (local host) - the machine where redis is running.</p><p>Complete the following steps only if you want to connect to your Redis server from remote hosts. If you are using a single server setup, where the application and redis are running on the same machine then you should not enable remote access.</p><p>To configure Redis to accept remote connections open the Redis configuration file with your text editor:</p><div class=highlight><pre class=chroma><code class=language-console-bash data-lang=console-bash>sudo nano /etc/redis/redis.conf</code></pre></div><p>Search for a line that begins with <code>bind 127.0.0.1</code> and replace <code>127.0.0.1</code> with <code>0.0.0.0</code>.</p><div class=code-label>/etc/redis/redis.conf</div><div class=highlight><pre class=chroma><code class=language-output data-lang=output># IF YOU ARE SURE YOU WANT YOUR INSTANCE TO LISTEN TO ALL THE INTERFACES
# JUST COMMENT THE FOLLOWING LINE.
# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
<span class=hl>bind 0.0.0.0</span></code></pre></div><p>Save the file and close the editor.</p><p>Restart the Redis service for changes to take effect:</p><div class=highlight><pre class=chroma><code class=language-console-bash data-lang=console-bash>sudo systemctl restart redis-server</code></pre></div><p>Use the following command to verify that redis is listening on all interfaces on port <code>6379</code>:</p><div class=highlight><pre class=chroma><code class=language-console-bash data-lang=console-bash>ss -an | grep 6379</code></pre></div><p>You should see something like below:</p><div class=highlight><pre class=chroma><code class=language-output data-lang=output>tcp    LISTEN     0      128       *:6379                  *:*</code></pre></div><p>Next, you’ll need to add a firewall rule that enables traffic from your remote machines on TCP port <code>6379</code>.</p><p>Assuming you are using <a href=/post/how-to-setup-a-firewall-with-ufw-on-debian-9/ ><code>UFW</code></a> to manage your firewall and you want to allow access from the <code>192.168.121.0/24</code> subnet you would run the following command:</p><div class=highlight><pre class=chroma><code class=language-console-bash data-lang=console-bash>sudo ufw allow proto tcp from 192.168.121.0/24 to any port 6379</code></pre></div><p>Make sure your firewall is configured to accept connections only from trusted IP ranges.</p><p>To verify that everything is setup properly, you can try to ping the Redis server from your remote machine using the <code>redis-cli</code> utility:</p><div class=highlight><pre class=chroma><code class=language-console-bash data-lang=console-bash>redis-cli -h &lt;REDIS_IP_ADDRESS> ping</code></pre></div><p>The command should return a response of <code>PONG</code>:</p><div class=highlight><pre class=chroma><code class=language-output data-lang=output>PONG</code></pre></div><h2 id=conclusion>Conclusion</h2><p>Congratulations, you have successfully installed Redis on your Debian 9 server. To find more information about how to manage your Redis installation visit the <a href=https://redis.io/documentation>Redis documentation</a> page.</p><div class="flex flex-wrap my-6"><a href=/tags/redis class="font-medium text-sm bg-indigo-dark hover:bg-indigo-darker mr-2 mt-2 px-4 py-2 rounded text-white tracking-wide">redis</a> <a href=/tags/debian class="font-medium text-sm bg-indigo-dark hover:bg-indigo-darker mr-2 mt-2 px-4 py-2 rounded text-white tracking-wide">debian</a></div></div></section></div></div></div></div><div class="w-full flex-grow -mb-16 absolute hidden lg:-mb-0 lg:block lg:pt-0 lg:static top-16 z-90" id=sidebar><div class=sideblock><div class="w-full flex justify-center content-center"><div class="w-full relative"><ins class="mx-auto adsbygoogle hidden lg:block" data-ad-client=ca-pub-9439755881064125 data-ad-format=auto data-ad-slot=9558702194 style=display:block data-full-width-responsive=true></ins></div></div></div><div class="bg-grey-lighter p-4 pb-2 my-6 related-content"><p class="font-medium text-xs mb-3 mb-3 tracking-tight uppercase xxl:text-sm text-grey-darker">Related Tutorials</p><ul class="border-grey-light border-t list-reset mb-0 mt-4 pt-3"><li class="flex mb-2 border-b border-grey-light pb-2"><a href=https://linuxize.com/post/how-to-install-tomcat-9-on-debian-9/ class="font-medium text-sm hover:text-grey-darkest text-grey-dark truncate">How to install Tomcat 9 on Debian 9</a></li><li class="flex mb-2 border-b border-grey-light pb-2"><a href=https://linuxize.com/post/how-to-install-django-on-debian-9/ class="font-medium text-sm hover:text-grey-darkest text-grey-dark truncate">How to Install Django on Debian 9</a></li><li class="flex mb-2 border-b border-grey-light pb-2"><a href=https://linuxize.com/post/how-to-install-and-configure-redis-on-centos-7/ class="font-medium text-sm hover:text-grey-darkest text-grey-dark truncate">How To Install and Configure Redis on CentOS 7</a></li><li class="flex mb-2 border-b border-grey-light pb-2"><a href=https://linuxize.com/post/how-to-install-and-secure-phpmyadmin-with-apache-on-debian-9/ class="font-medium text-sm hover:text-grey-darkest text-grey-dark truncate">How to Install and Secure phpMyAdmin with Apache on Debian 9</a></li><li class="flex mb-2 border-b border-grey-light pb-2"><a href=https://linuxize.com/post/how-to-install-and-use-docker-compose-on-debian-9/ class="font-medium text-sm hover:text-grey-darkest text-grey-dark truncate">How To Install and Use Docker Compose on Debian 9</a></li><li class="flex mb-2 border-b border-grey-light pb-2"><a href=https://linuxize.com/post/how-to-install-and-configure-redis-on-ubuntu-18-04/ class="font-medium text-sm hover:text-grey-darkest text-grey-dark truncate">How To Install and Configure Redis on Ubuntu 18.04</a></li><li class="flex mb-2 border-b border-grey-light pb-2"><a href=https://linuxize.com/post/how-to-set-up-ssh-keys-on-debian-9/ class="font-medium text-sm hover:text-grey-darkest text-grey-dark truncate">How to Set Up SSH Keys on Debian 9</a></li><li class="flex mb-2 border-b border-grey-light pb-2"><a href=https://linuxize.com/post/secure-apache-with-let-s-encrypt-on-debian-9/ class="font-medium text-sm hover:text-grey-darkest text-grey-dark truncate">Secure Apache with Let's Encrypt on Debian 9</a></li><li class="flex mb-2 border-b border-grey-light pb-2"><a href=https://linuxize.com/post/how-to-setup-a-firewall-with-ufw-on-debian-9/ class="font-medium text-sm hover:text-grey-darkest text-grey-dark truncate">How To Set Up a Firewall with UFW on Debian 9</a></li><li class="flex mb-2 border-b border-grey-light pb-2"><a href=https://linuxize.com/post/how-to-install-and-use-composer-on-debian-9/ class="font-medium text-sm hover:text-grey-darkest text-grey-dark truncate">How To Install and Use Composer on Debian 9</a></li></ul></div><div class="flex flex-col -mt-12 lg:block lg:relative lg:sticky lg:top-16 pt-12"><div class=sideblock><div class="hidden affiliate"><a href="https://www.vultr.com/?ref=7602414" class=vultr rel=noopener target=_blank></a> <a href="https://shareasale.com/r.cfm?b=1133389&u=1755182&m=75038&urllink=&afftrack=" class="cloudways mt-8" rel=noopener target=_blank></a></div><div class="w-full flex justify-center content-center"><div class="w-full relative"><ins class="mx-auto adsbygoogle" data-ad-client=ca-pub-9439755881064125 data-ad-format=auto data-ad-slot=7027266996 style=display:block data-full-width-responsive=true></ins></div></div></div></div></div></div></div></article><section class="w-full mx-auto border-grey-lighter border-t mt-8 pt-8 max-w-article"><div class="bg-grey-lighter p-8 sm:py-8"><p class="mx-auto my-0 lg:text-2xl max-w-md sm:text-xl text-center text-lg">Sign up to our newsletter and get our latest tutorials and news straight to your mailbox.</p><form action="https://linuxize.us17.list-manage.com/subscribe/post?u=35cd4cd9d021c25c3dd7cabfd&id=9cfa4c89de" class=pt-8 id=mc-embedded-subscribe-form method=post name=mc-embedded-subscribe-form novalidate><div class="w-full mx-auto flex items-center flex-col justify-between max-w-sm mb-2 sm:flex-row"><input class="w-full block bg-white appearance-none border hover:border-grey-dark mb-3 px-4 py-3 rounded sm:mb-0 text-grey-darker" name=EMAIL aria-label=email placeholder="Your email..." type=email> <input class=hidden name=b_35cd4cd9d021c25c3dd7cabfd_9cfa4c89de tabindex=-1> <button class="w-full px-4 py-3 rounded bg-indigo-dark hover:bg-indigo-darker sm:ml-4 sm:w-auto text-white tracking-wide" name=subscribe type=submit><span class=text-center>Subscribe</span></button></div><p class="w-full mx-auto max-w-sm my-0 text-sm">We’ll never share your email address or spam you.</p></form></div></section><section class="w-full mx-auto border-grey-lighter border-t mt-8 pt-8 max-w-xl"><div class="flex flex-wrap -mx-4"><div class="w-full flex justify-center content-center"><div class="w-full relative"><ins class=adsbygoogle data-ad-client=ca-pub-9439755881064125 data-ad-format=autorelaxed data-ad-slot=8589924088 style=display:block></ins></div></div></div></section><section class="w-full mx-auto border-grey-lighter border-t mt-8 max-w-lg pt-16 py-8 relative"><a href=https://linuxize.com/post/how-to-install-and-configure-redis-on-debian-9/#disqus_thread class="w-full block bg-grey-lighter disqus-comment-count disqus-load md:py-8 py-4 text-center" title="Show comments for post">Write a comment</a><div id=disqus_thread></div><noscript>Please enable JavaScript to view the <a href=https://disqus.com/?ref_noscript>comments powered by Disqus.</a></noscript></section></main><section class="w-full block bg-white absolute h-screen invisible pin search z-50" hidden id=search-box><div class="flex flex-col min-h-screen"><header class="w-full mx-auto flex items-center h-12 sm:h-16 justify-end px-6 z-10"><a href=# class="h-6 block sm:h-8" id=btn-search-close><svg aria-hidden=true class="h-6 w-6 fill-current inline-block text-grey-darkest sm:h-8 sm:w-8 -mb-2"><use xlink:href=#close></use><title>Close search form</title></svg> <small class="block text-center sm:w-8 w-6">ESC</small></a></header><div class="w-full px-6 flex-grow flex-no-shrink pb-8 pt-16 sm:pt-24"><div class="flex flex-col mx-auto max-w-xl mb-4 mb-8"><input class="w-full font-medium appearance-none bg-transparent focus:outline-0 md:text-3xl placeholder-grey-dark search-input sm:text-2xl text-grey-darkest text-xl" placeholder="Type to search" autocomplete=off id=search-input><div class=search-results id=search-results></div><div id=hits></div><div id=stats></div><footer class=mt-6><a href=https://algolia.com rel="noopener noreferrer" target=_blank tabindex=-1><svg aria-hidden=true class="inline-block fill-current search-algolia-logo text-grey-dark"><use xlink:href=#search-by-algolia></use><title>Search by Algolia</title></svg></a></footer></div></div></div></section><footer class="w-full px-6 bg-grey-lightest"><div class="w-full mx-auto flex items-center flex-wrap justify-center max-w-xl md:justify-between md:text-left py-8 text-center"><div class="w-full mb-2 md:mb-0 md:w-1/2 text-sm"><div class="w-full block md:flex md:items-center md:w-auto"><div class=md:flex-grow><span class="block text-grey-darker mb-2 md:inline-block md:mb-0 md:mr-8">© 2018 Linuxize.com</span> <a href=/privacy-policy/ class="inline-block text-grey-darkest footer-menu-item hover:text-grey-darker md:mt-0 no-underline mr-4">Privacy Policy </a><a href=/contact/ class="inline-block text-grey-darkest footer-menu-item hover:text-grey-darker md:mt-0 no-underline mr-0">Contact</a></div></div></div><div class="w-full flex justify-center md:justify-end md:w-1/2"><a href=https://twitter.com/linuxize class="h-6 block mr-2" aria-label=Twitter><svg aria-hidden=true class="h-6 w-6 fill-current inline-block text-grey-darkest"><use xlink:href=#twitter></use><title>Twitter</title></svg> </a><a href=https://www.facebook.com/linuxize/ class="h-6 block mr-2" aria-label=Facebook><svg aria-hidden=true class="h-6 w-6 fill-current inline-block text-grey-darkest"><use xlink:href=#facebook></use><title>Facebook</title></svg> </a><a href=/index.xml class="h-6 block" aria-label=RSS><svg aria-hidden=true class="h-6 w-6 fill-current inline-block text-grey-darkest"><use xlink:href=#rss></use><title>RSS</title></svg></a></div></div></footer></div><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script src=https://cdnjs.cloudflare.com/ajax/libs/instantsearch.js/2.7.4/instantsearch.min.js></script><script src=/js/1.0779b5aaf9cf6f3138ca.js></script><script src=/js/app.b7053e1607f74b413ca7.js></script></body></html>