<!doctype html><html class=no-js lang=en-us><head><meta charset=utf-8>
<script data-cfasync='false' data-pagespeed-no-defer>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</script><script data-cfasync='false' data-pagespeed-no-defer>__ez.pel=function(){var u=[],i="/porpoiseant/army.gif";function t(e,i,t,_,d,o,n){if(__ez.dot.isDefined(e)&&0!=__ez.dot.isAnyDefined(e.getSlotElementId,e.ElementId)){var r=parseInt(__ez.dot.getTargeting(e,"ap")),a=__ez.dot.getSlotIID(e),s=__ez.dot.getAdUnit(e),p=parseInt(__ez.dot.getTargeting(e,"compid")),z=0,f=0,g=function(e){if("undefined"==typeof _ezim_d)return!1;var i=__ez.dot.getAdUnitPath(e).split("/").pop();if("object"==typeof _ezim_d&&_ezim_d.hasOwnProperty(i))return _ezim_d[i];for(var t in _ezim_d)if(t.split("/").pop()===i)return _ezim_d[t];return!1}(e);"object"==typeof g&&(void 0!==g.creative_id&&(f=g.creative_id),void 0!==g.line_item_id&&(z=g.line_item_id)),__ez.dot.isDefined(a,s)&&__ez.dot.isValid(i)&&u.push({type:"impression",impression_id:a,domain_id:__ez.dot.getDID(),unit:s,t_epoch:__ez.dot.getEpoch(0),revenue:t,est_revenue:_,ad_position:r,ad_size:"",bid_floor_filled:d,bid_floor_prev:o,stat_source_id:n,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:p,line_item_id:z,creative_id:f,data:__ez.dot.dataToStr(i)})}}function _(){if(void 0===document.visibilityState||"prerender"!==document.visibilityState){if(__ez.dot.isDefined(u)&&0<u.length){var e=__ez.dot.getURL(i)+"?orig="+(!0===__ez.template.isOrig?1:0)+"&sts="+btoa(JSON.stringify(u));void 0!==window.isAmp&&isAmp&&void 0!==window._ezaq&&_ezaq.hasOwnProperty("domain_id")&&(e+="&visit_uuid="+_ezaq.visit_uuid),(new Image).src=e}u=[]}}return{Add:t,AddAndFire:function(e,i){t(e,i,0,0,0,0,0),_()},AddById:function(e,i){var t=e.split("/");if(__ez.dot.isDefined(e)&&3===t.length&&__ez.dot.isValid(i)){var _=t[0],d=t[2];u.push({type:"impression",impression_id:d,domain_id:__ez.dot.getDID(),unit:_,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(i)})}},Fire:_,GetPixels:function(){return u}}}();var EzoicPixel=function(){this.pixels=[],this.pixelUrl="/ezoic/e.gif",("undefined"!=typeof ezJsu&&!0===ezJsu||"undefined"!=typeof _ez_sa&&!0===_ez_sa||void 0!==window.isAmp&&!0===isAmp||"undefined"!=typeof ezWp&&!0===ezWp)&&(this.pixelUrl="//g.ezoic.net"+this.pixelUrl),this.tEpoch=0,"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("t_epoch")&&(this.tEpoch=_ezaq.t_epoch)},EzoicPixelData=function(e,i){this.name=e,this.val=i};EzoicPixel.prototype={constructor:EzoicPixel,AddAndFireImpPixel:function(e,i){this.AddImpPixel(e,i,0,0,0,0,0),this.FirePixels()},AddAndFirePVPixel:function(e,i){this.AddPVPixel(e,i),this.FirePixels()},AddImpPixel:function(e,i,t,n,o,a,d){if(0!=__ez.dot.isDefined(e)&&0!=__ez.dot.isAnyDefined(e.getSlotElementId,e.ElementId)){var s=parseInt(__ez.dot.getTargeting(e,"ap")),r=__ez.dot.getSizes(e)[0],_=r.l.toString()+"x"+r.j.toString(),p="0",l="XX";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(p=_ezaq.domain_id.toString()),"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("country")&&(l=_ezaq.country);var h=__ez.dot.getSlotIID(e),c=__ez.dot.getSlotElementId(e);__ez.dot.isDefined(h,c)&&this.validateData(i)&&(i=this.convertDataToStr(i),this.pixels.push({type:"impression",impression_id:h,domain_id:p,unit:c,t_epoch:this.tEpoch,revenue:t,est_revenue:n,ad_position:s,ad_size:_,bid_floor_filled:o,bid_floor_prev:a,stat_source_id:d,country_code:l,data:i}))}},AddImpPixelById:function(e,i){var t="0";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(t=_ezaq.domain_id.toString());var n=e.split("/");if(__ez.dot.isDefined(e)&&3===n.length&&this.validateData(i)){var o=n[0],a=n[2];i=this.convertDataToStr(i),this.pixels.push({type:"impression",impression_id:a,domain_id:t,unit:o,t_epoch:this.tEpoch,data:i})}},AddPVPixel:function(e,i){var t="0";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(t=_ezaq.domain_id.toString()),__ez.dot.isDefined(e)&&this.validateData(i)&&(i=this.convertDataToStr(i),this.pixels.push({type:"pageview",pageview_id:e,domain_id:t,t_epoch:this.tEpoch,data:i}))},FirePixels:function(){void 0!==document.visibilityState&&"prerender"===document.visibilityState||(__ez.dot.isDefined(this.pixels)&&0<this.pixels.length&&((new Image).src=this.pixelUrl+"?orig="+(!0===__ez.template.isOrig?1:0)+"&pixels="+encodeURIComponent(JSON.stringify(this.pixels))),this.pixels=[])},NewData:function(e,i){return new EzoicPixelData(e,i)},convertDataToStr:function(e){if(void 0===e)return[];try{for(var i in e)e[i].val=e[i].val+""}catch(e){}return e},validateData:function(e){for(var i=0;i<e.length;i++)if(e[i]instanceof EzoicPixelData==!1)return console.error("Invalid pixelData. ",e[i]),!1;return!0}};</script><title>How to Install PHP on Debian 10 Linux | Linuxize</title><meta content="IE=edge" http-equiv=X-UA-Compatible><meta content="width=device-width,initial-scale=1,shrink-to-fit=no" name=viewport><meta content=Linuxize name=apple-mobile-web-app-title><meta content=Linuxize name=application-name><meta content=#2271ff name=theme-color><meta content=#2271ff name=msapplication-TileColor><meta content="In this guide, we will discuss how to install PHP on Debian 10, Buster. We'll also show you how to integrate PHP with Nginx and Apache." name=description><meta content=$coil.xrptipbot.com/zcpKbIbXTOOdckFuNg5Pew name=monetization><meta content=unsafe-url name=referrer><link href=https://linuxize.com/post/how-to-install-php-on-debian-10/ rel=canonical><meta content="index, follow" name=robots><meta content="How to Install PHP on Debian 10 Linux" property=og:title><meta content="In this guide, we will discuss how to install PHP on Debian 10, Buster. We'll also show you how to integrate PHP with Nginx and Apache." property=og:description><meta content=article property=og:type><meta content=/post/how-to-install-php-on-debian-10/ property=og:url><meta content=https://linuxize.com/post/how-to-install-php-on-debian-10/featured.jpg property=og:image><meta content="In this guide, we will discuss how to install PHP on Debian 10, Buster. We'll also show you how to integrate PHP with Nginx and Apache." property=og:image:alt><meta content=2019-11-17T19:04:10+01:00 property=article:published_time><meta content=2019-11-17T19:04:10+01:00 property=article:modified_time><meta content=en property=og:locale><meta content=post property=article:section><meta content=https://www.facebook.com/linuxize property=article:publisher><meta content=php property=article:tag><meta content=debian property=article:tag><meta content=php,debian name=news_keywords><meta content=summary_large_image name=twitter:card><meta content=https://linuxize.com/post/how-to-install-php-on-debian-10/featured.jpg name=twitter:image><meta content="How to Install PHP on Debian 10 Linux" name=twitter:title><meta content="In this guide, we will discuss how to install PHP on Debian 10, Buster. We'll also show you how to integrate PHP with Nginx and Apache." name=twitter:description><meta content=@linuxize name=twitter:site><link href=/favicons/apple-touch-icon.png rel=apple-touch-icon sizes=180x180><link href=/favicons/favicon-32x32.png rel=icon type=image/png sizes=32x32><link href=/favicons/favicon-16x16.png rel=icon type=image/png sizes=16x16><link href=/favicons/safari-pinned-tab.svg rel=mask-icon color=#2271ff><link href=/fonts/ibm-plex-sans-v6-latin-regular.woff2 rel=preload type=font/woff2 as=font crossorigin><link href=/fonts/ibm-plex-sans-v6-latin-500.woff2 rel=preload type=font/woff2 as=font crossorigin><link href=/fonts/ibm-plex-sans-v6-latin-700.woff2 rel=preload type=font/woff2 as=font crossorigin><link href=/fonts/ibm-plex-serif-v7-latin-regular.woff2 rel=preload type=font/woff2 as=font crossorigin><link href=/fonts/ibm-plex-serif-v7-latin-700.woff2 rel=preload type=font/woff2 as=font crossorigin><script type=application/ld+json>{
  "@context": "http://schema.org",
  "@type": "BlogPosting",
  "headline": "How to Install PHP on Debian 10 Linux",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https:\/\/linuxize.com\/post\/how-to-install-php-on-debian-10\/"
  },"image": {
     "@type": "ImageObject",
     "url": "https:\/\/linuxize.com\/post\/how-to-install-php-on-debian-10\/featured.jpg",
     "width":  1000 ,
     "height":  530 
    },"keywords": "php, debian",
  "wordcount":  411 ,
  "url": "https:\/\/linuxize.com\/post\/how-to-install-php-on-debian-10\/",
  "datePublished": "2019-11-17T19:04:10+01:00",
  "dateModified": "2019-11-17T19:04:10+01:00",
  "publisher": {
    "@type": "Organization","logo": {
    "@type": "imageObject",
      "url": "https:\/\/linuxize.com\/assets\/linuxize-card.png"
    },"name": "Linuxize"
  },

  "author": {
    "@type": "Person",
    "name": "Linuxize"
  },
  "description": "In this guide, we will discuss how to install PHP on Debian 10, Buster. We'll also show you how to integrate PHP with Nginx and Apache."
}</script><script src=/js/ads.js async></script><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-P827G6S');</script><script src=https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js async></script><script>(adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-9439755881064125",
          enable_page_level_ads: true
     });</script><script data-cfasync=false>var _foxpush = _foxpush || []; 
    _foxpush.push(['_setDomain', 'linuxizecom']); 
    (function(){ 
    var foxscript = document.createElement('script'); 
    foxscript.src = '//cdn.foxpush.net/sdk/foxpush_SDK_min.js'; 
    foxscript.type = 'text/javascript'; 
    foxscript.async = 'true'; 
    var fox_s = document.getElementsByTagName('script')[0]; 
    fox_s.parentNode.insertBefore(foxscript, fox_s);})();</script><meta content=#2271ff name=theme-color><link href=/manifest.128dc4ca8d47b9db75ffbc72b588021a.json rel=manifest><link href=/css/app.9f564c9a9368eade1205.css rel=stylesheet><link rel='canonical' href='https://linuxize.com/post/how-to-install-php-on-debian-10/' />

<script data-cfasync="false" type="text/javascript">window.google_analytics_uacct = "UA-124335151-13";</script>
<script data-cfasync="false" type="text/javascript">
var _gaq = _gaq || [];
_gaq.push(['e._setAccount', 'UA-124335151-13']);
_gaq.push(['f._setAccount', 'UA-38339005-1']);
_gaq.push(['e._setDomainName', 'linuxize.com']);
_gaq.push(['f._setDomainName', 'linuxize.com']);
_gaq.push(['e._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['e._setCustomVar',2,'t','126',3]);
_gaq.push(['e._setCustomVar',3,'rid','0',2]);
_gaq.push(['e._setCustomVar',4,'bra','mod32',3]);
_gaq.push(['e._setAllowAnchor',true]);
_gaq.push(['e._setSiteSpeedSampleRate', 10]);
_gaq.push(['f._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['f._setCustomVar',2,'domain','linuxize.com',3]);
_gaq.push(['f._setSiteSpeedSampleRate', 20]);
_gaq.push(['e._trackPageview']);
_gaq.push(['f._trackPageview']);


(function() {
 var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
 ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
 var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
})();
</script>
<script type="text/javascript">var ezouid = "1";</script><base href="https://linuxize.com/post/how-to-install-php-on-debian-10/"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script type='text/javascript'>
var soc_app_id = '0';
var did = 93605;
var ezdomain = 'linuxize.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":93605,"engaged_time_visit":0,"ezcache_level":1,"forensiq_score":-1,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"24ce4ae9-cc3d-4de9-77a8-e00110f0a620","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_time_orig":9,"serverid":"54.81.226.99:4781","state":"VA","t_epoch":1574086431,"template_id":126,"time_on_site_visit":0,"url":"https://linuxize.com/post/how-to-install-php-on-debian-10/","user_id":0,"word_count":635,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script><script data-cfasync='false' type="text/javascript" src="/detroitchicago/rochester.js?cb=188-0&v=8" async></script>
<script data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl() {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_93605=" + new Date().getTime() + "|24ce4ae9-cc3d-4de9-77a8-e00110f0a620; " + expires, 3);
}
function attach_ezolpl() {
    if(window.attachEvent) {
        window.attachEvent('onload', create_ezolpl);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl();
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl;
        }
    }
}
attach_ezolpl();
</script></head><body class="font-sans kind-page leading-normal section-post text-gray-800 type-post"><div class="flex flex-col min-h-screen main-wrap"><header class="w-full px-6 bg-white border-b border-gray-400 fixed linuxize-shadow z-50" id=header><nav class="w-full flex items-center mx-auto h-12 justify-start md:h-16"><a href=/ class="flex items-center block flex-shrink-0 mr-6 no-underline text-black" aria-label=Linuxize.com><svg aria-hidden=true class="h-6 w-6 fill-current md:h-8 md:w-8 mr-2" role=img><use xlink:href=/svg/sprite.svg#logo></use></svg> <span class="font-medium tracking-tight hidden md:block text-md">Linuxize</span></a><div class="flex -mb-px flex-1 min-w-0 text-sm"><a href=/tags/ubuntu/ class="hidden md:block hover:text-gray-900 mr-4 no-underline text-gray-800"><span class="inline-block font-bold md:py-4 md:py-6 py-3">Ubuntu </span></a><a href=/tags/centos/ class="hidden md:block hover:text-gray-900 mr-4 no-underline text-gray-800"><span class="inline-block font-bold md:py-4 md:py-6 py-3">Centos </span></a><a href=/tags/debian/ class="hidden md:block hover:text-gray-900 mr-4 no-underline text-gray-800"><span class="inline-block font-bold md:py-4 md:py-6 py-3">Debian </span></a><a href=/tags/terminal/ class="hidden md:block hover:text-gray-900 mr-4 no-underline text-gray-800"><span class="inline-block font-bold md:py-4 md:py-6 py-3">Commands </span></a><a href=/series/ class="hidden md:block hover:text-gray-900 mr-4 no-underline text-gray-800"><span class="inline-block font-bold md:py-4 md:py-6 py-3">Series </span></a><a href=https://www.buymeacoffee.com/8swZOSU6I class="hidden md:block hover:text-gray-900 mr-4 no-underline text-gray-800 mr-0"><span class="inline-block font-bold md:py-4 md:py-6 py-3">Donate</span></a></div><div class="flex justify-end"><button class="block h-6 md:h-8" aria-label=Search id=btn-search><svg aria-hidden=true class="inline-block fill-current h-6 w-6 text-gray-900 md:h-8 md:w-8" role=img><use xlink:href=/svg/sprite.svg#search></use></svg></button></div></nav></header><main class="w-full flex-grow flex-shrink-0 pb-8 pt-16 sm:pt-24 main"><article class="relative single-post"><div class="w-full mx-auto px-6 post-width"><div class="mb-4 post-header xl:mb-8"><h1 class="mb-2 text-gray-800 font-bold leading-none lg:text-3xl text-2xl xxl:text-4xl">How to Install PHP on Debian 10 Linux</h1><div class="flex flex-col font-medium md:flex-row text-gray-700 text-xs"><div class="inline-flex flex-row"><p class="font-medium text-xs leading-normal rounded-sm"><span>Posted </span><time class="" datetime=2019-11-17T19:04:10+01:00>Nov 17, 2019</time></p><span class="inline-block mx-2">•</span><p>2 min read</p></div></div></div><div class=lg:flex><div class="w-full lg:max-h-full lg:overflow-visible lg:static min-h-screen"><div class=flex><div class="w-full pb-8"><div class="flex flex-col xl:flex-relative xl:flex-row"><aside class="w-full block hidden sidebar2 xxl:block" id=sidebar2><div class="w-full flex justify-center content-center"><div class="w-full relative"><ins class="hidden adsbygoogle mx-auto sidebar2-as xl:block" data-ad-client=ca-pub-9439755881064125 data-ad-format=horizontal,rectangle data-ad-slot=4501323511 style=display:block data-full-width-responsive=true></ins></div></div><div class="mb-6 wrap-collabsible"><input class="hidden toggle" type=checkbox id=collapsible> <label class="flex items-center block bg-indigo-700 cursor-pointer hover:bg-indigo-800 justify-between lbl-toggle px-4 py-2 relative text-white" for=collapsible><div class="font-medium text-sm tracking-wide"><span>Not using Debian 10?</span><br><span>Choose different OS:</span></div><div class=ml-3><svg aria-hidden=true class="inline-block fill-current icon h-5 w-5 white" role=img><use xlink:href=/svg/sprite.svg#arrow-right></use></svg></div></label><div class="bg-gray-200 collapsible-content"><div class="w-full distro-versions flex-wrap inline-flex items-center pt-2"><div class="w-full px-4 mb-2 pb-2"><a href=/post/install-php-7-on-centos-7/ class="w-full flex block capitalize font-medium hover:text-gray-900 leading-normal text-gray-700 text-xs xxl:text-sm"><span class=mr-2><svg aria-hidden=true class="inline-block fill-current icon h-3 w-3" role=img><use xlink:href=/svg/sprite.svg#link></use></svg> </span><span>centos 7</span></a></div><div class="w-full px-4 mb-2 pb-2"><a href=/post/how-to-install-php-on-centos-8/ class="w-full flex block capitalize font-medium hover:text-gray-900 leading-normal text-gray-700 text-xs xxl:text-sm"><span class=mr-2><svg aria-hidden=true class="inline-block fill-current icon h-3 w-3" role=img><use xlink:href=/svg/sprite.svg#link></use></svg> </span><span>centos 8</span></a></div><div class="w-full px-4 mb-2 pb-2"><a href=/post/how-to-install-php-on-ubuntu-18-04/ class="w-full flex block capitalize font-medium hover:text-gray-900 leading-normal text-gray-700 text-xs xxl:text-sm"><span class=mr-2><svg aria-hidden=true class="inline-block fill-current icon h-3 w-3" role=img><use xlink:href=/svg/sprite.svg#link></use></svg> </span><span>ubuntu 18.04</span></a></div></div></div></div><div class="w-full -mt-12 flex-col hidden justify-between pb-4 pt-12 sticky top-16 xl:flex"><div class="bg-gray-200 mb-6 p-4 pb-2 overflow-auto table-of-contents toc"><p class="font-medium text-xs mb-3 mb-3 tracking-tight uppercase xxl:text-sm text-gray-800">Contents</p><div class="relative overflow-hidden"><div class="lg:max-h-toc overflow-y-auto scrollbar-thumb-gray scrollbar-thumb-rounded scrollbar-track-gray-lighter scrollbar-w-2 scrolling-touch"><nav id=TableOfContents><ul><li><ul><li><a href=#prerequisites>Prerequisites</a></li><li><a href=#installing-php-with-apache>Installing PHP with Apache</a></li><li><a href=#installing-php-with-nginx>Installing PHP with Nginx</a></li><li><a href=#installing-php-extensions>Installing PHP extensions</a></li><li><a href=#testing-php-processing>Testing PHP Processing</a></li><li><a href=#conclusion>Conclusion</a></li></ul></li></ul></nav></div></div><p class="font-medium text-xs mb-3 mb-3 tracking-tight uppercase xxl:text-sm border-gray-400 border-t mt-2 pt-4">Share</p><section class="w-full mx-auto"><nav class="flex flex-wrap"><a href="https://twitter.com/share?text=How%20to%20Install%20PHP%20on%20Debian%2010%20Linux&url=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-install-php-on-debian-10%2f" class="h-6 w-6 mb-4 mr-3" target=_blank rel=noopener><svg aria-hidden=true class="inline-block fill-current h-6 w-6 hover:text-blue-600 text-gray-600" role=img><use xlink:href=/svg/sprite.svg#twitter></use></svg> </a><a href="https://www.facebook.com/sharer/sharer.php?caption=How%20to%20Install%20PHP%20on%20Debian%2010%20Linux&u=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-install-php-on-debian-10%2f" class="h-6 w-6 mb-4 mr-3" target=_blank rel=noopener><svg aria-hidden=true class="inline-block fill-current h-6 w-6 hover:text-blue-600 text-gray-600" role=img><use xlink:href=/svg/sprite.svg#facebook></use></svg> </a><a href="https://pinterest.com/pin/create/button/?url=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-install-php-on-debian-10%2f&media=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-install-php-on-debian-10%2ffeatured.jpg&description=How%20to%20Install%20PHP%20on%20Debian%2010%20Linux" class="h-6 w-6 mb-4 mr-3" target=_blank rel=noopener><svg aria-hidden=true class="inline-block fill-current h-6 w-6 hover:text-blue-600 text-gray-600" role=img><use xlink:href=/svg/sprite.svg#pinterest></use></svg> </a><a href="https://plus.google.com/share?url=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-install-php-on-debian-10%2f" class="h-6 w-6 mb-4 mr-3" target=_blank rel=noopener><svg aria-hidden=true class="inline-block fill-current h-6 w-6 hover:text-blue-600 text-gray-600" role=img><use xlink:href=/svg/sprite.svg#gplus></use></svg> </a><a href="https://news.ycombinator.com/submitlink?t=How%20to%20Install%20PHP%20on%20Debian%2010%20Linux&u=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-install-php-on-debian-10%2f" class="h-6 w-6 mb-4 mr-3" target=_blank rel=noopener><svg aria-hidden=true class="inline-block fill-current h-6 w-6 hover:text-blue-600 text-gray-600" role=img><use xlink:href=/svg/sprite.svg#hacker-news></use></svg> </a><a href="mailto:?subject=How%20to%20Install%20PHP%20on%20Debian%2010%20Linux&body=Check%20out%20this%20article:%0A%0Ahttps%3a%2f%2flinuxize.com%2fpost%2fhow-to-install-php-on-debian-10%2f" class="h-6 w-6 mb-4" target=_blank rel=noopener><svg aria-hidden=true class="inline-block fill-current h-6 w-6 hover:text-blue-600 text-gray-600" role=img><use xlink:href=/svg/sprite.svg#email></use></svg></a></nav></section></div></div></aside><section class="w-full mx-auto lg:ml-0 lg:mr-auto lg:pr-6 min-w-0 xl:mx-0 xl:w-full xxl:px-6"><figure class="relative -mx-6 lg:mx-0 mb-6"><div class="w-full mx-auto my-0 block relative"><div class=block style=padding-bottom:53%></div><div class="w-full h-full absolute inset-0 m-auto overflow-hidden bg-gray-200"><img alt="" class="w-full h-full absolute inset-0 m-auto lazy lazyload" src="data:image/gif;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAYAAAAfFcSJAAAADUlEQVR42mP8+PXHfwAJnAPfCuZXlQAAAABJRU5ErkJggg==" data-sizes=auto data-src=/post/how-to-install-php-on-debian-10/featured_hu1f4f3afe71bd34ad3ac991550594e137_24999_600x0_resize_q95_box.jpg data-srcset="
              /post/how-to-install-php-on-debian-10/featured_hu1f4f3afe71bd34ad3ac991550594e137_24999_600x0_resize_q95_box.jpg 600w,
              /post/how-to-install-php-on-debian-10/featured.jpg 1000w
            "><noscript><img alt="" class="w-full h-full absolute inset-0 m-auto" src=/post/how-to-install-php-on-debian-10/featured.jpg></noscript></div></div></figure><div class=markdown><p>PHP is one of the most used server-side programming languages.</p><p>In this guide, we will discuss how to install PHP on Debian 10, Buster. We’ll also show you how to integrate PHP with Nginx and Apache.</p><p>Debian 10 ships with PHP version 7.3, which is supported by the most popular CMS and frameworks such as WordPress, Magento, and Laravel.</p><h2 id=prerequisites>Prerequisites</h2><p>To be able to install packages, you need to be logged in as root or <a href=https://linuxize.com/post/how-to-create-a-sudo-user-on-debian/ >user with sudo privileges</a>.</p><h2 id=installing-php-with-apache>Installing PHP with Apache</h2><p>If you are using <a href=https://linuxize.com/post/how-to-install-apache-on-debian-10/ >Apache</a> as your webserver to install PHP and Apache PHP module run the following commands:</p><div class=highlight><pre class=chroma><code class=language-console-bash data-lang=console-bash>sudo apt update
sudo apt install php libapache2-mod-php</code></pre></div><p>Once the installation is complete, restart Apache to load the PHP module:</p><div class=highlight><pre class=chroma><code class=language-console-bash data-lang=console-bash>sudo systemctl restart apache2</code></pre></div><h2 id=installing-php-with-nginx>Installing PHP with Nginx</h2><p>Unlike Apache, <a href=https://linuxize.com/post/how-to-install-nginx-on-debian-10/ >Nginx</a> doesn’t have a built-in support for processing PHP files. You’ll need to use the PHP FPM (“fastCGI process manager”) service to handle the PHP files.</p><p>Install the PHP and PHP FPM packages by running the following command:</p><div class=highlight><pre class=chroma><code class=language-console-bash data-lang=console-bash>sudo apt update
sudo apt install php php-fpm</code></pre></div><p>Once the packages are installed, the PHP FPM service will start automatically.</p><p>You can now edit your domain Nginx server block and add the following lines so that Nginx can process PHP files:</p><div class=highlight><pre class=chroma><code class=language-nginx data-lang=nginx><span class=k>server</span> <span class=p>{</span>

    <span class=c1># . . . other code
</span><span class=c1></span>
<span class=hl>    <span class=kn>location</span> <span class=p>~</span> <span class=sr>\.php$</span> <span class=p>{</span>
</span><span class=hl>        <span class=kn>include</span> <span class=s>snippets/fastcgi-php.conf</span><span class=p>;</span>
</span><span class=hl>        <span class=kn>fastcgi_pass</span> <span class=s>unix:/run/php/php7.3-fpm.sock</span><span class=p>;</span>
</span><span class=hl>    <span class=p>}</span>
</span><span class=p>}</span></code></pre></div><p>Save the configuration file and <a href=https://linuxize.com/post/nginx-commands-you-should-know/ >restart the nginx service</a> for the new configuration take effect:</p><div class=highlight><pre class=chroma><code class=language-console-bash data-lang=console-bash>sudo systemctl restart nginx</code></pre></div><div class="w-full flex justify-center content-center"><div class="w-full relative"><ins class=adsbygoogle data-ad-client=ca-pub-9439755881064125 data-ad-format=fluid data-ad-slot=5120214995 style=display:block data-ad-layout=in-article></ins></div></div><h2 id=installing-php-extensions>Installing PHP extensions</h2><p>You can extend the PHP core functionalities by installing additional extensions. PHP extensions are available as packages and can be easily installed by typing:</p><div class=highlight><pre class=chroma><code class=language-console-bash data-lang=console-bash>sudo apt install php-[extname]</code></pre></div><p>For example, to install MySQL and GD PHP extensions, you would run the following command:</p><div class=highlight><pre class=chroma><code class=language-console-bash data-lang=console-bash>sudo apt install php-mysql php-gd</code></pre></div><p>When installing PHP extensions, do not forget to restart the Apache or the PHP FPM service, depending on your setup.</p><h2 id=testing-php-processing>Testing PHP Processing</h2><p>To test whether your web server is properly configured for PHP processing, create a new file called info.php inside the <code>/var/www/html</code> directory with the following code:</p><div class=code-label>/var/www/html/info.php</div><div class=highlight><pre class=chroma><code class=language-php data-lang=php><span class=cp>&lt;?php</span>

<span class=nx>phpinfo</span><span class=p>();</span>
</code></pre></div><p>Save the file, open your browser of choice and visit <code>http://your_server_ip/info.php</code></p><p>The <code>phpinfo</code> function prints information about your PHP configuration as shown on the image below:</p><figure class=relative><div class="w-full mx-auto my-0 block relative"><div class=block style=padding-bottom:101.64512338425382%></div><div class="w-full h-full absolute inset-0 m-auto overflow-hidden text-center"><img alt="" class=lazyload src="data:image/gif;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAYAAAAfFcSJAAAADUlEQVR42mP8+PXHfwAJnAPfCuZXlQAAAABJRU5ErkJggg==" data-sizes=auto data-src=/post/how-to-install-php-on-debian-10/phpinfo-debian_hub42ca3785d0c06faaf881b0ca8608dc8_169489_600x0_resize_q75_box.jpg data-srcset="
              /post/how-to-install-php-on-debian-10/phpinfo-debian_hub42ca3785d0c06faaf881b0ca8608dc8_169489_600x0_resize_q75_box.jpg 600w,
              /post/how-to-install-php-on-debian-10/phpinfo-debian.jpg 851w
            " data-action=zoom><noscript><img alt="" class="w-full h-full absolute inset-0 m-auto" src=/post/how-to-install-php-on-debian-10/phpinfo-debian.jpg></noscript></div></div></figure><h2 id=conclusion>Conclusion</h2><p>We have shown you how to install PHP on Debian 10 and configure your webserver to process PHP files.</p><p>If you have any questions or feedback, do not hesitate to leave a comment.</p><div class="flex flex-wrap my-6"><a href=/tags/php/ class="font-medium text-sm tracking-wide bg-indigo-700 hover:bg-indigo-800 mr-2 mt-2 px-4 py-2 rounded text-white">php</a> <a href=/tags/debian/ class="font-medium text-sm tracking-wide bg-indigo-700 hover:bg-indigo-800 mr-2 mt-2 px-4 py-2 rounded text-white">debian</a></div></div></section></div></div></div></div><div class="w-full absolute hidden -mb-16 flex-grow lg:-mb-0 lg:block lg:pt-0 lg:static sidebar top-16 z-40" id=sidebar><div class=sideblock><div class="w-full flex justify-center content-center"><div class="w-full relative"><ins class="hidden adsbygoogle mx-auto lg:block" data-ad-client=ca-pub-9439755881064125 data-ad-format=auto data-ad-slot=9558702194 style=display:block data-full-width-responsive=true></ins></div></div></div><div class="bg-gray-200 mb-6 p-4 pb-2 related-content"><p class="font-medium text-xs mb-3 mb-3 tracking-tight uppercase xxl:text-sm text-gray-800">Related Tutorials</p><ul class="mt-4 border-gray-400 border-t mb-0 pt-3"><li class="flex mb-2 border-b border-gray-400 pb-2"><a href=https://linuxize.com/post/how-to-install-and-secure-phpmyadmin-with-apache-on-debian-9/ class="font-medium text-gray-700 hover:text-gray-900 text-sm">How to Install and Secure phpMyAdmin with Apache on Debian 9</a></li><li class="flex mb-2 border-b border-gray-400 pb-2"><a href=https://linuxize.com/post/how-to-install-and-use-composer-on-debian-9/ class="font-medium text-gray-700 hover:text-gray-900 text-sm">How To Install and Use PHP Composer on Debian 9</a></li><li class="flex mb-2 border-b border-gray-400 pb-2"><a href=https://linuxize.com/post/how-to-install-php-on-debian-9/ class="font-medium text-gray-700 hover:text-gray-900 text-sm">How to Install PHP on Debian 9</a></li><li class="flex mb-2 border-b border-gray-400 pb-2"><a href=https://linuxize.com/post/how-to-install-anaconda-on-debian-10/ class="font-medium text-gray-700 hover:text-gray-900 text-sm">How to Install Anaconda on Debian 10</a></li><li class="flex mb-2 border-b border-gray-400 pb-2"><a href=https://linuxize.com/post/how-to-install-tomcat-9-on-debian-10/ class="font-medium text-gray-700 hover:text-gray-900 text-sm">How to Install Tomcat 9 on Debian 10 Linux</a></li><li class="flex mb-2 border-b border-gray-400 pb-2"><a href=https://linuxize.com/post/how-to-add-user-to-sudoers-in-debian/ class="font-medium text-gray-700 hover:text-gray-900 text-sm">How to Add User to Sudoers in Debian</a></li><li class="flex mb-2 border-b border-gray-400 pb-2"><a href=https://linuxize.com/post/how-to-install-postgresql-on-debian-10/ class="font-medium text-gray-700 hover:text-gray-900 text-sm">How to Install PostgreSQL on Debian 10</a></li></ul></div><div class="flex flex-col -mt-12 lg:block lg:relative lg:sticky lg:top-16 pt-12"><div class=sideblock><div class="hidden affiliate"><a href="https://www.vultr.com/?ref=6812257" class=vultr target=_blank rel=noopener></a></div><div class="w-full flex justify-center content-center"><div class="w-full relative"><ins class="adsbygoogle mx-auto" data-ad-client=ca-pub-9439755881064125 data-ad-format=auto data-ad-slot=7027266996 style=display:block data-full-width-responsive=true></ins></div></div></div></div></div></div></div></article><div class=px-6><section class="w-full mx-auto border-gray-200 border-t mt-8 pt-8 max-w-article"><div class="p-8 sm:py-8 bg-orange-100"><p class="text-sm mx-auto my-0 lg:text-base max-w-md sm:text-base text-center text-orange-800">If you like our content, please consider buying us a coffee.<br>Thank you for your support!</p><div class="w-full flex justify-center items-center mx-auto flex-col max-w-sm mt-6 sm:flex-row"><a href=https://www.buymeacoffee.com/8swZOSU6I class="font-bold bg-orange-500 hover:bg-orange-600 inline-flex items-center px-4 py-2 rounded text-orange-100" target=_blank><svg aria-hidden=true class="inline-block fill-current h-6 w-6 text-gray-900" role=img><use xlink:href=/svg/sprite.svg#bmc></use></svg> <span class="font-medium text-xs ml-2 uppercase">Buy me a coffee</span></a></div></div></section><section class="w-full mx-auto border-gray-200 border-t mt-8 pt-8 max-w-article"><div class="bg-gray-200 p-8 sm:py-8"><p class="text-sm mx-auto my-0 lg:text-base max-w-md sm:text-base text-center">Sign up to our newsletter and get our latest tutorials and news straight to your mailbox.</p><form action="https://linuxize.us17.list-manage.com/subscribe/post?u=35cd4cd9d021c25c3dd7cabfd&id=9cfa4c89de" class=pt-8 id=mc-embedded-subscribe-form method=post name=mc-embedded-subscribe-form novalidate><div class="w-full flex flex-col items-center max-w-sm mx-auto sm:flex-row justify-between mb-2"><input class="w-full block bg-white appearance-none border hover:border-gray-700 mb-3 px-4 py-3 rounded sm:mb-0 text-gray-800" name=EMAIL aria-label=email placeholder="Your email..." type=email> <input class=hidden name=b_35cd4cd9d021c25c3dd7cabfd_9cfa4c89de tabindex=-1> <button class="w-full px-4 py-3 rounded bg-indigo-700 hover:bg-indigo-800 sm:ml-4 sm:w-auto text-white tracking-wide" name=subscribe type=submit><span class=text-center>Subscribe</span></button></div><p class="w-full mx-auto my-0 max-w-sm text-sm">We’ll never share your email address or spam you.</p></form></div></section><section class="w-full mx-auto border-gray-200 border-t mt-8 pt-8 max-w-5xl"><div class="flex flex-wrap -mx-4"><a href=https://linuxize.com/post/how-to-install-and-secure-phpmyadmin-with-apache-on-debian-9/ class="w-full flex md:mb-0 md:w-1/3 overflow-hidden px-4 mb-8"><div class="w-full flex flex-col h-full"><p class="uppercase text-xs font-normal text-gray-700">Nov 21, 2018</p><div class="mb-2 text-gray-800 flex-grow font-normal md:mb-4 text-lg">How to Install and Secure phpMyAdmin with Apache on Debian 9</div><div><figure class=relative><div class="w-full mx-auto my-0 block relative"><div class=block style=padding-bottom:53%></div><div class="w-full h-full absolute inset-0 m-auto overflow-hidden bg-gray-200"><img alt="" class="w-full h-full absolute inset-0 m-auto lazy lazyload" src="data:image/gif;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAYAAAAfFcSJAAAADUlEQVR42mP8+PXHfwAJnAPfCuZXlQAAAABJRU5ErkJggg==" data-sizes=auto data-src=/post/how-to-install-and-secure-phpmyadmin-with-apache-on-debian-9/featured_huec0bc489af41920698a50cc7b6fc7a71_71332_600x0_resize_q95_box.jpg data-srcset="
              /post/how-to-install-and-secure-phpmyadmin-with-apache-on-debian-9/featured_huec0bc489af41920698a50cc7b6fc7a71_71332_600x0_resize_q95_box.jpg 600w,
              /post/how-to-install-and-secure-phpmyadmin-with-apache-on-debian-9/featured.jpg 1000w
            "><noscript><img alt="" class="w-full h-full absolute inset-0 m-auto" src=/post/how-to-install-and-secure-phpmyadmin-with-apache-on-debian-9/featured.jpg></noscript></div></div></figure></div></div></a><a href=https://linuxize.com/post/how-to-install-and-use-composer-on-debian-9/ class="w-full flex md:mb-0 md:w-1/3 overflow-hidden px-4 mb-8"><div class="w-full flex flex-col h-full"><p class="uppercase text-xs font-normal text-gray-700">Oct 16, 2018</p><div class="mb-2 text-gray-800 flex-grow font-normal md:mb-4 text-lg">How To Install and Use PHP Composer on Debian 9</div><div><figure class=relative><div class="w-full mx-auto my-0 block relative"><div class=block style=padding-bottom:53%></div><div class="w-full h-full absolute inset-0 m-auto overflow-hidden bg-gray-200"><img alt="" class="w-full h-full absolute inset-0 m-auto lazy lazyload" src="data:image/gif;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAYAAAAfFcSJAAAADUlEQVR42mP8+PXHfwAJnAPfCuZXlQAAAABJRU5ErkJggg==" data-sizes=auto data-src=/post/how-to-install-and-use-composer-on-debian-9/featured_hucf5ea943984b7cd6493fcaba5c354293_49958_600x0_resize_q95_box.jpg data-srcset="
              /post/how-to-install-and-use-composer-on-debian-9/featured_hucf5ea943984b7cd6493fcaba5c354293_49958_600x0_resize_q95_box.jpg 600w,
              /post/how-to-install-and-use-composer-on-debian-9/featured.jpg 1000w
            "><noscript><img alt="" class="w-full h-full absolute inset-0 m-auto" src=/post/how-to-install-and-use-composer-on-debian-9/featured.jpg></noscript></div></div></figure></div></div></a><a href=https://linuxize.com/post/how-to-install-php-on-debian-9/ class="w-full flex md:mb-0 md:w-1/3 overflow-hidden px-4 mb-0"><div class="w-full flex flex-col h-full"><p class="uppercase text-xs font-normal text-gray-700">Aug 30, 2018</p><div class="mb-2 text-gray-800 flex-grow font-normal md:mb-4 text-lg">How to Install PHP on Debian 9</div><div><figure class=relative><div class="w-full mx-auto my-0 block relative"><div class=block style=padding-bottom:53%></div><div class="w-full h-full absolute inset-0 m-auto overflow-hidden bg-gray-200"><img alt="" class="w-full h-full absolute inset-0 m-auto lazy lazyload" src="data:image/gif;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAYAAAAfFcSJAAAADUlEQVR42mP8+PXHfwAJnAPfCuZXlQAAAABJRU5ErkJggg==" data-sizes=auto data-src=/post/how-to-install-php-on-debian-9/featured_huf64f4f87688687dd00c9d463d22dd476_55912_600x0_resize_q95_box.jpg data-srcset="
              /post/how-to-install-php-on-debian-9/featured_huf64f4f87688687dd00c9d463d22dd476_55912_600x0_resize_q95_box.jpg 600w,
              /post/how-to-install-php-on-debian-9/featured.jpg 1000w
            "><noscript><img alt="" class="w-full h-full absolute inset-0 m-auto" src=/post/how-to-install-php-on-debian-9/featured.jpg></noscript></div></div></figure></div></div></a></div></section><section class="w-full mx-auto relative border-gray-200 border-t max-w-3xl mt-8 pt-16 py-8"><a href=https://linuxize.com/post/how-to-install-php-on-debian-10/#disqus_thread class="w-full block bg-gray-200 disqus-comment-count disqus-load md:py-8 py-4 text-center" title="Show comments for post">Write a comment</a><div id=disqus_thread></div><noscript>Please enable JavaScript to view the <a href=https://disqus.com/?ref_noscript>comments powered by Disqus.</a></noscript></section></div></main><section class="w-full absolute inset-0 bg-white block h-screen hidden search z-100" id=search-box><div class="flex flex-col min-h-screen"><header class="w-full flex items-center mx-auto h-12 justify-end px-6 sm:h-16 z-10"><a href=# class="block h-6 sm:h-8" id=btn-search-close><svg aria-hidden=true class="inline-block fill-current h-6 w-6 text-gray-900 sm:h-8 sm:w-8" role=img><use xlink:href=/svg/sprite.svg#close></use></svg> <small class="block text-center sm:w-8 w-6">ESC</small></a></header><div class="w-full px-6 flex-grow flex-shrink-0 pb-8 pt-16 sm:pt-24"><div class="flex flex-col mx-auto max-w-screen-xl mb-4 mb-8"><div class=searchbox-container id=searchbox></div><div class=search-results id=search-results></div><div id=hits></div><div id=stats></div><footer class=mt-6><a href=https://www.algolia.com/doc/ target=_blank rel="noopener noreferrer" tabindex=-1><svg aria-hidden=true class="inline-block fill-current search-algolia-logo text-gray-700" role=img><use xlink:href=/svg/sprite.svg#search-by-algolia></use></svg></a></footer></div></div></div></section><footer class="w-full px-6 bg-gray-100"><div class="w-full flex justify-center items-center mx-auto flex-wrap lg:justify-between lg:text-left max-w-screen-xl py-8 text-center"><div class="w-full lg:w-1/2 lg:mb-0 mb-2 text-sm"><div class="w-full block lg:flex lg:items-center lg:w-auto"><div class=lg:flex-grow><span class="block text-gray-800 lg:inline-block lg:mb-0 lg:mr-8 mb-2">© 2019 Linuxize.com</span> <a href=/privacy-policy/ class="inline-block text-gray-900 footer-menu-item hover:text-gray-800 lg:mt-0 no-underline mr-4">Privacy Policy </a><a href=/contact/ class="inline-block text-gray-900 footer-menu-item hover:text-gray-800 lg:mt-0 no-underline mr-0">Contact</a></div></div></div><div class="w-full flex justify-center lg:justify-end lg:w-1/2"><a href=https://twitter.com/linuxize class="block h-6 mr-2" aria-label=Twitter><svg aria-hidden=true class="inline-block fill-current h-6 w-6 text-gray-900" role=img><use xlink:href=/svg/sprite.svg#twitter></use></svg> </a><a href=https://www.facebook.com/linuxize/ class="block h-6 mr-2" aria-label=Facebook><svg aria-hidden=true class="inline-block fill-current h-6 w-6 text-gray-900" role=img><use xlink:href=/svg/sprite.svg#facebook></use></svg> </a><a href=/index.xml class="block h-6" aria-label=RSS><svg aria-hidden=true class="inline-block fill-current h-6 w-6 text-gray-900" role=img><use xlink:href=/svg/sprite.svg#rss></use></svg></a></div></div></footer></div><script src=https://cdnjs.cloudflare.com/ajax/libs/algoliasearch/3.32.1/algoliasearchLite.min.js></script><script src=https://cdnjs.cloudflare.com/ajax/libs/instantsearch.js/3.1.1/instantsearch.production.min.js></script><script src=/js/1.ce7a7db3de48392186fa.js></script><script src=/js/app.9f564c9a9368eade1205.js></script><script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('edmonton.php', '/detroitchicago/edmonton.webp?a=a&cb=0&shcb=32', true, [], true, false, false, false);
__ez.queue.addFile('jellyfish.php', '/porpoiseant/jellyfish.webp?a=a&cb=0&shcb=32', false, [], true, false, false, false);
</script>

<script>var _audins_dom="linuxize_com",_audins_did=93605;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=188-0");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.linuxize_com,DomainId.93605" border="0" height="1" width="1" alt="Quantcast"/></div></noscript><noscript><img src="https://sb.scorecardresearch.com/p?c1=2&c2=20015427&cv=2.0&cj=1"/></noscript>
<script type='text/javascript'>(function(){function f(b,d){for(var c=0;c<d.length;c++){var e=d[c];if(0==e.complete||"undefined"!=typeof e.readyState&&4>e.readyState){var k=e.getAttribute("src")||e.currentSrc;"undefined"!=typeof e.readyState&&0==e.readyState?e.addEventListener("loadstart",function(g){var l=g.getAttribute("src")||g.currentSrc;h(g,l)}):(k=e.getAttribute("src")||e.currentSrc,h(e,k));e.addEventListener("load",function(g){var l=g.currentTarget.getAttribute("src")||g.srcElement.currentSrc;m(g,l)});e.addEventListener("loadeddata",
	function(g){var l=g.currentTarget.getAttribute("src")||g.srcElement.currentSrc;m(g,l)});e.addEventListener("error",function(g){var l=g.currentTarget.getAttribute("src")||g.srcElement.currentSrc;m(g,l)})}}}function a(b){for(var d=0;d<document.styleSheets.length;d++)if(document.styleSheets[d].href==b)return!0;return!1}f("img",document.querySelectorAll("img"));f("video",document.querySelectorAll("video"));f("audio",document.querySelectorAll("audio"));(function(b){for(var d=0;d<b.length;d++){var c=b[d];
	if("stylesheet"==c.getAttribute("rel")&&null!=c.getAttribute("href")&&a(c.getAttribute("href"))){h(c,c.getAttribute("href"));var e=document.createElement("img");e.onerror=function(k){m(c,k.path[0].currentSrc)};e.src=c.getAttribute("href")}}})(document.querySelectorAll("link"))})();</script></body></html>