<!DOCTYPE html><html class=no-js lang=en-us><head><title>How to Setup Automatic Odoo Backup | Linuxize</title><meta charset=utf-8><meta content="IE=edge" http-equiv=X-UA-Compatible><meta content="width=device-width,initial-scale=1,shrink-to-fit=no" name=viewport><meta content=Linuxize name=apple-mobile-web-app-title><meta content=Linuxize name=application-name><meta content=#2271ff name=theme-color><meta content=#2271ff name=msapplication-TileColor><meta content="In this tutorial we will walk you through the process of creating automatic daily backups of your Odoo databases. Odoo is the most popular open source ERP system written in Python and uses PostgreSQL as database back-end. /" name=description><meta content=unsafe-url name=referrer><link href=https://linuxize.com/post/how-to-setup-automatic-odoo-backup/ rel=canonical><meta content="index, follow" name=robots><meta content="Hugo 0.36.1" name=generator><meta content="How to Setup Automatic Odoo Backup" property=og:title><meta content="In this tutorial we will walk you through the process of creating automatic daily backups of your Odoo databases. Odoo is the most popular open source ERP system written in Python and uses PostgreSQL as database back-end." property=og:description><meta content=article property=og:type><meta content=/post/how-to-setup-automatic-odoo-backup/ property=og:url><meta content=https://linuxize.com/post/how-to-setup-automatic-odoo-backup/featured.jpg property=og:image><meta content="In this tutorial we will walk you through the process of creating automatic daily backups of your Odoo databases. Odoo is the most popular open source ERP system written in Python and uses PostgreSQL as database back-end." property=og:image:alt><meta content=2018-04-14T00:31:47+01:00 property=article:published_time><meta content=2018-04-14T00:31:47+01:00 property=article:modified_time><meta content=en property=og:locale><meta content=post property=article:section><meta content=https://www.facebook.com/linuxize property=article:publisher><meta content=odoo property=article:tag><meta content=cron property=article:tag><meta content=cronjob property=article:tag><meta content=backup property=article:tag><meta content=odoo,cron,cronjob,backup name=news_keywords><meta content=summary_large_image name=twitter:card><meta content=https://linuxize.com/post/how-to-setup-automatic-odoo-backup/featured.jpg name=twitter:image:src><meta content="How to Setup Automatic Odoo Backup" name=twitter:title><meta content="In this tutorial we will walk you through the process of creating automatic daily backups of your Odoo databases. Odoo is the most popular open source ERP system written in Python and uses PostgreSQL as database back-end." name=twitter:description><meta content=@linuxize name=twitter:site><link href=/favicons/apple-touch-icon.png rel=apple-touch-icon sizes=180x180><link href=/favicons/favicon-32x32.png rel=icon sizes=32x32 type=image/png><link href=/favicons/favicon-16x16.png rel=icon sizes=16x16 type=image/png><link href=/favicons/safari-pinned-tab.svg rel=mask-icon color=#2271ff><script type=application/ld+json>{
  "@context": "http://schema.org",
  "@type": "BlogPosting",
  "headline": "How to Setup Automatic Odoo Backup",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://linuxize.com/post/how-to-setup-automatic-odoo-backup/"
  },"image": {
     "@type": "ImageObject",
     "url": "https://linuxize.com/post/how-to-setup-automatic-odoo-backup/featured.jpg",
     "width": 1000,
     "height": 530
    },"keywords": "odoo, cron, cronjob, backup",
  "wordcount": 741,
  "url": "https://linuxize.com/post/how-to-setup-automatic-odoo-backup/",
  "datePublished": "2018-04-14T00:31:47+01:00",
  "dateModified": "2018-04-14T00:31:47+01:00",
  "publisher": {
    "@type": "Organization","logo": {
    "@type": "imageObject",
      "url": "https://linuxize.com/assets/linuxize-card.png"
    },"name": "Linuxize"
  },

  "author": {
    "@type": "Person",
    "name": "Linuxize"
  },
  "description": "In this tutorial we will walk you through the process of creating automatic daily backups of your Odoo databases. Odoo is the most popular open source ERP system written in Python and uses PostgreSQL as database back-end."
}</script><link href="https://fonts.googleapis.com/css?family=IBM+Plex+Sans:300,400,400i,500,700%7CIBM+Plex+Serif:300,400,400i,600,600i" rel=stylesheet><script src=/js/ads.js></script><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-P827G6S');</script><script src=https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js async></script><meta content=#2271ff name=theme-color><link href=/manifest.79f739767e479131c04f7216cce1c084.json rel=manifest><link href=/css/app.3f6bd7be09f7bb8d469c.css rel=stylesheet></head><body class="text-black font-sans kind-page leading-normal section-post type-post"><div class="flex flex-col min-h-screen"><header class="w-full px-6 bg-white border-b border-grey-light fixed linuxize-shadow z-10" id=header><nav class="w-full mx-auto flex items-center h-12 justify-start sm:h-16"><a href=/ class="flex items-center block flex-no-shrink mr-6 no-underline text-black"><svg aria-hidden=true class="h-6 w-6 fill-current mr-2 sm:h-8 sm:w-8"><use xlink:href=#logo></use><title>Linuxize</title></svg> <span class="font-medium hidden sm:block text-xl tracking-tight">Linuxize</span></a><div class="flex justify-center -mb-px flex-1 min-w-0 text-sm"><div class="font-medium nav-post-title sm:text-lg text-center truncate">How to Setup Automatic Odoo Backup</div></div><div class="flex justify-end"><a href=https://twitter.com/linuxize class="block mr-2 h-4 sm:h-6"><svg aria-hidden=true class="inline-block text-grey-darkest fill-current h-4 sm:h-6 sm:w-6 w-4"><use xlink:href=#twitter></use><title>Twitter</title></svg> </a><a href=https://www.facebook.com/linuxize/ class="block mr-2 h-4 sm:h-6"><svg aria-hidden=true class="inline-block text-grey-darkest fill-current h-4 sm:h-6 sm:w-6 w-4"><use xlink:href=#facebook></use><title>Facebook</title></svg> </a><a href=/index.xml class="block h-4 sm:h-6"><svg aria-hidden=true class="inline-block text-grey-darkest fill-current h-4 sm:h-6 sm:w-6 w-4"><use xlink:href=#rss></use><title>RSS</title></svg></a></div></nav></header><div class="w-full bg-grey-lightest mb-8 md:pt-16 pt-12 top-ad"><div class="w-full mx-auto adsense-wrapper max-w-2xl py-4"><div class="w-full flex justify-center content-center"><div class="w-full relative"><ins class="mx-auto adsbygoogle top-leaderboard" data-ad-client=ca-pub-9439755881064125 data-ad-format=auto data-ad-slot=9558702194 style=display:block></ins></div></div></div></div><main class="w-full px-6 flex-grow flex-no-shrink main pb-8"><article class="single-post relative"><div class="mx-auto max-w-xl mb-4 xl:flex xl:max-w-4xl xl:mb-8"><div class="w-full xl:w-1/2 self-center"><section class="w-full post-header xl:pr-8"><div class="flex flex-col font-medium mb-4 md:flex-row text-xs uppercase xxl:text-sm"><div class=inline-flex><time class="" datetime=2018-04-14T00:31:47+01:00>April 14, 2018 </time><span class=mx-2>•</span><p>Read in 4 minutes</p></div></div><h1 class="text-black font-bold leading-none lg:text-5xl mb-4 text-3xl xl:mb-4 xxl:text-6xl">How to Setup Automatic Odoo Backup</h1></section></div><div class="w-full xl:w-1/2 bg-grey"><section class="w-full mx-auto max-w-xl"><figure class="-mx-6 lg:mx-0 relative"><div class="w-full mx-auto relative block my-0"><div class=block style=padding-bottom:53%></div><div class="w-full h-full absolute m-auto pin bg-grey-lighter overflow-hidden"><img src=/post/how-to-setup-automatic-odoo-backup/featured.jpg alt="" class="w-full h-full absolute m-auto pin"></div></div></figure></section></div></div><section class="w-full mx-auto max-w-article lg:max-w-xl sticky-element"><nav class="flex border-b lg:absolute lg:border-none lg:flex-col lg:mt-0 lg:p-0 lg:pin-r lg:w-6 mb-6 mt-8 pb-2"><span class="text-xs uppercase font-bold lg:-mx-6 lg:mb-4 lg:text-center mr-4 self-center tracking-wide">Share <span class="self-center lg:hidden">:</span> </span><a href="https://twitter.com/share?text=How%20to%20Setup%20Automatic%20Odoo%20Backup&url=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-setup-automatic-odoo-backup%2f" class="h-6 w-6 lg:mb-4 lg:mr-0 mr-4" target=_blank><svg aria-hidden=true class="h-6 w-6 fill-current inline-block text-grey-darkest hover:text-grey-darker"><use xlink:href=#twitter></use><title>Share on Twitter</title></svg> </a><a href="https://plus.google.com/share?url=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-setup-automatic-odoo-backup%2f" class="h-6 w-6 lg:mb-4 lg:mr-0 mr-4" target=_blank><svg aria-hidden=true class="h-6 w-6 fill-current inline-block text-grey-darkest hover:text-grey-darker"><use xlink:href=#gplus></use><title>Share on Google Plus</title></svg> </a><a href="https://www.facebook.com/sharer/sharer.php?caption=How%20to%20Setup%20Automatic%20Odoo%20Backup&u=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-setup-automatic-odoo-backup%2f" class="h-6 w-6 lg:mb-4 lg:mr-0 mr-4" target=_blank><svg aria-hidden=true class="h-6 w-6 fill-current inline-block text-grey-darkest hover:text-grey-darker"><use xlink:href=#facebook></use><title>Share on Facebook</title></svg> </a><a href="https://news.ycombinator.com/submitlink?t=How%20to%20Setup%20Automatic%20Odoo%20Backup&u=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-setup-automatic-odoo-backup%2f" class="h-6 w-6 lg:mb-4 lg:mr-0 mr-4" target=_blank><svg aria-hidden=true class="h-6 w-6 fill-current inline-block text-grey-darkest hover:text-grey-darker"><use xlink:href=#hacker-news></use><title>Submit to Hacker News</title></svg> </a><a href="/cdn-cgi/l/email-protection#82bdf1f7e0e8e7e1f6bfcaedf5a7b0b2f6eda7b0b2d1e7f6f7f2a7b0b2c3f7f6edefe3f6ebe1a7b0b2cde6ededa7b0b2c0e3e1e9f7f2a4e0ede6fbbfc1eae7e1e9a7b0b2edf7f6a7b0b2f6eaebf1a7b0b2e3f0f6ebe1eee7b8a7b2c3a7b2c3eaf6f6f2f1a7b1e3a7b0e4a7b0e4eeebecf7faebf8e7ace1edefa7b0e4f2edf1f6a7b0e4eaedf5aff6edaff1e7f6f7f2afe3f7f6edefe3f6ebe1afede6ededafe0e3e1e9f7f2a7b0e4" class="h-6 w-6" target=_blank><svg aria-hidden=true class="h-6 w-6 fill-current inline-block text-grey-darkest hover:text-grey-darker"><use xlink:href=#email></use><title>Share with Email</title></svg></a></nav></section><section class="w-full mx-auto max-w-article markdown"><div class="aside-wrapper relative"><aside class="w-full mx-auto relative sideblock xl:sticky"><div class="sideblock-content xl:-ml-52 xl:absolute xl:pin-l xl:w-40 xxl:-ml-89 xxl:w-75"><a href="https://www.vultr.com/?ref=6812257" class="hidden affiliate"></a><div class="w-full flex justify-center content-center"><div class="w-full relative"><ins class="mx-auto adsbygoogle" data-ad-client=ca-pub-9439755881064125 data-ad-format=auto data-ad-slot=4501323511 style=display:block></ins></div></div></div></aside></div><p>In this tutorial we will walk you through the process of creating automatic daily backups of your Odoo databases. Odoo is the most popular open source ERP system written in Python and uses PostgreSQL as database back-end.</p><p>All the data of your Odoo instance is stored in a PostgreSQL database. Regularly backing up the database will protect you from potentially catastrophic data loss and it is absolutely critical for anyone and everyone who has an Odoo installation.</p><h2 id=odoo-database-management-interface>Odoo database management interface</h2><p>The Odoo database management interface provides tools to backup, duplicate, delete, create and restore a database. Creating a backup using the database management interface is a no-brainer, simply open your browser and navigate to <code>http://your_server_ip:8069/web/database/manager</code>.</p><p>You will be presented with the following screen:</p><figure><img src=database-manager.png></figure><p>Click on the <code>Backup</code> link and a new popup will be displayed.</p><figure><img src=database-manager-backup.png></figure><p>Enter your Odoo database Master Password and create a backup by clicking on the blue <code>Backup</code> button.</p><p>Depending on the database size, the backup may take some time before being ready.</p><h2 id=create-a-database-backup-from-the-command-line>Create a database backup from the command line</h2><p>Now that we know how to create a backup through the Odoo database management interface, how can we use the same tool to create a backup from the command line? The answer is simple, we can use <code>wget</code> or <code>curl</code>. Both tools can send data with POST which we can use to pass the necessary variables to the Odoo database tool.</p><p>In the example bellow our Odoo Master Password is <code>ADMIN_PASSWORD</code> and we are creating a backup file <code>back_up_filename.zip</code> of a database named <code>DB_NAME</code> which will be saved in the <code>backup_dir</code> directory.</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash>curl -X POST -F <span class=s1>'master_pwd=ADMIN_PASSWORD'</span> -F <span class=s1>'name=DB_NAME'</span> -F <span class=s1>'backup_format=zip'</span> -o /backup_dir/back_up_filename.zip http://localhost:8069/web/database/backup</code></pre></div><p>If you prefer <code>wget</code> over <code>curl</code>, you can use the following command:</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash>wget --post-data <span class=s1>'master_pwd=ADMIN_PASSWORD&name=DB_NAME&backup_format=zip'</span> -O /backup_dir/back_up_filename.zip http://localhost:8069/web/database/backup</code></pre></div><p>If you want to create a backup from a remote location instead of <code>localhost</code> you need to enter the URL to your Odoo instance. In this case it is recommended to use HTTPS because you do not want your password to be send through Internet as a plain text. You can find more information about to configure Odoo with nginx as a reverse-proxy <a href=/post/configure-odoo-with-nginx-as-a-reverse-proxy/ >here</a>.</p><div class="w-full flex justify-center content-center"><div class="w-full relative py-8"><ins class=adsbygoogle data-ad-client=ca-pub-9439755881064125 data-ad-format=fluid data-ad-slot=5120214995 style=display:block data-ad-layout=in-article></ins></div></div><h2 id=setup-automatic-odoo-backup>Setup Automatic Odoo Backup</h2><p>To automate the backup process and backup our Odoo database at regular intervals we can create a <a href=/post/how-to-create-and-manage-cron-jobs/ >cron job</a>.</p><p>Let’s say that we want to backup our Odoo database each day at <code>01:30 am</code> and keep the latest 7 backups.</p><p>We will create a simple bash script which you can name it as you want:</p><div class=code-label>~/backup_odoo.sh</div><div class=highlight><pre class=chroma><code class=language-sh data-lang=sh><span class=cp>#!/bin/bash
</span><span class=cp></span>
<span class=c1># vars
</span><span class=c1></span><span class=nv>BACKUP_DIR</span><span class=o>=</span>~/odoo_backups
<span class=nv>ODOO_DATABASE</span><span class=o>=</span>db1
<span class=nv>ADMIN_PASSWORD</span><span class=o>=</span>superadmin_passwd

<span class=c1># create a backup directory
</span><span class=c1></span>mkdir -p <span class=si>${</span><span class=nv>BACKUP_DIR</span><span class=si>}</span>

<span class=c1># create a backup
</span><span class=c1></span>curl -X POST <span class=se>\
</span><span class=se></span>    -F <span class=s2>"master_pwd=</span><span class=si>${</span><span class=nv>ADMIN_PASSWORD</span><span class=si>}</span><span class=s2>"</span> <span class=se>\
</span><span class=se></span>    -F <span class=s2>"name=</span><span class=si>${</span><span class=nv>ODOO_DATABASE</span><span class=si>}</span><span class=s2>"</span> <span class=se>\
</span><span class=se></span>    -F <span class=s2>"backup_format=zip"</span> <span class=se>\
</span><span class=se></span>    -o <span class=si>${</span><span class=nv>BACKUP_DIR</span><span class=si>}</span>/<span class=si>${</span><span class=nv>ODOO_DATABASE</span><span class=si>}</span>.<span class=k>$(</span>date +%F<span class=k>)</span>.zip <span class=se>\
</span><span class=se></span>    http://localhost:8069/web/database/backup


<span class=c1># delete old backups
</span><span class=c1></span>find <span class=si>${</span><span class=nv>BACKUP_DIR</span><span class=si>}</span> -type f -mtime +7 -name <span class=s2>"</span><span class=si>${</span><span class=nv>ODOO_DATABASE</span><span class=si>}</span><span class=s2>.*.zip"</span> -delete</code></pre></div><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash>sudo chmod +x ~/backup_odoo.sh</code></pre></div><div class="-mx-6 bg-yellow-lightest border-l-4 border-yellow-light my-6 note p-6 text-yellow-darkest"><div class=flex><div class="w-full text-sm font-sans"><p>Do not forget to change the <code>BACKUP_DIR</code>, <code>ODOO_DATABASE</code> and <code>ADMIN_PASSWORD</code> variables according to your needs.</p></div></div></div><p>The last step is to create a new cron job which will run each day at <code>01:30 am</code>:</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash>crontab -e</code></pre></div><div class=highlight><pre class=chroma><code class=language-cron data-lang=cron>01 30 * * * /home/&lt;yourusername>/backup_odoo.sh</code></pre></div><div class="-mx-6 bg-yellow-lightest border-l-4 border-yellow-light my-6 note p-6 text-yellow-darkest"><div class=flex><div class="w-full text-sm font-sans"><p>Do not forget to set the correct name and path to the backup script.</p></div></div></div><p>You can modify the script and implement a more robust backup solution such as using a remote backup storage, keep weekly and monthly backups ..etc.</p><h2 id=restore-an-odoo-database>Restore an Odoo Database</h2><p>To restore a database backup using the database management interface, open your browser and navigate to <code>http://your_server_ip:8069/web/database/manager</code>.</p><figure><img src=database-manager.png></figure><p>Click on the <code>Restore Database</code> button and a new popup will be displayed.</p><figure><img src=database-manager-restore.png></figure><p>Enter your Odoo database Master Password, select the backup File, enter the new Database Name and restore the database by clicking on the blue <code>Continue</code> button.</p><div class="-mx-6 bg-yellow-lightest border-l-4 border-yellow-light my-6 note p-6 text-yellow-darkest"><div class=flex><div class="w-full text-sm font-sans"><p>Before restoring the database you will need to either delete the database or use another database name.</p></div></div></div><p>Depending on the database size and your Internet speed, the restoration process may take some time.</p><p>We can also restore the database from the command line:</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash>curl -F <span class=s1>'master_pwd=superadmin_passwd'</span> -F <span class=nv>backup_file</span><span class=o>=</span>@/opt/odoo/odoo_backups/db1.2018-04-14.zip -F <span class=s1>'copy=true'</span> -F <span class=s1>'name=db3'</span> http://localhost:8069/web/database/restore</code></pre></div><p>Of course you will need to adjust the command with your Odoo Master password, the path to the database backup and the database name.</p><p>If the restoration is successful the output should look like this:</p><div class=highlight><pre class=chroma><code class=language-Output data-lang=Output>!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2 Final//EN">
&lt;title>Redirecting...&lt;/title>
&lt;h1>Redirecting...&lt;/h1>
&lt;p>You should be redirected automatically to target URL: &lt;a href="/web/database/manager">/web/database/manager&lt;/a>.  If not click the link.</code></pre></div><p></p><hr><p>That’s all! If you have any question or feedback feel free to leave a comment.</p><div class="w-full flex justify-center content-center"><div class="w-full relative"><ins class="mx-auto adsbygoogle" data-ad-client=ca-pub-9439755881064125 data-ad-format=auto data-ad-slot=7027266996 style=display:block></ins></div></div><div class="flex flex-wrap mt-6"><a href=/tags/odoo class="bg-grey-lighter hover:bg-grey-light mr-2 mt-2 px-4 py-2 rounded text-grey-darker text-xs">odoo</a> <a href=/tags/cron class="bg-grey-lighter hover:bg-grey-light mr-2 mt-2 px-4 py-2 rounded text-grey-darker text-xs">cron</a> <a href=/tags/cronjob class="bg-grey-lighter hover:bg-grey-light mr-2 mt-2 px-4 py-2 rounded text-grey-darker text-xs">cronjob</a> <a href=/tags/backup class="bg-grey-lighter hover:bg-grey-light mr-2 mt-2 px-4 py-2 rounded text-grey-darker text-xs">backup</a></div></section></article><section class="w-full mx-auto max-w-xl border-grey-lighter border-t mt-8 pt-8"><div class="bg-grey-lighter p-8 sm:py-16"><p class="mx-auto my-0 lg:text-2xl max-w-md sm:text-xl text-center text-lg">Sign up to our newsletter and get our latest tutorails and news straight to your mailbox.</p><form action="https://linuxize.us17.list-manage.com/subscribe/post?u=35cd4cd9d021c25c3dd7cabfd&id=9cfa4c89de" class=pt-8 id=mc-embedded-subscribe-form method=post name=mc-embedded-subscribe-form novalidate target=_blank><div class="w-full mx-auto flex items-center flex-col justify-between max-w-sm mb-2 sm:flex-row"><input class="w-full px-4 py-3 rounded appearance-none bg-white block border hover:border-grey-dark mb-3 sm:mb-0 text-grey-darker" name=EMAIL placeholder="Your email..." type=email> <input class=hidden name=b_35cd4cd9d021c25c3dd7cabfd_9cfa4c89de tabindex=-1> <button class="w-full px-4 py-3 rounded bg-blue hover:bg-blue-dark sm:ml-4 sm:w-auto text-white" name=subscribe type=submit><span class=text-center>Subscribe</span></button></div><p class="w-full mx-auto my-0 max-w-sm text-sm">We’ll never share your email address or spam you.</p></form></div></section><div class="w-full mx-auto max-w-xl border-grey-lighter border-t mt-8 pt-8 justify-center"><a href="https://shareasale.com/r.cfm?b=1144537&u=1755182&m=41388&urllink=&afftrack=" class="mx-auto wp-engine block"></a></div><section class="w-full mx-auto max-w-xl border-grey-lighter border-t mt-8 pt-8"><div class="flex flex-wrap -mx-4"><a href=https://linuxize.com/post/how-to-create-and-manage-cron-jobs/ class="w-full flex md:mb-0 md:w-1/3 overflow-hidden px-4 mb-8"><div class="w-full flex flex-col h-full"><p class="text-xs uppercase font-normal text-grey-dark">Feb 20, 2018</p><div class="font-normal flex-grow mb-2 md:mb-4 text-black text-lg">How to create and manage cron jobs</div><div><figure class=relative><div class="w-full mx-auto relative block my-0"><div class=block style=padding-bottom:53%></div><div class="w-full h-full absolute m-auto pin bg-grey-lighter overflow-hidden"><img src=/post/how-to-create-and-manage-cron-jobs/featured.jpg alt="" class="w-full h-full absolute m-auto pin"></div></div></figure></div></div></a><a href=https://linuxize.com/post/install-odoo-11-on-centos-7/ class="w-full flex md:mb-0 md:w-1/3 overflow-hidden px-4 mb-8"><div class="w-full flex flex-col h-full"><p class="text-xs uppercase font-normal text-grey-dark">Mar 29, 2018</p><div class="font-normal flex-grow mb-2 md:mb-4 text-black text-lg">Install Odoo 11 on CentOS 7</div><div><figure class=relative><div class="w-full mx-auto relative block my-0"><div class=block style=padding-bottom:53%></div><div class="w-full h-full absolute m-auto pin bg-grey-lighter overflow-hidden"><img src=/post/install-odoo-11-on-centos-7/featured.jpg alt="" class="w-full h-full absolute m-auto pin"></div></div></figure></div></div></a><a href=https://linuxize.com/post/configure-odoo-with-nginx-as-a-reverse-proxy/ class="w-full flex md:mb-0 md:w-1/3 overflow-hidden px-4 mb-0"><div class="w-full flex flex-col h-full"><p class="text-xs uppercase font-normal text-grey-dark">Jan 22, 2018</p><div class="font-normal flex-grow mb-2 md:mb-4 text-black text-lg">Configure Odoo with with nginx as a reverse proxy</div><div><figure class=relative><div class="w-full mx-auto relative block my-0"><div class=block style=padding-bottom:53%></div><div class="w-full h-full absolute m-auto pin bg-grey-lighter overflow-hidden"><img src=/post/configure-odoo-with-nginx-as-a-reverse-proxy/featured.jpg alt="" class="w-full h-full absolute m-auto pin"></div></div></figure></div></div></a></div></section><section class="w-full mx-auto relative border-grey-lighter border-t max-w-lg mt-8 pt-16 py-8"><a href=https://linuxize.com/post/how-to-setup-automatic-odoo-backup/#disqus_thread class="w-full bg-grey-lighter block disqus-comment-count disqus-load md:py-8 py-4 text-center" title="Show comments for post">Write a comment</a><div id=disqus_thread></div><noscript>Please enable JavaScript to view the <a href=https://disqus.com/?ref_noscript>comments powered by Disqus.</a></noscript></section></main><footer class="w-full px-6 bg-grey-lightest"><div class="w-full mx-auto max-w-xl justify-center flex flex-wrap items-center md:justify-between md:text-left py-8 text-center"><div class="w-full text-sm mb-2 md:mb-0 md:w-1/2"><div class="w-full md:flex block md:items-center md:w-auto"><div class=md:flex-grow><span class="block mb-2 md:inline-block md:mb-0 md:mr-8 text-grey-dark">© 2018 Linuxize.com</span> <a href=/privacy-policy/ class="inline-block text-grey-darkest hover:text-grey-darker footer-menu-item md:mt-0 no-underline mr-4">Privacy Policy </a><a href=/contact/ class="inline-block text-grey-darkest hover:text-grey-darker footer-menu-item md:mt-0 no-underline mr-0">Contact</a></div></div></div><div class="w-full flex justify-center md:justify-end md:w-1/2"><a href=https://twitter.com/linuxize class="block mr-2 h-6"><svg aria-hidden=true class="h-6 w-6 fill-current inline-block text-grey-darkest"><use xlink:href=#twitter></use><title>Twitter</title></svg> </a><a href=https://www.facebook.com/linuxize/ class="block mr-2 h-6"><svg aria-hidden=true class="h-6 w-6 fill-current inline-block text-grey-darkest"><use xlink:href=#facebook></use><title>Facebook</title></svg> </a><a href=/index.xml class="block h-6"><svg aria-hidden=true class="h-6 w-6 fill-current inline-block text-grey-darkest"><use xlink:href=#rss></use><title>RSS</title></svg></a></div></div></footer></div><script data-cfasync="false" src="/cdn-cgi/scripts/d07b1474/cloudflare-static/email-decode.min.js"></script><script src=/js/0.a38c1ee6cb2916cf0afc.js></script><script src=/js/app.3f6bd7be09f7bb8d469c.js></script></body></html>