<!DOCTYPE html><html class="no-js" lang="en-us"><head><meta charset="utf-8">
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData)});}}
function AddPixelById(impFullId,pixelData){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData)});}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){while(pixels.length>0){var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(__ez.template.isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pushPixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
(new Image()).src=pixelURL;}}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=191-2&cb=1', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=191-2&cb=1', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=191-2&cb=2', false, [], true, false, true, false);</script><title>How to Find the Length of a List in Python | Linuxize</title><meta content="IE=edge" http-equiv="X-UA-Compatible"><meta content="width=device-width,initial-scale=1,shrink-to-fit=no" name="viewport"><meta content="Linuxize" name="apple-mobile-web-app-title"><meta content="Linuxize" name="application-name"><meta content="#2271ff" name="theme-color"><meta content="#2271ff" name="msapplication-TileColor"><meta content="Python has a built-in function len() that returns the length of a given object." name="description"><meta content="unsafe-url" name="referrer"><link href="https://linuxize.com/post/python-list-lenght/" rel="canonical"><meta content="index, follow" name="robots"><meta content="How to Find the Length of a List in Python" property="og:title"><meta content="Python has a built-in function len() that returns the length of a given object." property="og:description"><meta content="article" property="og:type"><meta content="/post/python-list-lenght/" property="og:url"><meta content="https://linuxize.com/post/python-list-lenght/featured.jpg" property="og:image"><meta content="http://" property="og:image:secure"><meta content="Python has a built-in function len() that returns the length of a given object." property="og:image:alt"><meta content="2020-09-27T18:11:31+01:00" property="article:published_time"><meta content="2020-09-27T18:11:31+01:00" property="article:modified_time"><meta content="en" property="og:locale"><meta content="post" property="article:section"><meta content="https://www.facebook.com/linuxize" property="article:publisher"><meta content="python" property="article:tag"><meta content="python" name="news_keywords"><meta content="summary_large_image" name="twitter:card"><meta content="https://linuxize.com/post/python-list-lenght/featured.jpg" name="twitter:image"><meta content="How to Find the Length of a List in Python" name="twitter:title"><meta content="Python has a built-in function len() that returns the length of a given object." name="twitter:description"><meta content="@linuxize" name="twitter:site"><link href="/favicons/apple-touch-icon.png" rel="apple-touch-icon" sizes="180x180"><link href="/favicons/favicon-32x32.png" rel="icon" sizes="32x32" type="image/png"><link href="/favicons/favicon-16x16.png" rel="icon" sizes="16x16" type="image/png"><link href="/favicons/safari-pinned-tab.svg" rel="mask-icon" color="#2271ff"><link href="//fonts.gstatic.com" rel="preconnect" crossorigin=""><link href="//fonts.googleapis.com" rel="preconnect" crossorigin=""><link href="//www.googletagmanager.com" rel="preconnect" crossorigin=""><link href="//www.google-analytics.com" rel="preconnect" crossorigin=""><link href="//pagead2.googlesyndication.com" rel="preconnect" crossorigin=""><link href="https://fonts.googleapis.com/css?family=Hind:400,500,600,700|Roboto+Mono:400,400i,700,700i|Roboto:400,400i,500,700,700i&amp;display=swap" rel="stylesheet"><script type="application/ld+json">{
  "@context": "http://schema.org",
  "@type": "BlogPosting",
  "headline": "How to Find the Length of a List in Python",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https:\/\/linuxize.com\/post\/python-list-lenght\/"
  },"image": {
     "@type": "ImageObject",
     "url": "https:\/\/linuxize.com\/post\/python-list-lenght\/featured.jpg",
     "width":  1000 ,
     "height":  530 
    },"keywords": "python",
  "wordcount":  258 ,
  "url": "https:\/\/linuxize.com\/post\/python-list-lenght\/",
  "datePublished": "2020-09-27T18:11:31+01:00",
  "dateModified": "2020-09-27T18:11:31+01:00",
  "publisher": {
    "@type": "Organization","logo": {
    "@type": "imageObject",
      "url": "https:\/\/linuxize.com\/assets\/linuxize-card.png"
    },"name": "Linuxize"
  },

  "author": {
    "@type": "Person",
    "name": "Linuxize"
  },
  "description": "Python has a built-in function len() that returns the length of a given object."
}</script><script src="/js/dfp.js" async></script><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-P827G6S');</script><script src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js" async data-ad-client="ca-pub-9439755881064125"></script><link href="/css/app.53470e946e62ae94e140.css" rel="stylesheet"><meta content="#2271ff" name="theme-color"><link href="/manifest.128dc4ca8d47b9db75ffbc72b588021a.json" rel="manifest">
<script data-ezscrex="false" data-cfasync="false" type="text/javascript">window.google_analytics_uacct = "UA-124335151-13";</script>
<script data-ezscrex="false" data-cfasync="false" type="text/javascript">
var _gaq = _gaq || [];
_gaq.push(function(){
	_gat._createTracker('UA-124335151-13', 'e');
});
_gaq.push(function(){
	_gat._createTracker('UA-38339005-1', 'f');
});
_gaq.push(['e._setDomainName', 'linuxize.com']);
_gaq.push(['f._setDomainName', 'linuxize.com']);
_gaq.push(['e._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['e._setCustomVar',2,'t','126',3]);
_gaq.push(['e._setCustomVar',3,'rid','0',2]);
_gaq.push(['e._setCustomVar',4,'bra','mod1',3]);
_gaq.push(['e._setAllowAnchor',true]);
_gaq.push(['e._setSiteSpeedSampleRate', 10]);
_gaq.push(['f._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['f._setCustomVar',2,'domain','linuxize.com',3]);
_gaq.push(['f._setSiteSpeedSampleRate', 20]);
_gaq.push(['e._trackPageview']);
_gaq.push(['f._trackPageview']);


(function() {
 var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
 ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
 var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
})();
</script>
<script type="text/javascript">var ezouid = "1";</script><base href="https://linuxize.com/post/python-list-lenght/"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 93605;
var ezdomain = 'linuxize.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":93605,"domain_test_group":20200409,"engaged_time_visit":0,"ezcache_level":1,"forensiq_score":-1,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"837f3016-7d4e-48e9-425e-23c8e9e0f0b8","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_time_orig":10,"serverid":"54.226.13.53:15947","state":"VA","t_epoch":1601270958,"template_id":126,"time_on_site_visit":0,"url":"https://linuxize.com/post/python-list-lenght/","user_id":0,"word_count":450,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script><script data-ezscrex='false' data-cfasync='false' type="text/javascript" src="/detroitchicago/rochester.js?cb=191-2&v=9" async></script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_93605=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["837f3016-7d4e-48e9-425e-23c8e9e0f0b8", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script></head><body class="leading-normal font-sans kind-page section-post type-post"><div class="flex flex-col min-h-screen main-wrap"><header class="w-full dark:border-gray-900 border-b border-gray-400 fixed header linuxize-shadow px-6 z-50" id="header"><nav class="w-full mx-auto flex items-center h-12 justify-start md:h-16"><a href="/" class="flex items-center block dark:text-gray-200 flex-shrink-0 logo mr-6 no-underline text-black" aria-label="Linuxize.com"><svg aria-hidden="true" class="md:h-8 fill-current h-6 md:w-8 mr-2 w-6" role="img"><use xlink:href="/svg/sprite.svg#logo"></use></svg> <span class="font-medium hidden md:block text-md tracking-tight">Linuxize</span></a><div class="flex -mb-px flex-1 min-w-0 text-sm"><a href="/tags/ubuntu/" class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 hidden md:block mr-4 no-underline text-gray-800"><span class="inline-block font-bold md:py-4 md:py-6 py-3">Ubuntu </span></a><a href="/tags/centos/" class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 hidden md:block mr-4 no-underline text-gray-800"><span class="inline-block font-bold md:py-4 md:py-6 py-3">Centos </span></a><a href="/tags/debian/" class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 hidden md:block mr-4 no-underline text-gray-800"><span class="inline-block font-bold md:py-4 md:py-6 py-3">Debian </span></a><a href="/tags/terminal/" class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 hidden md:block mr-4 no-underline text-gray-800"><span class="inline-block font-bold md:py-4 md:py-6 py-3">Commands </span></a><a href="/series/" class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 hidden md:block mr-4 no-underline text-gray-800"><span class="inline-block font-bold md:py-4 md:py-6 py-3">Series </span></a><a href="https://www.buymeacoffee.com/8swZOSU6I" class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 hidden md:block mr-4 no-underline text-gray-800 mr-0"><span class="inline-block font-bold md:py-4 md:py-6 py-3">Donate</span></a></div><div class="flex justify-end"><button class="block h-6" id="btn-search" aria-label="Search"><svg aria-hidden="true" class="dark:text-gray-300 inline-block fill-current h-6 w-6 text-gray-900" role="img"><use xlink:href="/svg/sprite.svg#search"></use></svg></button> <button class="ml-2 mode-toggle" id="mode-toggle"><span class="mode-toggle-icons"><svg aria-hidden="true" class="dark:text-gray-300 inline-block fill-current h-6 w-6 text-gray-900" role="img"><use xlink:href="/svg/sprite.svg#moon"></use></svg> <svg aria-hidden="true" class="dark:text-gray-300 inline-block fill-current h-6 w-6 text-gray-900" role="img"><use xlink:href="/svg/sprite.svg#sun"></use></svg></span></button></div></nav></header><main class="w-full flex-grow flex-shrink-0 pb-8 pt-16 sm:pt-24 main"><article class="relative single-post"><div class="w-full mx-auto px-6 post-width"><div class="relative mb-4 post-header xl:mb-8 z-40"><h1 class="font-semibold leading-none lg:text-3xl mb-2 text-2xl xxl:text-4xl">How to Find the Length of a List in Python</h1><div class="dark:text-gray-300 font-medium text-gray-700 flex flex-col md:flex-row text-xs"><div class="inline-flex flex-row"><p class="font-medium text-xs leading-normal rounded-sm"><span>Posted&nbsp;</span><time class="" datetime="2020-09-27T18:11:31+01:00">Sep 27, 2020</time></p><span class="inline-block mx-2">•</span><p>2 min read</p></div></div></div><div class="lg:flex"><div class="w-full lg:max-h-full lg:overflow-visible lg:static min-h-screen"><div class="flex"><div class="w-full pb-8"><div class="flex flex-col xl:flex-relative xl:flex-row"><aside class="w-full block hidden sidebar2 xxl:block" id="sidebar2"><script src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js" async></script><div class="w-full flex justify-center content-center"><div class="w-full relative"><ins class="block hidden adsbygoogle mx-autosidebar2-as xl:block" data-ad-client="ca-pub-9439755881064125" data-ad-format="horizontal,rectangle" data-ad-slot="4501323511" data-full-width-responsive="true"></ins></div></div><script>(adsbygoogle = window.adsbygoogle || []).push({});</script><div class="w-full -mt-12 flex-col hidden justify-between pb-4 pt-12 sticky top-16 xl:flex"><div class="bg-gray-200 dark:bg-gray-900 mb-6 p-4 pb-2 overflow-auto table-of-contents toc"><p class="font-medium text-xs uppercase xxl:text-sm mb-3 text-gray-800 tracking-tight dark:text-gray-200">Contents</p><div class="relative overflow-hidden"><div class="lg:max-h-toc overflow-y-auto scrollbar-thumb-gray scrollbar-thumb-rounded scrollbar-track-gray-lighter scrollbar-w-2 scrolling-touch"><nav id="TableOfContents"><ul><li><a href="#len-function"><code>len()</code> Function</a></li><li><a href="#using-loop">Using Loop</a></li><li><a href="#conclusion">Conclusion</a></li></ul></nav></div></div><div class="flex border-gray-400 border-t dark:border-gray-900 items-center justify-content mb-3 mr-2 pt-4 tracking-tight"><p class="font-medium text-xs uppercase xxl:text-sm mr-4">Share:</p><section class="w-full mx-auto"><nav class="flex flex-wrap"><a href="https://twitter.com/share?text=How%20to%20Find%20the%20Length%20of%20a%20List%20in%20Python&amp;url=https%3a%2f%2flinuxize.com%2fpost%2fpython-list-lenght%2f" class="mr-3 h-6 w-6" rel="noopener" target="_blank"><svg aria-hidden="true" class="dark:text-gray-300 inline-block fill-current h-6 w-6 hover:text-blue-600 text-gray-600" role="img"><use xlink:href="/svg/sprite.svg#twitter"></use></svg> </a><a href="https://www.facebook.com/sharer/sharer.php?caption=How%20to%20Find%20the%20Length%20of%20a%20List%20in%20Python&amp;u=https%3a%2f%2flinuxize.com%2fpost%2fpython-list-lenght%2f" class="mr-3 h-6 w-6" rel="noopener" target="_blank"><svg aria-hidden="true" class="dark:text-gray-300 inline-block fill-current h-6 w-6 hover:text-blue-600 text-gray-600" role="img"><use xlink:href="/svg/sprite.svg#facebook"></use></svg> </a><a href="https://pinterest.com/pin/create/button/?url=https%3a%2f%2flinuxize.com%2fpost%2fpython-list-lenght%2f&amp;media=https%3a%2f%2flinuxize.com%2fpost%2fpython-list-lenght%2ffeatured.jpg&amp;description=How%20to%20Find%20the%20Length%20of%20a%20List%20in%20Python" class="mr-3 h-6 w-6" rel="noopener" target="_blank"><svg aria-hidden="true" class="dark:text-gray-300 inline-block fill-current h-6 w-6 hover:text-blue-600 text-gray-600" role="img"><use xlink:href="/svg/sprite.svg#pinterest"></use></svg> </a><a href="mailto:?subject=How%20to%20Find%20the%20Length%20of%20a%20List%20in%20Python&amp;body=Check%20out%20this%20article:%0A%0Ahttps%3a%2f%2flinuxize.com%2fpost%2fpython-list-lenght%2f" class="h-6 w-6" rel="noopener" target="_blank"><svg aria-hidden="true" class="dark:text-gray-300 inline-block fill-current h-6 w-6 hover:text-blue-600 text-gray-600" role="img"><use xlink:href="/svg/sprite.svg#email"></use></svg></a></nav></section></div></div><div class="w-full flex justify-center content-center hidden" id="bs-a"><div class="w-full mb-6 relative"><div id="bsa-block"></div></div></div></div></aside><section class="w-full mx-auto lg:ml-0 lg:mr-auto lg:pr-6 min-w-0 xl:mx-0 xl:w-full xxl:px-6"><figure class="relative mb-6 -mx-6 lg:mx-0"><div class="w-full mx-auto my-0 block relative"><div class="block" style="padding-bottom:53%"></div><div class="w-full h-full absolute inset-0 m-auto bg-gray-200 overflow-hidden"><img alt="" class="w-full h-full absolute inset-0 m-auto" loading="lazy" sizes="(max-width: 991px) 100w, 1000px" src="/post/python-list-lenght/featured.jpg" srcset="/post/python-list-lenght/featured_hu5b66a8e09f1ac9194fad7c769d3612ef_23265_600x0_resize_q95_box.jpg 600w, /post/python-list-lenght/featured.jpg 1000w"></div></div></figure><div class="markdown"><p>Lists are one of the most commonly used data types in Python and are used to store collections of items of the same type.</p><p>This article shows how to find the length of a list.</p><h2 id="len-function"><code>len()</code> Function <a href="#len-function" class="headline-link" aria-hidden="true">#</a></h2><p>Python has a built-in function <code>len()</code> that returns the length of a given object. The object can be a <a href="https://linuxize.com/post/python-list/">list</a> , tuple, string, dictionary, etc.</p><p>The syntax of the <code>len()</code> function is as follows:</p><div class="highlight"><pre class="chroma"><code class="language-python" data-lang="python"><span class="nb">len</span><span class="p">(</span><span class="nb">list</span><span class="p">)</span>
</code></pre></div><p>The function accepts only one argument. The returned value is an integer that is the number of elements in the list.</p><p>Here is an example:</p><div class="highlight"><pre class="chroma"><code class="language-python" data-lang="python"><span class="n">capitals</span> <span class="o">=</span> <span class="p">[</span><span class="s1">'Tokyo'</span><span class="p">,</span> <span class="s1">'Sofia'</span><span class="p">,</span> <span class="s1">'London'</span><span class="p">,</span> <span class="s1">'Budapest'</span><span class="p">]</span>

<span class="n">list_len</span> <span class="o">=</span> <span class="nb">len</span><span class="p">(</span><span class="n">capitals</span><span class="p">)</span>

<span class="k">print</span><span class="p">(</span><span class="s2">"The list has {0} elements."</span><span class="o">.</span><span class="n">format</span><span class="p">(</span><span class="n">list_len</span><span class="p">))</span>
</code></pre></div><pre><code class="language-output" data-lang="output">The list has 4 elements.
</code></pre><h2 id="using-loop">Using Loop <a href="#using-loop" class="headline-link" aria-hidden="true">#</a></h2><p>Another way to get the length of a list is to use the <code>for</code> loop. This works by setting up a counter and looping through all the elements of the list. On each iteration, the current value of the <code>counter</code> variable is incremented by one.</p><p>Below is a sample code that shows how to find the number of elements in a given list using the <code>for</code> loop:</p><div class="highlight"><pre class="chroma"><code class="language-python" data-lang="python"><span class="n">capitals</span> <span class="o">=</span> <span class="p">[</span><span class="s1">'Tokyo'</span><span class="p">,</span> <span class="s1">'Sofia'</span><span class="p">,</span> <span class="s1">'London'</span><span class="p">,</span> <span class="s1">'Budapest'</span><span class="p">]</span>
<span class="n">counter</span> <span class="o">=</span> <span class="mi">0</span>

<span class="k">for</span> <span class="n">capital</span> <span class="ow">in</span> <span class="n">capitals</span><span class="p">:</span>
  <span class="n">counter</span> <span class="o">=</span> <span class="n">counter</span> <span class="o">+</span> <span class="mi">1</span>

<span class="k">print</span><span class="p">(</span><span class="s2">"The list has {0} elements."</span><span class="o">.</span><span class="n">format</span><span class="p">(</span><span class="n">counter</span><span class="p">))</span>
</code></pre></div><pre><code class="language-output" data-lang="output">The list has 4 elements.
</code></pre><p>This method is not very Pythonic. You should always prefer using the <code>len()</code> function.</p><h2 id="conclusion">Conclusion <a href="#conclusion" class="headline-link" aria-hidden="true">#</a></h2><p>To find the length of a list in Python list, use the <code>len()</code> function.</p><p>If you have any questions or feedback, feel free to leave a comment.</p><div class="flex flex-wrap my-8"><a href="/tags/python/" class="font-medium text-sm bg-indigo-700 hover:bg-indigo-800 mr-2 mt-2 px-4 py-2 rounded text-white tracking-wide">python</a></div></div></section></div></div></div></div><div class="w-full absolute hidden -mb-16 flex-grow lg:-mb-0 lg:block lg:pt-0 lg:static sidebar top-16 z-40" id="sidebar"><div class="bg-gray-200 dark:bg-gray-900 mb-6 p-4 pb-2 related-content"><p class="dark:text-gray-300 font-medium text-gray-800 mb-3 text-xs tracking-tight uppercase xxl:text-sm">Related Tutorials</p><ul class="border-gray-400 dark:border-gray-800 border-t mb-0 mt-4 pt-3"><li class="flex border-gray-400 border-b dark:border-gray-800 mb-2 pb-2"><a href="https://linuxize.com/post/python-list-reverse/" class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 font-medium text-gray-700 text-sm">Python List reverse</a></li><li class="flex border-gray-400 border-b dark:border-gray-800 mb-2 pb-2"><a href="https://linuxize.com/post/python-map/" class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 font-medium text-gray-700 text-sm">Python map() Function</a></li><li class="flex border-gray-400 border-b dark:border-gray-800 mb-2 pb-2"><a href="https://linuxize.com/post/how-to-install-opencv-on-ubuntu-20-04/" class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 font-medium text-gray-700 text-sm">How to Install OpenCV on Ubuntu 20.04</a></li><li class="flex border-gray-400 border-b dark:border-gray-800 mb-2 pb-2"><a href="https://linuxize.com/post/how-to-install-tensorflow-on-ubuntu-20-04/" class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 font-medium text-gray-700 text-sm">How to Install TensorFlow on Ubuntu 20.04</a></li><li class="flex border-gray-400 border-b dark:border-gray-800 mb-2 pb-2"><a href="https://linuxize.com/post/python-comments/" class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 font-medium text-gray-700 text-sm">How to Comment in Python</a></li><li class="flex border-gray-400 border-b dark:border-gray-800 mb-2 pb-2"><a href="https://linuxize.com/post/python-json/" class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 font-medium text-gray-700 text-sm">Parsing JSON Data in Python</a></li><li class="flex border-gray-400 border-b dark:border-gray-800 mb-2 pb-2"><a href="https://linuxize.com/post/python-modulo-operator/" class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 font-medium text-gray-700 text-sm">Python Modulo Operator</a></li></ul></div><div class="flex flex-col -mt-12 lg:block lg:relative lg:sticky lg:top-16 pt-12"><div class="sideblock"><div class="affiliate hidden mb-5" id="server-hunter"></div><div class="affiliate hidden" id="vultr"></div><script src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js" async></script><div class="w-full flex justify-center content-center"><div class="w-full relative"><ins class="block mx-auto adsbygoogle" data-ad-client="ca-pub-9439755881064125" data-ad-format="auto" data-ad-slot="7027266996" data-full-width-responsive="true"></ins></div></div><script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></div></div></div></div></article><div class="px-6"><section class="w-full mx-auto border-gray-200 border-t dark:border-gray-900 mt-8 pt-8 max-w-article"><div class="p-8 dark:bg-gray-900 sm:py-8 bg-orange-100"><p class="dark:text-gray-300 lg:text-base max-w-md mx-auto my-0 sm:text-base text-center text-orange-800 text-sm">If you like our content, please consider buying us a coffee.<br>Thank you for your support!</p><div class="w-full mx-auto flex items-center flex-col max-w-sm sm:flex-row justify-center mt-6"><a href="https://www.buymeacoffee.com/8swZOSU6I" class="font-medium px-4 py-2 rounded bg-orange-500 hover:bg-orange-600 inline-flex items-center text-orange-100" rel="noopener" target="_blank"><svg aria-hidden="true" class="inline-block fill-current h-6 w-6 text-gray-900" role="img"><use xlink:href="/svg/sprite.svg#bmc"></use></svg> <span class="font-medium text-xs uppercase ml-2">Buy me a coffee</span></a></div></div></section><section class="w-full mx-auto border-gray-200 border-t dark:border-gray-900 mt-8 pt-8 max-w-article"><div class="bg-gray-200 dark:bg-gray-900 p-8 sm:py-8"><p class="lg:text-base max-w-md mx-auto my-0 sm:text-base text-center text-sm">Sign up to our newsletter and get our latest tutorials and news straight to your mailbox.</p><form action="https://linuxize.us17.list-manage.com/subscribe/post?u=35cd4cd9d021c25c3dd7cabfd&amp;id=9cfa4c89de" class="pt-8" id="mc-embedded-subscribe-form" method="post" name="mc-embedded-subscribe-form" novalidate=""><div class="w-full mx-auto flex items-center flex-col max-w-sm sm:flex-row justify-between mb-2"><input class="w-full block bg-white appearance-none border hover:border-gray-700 mb-3 px-4 py-3 rounded sm:mb-0 text-gray-800" name="EMAIL" aria-label="email" placeholder="Your email..." type="email"> <input class="hidden" name="b_35cd4cd9d021c25c3dd7cabfd_9cfa4c89de" tabindex="-1"> <button class="w-full px-4 py-3 rounded bg-indigo-700 hover:bg-indigo-800 sm:ml-4 sm:w-auto text-white tracking-wide" name="subscribe" type="submit"><span class="text-center">Subscribe</span></button></div><p class="w-full mx-auto my-0 max-w-sm text-sm">We’ll never share your email address or spam you.</p></form></div></section><section class="w-full mx-auto border-gray-200 border-t dark:border-gray-900 mt-8 pt-8 max-w-5xl"><h2 class="dark:text-gray-300 font-medium text-lg leading-7 mb-4 text-gray-900 text-xl tracking-tight">Related Articles</h2><div class="flex flex-wrap -mx-4"><a href="https://linuxize.com/post/python-list-reverse/" class="w-full flex md:mb-0 md:w-1/3 overflow-hidden px-4 mb-8"><div class="w-full flex flex-col h-full"><p class="dark:text-gray-300 text-xs text-gray-700 font-normal uppercase">Aug 25, 2020</p><h3 class="dark:text-gray-300 font-medium text-gray-800 flex-grow mb-2 md:mb-4 text-lg">Python List reverse</h3><div><figure class="relative"><div class="w-full mx-auto my-0 block relative"><div class="block" style="padding-bottom:53%"></div><div class="w-full h-full absolute inset-0 m-auto bg-gray-200 overflow-hidden"><img alt="" class="w-full h-full absolute inset-0 m-auto" loading="lazy" sizes="(max-width: 991px) 100w, 1000px" src="/post/python-list-reverse/featured.jpg" srcset="/post/python-list-reverse/featured_hu8a667e184dadc2ab058962b660e19141_16476_600x0_resize_q95_box.jpg 600w, /post/python-list-reverse/featured.jpg 1000w"></div></div></figure></div></div></a><a href="https://linuxize.com/post/python-map/" class="w-full flex md:mb-0 md:w-1/3 overflow-hidden px-4 mb-8"><div class="w-full flex flex-col h-full"><p class="dark:text-gray-300 text-xs text-gray-700 font-normal uppercase">Jul 12, 2020</p><h3 class="dark:text-gray-300 font-medium text-gray-800 flex-grow mb-2 md:mb-4 text-lg">Python map() Function</h3><div><figure class="relative"><div class="w-full mx-auto my-0 block relative"><div class="block" style="padding-bottom:53%"></div><div class="w-full h-full absolute inset-0 m-auto bg-gray-200 overflow-hidden"><img alt="" class="w-full h-full absolute inset-0 m-auto" loading="lazy" sizes="(max-width: 991px) 100w, 1000px" src="/post/python-map/featured.jpg" srcset="/post/python-map/featured_hu99a73c32b771f5f4bf252d3c7544633e_24394_600x0_resize_q95_box.jpg 600w, /post/python-map/featured.jpg 1000w"></div></div></figure></div></div></a><a href="https://linuxize.com/post/how-to-install-opencv-on-ubuntu-20-04/" class="w-full flex md:mb-0 md:w-1/3 overflow-hidden px-4 mb-0"><div class="w-full flex flex-col h-full"><p class="dark:text-gray-300 text-xs text-gray-700 font-normal uppercase">Jul 5, 2020</p><h3 class="dark:text-gray-300 font-medium text-gray-800 flex-grow mb-2 md:mb-4 text-lg">How to Install OpenCV on Ubuntu 20.04</h3><div><figure class="relative"><div class="w-full mx-auto my-0 block relative"><div class="block" style="padding-bottom:53%"></div><div class="w-full h-full absolute inset-0 m-auto bg-gray-200 overflow-hidden"><img alt="" class="w-full h-full absolute inset-0 m-auto" loading="lazy" sizes="(max-width: 991px) 100w, 1000px" src="/post/how-to-install-opencv-on-ubuntu-20-04/featured.jpg" srcset="/post/how-to-install-opencv-on-ubuntu-20-04/featured_hueed1db52e7d1778105fa3855bf4aa2fd_30854_600x0_resize_q95_box.jpg 600w, /post/how-to-install-opencv-on-ubuntu-20-04/featured.jpg 1000w"></div></div></figure></div></div></a></div></section><section class="w-full mx-auto relative border-gray-200 border-t dark:border-gray-900 max-w-3xl mt-8 pt-16 py-8"><a href="https://linuxize.com/post/python-list-lenght/#disqus_thread" class="w-full block bg-gray-200 dark:bg-gray-900 disqus-comment-count disqus-load md:py-8 py-4 text-center" title="Show comments for post">Write a comment</a><div id="disqus_thread"></div><noscript>Please enable JavaScript to view the <a href="https://disqus.com/?ref_noscript">comments powered by Disqus.</a></noscript></section></div></main><section class="w-full absolute inset-0 bg-white block h-screen hidden search z-100" id="search-box"><div class="flex flex-col min-h-screen"><header class="w-full mx-auto flex items-center h-12 justify-end px-6 sm:h-16 z-10"><a href="#" class="block h-6 sm:h-8" id="btn-search-close"><svg aria-hidden="true" class="inline-block fill-current h-6 w-6 text-gray-900 sm:h-8 sm:w-8" role="img"><use xlink:href="/svg/sprite.svg#close"></use></svg> <small class="block text-center sm:w-8 w-6">ESC</small></a></header><div class="w-full px-6 flex-grow flex-shrink-0 pb-8 pt-16 sm:pt-24"><div class="flex flex-col mx-auto max-w-screen-xl mb-4 mb-8"><div class="searchbox-container" id="searchbox"></div><div class="search-results" id="search-results"></div><div id="hits"></div><div id="stats"></div><footer class="mt-6"><a href="https://github.com/algolia/instantsearch.js/" rel="noopener noreferrer" target="_blank" tabindex="-1"><svg aria-hidden="true" class="inline-block fill-current search-algolia-logo text-gray-700" role="img"><use xlink:href="/svg/sprite.svg#search-by-algolia"></use></svg></a></footer></div></div></div></section><footer class="w-full px-6 bg-gray-100 dark:bg-gray-900"><div class="w-full mx-auto flex items-center justify-center flex-wrap lg:justify-between lg:text-left max-w-screen-xl py-8 text-center"><div class="w-full lg:w-1/2 lg:mb-0 mb-2 text-sm"><div class="w-full block lg:flex lg:items-center lg:w-auto"><div class="lg:flex-grow"><span class="dark:text-gray-300 text-gray-800 mb-2 block lg:inline-block lg:mb-0 lg:mr-8">© 2020 Linuxize.com</span> <a href="/privacy-policy/" class="dark:text-gray-300 dark-hover:text-gray-100 no-underline mr-4 footer-menu-item hover:text-gray-800 inline-block lg:mt-0 text-gray-900">Privacy Policy </a><a href="/terms-of-service/" class="dark:text-gray-300 dark-hover:text-gray-100 no-underline mr-4 footer-menu-item hover:text-gray-800 inline-block lg:mt-0 text-gray-900">Terms </a><a href="/contact/" class="dark:text-gray-300 dark-hover:text-gray-100 no-underline footer-menu-item hover:text-gray-800 inline-block lg:mt-0 text-gray-900 mr-0">Contact</a></div></div></div><div class="w-full flex justify-center lg:justify-end lg:w-1/2"><a href="https://twitter.com/linuxize" class="block h-6 mr-2" aria-label="Twitter"><svg aria-hidden="true" class="dark:text-gray-300 inline-block fill-current h-6 w-6 text-gray-900" role="img"><use xlink:href="/svg/sprite.svg#twitter"></use></svg> </a><a href="https://www.facebook.com/linuxize/" class="block h-6 mr-2" aria-label="Facebook"><svg aria-hidden="true" class="dark:text-gray-300 inline-block fill-current h-6 w-6 text-gray-900" role="img"><use xlink:href="/svg/sprite.svg#facebook"></use></svg> </a><a href="/index.xml" class="block h-6" aria-label="RSS"><svg aria-hidden="true" class="dark:text-gray-300 inline-block fill-current h-6 w-6 text-gray-900" role="img"><use xlink:href="/svg/sprite.svg#rss"></use></svg></a></div></div></footer></div><script src="https://cdn.jsdelivr.net/npm/algoliasearch@4.3.0/dist/algoliasearch-lite.umd.js" defer crossorigin="anonymous"></script><script src="https://cdn.jsdelivr.net/npm/instantsearch.js@4.7.0/dist/instantsearch.production.min.js" defer crossorigin="anonymous"></script><script src="/js/1.d1b1301344033c8fd585.js" defer></script><script src="/js/app.53470e946e62ae94e140.js" defer></script><script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('edmonton.php', '/detroitchicago/edmonton.webp?a=a&cb=2&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('jellyfish.php', '/porpoiseant/jellyfish.webp?a=a&cb=2&shcb=34', false, [], true, false, false, false);
</script>

<script>var _audins_dom="linuxize_com",_audins_did=93605;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=191-2");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.linuxize_com,DomainId.93605" border="0" height="1" width="1" alt="Quantcast"/></div></noscript><noscript><img src="https://sb.scorecardresearch.com/p?c1=2&c2=20015427&cv=2.0&cj=1"/></noscript>
<script type='text/javascript' data-cfasync='false'></script><script defer src="https://static.cloudflareinsights.com/beacon.min.js" data-cf-beacon='{"rayId":"5d9b10e16d9fe6e0","version":"2020.9.1","si":10}'></script>
</body></html><!--[selectron:done]-->
