<!doctype html><html class=no-js lang=en-us><head><meta charset=utf-8>
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=function(){var u=[],i="/porpoiseant/army.gif";function t(e,i,t,_,d,o,n){if(__ez.dot.isDefined(e)&&0!=__ez.dot.isAnyDefined(e.getSlotElementId,e.ElementId)){var r=parseInt(__ez.dot.getTargeting(e,"ap")),a=__ez.dot.getSlotIID(e),s=__ez.dot.getAdUnit(e),p=parseInt(__ez.dot.getTargeting(e,"compid")),z=0,f=0,g=function(e){if("undefined"==typeof _ezim_d)return!1;var i=__ez.dot.getAdUnitPath(e).split("/").pop();if("object"==typeof _ezim_d&&_ezim_d.hasOwnProperty(i))return _ezim_d[i];for(var t in _ezim_d)if(t.split("/").pop()===i)return _ezim_d[t];return!1}(e);"object"==typeof g&&(void 0!==g.creative_id&&(f=g.creative_id),void 0!==g.line_item_id&&(z=g.line_item_id)),__ez.dot.isDefined(a,s)&&__ez.dot.isValid(i)&&u.push({type:"impression",impression_id:a,domain_id:__ez.dot.getDID(),unit:s,t_epoch:__ez.dot.getEpoch(0),revenue:t,est_revenue:_,ad_position:r,ad_size:"",bid_floor_filled:d,bid_floor_prev:o,stat_source_id:n,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:p,line_item_id:z,creative_id:f,data:__ez.dot.dataToStr(i)})}}function _(){if(void 0===document.visibilityState||"prerender"!==document.visibilityState){if(__ez.dot.isDefined(u)&&0<u.length){var e=__ez.dot.getURL(i)+"?orig="+(!0===__ez.template.isOrig?1:0)+"&sts="+btoa(JSON.stringify(u));void 0!==window.isAmp&&isAmp&&void 0!==window._ezaq&&_ezaq.hasOwnProperty("domain_id")&&(e+="&visit_uuid="+_ezaq.visit_uuid),(new Image).src=e}u=[]}}return{Add:t,AddAndFire:function(e,i){t(e,i,0,0,0,0,0),_()},AddById:function(e,i){var t=e.split("/");if(__ez.dot.isDefined(e)&&3===t.length&&__ez.dot.isValid(i)){var _=t[0],d=t[2];u.push({type:"impression",impression_id:d,domain_id:__ez.dot.getDID(),unit:_,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(i)})}},Fire:_,GetPixels:function(){return u}}}();var EzoicPixel=function(){this.pixels=[],this.pixelUrl="/ezoic/e.gif",("undefined"!=typeof ezJsu&&!0===ezJsu||"undefined"!=typeof _ez_sa&&!0===_ez_sa||void 0!==window.isAmp&&!0===isAmp||"undefined"!=typeof ezWp&&!0===ezWp)&&(this.pixelUrl="//g.ezoic.net"+this.pixelUrl),this.tEpoch=0,"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("t_epoch")&&(this.tEpoch=_ezaq.t_epoch)},EzoicPixelData=function(e,i){this.name=e,this.val=i};EzoicPixel.prototype={constructor:EzoicPixel,AddAndFireImpPixel:function(e,i){this.AddImpPixel(e,i,0,0,0,0,0),this.FirePixels()},AddAndFirePVPixel:function(e,i){this.AddPVPixel(e,i),this.FirePixels()},AddImpPixel:function(e,i,t,n,o,a,d){if(0!=__ez.dot.isDefined(e)&&0!=__ez.dot.isAnyDefined(e.getSlotElementId,e.ElementId)){var s=parseInt(__ez.dot.getTargeting(e,"ap")),r=__ez.dot.getSizes(e)[0],_=r.l.toString()+"x"+r.j.toString(),p="0",l="XX";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(p=_ezaq.domain_id.toString()),"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("country")&&(l=_ezaq.country);var h=__ez.dot.getSlotIID(e),c=__ez.dot.getSlotElementId(e);__ez.dot.isDefined(h,c)&&this.validateData(i)&&(i=this.convertDataToStr(i),this.pixels.push({type:"impression",impression_id:h,domain_id:p,unit:c,t_epoch:this.tEpoch,revenue:t,est_revenue:n,ad_position:s,ad_size:_,bid_floor_filled:o,bid_floor_prev:a,stat_source_id:d,country_code:l,data:i}))}},AddImpPixelById:function(e,i){var t="0";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(t=_ezaq.domain_id.toString());var n=e.split("/");if(__ez.dot.isDefined(e)&&3===n.length&&this.validateData(i)){var o=n[0],a=n[2];i=this.convertDataToStr(i),this.pixels.push({type:"impression",impression_id:a,domain_id:t,unit:o,t_epoch:this.tEpoch,data:i})}},AddPVPixel:function(e,i){var t="0";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(t=_ezaq.domain_id.toString()),__ez.dot.isDefined(e)&&this.validateData(i)&&(i=this.convertDataToStr(i),this.pixels.push({type:"pageview",pageview_id:e,domain_id:t,t_epoch:this.tEpoch,data:i}))},FirePixels:function(){void 0!==document.visibilityState&&"prerender"===document.visibilityState||(__ez.dot.isDefined(this.pixels)&&0<this.pixels.length&&((new Image).src=this.pixelUrl+"?orig="+(!0===__ez.template.isOrig?1:0)+"&pixels="+encodeURIComponent(JSON.stringify(this.pixels))),this.pixels=[])},NewData:function(e,i){return new EzoicPixelData(e,i)},convertDataToStr:function(e){if(void 0===e)return[];try{for(var i in e)e[i].val=e[i].val+""}catch(e){}return e},validateData:function(e){for(var i=0;i<e.length;i++)if(e[i]instanceof EzoicPixelData==!1)return console.error("Invalid pixelData. ",e[i]),!1;return!0}};</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">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</script><title>How to Install TensorFlow on CentOS 8 | Linuxize</title><meta content="IE=edge" http-equiv=X-UA-Compatible><meta content="width=device-width,initial-scale=1,shrink-to-fit=no" name=viewport><meta content=Linuxize name=apple-mobile-web-app-title><meta content=Linuxize name=application-name><meta content=#2271ff name=theme-color><meta content=#2271ff name=msapplication-TileColor><meta content="TensorFlow is a free and open-source platform for machine learning built by Google. This tutorial explains how to install TensorFlow on CentOS 8. " name=description><meta content=unsafe-url name=referrer><link href=https://linuxize.com/post/how-to-install-tensorflow-on-centos-8/ rel=canonical><meta content="index, follow" name=robots><meta content="How to Install TensorFlow on CentOS 8" property=og:title><meta content="TensorFlow is a free and open-source platform for machine learning built by Google. This tutorial explains how to install TensorFlow on CentOS 8. " property=og:description><meta content=article property=og:type><meta content=/post/how-to-install-tensorflow-on-centos-8/ property=og:url><meta content=https://linuxize.com/post/how-to-install-tensorflow-on-centos-8/featured.jpg property=og:image><meta content="TensorFlow is a free and open-source platform for machine learning built by Google. This tutorial explains how to install TensorFlow on CentOS 8. " property=og:image:alt><meta content=2020-02-22T20:24:10+01:00 property=article:published_time><meta content=2020-02-22T20:24:10+01:00 property=article:modified_time><meta content=en property=og:locale><meta content=post property=article:section><meta content=https://www.facebook.com/linuxize property=article:publisher><meta content=python property=article:tag><meta content=centos property=article:tag><meta content=python,centos name=news_keywords><meta content=summary_large_image name=twitter:card><meta content=https://linuxize.com/post/how-to-install-tensorflow-on-centos-8/featured.jpg name=twitter:image><meta content="How to Install TensorFlow on CentOS 8" name=twitter:title><meta content="TensorFlow is a free and open-source platform for machine learning built by Google. This tutorial explains how to install TensorFlow on CentOS 8. " name=twitter:description><meta content=@linuxize name=twitter:site><link href=/favicons/apple-touch-icon.png rel=apple-touch-icon sizes=180x180><link href=/favicons/favicon-32x32.png rel=icon sizes=32x32 type=image/png><link href=/favicons/favicon-16x16.png rel=icon sizes=16x16 type=image/png><link href=/favicons/safari-pinned-tab.svg rel=mask-icon color=#2271ff><link href=//fonts.gstatic.com rel=preconnect crossorigin=""><link href=//fonts.googleapis.com rel=preconnect crossorigin=""><link href=//www.googletagmanager.com rel=preconnect crossorigin=""><link href=//www.google-analytics.com rel=preconnect crossorigin=""><link href=//pagead2.googlesyndication.com rel=preconnect crossorigin=""><link href="https://fonts.googleapis.com/css?family=Hind:400,500,600,700|Roboto+Mono:400,400i,700,700i|Roboto:400,400i,500,700,700i&display=swap" rel=stylesheet><script type=application/ld+json>{
  "@context": "http://schema.org",
  "@type": "BlogPosting",
  "headline": "How to Install TensorFlow on CentOS 8",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https:\/\/linuxize.com\/post\/how-to-install-tensorflow-on-centos-8\/"
  },"image": {
     "@type": "ImageObject",
     "url": "https:\/\/linuxize.com\/post\/how-to-install-tensorflow-on-centos-8\/featured.jpg",
     "width":  1000 ,
     "height":  530 
    },"keywords": "python, centos",
  "wordcount":  596 ,
  "url": "https:\/\/linuxize.com\/post\/how-to-install-tensorflow-on-centos-8\/",
  "datePublished": "2020-02-22T20:24:10+01:00",
  "dateModified": "2020-02-22T20:24:10+01:00",
  "publisher": {
    "@type": "Organization","logo": {
    "@type": "imageObject",
      "url": "https:\/\/linuxize.com\/assets\/linuxize-card.png"
    },"name": "Linuxize"
  },

  "author": {
    "@type": "Person",
    "name": "Linuxize"
  },
  "description": "TensorFlow is a free and open-source platform for machine learning built by Google. This tutorial explains how to install TensorFlow on CentOS 8. "
}</script><script src=/js/dfp.js async></script><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-P827G6S');</script><script src=https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js async data-ad-client=ca-pub-9439755881064125></script><meta content=#2271ff name=theme-color><link href=/manifest.128dc4ca8d47b9db75ffbc72b588021a.json rel=manifest><link href=/css/app.8f918459c14a510c7c16.css rel=stylesheet><link rel='canonical' href='https://linuxize.com/post/how-to-install-tensorflow-on-centos-8/' />

<script data-ezscrex="false" data-cfasync="false" type="text/javascript">window.google_analytics_uacct = "UA-124335151-13";</script>
<script data-ezscrex="false" data-cfasync="false" type="text/javascript">
var _gaq = _gaq || [];
_gaq.push(['e._setAccount', 'UA-124335151-13']);
_gaq.push(['f._setAccount', 'UA-38339005-1']);
_gaq.push(['e._setDomainName', 'linuxize.com']);
_gaq.push(['f._setDomainName', 'linuxize.com']);
_gaq.push(['e._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['e._setCustomVar',2,'t','126',3]);
_gaq.push(['e._setCustomVar',3,'rid','0',2]);
_gaq.push(['e._setCustomVar',4,'bra','mod55',3]);
_gaq.push(['e._setAllowAnchor',true]);
_gaq.push(['e._setSiteSpeedSampleRate', 10]);
_gaq.push(['f._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['f._setCustomVar',2,'domain','linuxize.com',3]);
_gaq.push(['f._setSiteSpeedSampleRate', 20]);
_gaq.push(['e._trackPageview']);
_gaq.push(['f._trackPageview']);


(function() {
 var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
 ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
 var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
})();
</script>
<script type="text/javascript">var ezouid = "1";</script><base href="https://linuxize.com/post/how-to-install-tensorflow-on-centos-8/"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 93605;
var ezdomain = 'linuxize.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":93605,"engaged_time_visit":0,"ezcache_level":1,"forensiq_score":-1,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"63097190-714e-441d-5602-27b1590dff00","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_time_orig":9,"serverid":"100.25.181.207:13455","state":"VA","t_epoch":1582524785,"template_id":126,"time_on_site_visit":0,"url":"https://linuxize.com/post/how-to-install-tensorflow-on-centos-8/","user_id":0,"word_count":799,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script><script data-ezscrex='false' data-cfasync='false' type="text/javascript" src="/detroitchicago/rochester.js?cb=188-0&v=8" async></script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl() {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_93605=" + new Date().getTime() + "|63097190-714e-441d-5602-27b1590dff00; " + expires, 3);
}
function attach_ezolpl() {
    if(window.attachEvent) {
        window.attachEvent('onload', create_ezolpl);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl();
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl;
        }
    }
}
attach_ezolpl();
</script></head><body class="kind-page font-sans leading-normal section-post type-post"><div class="flex flex-col min-h-screen main-wrap"><header class="w-full dark:border-gray-900 border-b border-gray-400 fixed header linuxize-shadow px-6 z-50" id=header><nav class="w-full mx-auto flex items-center h-12 justify-start md:h-16"><a href=/ class="flex items-center block dark:text-gray-200 flex-shrink-0 logo mr-6 no-underline text-black" aria-label=Linuxize.com><svg aria-hidden=true class="mr-2 h-6 fill-current md:h-8 md:w-8 w-6" role=img><use xlink:href=/svg/sprite.svg#logo></use></svg> <span class="hidden md:block font-medium text-md tracking-tight">Linuxize</span></a><div class="flex -mb-px flex-1 min-w-0 text-sm"><a href=/tags/ubuntu/ class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 hidden md:block mr-4 no-underline text-gray-800"><span class="inline-block font-bold md:py-4 md:py-6 py-3">Ubuntu </span></a><a href=/tags/centos/ class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 hidden md:block mr-4 no-underline text-gray-800"><span class="inline-block font-bold md:py-4 md:py-6 py-3">Centos </span></a><a href=/tags/debian/ class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 hidden md:block mr-4 no-underline text-gray-800"><span class="inline-block font-bold md:py-4 md:py-6 py-3">Debian </span></a><a href=/tags/terminal/ class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 hidden md:block mr-4 no-underline text-gray-800"><span class="inline-block font-bold md:py-4 md:py-6 py-3">Commands </span></a><a href=/series/ class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 hidden md:block mr-4 no-underline text-gray-800"><span class="inline-block font-bold md:py-4 md:py-6 py-3">Series </span></a><a href=https://www.buymeacoffee.com/8swZOSU6I class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 hidden md:block mr-4 no-underline text-gray-800 mr-0"><span class="inline-block font-bold md:py-4 md:py-6 py-3">Donate</span></a></div><div class="flex justify-end"><button class="block h-6" id=btn-search aria-label=Search><svg aria-hidden=true class="dark:text-gray-300 inline-block fill-current h-6 w-6 text-gray-900" role=img><use xlink:href=/svg/sprite.svg#search></use></svg></button> <button class="ml-2 mode-toggle" id=mode-toggle><div class=mode-toggle-icons><svg aria-hidden=true class="dark:text-gray-300 inline-block fill-current h-6 w-6 text-gray-900" role=img><use xlink:href=/svg/sprite.svg#moon></use></svg> <svg aria-hidden=true class="dark:text-gray-300 inline-block fill-current h-6 w-6 text-gray-900" role=img><use xlink:href=/svg/sprite.svg#sun></use></svg></div></button></div></nav></header><main class="w-full flex-grow flex-shrink-0 pb-8 pt-16 sm:pt-24 main"><article class="relative single-post"><div class="w-full mx-auto px-6 post-width"><div class="relative mb-4 post-header xl:mb-8 z-40"><h1 class="font-semibold leading-none lg:text-3xl mb-2 text-2xl xxl:text-4xl">How to Install TensorFlow on CentOS 8</h1><div class="dark:text-gray-300 font-medium text-gray-700 flex text-xs flex-col md:flex-row"><div class="inline-flex flex-row"><p class="rounded-sm font-medium leading-normal text-xs"><span>Posted </span><time class="" datetime=2020-02-22T20:24:10+01:00>Feb 22, 2020</time></p><span class="inline-block mx-2">•</span><p>3 min read</p></div></div></div><div class=lg:flex><div class="w-full lg:max-h-full lg:overflow-visible lg:static min-h-screen"><div class=flex><div class="w-full pb-8"><div class="flex flex-col xl:flex-relative xl:flex-row"><aside class="w-full block hidden sidebar2 xxl:block" id=sidebar2><div class="wrap-collabsible mb-6"><input class="hidden toggle" type=checkbox id=collapsible> <label class="flex items-center block bg-indigo-700 cursor-pointer hover:bg-indigo-800 justify-between lbl-toggle px-4 py-2 relative text-white" for=collapsible><div class="text-sm font-medium tracking-wide"><span>Not using CentOS 8?</span><br><span>Choose different OS:</span></div><div class=ml-3><svg aria-hidden=true class="inline-block fill-current icon h-5 w-5 white" role=img><use xlink:href=/svg/sprite.svg#arrow-right></use></svg></div></label><div class="bg-gray-200 dark:bg-gray-900 collapsible-content"><div class="w-full distro-versions flex-wrap inline-flex items-center pt-2"><div class="w-full px-4 mb-2 pb-2"><a href=/post/how-to-install-tensorflow-on-centos-7/ class="w-full flex block capitalize dark-hover:text-gray-100 dark:text-gray-300 font-medium hover:text-gray-900 leading-normal text-gray-700 text-xs xxl:text-sm"><span class=mr-2><svg aria-hidden=true class="inline-block fill-current icon h-3 w-3" role=img><use xlink:href=/svg/sprite.svg#link></use></svg> </span><span>centos 7</span></a></div><div class="w-full px-4 mb-2 pb-2"><a href=/post/how-to-install-tensorflow-on-debian-10/ class="w-full flex block capitalize dark-hover:text-gray-100 dark:text-gray-300 font-medium hover:text-gray-900 leading-normal text-gray-700 text-xs xxl:text-sm"><span class=mr-2><svg aria-hidden=true class="inline-block fill-current icon h-3 w-3" role=img><use xlink:href=/svg/sprite.svg#link></use></svg> </span><span>debian 10</span></a></div><div class="w-full px-4 mb-2 pb-2"><a href=/post/how-to-install-tensorflow-on-debian-9/ class="w-full flex block capitalize dark-hover:text-gray-100 dark:text-gray-300 font-medium hover:text-gray-900 leading-normal text-gray-700 text-xs xxl:text-sm"><span class=mr-2><svg aria-hidden=true class="inline-block fill-current icon h-3 w-3" role=img><use xlink:href=/svg/sprite.svg#link></use></svg> </span><span>debian 9</span></a></div><div class="w-full px-4 mb-2 pb-2"><a href=/post/how-to-install-tensorflow-on-ubuntu-18-04/ class="w-full flex block capitalize dark-hover:text-gray-100 dark:text-gray-300 font-medium hover:text-gray-900 leading-normal text-gray-700 text-xs xxl:text-sm"><span class=mr-2><svg aria-hidden=true class="inline-block fill-current icon h-3 w-3" role=img><use xlink:href=/svg/sprite.svg#link></use></svg> </span><span>ubuntu 18.04</span></a></div></div></div></div><div class="w-full -mt-12 flex-col hidden justify-between pb-4 pt-12 sticky top-16 xl:flex"><div class="pb-2 bg-gray-200 dark:bg-gray-900 mb-6 p-4 overflow-auto table-of-contents toc"><p class="uppercase text-xs font-medium mb-3 mb-3 text-gray-800 tracking-tight xxl:text-sm dark:text-gray-200">Contents</p><div class="relative overflow-hidden"><div class="lg:max-h-toc overflow-y-auto scrollbar-thumb-gray scrollbar-thumb-rounded scrollbar-track-gray-lighter scrollbar-w-2 scrolling-touch"><nav id=TableOfContents><ul><li><a href=#installing-tensorflow-on-centos>Installing TensorFlow on CentOS</a></li><li><a href=#conclusion>Conclusion</a></li></ul></nav></div></div><div class="flex border-gray-400 border-t dark:border-gray-900 items-center justify-content mb-3 mr-2 pt-4 tracking-tight"><p class="uppercase text-xs font-medium mr-4 xxl:text-sm">Share:</p><section class="w-full mx-auto"><nav class="flex flex-wrap"><a href="https://twitter.com/share?text=How%20to%20Install%20TensorFlow%20on%20CentOS%208&url=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-install-tensorflow-on-centos-8%2f" class="mr-3 h-6 w-6" rel=noopener target=_blank><svg aria-hidden=true class="dark:text-gray-300 inline-block fill-current h-6 w-6 hover:text-blue-600 text-gray-600" role=img><use xlink:href=/svg/sprite.svg#twitter></use></svg> </a><a href="https://www.facebook.com/sharer/sharer.php?caption=How%20to%20Install%20TensorFlow%20on%20CentOS%208&u=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-install-tensorflow-on-centos-8%2f" class="mr-3 h-6 w-6" rel=noopener target=_blank><svg aria-hidden=true class="dark:text-gray-300 inline-block fill-current h-6 w-6 hover:text-blue-600 text-gray-600" role=img><use xlink:href=/svg/sprite.svg#facebook></use></svg> </a><a href="https://pinterest.com/pin/create/button/?url=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-install-tensorflow-on-centos-8%2f&media=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-install-tensorflow-on-centos-8%2ffeatured.jpg&description=How%20to%20Install%20TensorFlow%20on%20CentOS%208" class="mr-3 h-6 w-6" rel=noopener target=_blank><svg aria-hidden=true class="dark:text-gray-300 inline-block fill-current h-6 w-6 hover:text-blue-600 text-gray-600" role=img><use xlink:href=/svg/sprite.svg#pinterest></use></svg> </a><a href="mailto:?subject=How%20to%20Install%20TensorFlow%20on%20CentOS%208&body=Check%20out%20this%20article:%0A%0Ahttps%3a%2f%2flinuxize.com%2fpost%2fhow-to-install-tensorflow-on-centos-8%2f" class="h-6 w-6" rel=noopener target=_blank><svg aria-hidden=true class="dark:text-gray-300 inline-block fill-current h-6 w-6 hover:text-blue-600 text-gray-600" role=img><use xlink:href=/svg/sprite.svg#email></use></svg></a></nav></section></div></div></div></aside><section class="w-full mx-auto lg:ml-0 lg:mr-auto lg:pr-6 min-w-0 xl:mx-0 xl:w-full xxl:px-6"><figure class="relative -mx-6 lg:mx-0 mb-6"><div class="w-full mx-auto my-0 block relative"><div class=block style=padding-bottom:53%></div><div class="w-full h-full absolute inset-0 m-auto bg-gray-200 overflow-hidden"><img alt="" class="w-full h-full absolute inset-0 m-auto lazy lazyload" src="data:image/gif;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAYAAAAfFcSJAAAADUlEQVR42mP8+PXHfwAJnAPfCuZXlQAAAABJRU5ErkJggg==" data-sizes=auto data-src=/post/how-to-install-tensorflow-on-centos-8/featured_hufe611200947a70821dab04045d880d17_22933_600x0_resize_q95_box.jpg data-srcset="
              /post/how-to-install-tensorflow-on-centos-8/featured_hufe611200947a70821dab04045d880d17_22933_600x0_resize_q95_box.jpg 600w,
              /post/how-to-install-tensorflow-on-centos-8/featured.jpg 1000w
            "><noscript><img alt="" class="w-full h-full absolute inset-0 m-auto" src=/post/how-to-install-tensorflow-on-centos-8/featured.jpg></noscript></div></div></figure><div class=markdown><p><a href=https://www.tensorflow.org/ >TensorFlow</a> is an open-source platform for machine learning built by Google. It can runs on CPU or GPU on different devices, and it is used by a number of organizations, including Twitter, PayPal, Intel, Lenovo, and Airbus.</p><p>TensorFlow can be installed system-wide, in a Python virtual environment, as a Docker container, or with <a href=https://linuxize.com/post/how-to-install-anaconda-on-centos-8/ >Anaconda</a>.</p><p>This tutorial explains how to install TensorFlow on CentOS 8.</p><p>TensorFlow supports both Python 2 and 3. We will be using Python 3 and install TensorFlow inside a virtual environment. A virtual environment allows you to have multiple different isolated Python environments on a single computer and install a specific version of a module on a per-project basis, without worrying that it will affect your other Projects.</p><h2 id=installing-tensorflow-on-centos>Installing TensorFlow on CentOS <a href=#installing-tensorflow-on-centos class=headline-link aria-hidden=true>#</a></h2><p>Unlike other Linux distributions, Python is not installed by default on CentOS 8. To <a href=https://linuxize.com/post/how-to-install-python-3-on-centos-7/ >install Python 3 on CentOS 8</a> run the following command as root or sudo user in your terminal:</p><pre class=terminal><code class=terminal-line prefix=$>sudo dnf install python3</code></pre><p>The command above will install Python 3.6 and <a href=https://linuxize.com/post/how-to-install-pip-on-centos-8/ >pip</a>. To run Python 3, you need to type <code>python3</code> explicitly, and to run pip type <code>pip3</code>.</p><p>Starting from Python 3.6, the recommended way to create a virtual environment is to use the <code>venv</code> module.</p><p><a href=https://linuxize.com/post/linux-cd-command/ >Navigate to the directory</a> where you would like to store your TensorFlow project. It can be your home directory or any other directory where the user has read and write permissions.</p><p><a href=https://linuxize.com/post/how-to-create-directories-in-linux-with-the-mkdir-command/ >Create a new directory</a> for the TensorFlow project and switch into it:</p><pre class=terminal><code class=terminal-line prefix=$>mkdir tensorflow_project </code><code class=terminal-line prefix=$>cd tensorflow_project</code></pre><p>Within the directory, run the following command to create the virtual environment:</p><pre class=terminal><code class=terminal-line prefix=$>python3 -m venv venv</code></pre><p>The command above creates a directory named <code>venv</code>, containing a copy of the Python binary, pip the standard Python library, and other supporting files. You can use any name you want for the virtual environment.</p><p>To start using the virtual environment, activate it by typing:</p><pre class=terminal><code class=terminal-line prefix=$>source venv/bin/activate</code></pre><p>Once activated, the virtual environment’s bin directory will be added at the beginning of the <code>$PATH</code> <a href=https://linuxize.com/post/how-to-set-and-list-environment-variables-in-linux/ >variable</a>. Also, your shell’s prompt will change, and it will show the name of the virtual environment you’re currently using. In this case, that is <code>venv</code>.</p><p>TensorFlow installation requires <code>pip</code> version 19 or higher. Run the following command to upgrade <code>pip</code> to the latest version:</p><pre class=terminal><code class=terminal-line prefix="(venv) $">pip install --upgrade pip</code></pre><p>Now that the virtual environment is created and activated, install the TensorFlow library using the following command:</p><pre class=terminal><code class=terminal-line prefix="(venv) $">pip install --upgrade tensorflow</code></pre><div class="my-6 bg-yellow-100 border-l-4 border-yellow-400 dark:bg-gray-800 dark:border-0 dark:text-yellow-200 note p-6"><div class=flex><div class="w-full text-sm font-sans"><p>If you have a dedicated NVIDIA GPU and want to take advantage of its processing power, instead of <code>tensorflow</code>, install the <code>tensorflow-gpu</code> package, which includes GPU support.</p><p>Within the virtual environment, you can use the command <code>pip</code> instead of <code>pip3</code> and <code>python</code> instead of <code>python3</code>.</p></div></div></div><p>To verify the installation, run the following command, which will print the TensorFlow version:</p><pre class=terminal><code class=terminal-line prefix="(venv) $">python -c 'import tensorflow as tf; print(tf.__version__)'</code></pre><p>At the time of writing this article, the latest stable version of TensorFlow is 2.1.0:</p><pre><code class=language-output data-lang=output>2.1.0
</code></pre><p>Your TensorFlow version may differ from the version shown here.</p><p>If you are new to TensorFlow, visit the <a href=https://www.tensorflow.org/learn>Get Started with TensorFlow</a> page and learn how to build your first ML application. You can also clone the <a href=https://github.com/tensorflow/models>TensorFlow Models</a> or <a href=https://github.com/aymericdamien/TensorFlow-Examples>TensorFlow-Examples</a> repositories from Github and explore and test the TensorFlow examples.</p><p>Once you are done with your work, deactivate the environment by typing <code>deactivate</code>, and you will return to your normal shell.</p><pre class=terminal><code class=terminal-line prefix="(venv) $">deactivate</code></pre><p>That’s it! You have successfully installed TensorFlow, and you can start using it.</p><h2 id=conclusion>Conclusion <a href=#conclusion class=headline-link aria-hidden=true>#</a></h2><p>We have shown you how to install TensorFlow inside a virtual environment on CentOS 8.</p><p>If you hit a problem or have feedback, leave a comment below.</p><div class="flex flex-wrap my-6"><a href=/tags/python/ class="text-sm font-medium tracking-wide bg-indigo-700 hover:bg-indigo-800 mr-2 mt-2 px-4 py-2 rounded text-white">python</a> <a href=/tags/centos/ class="text-sm font-medium tracking-wide bg-indigo-700 hover:bg-indigo-800 mr-2 mt-2 px-4 py-2 rounded text-white">centos</a></div></div></section></div></div></div></div><div class="w-full absolute hidden -mb-16 flex-grow lg:-mb-0 lg:block lg:pt-0 lg:static sidebar top-16 z-40" id=sidebar><div class="pb-2 bg-gray-200 dark:bg-gray-900 mb-6 p-4 related-content"><p class="dark:text-gray-300 font-medium text-xs xxl:text-sm mb-3 mb-3 text-gray-800 tracking-tight uppercase">Related Tutorials</p><ul class="mt-4 border-gray-400 border-t dark:border-gray-800 mb-0 pt-3"><li class="flex border-gray-400 border-b dark:border-gray-800 mb-2 pb-2"><a href=https://linuxize.com/post/how-to-install-python-3-8-on-centos-8/ class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 font-medium text-gray-700 text-sm">How to Install Python 3.8 on CentOS 8</a></li><li class="flex border-gray-400 border-b dark:border-gray-800 mb-2 pb-2"><a href=https://linuxize.com/post/how-to-install-pip-on-centos-8/ class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 font-medium text-gray-700 text-sm">How to Install Pip on CentOS 8</a></li><li class="flex border-gray-400 border-b dark:border-gray-800 mb-2 pb-2"><a href=https://linuxize.com/post/how-to-install-odoo-13-on-centos-8/ class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 font-medium text-gray-700 text-sm">Install Odoo 13 on CentOS 8</a></li><li class="flex border-gray-400 border-b dark:border-gray-800 mb-2 pb-2"><a href=https://linuxize.com/post/how-to-install-python-on-centos-8/ class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 font-medium text-gray-700 text-sm">How to Install Python on CentOS 8</a></li><li class="flex border-gray-400 border-b dark:border-gray-800 mb-2 pb-2"><a href=https://linuxize.com/post/how-to-install-tensorflow-on-centos-7/ class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 font-medium text-gray-700 text-sm">How to Install TensorFlow on CentOS 7</a></li><li class="flex border-gray-400 border-b dark:border-gray-800 mb-2 pb-2"><a href=https://linuxize.com/post/how-to-install-flask-on-centos-7/ class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 font-medium text-gray-700 text-sm">How to Install Flask on CentOS 7</a></li><li class="flex border-gray-400 border-b dark:border-gray-800 mb-2 pb-2"><a href=https://linuxize.com/post/how-to-install-opencv-on-centos-7/ class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 font-medium text-gray-700 text-sm">How to Install OpenCV on CentOS 7</a></li></ul></div><div class="flex flex-col -mt-12 lg:block lg:relative lg:sticky lg:top-16 pt-12"><div class=sideblock><div class="hidden affiliate"><a href="https://www.vultr.com/?ref=8389060-6G" class=vultr rel=noopener target=_blank></a></div></div></div></div></div></div></article><div class=px-6><section class="w-full mx-auto border-gray-200 border-t dark:border-gray-900 mt-8 pt-8 max-w-article"><div class="p-8 dark:bg-gray-900 sm:py-8 bg-orange-100"><p class="dark:text-gray-300 lg:text-base max-w-md mx-auto my-0 sm:text-base text-center text-orange-800 text-sm">If you like our content, please consider buying us a coffee.<br>Thank you for your support!</p><div class="w-full mx-auto flex items-center flex-col max-w-sm sm:flex-row justify-center mt-6"><a href=https://www.buymeacoffee.com/8swZOSU6I class="inline-flex items-center bg-orange-500 font-medium hover:bg-orange-600 px-4 py-2 rounded text-orange-100" rel=noopener target=_blank><svg aria-hidden=true class="inline-block fill-current h-6 w-6 text-gray-900" role=img><use xlink:href=/svg/sprite.svg#bmc></use></svg> <span class="uppercase text-xs font-medium ml-2">Buy me a coffee</span></a></div></div></section><section class="w-full mx-auto border-gray-200 border-t dark:border-gray-900 mt-8 pt-8 max-w-article"><div class="bg-gray-200 dark:bg-gray-900 p-8 sm:py-8"><p class="text-sm mx-auto my-0 lg:text-base max-w-md sm:text-base text-center">Sign up to our newsletter and get our latest tutorials and news straight to your mailbox.</p><form action="https://linuxize.us17.list-manage.com/subscribe/post?u=35cd4cd9d021c25c3dd7cabfd&id=9cfa4c89de" class=pt-8 id=mc-embedded-subscribe-form method=post name=mc-embedded-subscribe-form novalidate><div class="w-full mx-auto flex items-center flex-col max-w-sm sm:flex-row justify-between mb-2"><input class="w-full block bg-white appearance-none border hover:border-gray-700 mb-3 px-4 py-3 rounded sm:mb-0 text-gray-800" name=EMAIL aria-label=email placeholder="Your email..." type=email> <input class=hidden name=b_35cd4cd9d021c25c3dd7cabfd_9cfa4c89de tabindex=-1> <button class="w-full px-4 py-3 rounded bg-indigo-700 hover:bg-indigo-800 sm:ml-4 sm:w-auto text-white tracking-wide" name=subscribe type=submit><span class=text-center>Subscribe</span></button></div><p class="w-full mx-auto my-0 max-w-sm text-sm">We’ll never share your email address or spam you.</p></form></div></section><section class="w-full mx-auto border-gray-200 border-t dark:border-gray-900 mt-8 pt-8 max-w-5xl"><div class="flex flex-wrap -mx-4"><a href=https://linuxize.com/post/how-to-install-python-3-8-on-centos-8/ class="w-full flex md:mb-0 md:w-1/3 overflow-hidden px-4 mb-8"><div class="w-full flex flex-col h-full"><p class="dark:text-gray-300 uppercase text-xs font-normal text-gray-700">Feb 11, 2020</p><h2 class="dark:text-gray-300 font-medium text-gray-800 flex-grow mb-2 md:mb-4 text-lg">How to Install Python 3.8 on CentOS 8</h2><div><figure class=relative><div class="w-full mx-auto my-0 block relative"><div class=block style=padding-bottom:53%></div><div class="w-full h-full absolute inset-0 m-auto bg-gray-200 overflow-hidden"><img alt="" class="w-full h-full absolute inset-0 m-auto lazy lazyload" src="data:image/gif;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAYAAAAfFcSJAAAADUlEQVR42mP8+PXHfwAJnAPfCuZXlQAAAABJRU5ErkJggg==" data-sizes=auto data-src=/post/how-to-install-python-3-8-on-centos-8/featured_huca619263161de3b3a5a20e15c4388373_25334_600x0_resize_q95_box.jpg data-srcset="
              /post/how-to-install-python-3-8-on-centos-8/featured_huca619263161de3b3a5a20e15c4388373_25334_600x0_resize_q95_box.jpg 600w,
              /post/how-to-install-python-3-8-on-centos-8/featured.jpg 1000w
            "><noscript><img alt="" class="w-full h-full absolute inset-0 m-auto" src=/post/how-to-install-python-3-8-on-centos-8/featured.jpg></noscript></div></div></figure></div></div></a><a href=https://linuxize.com/post/how-to-install-pip-on-centos-8/ class="w-full flex md:mb-0 md:w-1/3 overflow-hidden px-4 mb-8"><div class="w-full flex flex-col h-full"><p class="dark:text-gray-300 uppercase text-xs font-normal text-gray-700">Jan 19, 2020</p><h2 class="dark:text-gray-300 font-medium text-gray-800 flex-grow mb-2 md:mb-4 text-lg">How to Install Pip on CentOS 8</h2><div><figure class=relative><div class="w-full mx-auto my-0 block relative"><div class=block style=padding-bottom:53%></div><div class="w-full h-full absolute inset-0 m-auto bg-gray-200 overflow-hidden"><img alt="" class="w-full h-full absolute inset-0 m-auto lazy lazyload" src="data:image/gif;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAYAAAAfFcSJAAAADUlEQVR42mP8+PXHfwAJnAPfCuZXlQAAAABJRU5ErkJggg==" data-sizes=auto data-src=/post/how-to-install-pip-on-centos-8/featured_hu61fa9aeda25b8dc60225d19a5d8c7064_25670_600x0_resize_q95_box.jpg data-srcset="
              /post/how-to-install-pip-on-centos-8/featured_hu61fa9aeda25b8dc60225d19a5d8c7064_25670_600x0_resize_q95_box.jpg 600w,
              /post/how-to-install-pip-on-centos-8/featured.jpg 1000w
            "><noscript><img alt="" class="w-full h-full absolute inset-0 m-auto" src=/post/how-to-install-pip-on-centos-8/featured.jpg></noscript></div></div></figure></div></div></a><a href=https://linuxize.com/post/how-to-install-odoo-13-on-centos-8/ class="w-full flex md:mb-0 md:w-1/3 overflow-hidden px-4 mb-0"><div class="w-full flex flex-col h-full"><p class="dark:text-gray-300 uppercase text-xs font-normal text-gray-700">Dec 11, 2019</p><h2 class="dark:text-gray-300 font-medium text-gray-800 flex-grow mb-2 md:mb-4 text-lg">Install Odoo 13 on CentOS 8</h2><div><figure class=relative><div class="w-full mx-auto my-0 block relative"><div class=block style=padding-bottom:53%></div><div class="w-full h-full absolute inset-0 m-auto bg-gray-200 overflow-hidden"><img alt="" class="w-full h-full absolute inset-0 m-auto lazy lazyload" src="data:image/gif;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAYAAAAfFcSJAAAADUlEQVR42mP8+PXHfwAJnAPfCuZXlQAAAABJRU5ErkJggg==" data-sizes=auto data-src=/post/how-to-install-odoo-13-on-centos-8/featured_hu67d44bbcf73f20373cf87af3f52a98cc_31295_600x0_resize_q95_box.jpg data-srcset="
              /post/how-to-install-odoo-13-on-centos-8/featured_hu67d44bbcf73f20373cf87af3f52a98cc_31295_600x0_resize_q95_box.jpg 600w,
              /post/how-to-install-odoo-13-on-centos-8/featured.jpg 1000w
            "><noscript><img alt="" class="w-full h-full absolute inset-0 m-auto" src=/post/how-to-install-odoo-13-on-centos-8/featured.jpg></noscript></div></div></figure></div></div></a></div></section><section class="w-full mx-auto relative border-gray-200 border-t dark:border-gray-900 max-w-3xl mt-8 pt-16 py-8"><a href=https://linuxize.com/post/how-to-install-tensorflow-on-centos-8/#disqus_thread class="w-full block bg-gray-200 dark:bg-gray-900 disqus-comment-count disqus-load md:py-8 py-4 text-center" title="Show comments for post">Write a comment</a><div id=disqus_thread></div><noscript>Please enable JavaScript to view the <a href=https://disqus.com/?ref_noscript>comments powered by Disqus.</a></noscript></section></div></main><section class="w-full absolute inset-0 bg-white block h-screen hidden search z-100" id=search-box><div class="flex flex-col min-h-screen"><header class="w-full mx-auto flex items-center h-12 justify-end px-6 sm:h-16 z-10"><a href=# class="block h-6 sm:h-8" id=btn-search-close><svg aria-hidden=true class="inline-block fill-current h-6 w-6 text-gray-900 sm:h-8 sm:w-8" role=img><use xlink:href=/svg/sprite.svg#close></use></svg> <small class="block text-center sm:w-8 w-6">ESC</small></a></header><div class="w-full px-6 flex-grow flex-shrink-0 pb-8 pt-16 sm:pt-24"><div class="flex flex-col mx-auto max-w-screen-xl mb-4 mb-8"><div class=searchbox-container id=searchbox></div><div class=search-results id=search-results></div><div id=hits></div><div id=stats></div><footer class=mt-6><a href=https://github.com/algolia/instantsearch.js/ rel="noopener noreferrer" target=_blank tabindex=-1><svg aria-hidden=true class="inline-block fill-current search-algolia-logo text-gray-700" role=img><use xlink:href=/svg/sprite.svg#search-by-algolia></use></svg></a></footer></div></div></div></section><footer class="w-full px-6 bg-gray-100 dark:bg-gray-900"><div class="w-full mx-auto flex items-center justify-center flex-wrap lg:justify-between lg:text-left max-w-screen-xl py-8 text-center"><div class="w-full text-sm lg:mb-0 lg:w-1/2 mb-2"><div class="w-full block lg:flex lg:items-center lg:w-auto"><div class=lg:flex-grow><span class="dark:text-gray-300 text-gray-800 mb-2 block lg:inline-block lg:mb-0 lg:mr-8">© 2020 Linuxize.com</span> <a href=/privacy-policy/ class="dark:text-gray-300 dark-hover:text-gray-100 no-underline mr-4 footer-menu-item hover:text-gray-800 inline-block lg:mt-0 text-gray-900">Privacy Policy </a><a href=/contact/ class="dark:text-gray-300 dark-hover:text-gray-100 no-underline footer-menu-item hover:text-gray-800 inline-block lg:mt-0 text-gray-900 mr-0">Contact</a></div></div></div><div class="w-full flex lg:justify-end justify-center lg:w-1/2"><a href=https://twitter.com/linuxize class="block h-6 mr-2" aria-label=Twitter><svg aria-hidden=true class="dark:text-gray-300 inline-block fill-current h-6 w-6 text-gray-900" role=img><use xlink:href=/svg/sprite.svg#twitter></use></svg> </a><a href=https://www.facebook.com/linuxize/ class="block h-6 mr-2" aria-label=Facebook><svg aria-hidden=true class="dark:text-gray-300 inline-block fill-current h-6 w-6 text-gray-900" role=img><use xlink:href=/svg/sprite.svg#facebook></use></svg> </a><a href=/index.xml class="block h-6" aria-label=RSS><svg aria-hidden=true class="dark:text-gray-300 inline-block fill-current h-6 w-6 text-gray-900" role=img><use xlink:href=/svg/sprite.svg#rss></use></svg></a></div></div></footer></div><script src=https://cdn.jsdelivr.net/npm/algoliasearch@4.0.0/dist/algoliasearch-lite.umd.js crossorigin=anonymous integrity="sha256-MfeKq2Aw9VAkaE9Caes2NOxQf6vUa8Av0JqcUXUGkd0="></script><script src=https://cdn.jsdelivr.net/npm/instantsearch.js@4.2.0/dist/instantsearch.production.min.js crossorigin=anonymous integrity="sha256-B+gqnZmUVBAmEIiecyayAjKMHpQjJhlNMly7YIxbdfw="></script><script src=/js/1.c8402656c14c8f6b05f9.js></script><script src=/js/app.8f918459c14a510c7c16.js></script><script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('edmonton.php', '/detroitchicago/edmonton.webp?a=a&cb=0&shcb=32', true, [], true, false, false, false);
__ez.queue.addFile('jellyfish.php', '/porpoiseant/jellyfish.webp?a=a&cb=0&shcb=32', false, [], true, false, false, false);
</script>

<script>var _audins_dom="linuxize_com",_audins_did=93605;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=188-0");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.linuxize_com,DomainId.93605" border="0" height="1" width="1" alt="Quantcast"/></div></noscript><noscript><img src="https://sb.scorecardresearch.com/p?c1=2&c2=20015427&cv=2.0&cj=1"/></noscript>
<script type='text/javascript' data-cfasync='false'>(function(){function b(g,c){for(var e=0;e<c.length;e++){var d=c[e];if(0==d.complete||"undefined"!=typeof d.readyState&&4>d.readyState){var f=d.getAttribute("src")||d.currentSrc;"undefined"!=typeof d.readyState&&0==d.readyState?d.addEventListener("loadstart",function(h){var k=h.getAttribute("src")||h.currentSrc;window.ezorqs(h,k)}):(f=d.getAttribute("src")||d.currentSrc,window.ezorqs(d,f));d.addEventListener("load",function(h){var k=h.currentTarget.getAttribute("src")||h.srcElement.currentSrc;window.ezorqe(h,
k)});d.addEventListener("loadeddata",function(h){var k=h.currentTarget.getAttribute("src")||h.srcElement.currentSrc;window.ezorqe(h,k)});d.addEventListener("error",function(h){var k=h.currentTarget.getAttribute("src")||h.srcElement.currentSrc;window.ezorqe(h,k)})}}}function a(g){for(var c=0;c<document.styleSheets.length;c++)if(document.styleSheets[c].href==g)return!0;return!1}b("img",document.querySelectorAll("img"));b("video",document.querySelectorAll("video"));b("audio",document.querySelectorAll("audio"));
(function(g){for(var c=0;c<g.length;c++){var e=g[c];if(("preload"==e.getAttribute("rel")||"stylesheet"==e.getAttribute("rel"))&&null!=e.getAttribute("href")&&a(e.getAttribute("href"))){window.ezorqs(e,e.getAttribute("href"));var d=document.createElement("img");d.onerror=function(f){"undefined"!=typeof f.path&&"undefined"!=typeof f.path[0].currentSrc?window.ezorqe(e,f.path[0].currentSrc):"undefined"!=typeof f.srcElement&&"undefined"!=typeof f.srcElement.href&&window.ezorqe(e,f.srcElement.href)};d.src=
e.getAttribute("href")}}})(document.querySelectorAll("link"));"undefined"!=typeof window.__ez.ssaf&&-1<window.__ez.ssaf.indexOf(16)&&"undefined"!==typeof window.__ez.sshsdef&&!1===window.__ez.sshsdef&&Element.prototype.addEventListener&&("function"==typeof window.onload&&(window.addEventListener("load",window.onload),window.onload=null),"function"==typeof document.onload&&(document.addEventListener.addEventListener("load",document.onload),document.onload=null))})();</script><script type="text/javascript" onload="__ezcl.handle(true);" async src="/utilcave_com/inc/ezcl.webp?cb=4"></script></body></html>