<!DOCTYPE html><html class=no-js lang=en-us><head><title>How to install Python 3 on CentOS 7 | Linuxize</title><meta charset=utf-8><meta content="IE=edge" http-equiv=X-UA-Compatible><meta content="width=device-width,initial-scale=1,shrink-to-fit=no" name=viewport><meta content=Linuxize name=apple-mobile-web-app-title><meta content=Linuxize name=application-name><meta content=#2271ff name=theme-color><meta content=#2271ff name=msapplication-TileColor><meta content="This tutorial will guide you through installing Python 3 on a CentOS 7 system using the Software Collections (SCL) along side the distribution default Python version 2.7. We will also show you how to create a Python virtual environment." name=description><meta content=unsafe-url name=referrer><link href=https://linuxize.com/post/how-to-install-python-3-on-centos-7/ rel=canonical><meta content="index, follow" name=robots><meta content="Hugo 0.41" name=generator><meta content="How to install Python 3 on CentOS 7" property=og:title><meta content="This tutorial will guide you through installing Python 3 on a CentOS 7 system using the Software Collections (SCL) along side the distribution default Python version 2.7. We will also show you how to create a Python virtual environment." property=og:description><meta content=article property=og:type><meta content=/post/how-to-install-python-3-on-centos-7/ property=og:url><meta content=https://linuxize.com/post/how-to-install-python-3-on-centos-7/featured.jpg property=og:image><meta content="This tutorial will guide you through installing Python 3 on a CentOS 7 system using the Software Collections (SCL) along side the distribution default Python version 2.7. We will also show you how to create a Python virtual environment." property=og:image:alt><meta content=2018-05-29T00:40:24+01:00 property=article:published_time><meta content=2018-05-29T00:40:24+01:00 property=article:modified_time><meta content=en property=og:locale><meta content=post property=article:section><meta content=https://www.facebook.com/linuxize property=article:publisher><meta content=python property=article:tag><meta content=pip property=article:tag><meta content=virtenv property=article:tag><meta content=centos property=article:tag><meta content=python,pip,virtenv,centos name=news_keywords><meta content=summary_large_image name=twitter:card><meta content=https://linuxize.com/post/how-to-install-python-3-on-centos-7/featured.jpg name=twitter:image><meta content="How to install Python 3 on CentOS 7" name=twitter:title><meta content="This tutorial will guide you through installing Python 3 on a CentOS 7 system using the Software Collections (SCL) along side the distribution default Python version 2.7. We will also show you how to create a Python virtual environment." name=twitter:description><meta content=@linuxize name=twitter:site><link href=/favicons/apple-touch-icon.png rel=apple-touch-icon sizes=180x180><link href=/favicons/favicon-32x32.png rel=icon sizes=32x32 type=image/png><link href=/favicons/favicon-16x16.png rel=icon sizes=16x16 type=image/png><link href=/favicons/safari-pinned-tab.svg rel=mask-icon color=#2271ff><script type=application/ld+json>{
  "@context": "http://schema.org",
  "@type": "BlogPosting",
  "headline": "How to install Python 3 on CentOS 7",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://linuxize.com/post/how-to-install-python-3-on-centos-7/"
  },"image": {
     "@type": "ImageObject",
     "url": "https://linuxize.com/post/how-to-install-python-3-on-centos-7/featured.jpg",
     "width": 1000,
     "height": 530
    },"keywords": "python, pip, virtenv, centos",
  "wordcount": 686,
  "url": "https://linuxize.com/post/how-to-install-python-3-on-centos-7/",
  "datePublished": "2018-05-29T00:40:24+01:00",
  "dateModified": "2018-05-29T00:40:24+01:00",
  "publisher": {
    "@type": "Organization","logo": {
    "@type": "imageObject",
      "url": "https://linuxize.com/assets/linuxize-card.png"
    },"name": "Linuxize"
  },

  "author": {
    "@type": "Person",
    "name": "Linuxize"
  },
  "description": "This tutorial will guide you through installing Python 3 on a CentOS 7 system using the Software Collections (SCL) along side the distribution default Python version 2.7. We will also show you how to create a Python virtual environment."
}</script><script src=/js/ads.js></script><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-P827G6S');</script><script src=https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js async></script><meta content=#2271ff name=theme-color><link href=/manifest.79f739767e479131c04f7216cce1c084.json rel=manifest><link href="https://fonts.googleapis.com/css?family=IBM+Plex+Sans:300,400,400i,500,700%7CIBM+Plex+Serif:300,400,400i,600,600i" rel=stylesheet><link href=/css/app.a9358911e1fcc5712cc9.css rel=stylesheet></head><body class="text-black font-sans kind-page leading-normal section-post type-post"><div class="flex flex-col min-h-screen main-wrap"><header class="w-full px-6 z-10 bg-white border-b border-grey-light fixed linuxize-shadow" id=header><nav class="w-full mx-auto flex items-center h-12 sm:h-16 justify-start"><a href=/ class="flex items-center block flex-no-shrink mr-6 no-underline text-black"><svg aria-hidden=true class="h-6 w-6 fill-current sm:h-8 sm:w-8 mr-2"><use xlink:href=#logo></use><title>Linuxize</title></svg> <span class="hidden font-medium sm:block text-xl tracking-tight">Linuxize</span></a><div class="flex justify-center -mb-px flex-1 min-w-0 text-sm"><div class="hidden font-medium nav-post-title sm:text-lg text-center truncate">How to install Python 3 on CentOS 7</div></div><div class="flex justify-end"><button class="h-6 block sm:h-8" id=btn-search><svg aria-hidden=true class="h-6 w-6 fill-current inline-block text-grey-darkest sm:h-8 sm:w-8"><use xlink:href=#search></use><title>Search</title></svg></button></div></nav></header><main class="w-full px-6 flex-grow flex-no-shrink pb-8 pt-16 sm:pt-24 main"><article class="single-post relative"><div class="mx-auto max-w-xl mb-4 xl:flex xl:max-w-4xl xl:mb-8"><div class="w-full xl:w-1/2 self-auto xxl:flex-no-shrink xxl:w-190"><section class="w-full post-header xl:pr-8"><div class=mb-4><div class="w-full flex justify-center content-center"><div class="w-full relative"><ins class="mx-auto adsbygoogle top-a" data-ad-client=ca-pub-9439755881064125 data-ad-format=auto data-ad-slot=4501323511 style=display:block></ins></div></div></div><div class="flex flex-col mb-4 font-medium md:flex-row text-xs uppercase xxl:text-sm"><div class=inline-flex><time class="" datetime=2018-05-29T00:40:24+01:00>May 29, 2018 </time><span class=mx-2>•</span><p>Read in 4 minutes</p></div></div><h1 class="text-black font-bold leading-none lg:text-5xl mb-4 text-3xl xl:mb-4 xxl:text-6xl">How to install Python 3 on CentOS 7</h1></section></div><div class="w-full xl:w-1/2 bg-grey"><section class="w-full mx-auto max-w-xl"><figure class="-mx-6 lg:mx-0 relative"><div class="w-full mx-auto my-0 block relative"><div class=block style=padding-bottom:53%></div><div class="w-full h-full absolute m-auto pin bg-grey-lighter overflow-hidden"><img alt="" class="w-full h-full absolute m-auto pin" src=/post/how-to-install-python-3-on-centos-7/featured.jpg></div></div></figure></section></div></div><section class="w-full mx-auto sticky-element"><section class="w-full mx-auto max-w-article hidden sticky-element xl:block xl:max-w-4xl"><aside class="bg-grey-lighter mb-6 mt-8 p-4 pb-2 table-of-contents xl:absolute xl:mt-0 xl:pin-r xl:text-sm xl:w-48 xxl:w-75"><p class="font-bold mb-3 text-grey-darker xl:text-base">Contents</p><nav id=TableOfContents><ul><li><ul><li><a href=#enable-software-collections>Enable Software Collections</a></li><li><a href=#install-python-3>Install Python 3</a></li><li><a href=#using-python-3>Using Python 3</a></li><li><a href=#install-development-tools>Install development tools</a></li><li><a href=#creating-a-virtual-environment>Creating a virtual environment</a></li><li><a href=#conclusion>Conclusion</a></li></ul></li></ul></nav></aside></section></section><section class="w-full mx-auto max-w-article markdown"><aside class="aside-wrapper relative"><div class="w-full mx-auto sideblock sticky"><div class="xl:absolute xxl:w-75 sideblock-content xl:-ml-52 xl:pin-l xl:w-40 xxl:-ml-89"><a href="https://www.vultr.com/?ref=6812257" class="hidden affiliate"></a><div class="w-full flex justify-center content-center"><div class="w-full relative"><ins class="mx-auto adsbygoogle" data-ad-client=ca-pub-9439755881064125 data-ad-format=auto data-ad-slot=9558702194 style=display:block></ins></div></div></div></div></aside><p>This tutorial will guide you through installing Python 3 on a CentOS 7 system using the Software Collections (SCL) along side the distribution default Python version 2.7. We will also show you how to create a Python virtual environment.</p><p>Python is one of the most popular programming languages in the world, with its simple and easy to learn syntax Python is a great choice for beginners and experienced developers. Python is quite versatile programming language, you can use it to do almost anything you want, write small scripts, build games, develop websites, create machine learning algorithms, analyze data and more.</p><p>While Python 2 is well-supported and active, Python 3 is considered to be the present and future of the language.</p><h2 id=enable-software-collections>Enable Software Collections</h2><p><a href=https://www.softwarecollections.org/en/ >Software Collections</a>, also known as SCL is a community project that allows you to build, install, and use multiple versions of software on the same system, without affecting system default packages. By enabling Software Collections you will gain access to the newer versions of programming languages and services which are not available in the core repositories.</p><p>In order to enable SCL we need to install the CentOS SCL release file. It is part of the CentOS extras repository and can be installed by running the following command:</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash>sudo yum install centos-release-scl</code></pre></div><h2 id=install-python-3>Install Python 3</h2><p>Now that we have access to the SCL repository we can install any Python 3.x version we need. Currently the following collections are available:</p><ul><li>Python 3.3</li><li>Python 3.4</li><li>Python 3.5</li><li>Python 3.6</li></ul><p>In this tutorial we will install Python 3.6 which is the latest version available at the time of writing. To do so type the following command on your CentOS 7 terminal:</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash>sudo yum install rh-python36</code></pre></div><h2 id=using-python-3>Using Python 3</h2><p>If you check the Python version by typing:</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash>python --version</code></pre></div><div class=highlight><pre class=chroma><code class=language-output data-lang=output>Python 2.7.5</code></pre></div><p>you will notice that Python 2.7 is the default Python version in your current shell.</p><p>To access Python 3.6 you need to launch a new shell instance using the Software Collection <code>scl</code> tool:</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash>scl <span class=nb>enable</span> rh-python36 bash</code></pre></div><p>What the command above does is calling the script <code>/opt/rh/rh-python36/enable</code> which changes the shell environment variables.</p><p>If you check the Python version now you’ll notice that Python 3.6 is the default version.</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash>python --version</code></pre></div><div class=highlight><pre class=chroma><code class=language-output data-lang=output>Python 3.6.3</code></pre></div><p>It is important to point out that Python 3.6 is the default Python version only in this shell session. If you exit the session or open a new session from another terminal Python 2.7 will be the default Python version.</p><h2 id=install-development-tools>Install development tools</h2><p>Development tools are required for building Python modules, you can install the necessary tools and libraries by typing:</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash>sudo yum groupinstall <span class=s1>'Development Tools'</span></code></pre></div><div><small class=text-grey><small>Advertisement</small></small></div><div class="w-full flex justify-center content-center"><div class="w-full relative"><ins class=adsbygoogle data-ad-client=ca-pub-9439755881064125 data-ad-format=fluid data-ad-slot=5120214995 style=display:block data-ad-layout=in-article></ins></div></div><h2 id=creating-a-virtual-environment>Creating a virtual environment</h2><p>Python <code>Virtual Environments</code> allows you to install Python modules in an isolated location for a specific project, rather than being installed globally. This way you do not have to worry of affecting other Python projects.</p><p>The preferred way to create a new virtual environment in Python 3 is by executing the <code>venv</code> command.</p><p>Let’s say we want to create a new Python 3 project called <code>my_new_project</code> inside our user home directory and matching virtual environment.</p><p>First create the project directory and switch to it:</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash>mkdir ~/my_new_project
<span class=nb>cd</span> ~/my_new_project</code></pre></div><p>Activate Python 3.6 using the <code>scl</code> tool:</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash>scl <span class=nb>enable</span> rh-python36 bash</code></pre></div><p>From inside the project root run the following command to create a virtual environment named <code>my_project_venv</code>:</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash>python -m venv my_project_venv</code></pre></div><p>To use the virtual environment we need to activate it, by typing:</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash><span class=nb>source</span> my_project_venv/bin/activate</code></pre></div><p>After activating the environment, the shell prompt will be prefixed with the name of the environment:</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash><span class=o>(</span>my_project_venv<span class=o>)</span> <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="d8adabbdaa98b0b7abac">[email&#160;protected]</a>:~/my_new_project$</code></pre></div><p>It’s worth mentioning that starting with Python 3.4, when creating virtual environments, <a href=/post/how-to-install-pip-on-centos-7/ >pip the package manager</a> for Python is installed by default.</p><h2 id=conclusion>Conclusion</h2><p>You should now have Python 3 programming environment setup on your CentOS 7 machine and you can start developing a Python 3 project. You can also read about how to <a href=/post/install-odoo-11-on-centos-7/ >Install Odoo 11 on CentOS 7</a> and see an example of how to use Python 3 virtual environment to run Python software on a CentOS 7 server.</p><p>If you have any questions or feedback, feel free to comment below.</p><div class="w-full flex justify-center content-center"><div class="w-full relative"><ins class="mx-auto adsbygoogle" data-ad-client=ca-pub-9439755881064125 data-ad-format=auto data-ad-slot=7027266996 style=display:block></ins></div></div><div class="flex flex-wrap mt-6"><a href=/tags/python class="bg-grey-lighter hover:bg-grey-light mr-2 mt-2 px-4 py-2 rounded text-grey-darker text-xs">python</a> <a href=/tags/pip class="bg-grey-lighter hover:bg-grey-light mr-2 mt-2 px-4 py-2 rounded text-grey-darker text-xs">pip</a> <a href=/tags/virtenv class="bg-grey-lighter hover:bg-grey-light mr-2 mt-2 px-4 py-2 rounded text-grey-darker text-xs">virtenv</a> <a href=/tags/centos class="bg-grey-lighter hover:bg-grey-light mr-2 mt-2 px-4 py-2 rounded text-grey-darker text-xs">centos</a></div></section><section class="w-full mx-auto max-w-article bg-blue rounded"><nav class="flex mb-6 mt-8 p-8"><span class="font-bold mr-4 self-center text-sm text-white tracking-wide uppercase">Share <span class="self-center lg:hidden">:</span> </span><a href="https://twitter.com/share?text=How%20to%20install%20Python%203%20on%20CentOS%207&url=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-install-python-3-on-centos-7%2f" class="h-6 w-6 mr-3" target=_blank><svg aria-hidden=true class="h-6 w-6 fill-current inline-block hover:text-white text-blue-lightest"><use xlink:href=#twitter></use><title>Share on Twitter</title></svg> </a><a href="https://www.facebook.com/sharer/sharer.php?caption=How%20to%20install%20Python%203%20on%20CentOS%207&u=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-install-python-3-on-centos-7%2f" class="h-6 w-6 mr-3" target=_blank><svg aria-hidden=true class="h-6 w-6 fill-current inline-block hover:text-white text-blue-lightest"><use xlink:href=#facebook></use><title>Share on Facebook</title></svg> </a><a href="https://pinterest.com/pin/create/button/?url=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-install-python-3-on-centos-7%2f&media=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-install-python-3-on-centos-7%2ffeatured.jpg&description=How%20to%20install%20Python%203%20on%20CentOS%207" class="h-6 w-6 mr-3" target=_blank><svg aria-hidden=true class="h-6 w-6 fill-current inline-block hover:text-white text-blue-lightest"><use xlink:href=#pinterest></use><title>Share on Pinterest</title></svg> </a><a href="https://plus.google.com/share?url=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-install-python-3-on-centos-7%2f" class="h-6 w-6 mr-3" target=_blank><svg aria-hidden=true class="h-6 w-6 fill-current inline-block hover:text-white text-blue-lightest"><use xlink:href=#gplus></use><title>Share on Google Plus</title></svg> </a><a href="https://news.ycombinator.com/submitlink?t=How%20to%20install%20Python%203%20on%20CentOS%207&u=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-install-python-3-on-centos-7%2f" class="h-6 w-6 mr-3" target=_blank><svg aria-hidden=true class="h-6 w-6 fill-current inline-block hover:text-white text-blue-lightest"><use xlink:href=#hacker-news></use><title>Submit to Hacker News</title></svg> </a><a href="/cdn-cgi/l/email-protection#c0ffb3b5a2aaa5a3b4fd88afb7e5f2f0b4afe5f2f0a9aeb3b4a1acace5f2f090b9b4a8afaee5f2f0f3e5f2f0afaee5f2f083a5aeb48f93e5f2f0f7e6a2afa4b9fd83a8a5a3abe5f2f0afb5b4e5f2f0b4a8a9b3e5f2f0a1b2b4a9a3aca5fae5f081e5f081a8b4b4b0b3e5f3a1e5f2a6e5f2a6aca9aeb5b8a9baa5eea3afade5f2a6b0afb3b4e5f2a6a8afb7edb4afeda9aeb3b4a1acacedb0b9b4a8afaeedf3edafaeeda3a5aeb4afb3edf7e5f2a6" class="h-6 w-6" target=_blank><svg aria-hidden=true class="h-6 w-6 fill-current inline-block hover:text-white text-blue-lightest"><use xlink:href=#email></use><title>Share with Email</title></svg></a></nav></section></article><section class="w-full mx-auto max-w-xl border-grey-lighter border-t mt-8 pt-8"><div class="bg-grey-lighter p-8 sm:py-16"><p class="mx-auto my-0 lg:text-2xl max-w-md sm:text-xl text-center text-lg">Sign up to our newsletter and get our latest tutorials and news straight to your mailbox.</p><form action="https://linuxize.us17.list-manage.com/subscribe/post?u=35cd4cd9d021c25c3dd7cabfd&id=9cfa4c89de" class=pt-8 id=mc-embedded-subscribe-form method=post name=mc-embedded-subscribe-form novalidate target=_blank><div class="w-full mx-auto flex items-center flex-col justify-between max-w-sm mb-2 sm:flex-row"><input class="w-full px-4 py-3 rounded appearance-none bg-white block border hover:border-grey-dark mb-3 sm:mb-0 text-grey-darker" name=EMAIL placeholder="Your email..." type=email> <input class=hidden name=b_35cd4cd9d021c25c3dd7cabfd_9cfa4c89de tabindex=-1> <button class="w-full px-4 py-3 rounded bg-blue hover:bg-blue-dark sm:ml-4 sm:w-auto text-white" name=subscribe type=submit><span class=text-center>Subscribe</span></button></div><p class="w-full mx-auto my-0 max-w-sm text-sm">We’ll never share your email address or spam you.</p></form></div></section><div class="w-full mx-auto max-w-xl border-grey-lighter border-t mt-8 pt-8 justify-center"><a href="https://shareasale.com/r.cfm?b=1144537&u=1755182&m=41388&urllink=&afftrack=" class="mx-auto block wp-engine"></a></div><section class="w-full mx-auto max-w-xl border-grey-lighter border-t mt-8 pt-8"><div class="flex flex-wrap -mx-4"><a href=https://linuxize.com/post/install-odoo-11-on-centos-7/ class="w-full flex md:mb-0 md:w-1/3 overflow-hidden px-4 mb-8"><div class="w-full flex flex-col h-full"><p class="text-xs uppercase font-normal text-grey-dark">Mar 29, 2018</p><div class="font-normal flex-grow mb-2 md:mb-4 text-black text-lg">Install Odoo 11 on CentOS 7</div><div><figure class=relative><div class="w-full mx-auto my-0 block relative"><div class=block style=padding-bottom:53%></div><div class="w-full h-full absolute m-auto pin bg-grey-lighter overflow-hidden"><img alt="" class="w-full h-full absolute m-auto pin" src=/post/install-odoo-11-on-centos-7/featured.jpg></div></div></figure></div></div></a><a href=https://linuxize.com/post/how-to-install-pip-on-centos-7/ class="w-full flex md:mb-0 md:w-1/3 overflow-hidden px-4 mb-8"><div class="w-full flex flex-col h-full"><p class="text-xs uppercase font-normal text-grey-dark">May 27, 2018</p><div class="font-normal flex-grow mb-2 md:mb-4 text-black text-lg">How to install Pip on CentOS 7</div><div><figure class=relative><div class="w-full mx-auto my-0 block relative"><div class=block style=padding-bottom:53%></div><div class="w-full h-full absolute m-auto pin bg-grey-lighter overflow-hidden"><img alt="" class="w-full h-full absolute m-auto pin" src=/post/how-to-install-pip-on-centos-7/featured.jpg></div></div></figure></div></div></a><a href=https://linuxize.com/post/how-to-deploy-odoo-11-on-ubuntu-18-04/ class="w-full flex md:mb-0 md:w-1/3 overflow-hidden px-4 mb-0"><div class="w-full flex flex-col h-full"><p class="text-xs uppercase font-normal text-grey-dark">May 3, 2018</p><div class="font-normal flex-grow mb-2 md:mb-4 text-black text-lg">How to deploy Odoo 11 on Ubuntu 18.04</div><div><figure class=relative><div class="w-full mx-auto my-0 block relative"><div class=block style=padding-bottom:53%></div><div class="w-full h-full absolute m-auto pin bg-grey-lighter overflow-hidden"><img alt="" class="w-full h-full absolute m-auto pin" src=/post/how-to-deploy-odoo-11-on-ubuntu-18-04/featured.jpg></div></div></figure></div></div></a></div></section><section class="w-full mx-auto relative border-grey-lighter border-t max-w-lg mt-8 pt-16 py-8"><a href=https://linuxize.com/post/how-to-install-python-3-on-centos-7/#disqus_thread class="w-full disqus-comment-count bg-grey-lighter block disqus-load md:py-8 py-4 text-center" title="Show comments for post">Write a comment</a><div id=disqus_thread></div><noscript>Please enable JavaScript to view the <a href=https://disqus.com/?ref_noscript>comments powered by Disqus.</a></noscript></section></main><section class="w-full absolute pin bg-white block h-screen invisible search z-50" hidden id=search><div class="flex flex-col min-h-screen"><header class="w-full mx-auto flex items-center h-12 sm:h-16 justify-end px-6 z-10"><a href=# class="h-6 block sm:h-8" id=btn-search-close><svg aria-hidden=true class="h-6 w-6 fill-current inline-block text-grey-darkest sm:h-8 sm:w-8 -mb-2"><use xlink:href=#close></use><title>Close search form</title></svg> <small class="block text-center sm:w-8 w-6">ESC</small></a></header><div class="w-full px-6 flex-grow flex-no-shrink pb-8 pt-16 sm:pt-24"><div class="mx-auto max-w-xl flex flex-col mb-4 mb-8"><input class="w-full appearance-none bg-transparent focus:outline-0 font-medium md:text-3xl placeholder-grey-dark search-input sm:text-2xl text-grey-darkest text-xl" placeholder="Type to search" autocomplete=off id=search-input><div class=search-results id=search-results></div><div id=hits></div><div id=stats></div><footer class=mt-6><a href=https://algolia.com target=_blank rel="noopener noreferrer" tabindex=-1><svg aria-hidden=true class="inline-block fill-current search-algolia-logo text-grey-dark"><use xlink:href=#search-by-algolia></use><title>Search by Algolia</title></svg></a></footer></div></div></div></section><footer class="w-full px-6 bg-grey-lightest"><div class="w-full mx-auto max-w-xl justify-center flex flex-wrap items-center md:justify-between md:text-left py-8 text-center"><div class="w-full md:w-1/2 mb-2 md:mb-0 text-sm"><div class="w-full md:flex block md:items-center md:w-auto"><div class=md:flex-grow><span class="block mb-2 md:inline-block md:mb-0 md:mr-8 text-grey-dark">© 2018 Linuxize.com</span> <a href=/privacy-policy/ class="inline-block text-grey-darkest footer-menu-item hover:text-grey-darker md:mt-0 no-underline mr-4">Privacy Policy </a><a href=/contact/ class="inline-block text-grey-darkest footer-menu-item hover:text-grey-darker md:mt-0 no-underline mr-0">Contact</a></div></div></div><div class="w-full flex justify-center md:justify-end md:w-1/2"><a href=https://twitter.com/linuxize class="h-6 block mr-2"><svg aria-hidden=true class="h-6 w-6 fill-current inline-block text-grey-darkest"><use xlink:href=#twitter></use><title>Twitter</title></svg> </a><a href=https://www.facebook.com/linuxize/ class="h-6 block mr-2"><svg aria-hidden=true class="h-6 w-6 fill-current inline-block text-grey-darkest"><use xlink:href=#facebook></use><title>Facebook</title></svg> </a><a href=/index.xml class="h-6 block"><svg aria-hidden=true class="h-6 w-6 fill-current inline-block text-grey-darkest"><use xlink:href=#rss></use><title>RSS</title></svg></a></div></div></footer></div><script data-cfasync="false" src="/cdn-cgi/scripts/f2bf09f8/cloudflare-static/email-decode.min.js"></script><script src=https://cdnjs.cloudflare.com/ajax/libs/instantsearch.js/2.7.4/instantsearch.min.js></script><script src=/js/0.08e756336321857fbed0.js></script><script src=/js/app.a9358911e1fcc5712cc9.js></script></body></html>