<!doctype html><html class=no-js lang=en-us><head><meta charset=utf-8>
<script data-cfasync='false' data-pagespeed-no-defer>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</script><script data-cfasync='false' data-pagespeed-no-defer>__ez.pel=function(){var z=[],i="/porpoiseant/army.gif";function t(e,i,t,d,_,o,n){if(__ez.dot.isDefined(e,e.getSlotElementId)){var a=parseInt(e.getTargeting("ap")[0]),r=function(e){var i=0;try{var t=e.getTargetingMap(),d=e.getSlotElementId();if(-1===d.indexOf("div-gpt-ad"))return i;if(void 0!==t)for(var _ in t)if(-1!==_.indexOf("iid")&&void 0!==t[_][0]){i=t[_][0];break}}catch(e){}return i}(e),s=e.getSlotElementId(),p=parseInt(e.getTargeting("compid")[0]),g=0,v=0;if("object"==typeof _ezim_d){var m=e.getAdUnitPath().split("/").pop();void 0!==_ezim_d[m]&&(void 0!==_ezim_d[m].creative_id&&(v=_ezim_d[m].creative_id),void 0!==_ezim_d[m].line_item_id&&(g=_ezim_d[m].line_item_id))}__ez.dot.isDefined(r,s)&&__ez.dot.isValid(i)&&z.push({type:"impression",impression_id:r,domain_id:__ez.dot.getDID(),unit:s,t_epoch:__ez.dot.getEpoch(0),revenue:t,est_revenue:d,ad_position:a,ad_size:"",bid_floor_filled:_,bid_floor_prev:o,stat_source_id:n,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:p,line_item_id:g,creative_id:v,data:__ez.dot.dataToStr(i)})}}function d(){if(void 0===document.visibilityState||"prerender"!==document.visibilityState){if(__ez.dot.isDefined(z)&&0<z.length){var e=__ez.dot.getURL(i)+"?orig="+(!0===__ez.template.isOrig?1:0)+"&sts="+btoa(JSON.stringify(z));void 0!==window.isAmp&&isAmp&&void 0!==window._ezaq&&_ezaq.hasOwnProperty("domain_id")&&(e+="&visit_uuid="+_ezaq.visit_uuid),(new Image).src=e}z=[]}}return{Add:t,AddAndFire:function(e,i){t(e,i,0,0,0,0,0),d()},AddById:function(e,i){var t=e.split("/");if(__ez.dot.isDefined(e)&&3===t.length&&__ez.dot.isValid(i)){var d=t[0],_=t[2];z.push({type:"impression",impression_id:_,domain_id:__ez.dot.getDID(),unit:d,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(i)})}},Fire:d}}();var EzoicPixel=function(){this.pixels=[],this.pixelUrl="/ezoic/e.gif",("undefined"!=typeof ezJsu&&!0===ezJsu||"undefined"!=typeof _ez_sa&&!0===_ez_sa||void 0!==window.isAmp&&!0===isAmp||"undefined"!=typeof ezWp&&!0===ezWp)&&(this.pixelUrl="//g.ezoic.net"+this.pixelUrl),this.tEpoch=0,"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("t_epoch")&&(this.tEpoch=_ezaq.t_epoch)},EzoicPixelData=function(i,e){this.name=i,this.val=e};EzoicPixel.prototype={constructor:EzoicPixel,AddAndFireImpPixel:function(i,e){this.AddImpPixel(i,e,0,0,0,0,0),this.FirePixels()},AddAndFirePVPixel:function(i,e){this.AddPVPixel(i,e),this.FirePixels()},AddImpPixel:function(i,e,t,n,o,a,r){if(this.isDefined(i,i.getSlotElementId)){var d=parseInt(i.getTargeting("ap")[0]),s=i.getSizes()[0],p=s.l.toString()+"x"+s.j.toString(),l="0",h="XX";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(l=_ezaq.domain_id.toString()),"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("country")&&(h=_ezaq.country);var f=this.getSlotIID(i),c=i.getSlotElementId();this.isDefined(f,c)&&this.validateData(e)&&(e=this.convertDataToStr(e),this.pixels.push({type:"impression",impression_id:f,domain_id:l,unit:c,t_epoch:this.tEpoch,revenue:t,est_revenue:n,ad_position:d,ad_size:p,bid_floor_filled:o,bid_floor_prev:a,stat_source_id:r,country_code:h,data:e}))}},AddImpPixelById:function(i,e){var t="0";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(t=_ezaq.domain_id.toString());var n=i.split("/");if(this.isDefined(i)&&3===n.length&&this.validateData(e)){var o=n[0],a=n[2];e=this.convertDataToStr(e),this.pixels.push({type:"impression",impression_id:a,domain_id:t,unit:o,t_epoch:this.tEpoch,data:e})}},AddPVPixel:function(i,e){var t="0";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(t=_ezaq.domain_id.toString()),this.isDefined(i)&&this.validateData(e)&&(e=this.convertDataToStr(e),this.pixels.push({type:"pageview",pageview_id:i,domain_id:t,t_epoch:this.tEpoch,data:e}))},FirePixels:function(){void 0!==document.visibilityState&&"prerender"===document.visibilityState||(this.isDefined(this.pixels)&&this.pixels.length>0&&((new Image).src=this.pixelUrl+"?orig="+(!0===__ez.template.isOrig?1:0)+"&pixels="+encodeURIComponent(JSON.stringify(this.pixels))),this.pixels=[])},NewData:function(i,e){return new EzoicPixelData(i,e)},convertDataToStr:function(i){if(void 0===i)return[];try{for(var e in i)i[e].val=i[e].val+""}catch(i){}return i},getSlotIID:function(i){var e=0;try{var t=i.getTargetingMap();if(-1===i.getSlotElementId().indexOf("div-gpt-ad"))return e;if(void 0!==t)for(var n in t)if(-1!==n.indexOf("iid")&&void 0!==t[n][0]){e=t[n][0];break}}catch(i){}return e},isDefined:function(){for(var i=0;i<arguments.length;i++)if(void 0===arguments[i]||null===arguments[i])return console.error("Argument not defined. ",arguments),!1;return!0},validateData:function(i){for(var e=0;e<i.length;e++)if(i[e]instanceof EzoicPixelData==!1)return console.error("Invalid pixelData. ",i[e]),!1;return!0}};</script><title>Bash Arrays | Linuxize</title><meta content="IE=edge" http-equiv=X-UA-Compatible><meta content="width=device-width,initial-scale=1,shrink-to-fit=no" name=viewport><meta content=Linuxize name=apple-mobile-web-app-title><meta content=Linuxize name=application-name><meta content=#2271ff name=theme-color><meta content=#2271ff name=msapplication-TileColor><meta content="Arrays are one of the most used and fundamental data structures. In this article, we’ll discuss Bash arrays, and how to use them in your Bash scripts with the help of examples." name=description><meta content=unsafe-url name=referrer><link href=https://linuxize.com/post/bash-arrays/ rel=canonical><meta content="index, follow" name=robots><meta content="Bash Arrays" property=og:title><meta content="Arrays are one of the most used and fundamental data structures. In this article, we’ll discuss Bash arrays, and how to use them in your Bash scripts with the help of examples." property=og:description><meta content=article property=og:type><meta content=/post/bash-arrays/ property=og:url><meta content=https://linuxize.com/post/bash-arrays/featured.jpg property=og:image><meta content="Arrays are one of the most used and fundamental data structures. In this article, we’ll discuss Bash arrays, and how to use them in your Bash scripts with the help of examples." property=og:image:alt><meta content=2019-05-27T20:31:47+01:00 property=article:published_time><meta content=2019-05-27T20:31:47+01:00 property=article:modified_time><meta content=en property=og:locale><meta content=post property=article:section><meta content=https://www.facebook.com/linuxize property=article:publisher><meta content=bash property=article:tag><meta content=terminal property=article:tag><meta content=bash,terminal name=news_keywords><meta content=summary_large_image name=twitter:card><meta content=https://linuxize.com/post/bash-arrays/featured.jpg name=twitter:image><meta content="Bash Arrays" name=twitter:title><meta content="Arrays are one of the most used and fundamental data structures. In this article, we’ll discuss Bash arrays, and how to use them in your Bash scripts with the help of examples." name=twitter:description><meta content=@linuxize name=twitter:site><link href=/favicons/apple-touch-icon.png rel=apple-touch-icon sizes=180x180><link href=/favicons/favicon-32x32.png rel=icon type=image/png sizes=32x32><link href=/favicons/favicon-16x16.png rel=icon type=image/png sizes=16x16><link href=/favicons/safari-pinned-tab.svg rel=mask-icon color=#2271ff><link href=/fonts/ibm-plex-sans-v6-latin-regular.woff2 rel=preload type=font/woff2 as=font crossorigin><link href=/fonts/ibm-plex-sans-v6-latin-500.woff2 rel=preload type=font/woff2 as=font crossorigin><link href=/fonts/ibm-plex-sans-v6-latin-700.woff2 rel=preload type=font/woff2 as=font crossorigin><link href=/fonts/ibm-plex-serif-v7-latin-regular.woff2 rel=preload type=font/woff2 as=font crossorigin><link href=/fonts/ibm-plex-serif-v7-latin-700.woff2 rel=preload type=font/woff2 as=font crossorigin><script type=application/ld+json>{
  "@context": "http://schema.org",
  "@type": "BlogPosting",
  "headline": "Bash Arrays",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https:\/\/linuxize.com\/post\/bash-arrays\/"
  },"image": {
     "@type": "ImageObject",
     "url": "https:\/\/linuxize.com\/post\/bash-arrays\/featured.jpg",
     "width":  1000 ,
     "height":  530 
    },"keywords": "bash, terminal",
  "wordcount":  1021 ,
  "url": "https:\/\/linuxize.com\/post\/bash-arrays\/",
  "datePublished": "2019-05-27T20:31:47+01:00",
  "dateModified": "2019-05-27T20:31:47+01:00",
  "publisher": {
    "@type": "Organization","logo": {
    "@type": "imageObject",
      "url": "https:\/\/linuxize.com\/assets\/linuxize-card.png"
    },"name": "Linuxize"
  },

  "author": {
    "@type": "Person",
    "name": "Linuxize"
  },
  "description": "Arrays are one of the most used and fundamental data structures. In this article, we’ll discuss Bash arrays, and how to use them in your Bash scripts with the help of examples."
}</script><script src=/js/ads.js></script><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-P827G6S');</script><script src=https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js async></script><script>(adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-9439755881064125",
          enable_page_level_ads: true
     });</script><meta content=#2271ff name=theme-color><link href=/manifest.79f739767e479131c04f7216cce1c084.json rel=manifest><link href=/css/app.1b285cee43d21dd67288.css rel=stylesheet>
<script data-cfasync="false" type="text/javascript">window.google_analytics_uacct = "UA-124335151-13";</script>
<script data-cfasync="false" type="text/javascript">
var _gaq = _gaq || [];
_gaq.push(['e._setAccount', 'UA-124335151-13']);
_gaq.push(['f._setAccount', 'UA-38339005-1']);
_gaq.push(['e._setDomainName', 'linuxize.com']);
_gaq.push(['f._setDomainName', 'linuxize.com']);
_gaq.push(['e._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['e._setCustomVar',2,'t','126',3]);
_gaq.push(['e._setCustomVar',3,'rid','0',2]);
_gaq.push(['e._setCustomVar',4,'bra','mod52-c',3]);
_gaq.push(['e._setAllowAnchor',true]);
_gaq.push(['e._setSiteSpeedSampleRate', 10]);
_gaq.push(['f._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['f._setCustomVar',2,'domain','linuxize.com',3]);
_gaq.push(['f._setSiteSpeedSampleRate', 20]);
_gaq.push(['e._trackPageview']);
_gaq.push(['f._trackPageview']);


(function() {
 var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
 ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
 var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
})();
</script>
<script type="text/javascript">var ezouid = "1";</script><base href="https://linuxize.com/post/bash-arrays/"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script type='text/javascript'>
var soc_app_id = '0';
var did = 93605;
var ezdomain = 'linuxize.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":93605,"engaged_time_visit":0,"ezcache_level":1,"forensiq_score":-1,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"ba410453-0941-426b-4cce-40759ef1b798","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_time_orig":7,"serverid":"3.94.82.139:3872","state":"VA","t_epoch":1559036500,"template_id":126,"time_on_site_visit":0,"url":"https://linuxize.com/post/bash-arrays/","user_id":0,"word_count":1408,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script><script data-cfasync='false' type="text/javascript" src="/detroitchicago/rochester.js?cb=184-0&v=8" async></script>
<script data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl() {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_93605=" + new Date().getTime() + "|ba410453-0941-426b-4cce-40759ef1b798; " + expires, 3);
}
function attach_ezolpl() {
    if(window.attachEvent) {
        window.attachEvent('onload', create_ezolpl);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl();
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl;
        }
    }
}
attach_ezolpl();
</script></head><body class="text-gray-800 font-sans kind-page leading-normal section-post type-post"><div class="flex flex-col min-h-screen main-wrap"><header class="w-full px-6 bg-white border-b border-gray-400 fixed linuxize-shadow z-50" id=header><nav class="w-full mx-auto flex items-center h-12 sm:h-16 justify-start"><a href=/ class="flex items-center block flex-shrink-0 mr-6 no-underline text-black" aria-label=Linuxize.com><svg aria-hidden=true class="h-6 w-6 fill-current sm:h-8 sm:w-8 mr-2"><use xlink:href=/svg/sprite.svg#logo></use><title>Linuxize</title></svg> <span class="font-medium hidden sm:block text-xl tracking-tight">Linuxize</span></a><div class="flex -mb-px flex-1 min-w-0 text-sm"><a href=/tags/ubuntu/ class="hidden sm:block hover:text-gray-900 mr-4 no-underline text-gray-800"><span class="inline-block font-bold md:py-6 py-3 sm:py-4">Ubuntu </span></a><a href=/tags/centos/ class="hidden sm:block hover:text-gray-900 mr-4 no-underline text-gray-800"><span class="inline-block font-bold md:py-6 py-3 sm:py-4">Centos </span></a><a href=/tags/debian/ class="hidden sm:block hover:text-gray-900 mr-4 no-underline text-gray-800"><span class="inline-block font-bold md:py-6 py-3 sm:py-4">Debian </span></a><a href=/tags/terminal/ class="hidden sm:block hover:text-gray-900 mr-4 no-underline text-gray-800"><span class="inline-block font-bold md:py-6 py-3 sm:py-4">Linux Commands </span></a><a href=/series/ class="hidden sm:block hover:text-gray-900 mr-4 no-underline text-gray-800"><span class="inline-block font-bold md:py-6 py-3 sm:py-4">Series </span></a><a href=https://www.buymeacoffee.com/8swZOSU6I class="hidden sm:block hover:text-gray-900 mr-4 no-underline text-gray-800 mr-0"><span class="inline-block font-bold md:py-6 py-3 sm:py-4">Donate</span></a></div><div class="flex justify-end"><button class="h-6 block sm:h-8" aria-label=Search id=btn-search><svg aria-hidden=true class="h-6 w-6 fill-current inline-block text-gray-900 sm:h-8 sm:w-8"><use xlink:href=/svg/sprite.svg#search></use><title>Search</title></svg></button></div></nav></header><main class="w-full flex-grow flex-shrink-0 pb-8 pt-16 sm:pt-24 main"><article class="single-post relative"><div class="w-full mx-auto px-6 max-w-screen-2xl"><div class="mx-auto lg:ml-0 lg:mr-auto lg:pr-6 xl:mx-0 mb-6 xl:max-w-full xl:pr-8"><div class="flex mb-2 flex-col font-medium md:flex-row text-xs uppercase"><div class=inline-flex><time class="" datetime=2019-05-27T20:31:47+01:00>May 27, 2019 </time><span class=mx-2>•</span><p>Read in 5 minutes</p></div><span class="hidden md:block mx-2">|</span><p class="font-medium leading-normal rounded-sm text-xs uppercase">last updated  <time class="" datetime=2019-05-27T20:31:47+01:00>May 27, 2019</time></p></div><div class=post-header><h1 class="text-gray-800 font-bold leading-none lg:text-3xl mb-4 text-2xl xl:mb-8 xxl:text-4xl">Bash Arrays</h1></div></div><div class=lg:flex><div class="w-full lg:max-h-full lg:overflow-visible lg:static min-h-screen"><div class=flex><div class="w-full pb-8"><div class="flex flex-col xl:flex-relative xl:flex-row"><aside class="w-full block lg:hidden sidebar2 xl:block" id=sidebar2><div class="w-full flex justify-center content-center"><div class="w-full relative"><ins class="mx-auto adsbygoogle hidden sidebar2-as xl:block" data-ad-client=ca-pub-9439755881064125 data-ad-format=horizontal,rectangle data-ad-slot=4501323511 data-full-width-responsive=true style=display:block></ins></div></div><div class="w-full -mt-12 flex-col hidden justify-between pb-4 pt-12 sticky top-16 xl:flex"><div class="bg-gray-200 mb-6 p-4 pb-2 table-of-contents toc"><p class="font-medium mb-3 mb-3 text-xs tracking-tight uppercase xxl:text-sm text-gray-800">Contents</p><nav id=TableOfContents><ul><li><ul><li><a href=#bash-arrays>Bash Arrays</a></li><li><a href=#creating-bash-arrays>Creating Bash Arrays</a><ul><li><a href=#creating-numerically-indexed-arrays>Creating numerically indexed arrays</a></li><li><a href=#creating-associative-arrays>Creating associative arrays</a></li></ul></li><li><a href=#array-operations>Array Operations</a><ul><li><a href=#reference-elements>Reference Elements</a></li><li><a href=#array-length>Array Length</a></li><li><a href=#loop-through-the-array>Loop through the array</a></li><li><a href=#add-a-new-element>Add a new element</a></li></ul></li><li><a href=#delete-an-element>Delete an element</a></li><li><a href=#conclusion>Conclusion</a></li></ul></li></ul></nav><p class="font-medium mb-3 mb-3 text-xs tracking-tight uppercase xxl:text-sm border-gray-400 border-t mt-4 pt-4">Share</p><section class="w-full mx-auto"><nav class="flex flex-wrap"><a href="https://twitter.com/share?text=Bash%20Arrays&url=https%3a%2f%2flinuxize.com%2fpost%2fbash-arrays%2f" class="h-6 w-6 mb-4 mr-3" target=_blank rel=noopener><svg aria-hidden=true class="h-6 w-6 fill-current inline-block hover:text-blue-600 text-gray-600"><use xlink:href=/svg/sprite.svg#twitter></use><title>Share on Twitter</title></svg> </a><a href="https://www.facebook.com/sharer/sharer.php?caption=Bash%20Arrays&u=https%3a%2f%2flinuxize.com%2fpost%2fbash-arrays%2f" class="h-6 w-6 mb-4 mr-3" target=_blank rel=noopener><svg aria-hidden=true class="h-6 w-6 fill-current inline-block hover:text-blue-600 text-gray-600"><use xlink:href=/svg/sprite.svg#facebook></use><title>Share on Facebook</title></svg> </a><a href="https://pinterest.com/pin/create/button/?url=https%3a%2f%2flinuxize.com%2fpost%2fbash-arrays%2f&media=https%3a%2f%2flinuxize.com%2fpost%2fbash-arrays%2ffeatured.jpg&description=Bash%20Arrays" class="h-6 w-6 mb-4 mr-3" target=_blank rel=noopener><svg aria-hidden=true class="h-6 w-6 fill-current inline-block hover:text-blue-600 text-gray-600"><use xlink:href=/svg/sprite.svg#pinterest></use><title>Share on Pinterest</title></svg> </a><a href="https://plus.google.com/share?url=https%3a%2f%2flinuxize.com%2fpost%2fbash-arrays%2f" class="h-6 w-6 mb-4 mr-3" target=_blank rel=noopener><svg aria-hidden=true class="h-6 w-6 fill-current inline-block hover:text-blue-600 text-gray-600"><use xlink:href=/svg/sprite.svg#gplus></use><title>Share on Google Plus</title></svg> </a><a href="https://news.ycombinator.com/submitlink?t=Bash%20Arrays&u=https%3a%2f%2flinuxize.com%2fpost%2fbash-arrays%2f" class="h-6 w-6 mb-4 mr-3" target=_blank rel=noopener><svg aria-hidden=true class="h-6 w-6 fill-current inline-block hover:text-blue-600 text-gray-600"><use xlink:href=/svg/sprite.svg#hacker-news></use><title>Submit to Hacker News</title></svg> </a><a href="/cdn-cgi/l/email-protection#bf80cccaddd5dadccb82fddeccd79a8d8ffecdcddec6cc99ddd0dbc682fcd7dadcd49a8d8fd0cacb9a8d8fcbd7d6cc9a8d8fdecdcbd6dcd3da859a8ffe9a8ffed7cbcbcfcc9a8cde9a8dd99a8dd9d3d6d1cac7d6c5da91dcd0d29a8dd9cfd0cccb9a8dd9dddeccd792decdcddec6cc9a8dd9" class="h-6 w-6 mb-4" target=_blank rel=noopener><svg aria-hidden=true class="h-6 w-6 fill-current inline-block hover:text-blue-600 text-gray-600"><use xlink:href=/svg/sprite.svg#email></use><title>Share with Email</title></svg></a></nav></section></div></div></aside><section class="w-full mx-auto lg:ml-0 lg:mr-auto lg:pr-6 min-w-0 xl:mx-0 xl:px-8 xl:w-full"><figure class="mb-6 -mx-6 lg:mx-0 relative"><div class="w-full mx-auto my-0 block relative"><div class=block style=padding-bottom:53%></div><div class="w-full h-full absolute inset-0 m-auto bg-gray-200 overflow-hidden"><img src="data:image/gif;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAYAAAAfFcSJAAAADUlEQVR42mP8+PXHfwAJnAPfCuZXlQAAAABJRU5ErkJggg==" class="w-full h-full absolute inset-0 m-auto lazy lazyload" alt="" data-sizes=auto data-src=/post/bash-arrays/featured_hu5211e0def6efeae1492e9cb1dee162bc_49937_600x0_resize_q95_box.jpg data-srcset="
              /post/bash-arrays/featured_hu5211e0def6efeae1492e9cb1dee162bc_49937_600x0_resize_q95_box.jpg 600w,
              /post/bash-arrays/featured.jpg 1000w
            "><noscript><img src=/post/bash-arrays/featured.jpg class="w-full h-full absolute inset-0 m-auto"></noscript></div></div></figure><div class=markdown><p>Arrays are one of the most used and fundamental data structures. You can think of an array is a variable that can store multiple variables within it.</p><p>In this article, we’ll discuss Bash arrays, and how to use them in your Bash scripts with the help of examples.</p><h2 id=bash-arrays>Bash Arrays</h2><p>Bash supports both one-dimensional numerically indexed and associative arrays types. Numerical arrays are referenced using integers and associative are referenced using strings. The indices do not have to be contiguous.</p><p>Numerically indexed arrays can be accessed from the end using negative indices, the index of <code>-1</code> references the last element.</p><p>Unlike most of the programming languages, Bash array elements don’t have to be of the same data type. You can create an array that contains both strings and numbers. Bash does not support multidimensional arrays and you can’t have array elements that are also arrays.</p><p>There is no limit on the maximum number of elements that can be stored in an array.</p><h2 id=creating-bash-arrays>Creating Bash Arrays</h2><p>Arrays in Bash can be initialized in different ways.</p><h3 id=creating-numerically-indexed-arrays>Creating numerically indexed arrays</h3><p>Bash variables are untyped and any variable can be used as an indexed array without declaring it.</p><p>To explicitly declare an array, use the declare builtin:</p><div class=highlight><pre class=chroma><code class=language-sh data-lang=sh><span class=nb>declare</span> -a array_name</code></pre></div><p>One way to create an indexed array is by using the following form:</p><div class=highlight><pre class=chroma><code class=language-sh data-lang=sh>array_name<span class=o>[</span>index_1<span class=o>]=</span>value_1
array_name<span class=o>[</span>index_2<span class=o>]=</span>value_2
array_name<span class=o>[</span>index_n<span class=o>]=</span>value_n</code></pre></div><p>Where <code>index_</code> is a positive integer.</p><p>Another way to create a numeric array is to specify the list of the elements within parentheses, separated by empty space:</p><div class=highlight><pre class=chroma><code class=language-sh data-lang=sh><span class=nv>array_name</span><span class=o>=(</span> element_1 element_2 element_N <span class=o>)</span></code></pre></div><p>When the array is created using the form above, indexing starts at zero i.e the first element will have an index of <code>0</code>.</p><h3 id=creating-associative-arrays>Creating associative arrays</h3><p>Unlike numerically indexed, the associative arrays must be declared first using the declare builtin and the <code>-A</code> (uppercase) option:</p><div class=highlight><pre class=chroma><code class=language-sh data-lang=sh><span class=nb>declare</span> -A array_name</code></pre></div><p>To create an associative array use the following form:</p><div class=highlight><pre class=chroma><code class=language-sh data-lang=sh><span class=nb>declare</span> -A array_name

array_name<span class=o>[</span>index_foo<span class=o>]=</span>value_foo
array_name<span class=o>[</span>index_bar<span class=o>]=</span>value_bar
array_name<span class=o>[</span>index_xyz<span class=o>]=</span>value_xyz</code></pre></div><p>Where <code>index_</code> can be any string.</p><p>You can also create an associative array using the following form:</p><div class=highlight><pre class=chroma><code class=language-sh data-lang=sh><span class=nb>declare</span> -A array_name

<span class=nv>array_name</span><span class=o>=(</span> 
  <span class=o>[</span>index_foo<span class=o>]=</span>value_foo 
  <span class=o>[</span>index_bar<span class=o>]=</span>value_bar 
  <span class=o>[</span>index_xyz<span class=o>]=</span>value_xyz 
<span class=o>)</span></code></pre></div><h2 id=array-operations>Array Operations</h2><p>Bash arrays syntax may look a little strange at first, but it will make more sense once you read this article.</p><h3 id=reference-elements>Reference Elements</h3><p>To reference a single element you’ll need to know the element index. Any element can be referenced using the following form:</p><div class=highlight><pre class=chroma><code class=language-sh data-lang=sh><span class=si>${</span><span class=nv>array_name</span><span class=p>[index]</span><span class=si>}</span></code></pre></div><div class="my-6 bg-yellow-100 border-l-4 border-yellow-400 note p-6 text-yellow-900"><div class=flex><div class="w-full text-sm font-sans"><p>When working with arrays the curly braces <code>${}</code> are required to avoid shell’s filename expansion operators.</p><p>Without the braces, <code>${}</code> the syntax for accessing an array element is similar to the syntax of most of the programming languages.</p></div></div></div><p>Let’s print the element with index of <code>1</code>:</p><div class=highlight><pre class=chroma><code class=language-sh data-lang=sh><span class=c1>## declare the array</span>
<span class=nb>declare</span> -a <span class=nv>my_array</span><span class=o>=(</span> <span class=s2>"Hydrogen"</span> <span class=s2>"Helium"</span> <span class=s2>"Lithium"</span> <span class=s2>"Beryllium"</span> <span class=o>)</span>

<span class=c1>## print element</span>
<span class=nb>echo</span> <span class=si>${</span><span class=nv>my_array</span><span class=p>[1]</span><span class=si>}</span></code></pre></div><div class=highlight><pre class=chroma><code class=language-output data-lang=output>Helium</code></pre></div><p>If the specified index is <code>@</code> or <code>*</code>, the word expands to all members of the array. To print all elements you would use:</p><div class=highlight><pre class=chroma><code class=language-sh data-lang=sh><span class=c1>## declare the array</span>
<span class=nb>declare</span> -a <span class=nv>my_array</span><span class=o>=(</span> <span class=s2>"Hydrogen"</span> <span class=s2>"Helium"</span> <span class=s2>"Lithium"</span> <span class=s2>"Beryllium"</span> <span class=o>)</span>

<span class=c1>## print all elements</span>
<span class=nb>echo</span> <span class=s2>"</span><span class=si>${</span><span class=nv>my_array</span><span class=p>[@]</span><span class=si>}</span><span class=s2>"</span></code></pre></div><div class=highlight><pre class=chroma><code class=language-output data-lang=output>Hydrogen Helium Lithium Beryllium</code></pre></div><p>The only difference between <code>@</code> or <code>*</code> is when the form <code>${my_array[x]}</code> is surrounded with double quotes. In this case <code>*</code> expands to a single word where array elements are separated with space, and <code>@</code> expands each array element to a separate word. This is especially important when using the form to illiterate through array elements.</p><p>You can also print the keys of the array by adding the <code>!</code> operator before the array name:</p><div class=highlight><pre class=chroma><code class=language-sh data-lang=sh><span class=si>${</span><span class=p>!array_name[index]</span><span class=si>}</span></code></pre></div><p>For example, to print all the keys you would use:</p><div class=highlight><pre class=chroma><code class=language-sh data-lang=sh><span class=c1>## declare the array</span>
<span class=nb>declare</span> -a <span class=nv>my_array</span><span class=o>=(</span> <span class=s2>"Hydrogen"</span> <span class=s2>"Helium"</span> <span class=s2>"Lithium"</span> <span class=s2>"Beryllium"</span> <span class=o>)</span>

<span class=c1>## print all elements</span>
<span class=nb>echo</span> <span class=s2>"</span><span class=si>${</span><span class=p>!my_array[@]</span><span class=si>}</span><span class=s2>"</span></code></pre></div><div class=highlight><pre class=chroma><code class=language-output data-lang=output>0 1 2 3</code></pre></div><h3 id=array-length>Array Length</h3><p>To get the length of an array, use the following form:</p><div class=highlight><pre class=chroma><code class=language-sh data-lang=sh><span class=si>${#</span><span class=nv>array_name</span><span class=p>[@]</span><span class=si>}</span></code></pre></div><div class="my-6 bg-yellow-100 border-l-4 border-yellow-400 note p-6 text-yellow-900"><div class=flex><div class="w-full text-sm font-sans">The syntax is the same as when referencing all elements plus the <code>#</code> character before the array name.</div></div></div><div class=highlight><pre class=chroma><code class=language-sh data-lang=sh><span class=c1>## declare the array</span>
<span class=nb>declare</span> -a <span class=nv>my_array</span><span class=o>=(</span> <span class=s2>"Hydrogen"</span> <span class=s2>"Helium"</span> <span class=s2>"Lithium"</span> <span class=s2>"Beryllium"</span> <span class=o>)</span>

<span class=c1>## array Length</span>
<span class=nb>echo</span> <span class=si>${#</span><span class=nv>my_array</span><span class=p>[@]</span><span class=si>}</span></code></pre></div><div class=highlight><pre class=chroma><code class=language-output data-lang=output>4</code></pre></div><h3 id=loop-through-the-array>Loop through the array</h3><p>The most common way to iterate over each item in an array is by using the <a href=https://linuxize.com/post/bash-for-loop/ >for loop</a>.</p><div class=highlight><pre class=chroma><code class=language-sh data-lang=sh><span class=nb>declare</span> -a <span class=nv>my_array</span><span class=o>=(</span> <span class=s2>"Hydrogen"</span> <span class=s2>"Helium"</span> <span class=s2>"Lithium"</span> <span class=s2>"Beryllium"</span> <span class=o>)</span>

<span class=c1>## Array Loop</span>
<span class=k>for</span> i in <span class=s2>"</span><span class=si>${</span><span class=nv>my_array</span><span class=p>[@]</span><span class=si>}</span><span class=s2>"</span>
<span class=k>do</span> 
  <span class=nb>echo</span> <span class=s2>"</span><span class=nv>$i</span><span class=s2>"</span>
<span class=k>done</span></code></pre></div><p>The code above will iterate over the array and print each element in a new line:</p><div class=highlight><pre class=chroma><code class=language-output data-lang=output>Hydrogen
Helium
Lithium
Beryllium</code></pre></div><p>Here is an example of how to print all keys and values</p><div class=highlight><pre class=chroma><code class=language-sh data-lang=sh><span class=nb>declare</span> -a <span class=nv>my_array</span><span class=o>=(</span> <span class=s2>"Hydrogen"</span> <span class=s2>"Helium"</span> <span class=s2>"Lithium"</span> <span class=s2>"Beryllium"</span> <span class=o>)</span>

<span class=c1>## Array Loop</span>
<span class=k>for</span> i in <span class=s2>"</span><span class=si>${</span><span class=p>!my_array[@]</span><span class=si>}</span><span class=s2>"</span>
<span class=k>do</span>
  <span class=nb>echo</span> <span class=s2>"</span><span class=nv>$i</span><span class=s2>"</span> <span class=s2>"</span><span class=si>${</span><span class=nv>my_array</span><span class=p>[</span><span class=nv>$i</span><span class=p>]</span><span class=si>}</span><span class=s2>"</span>
<span class=k>done</span></code></pre></div><div class=highlight><pre class=chroma><code class=language-output data-lang=output>0 Hydrogen
1 Helium
2 Lithium
3 Beryllium</code></pre></div><p>Another way to loop through an array is to get the length of the array and use the C style loop:</p><div class=highlight><pre class=chroma><code class=language-sh data-lang=sh><span class=nb>declare</span> -a <span class=nv>my_array</span><span class=o>=(</span> <span class=s2>"Hydrogen"</span> <span class=s2>"Helium"</span> <span class=s2>"Lithium"</span> <span class=s2>"Beryllium"</span> <span class=o>)</span>

<span class=c1># Length of the array</span>
<span class=nv>length</span><span class=o>=</span><span class=si>${#</span><span class=nv>my_array</span><span class=p>[@]</span><span class=si>}</span>

<span class=c1># Array Loop</span>
<span class=k>for</span> <span class=o>((</span> <span class=nv>i</span><span class=o>=</span><span class=m>0</span><span class=p>;</span> i &lt; <span class=si>${</span><span class=nv>length</span><span class=si>}</span><span class=p>;</span> i++ <span class=o>))</span>
<span class=k>do</span>
  <span class=nb>echo</span> <span class=nv>$i</span> <span class=si>${</span><span class=nv>my_array</span><span class=p>[</span><span class=nv>$i</span><span class=p>]</span><span class=si>}</span>
<span class=k>done</span></code></pre></div><div class=highlight><pre class=chroma><code class=language-output data-lang=output>0 Hydrogen
1 Helium
2 Lithium
3 Beryllium</code></pre></div><h3 id=add-a-new-element>Add a new element</h3><p>To add a new element to a bash array and specify its index use the following form:</p><div class=highlight><pre class=chroma><code class=language-sh data-lang=sh>my_array<span class=o>[</span>index_n<span class=o>]=</span><span class=s2>"New Element"</span></code></pre></div><p>Here is an example:</p><div class=highlight><pre class=chroma><code class=language-sh data-lang=sh><span class=nb>declare</span> -a <span class=nv>my_array</span><span class=o>=(</span> <span class=s2>"Hydrogen"</span> <span class=s2>"Helium"</span> <span class=s2>"Lithium"</span> <span class=s2>"Beryllium"</span> <span class=o>)</span>

<span class=c1>## add new element</span>
my_array<span class=o>[</span><span class=m>9</span><span class=o>]=</span><span class=s2>"Aluminum"</span>

<span class=c1>## print all elements</span>
<span class=nb>echo</span> <span class=s2>"</span><span class=si>${</span><span class=nv>my_array</span><span class=p>[@]</span><span class=si>}</span><span class=s2>"</span></code></pre></div><div class=highlight><pre class=chroma><code class=language-output data-lang=output>Hydrogen Helium Lithium Beryllium Aluminum</code></pre></div><p>Another way of adding a new element to an array without specifying the index is by using the <code>+=</code> operator. You can add one or multiple elements:</p><div class=highlight><pre class=chroma><code class=language-sh data-lang=sh><span class=nb>declare</span> -a <span class=nv>my_array</span><span class=o>=(</span> <span class=s2>"Hydrogen"</span> <span class=s2>"Helium"</span> <span class=s2>"Lithium"</span> <span class=s2>"Beryllium"</span> <span class=o>)</span>

<span class=c1>## add new elements</span>
<span class=nv>my_array</span><span class=o>+=(</span> Cobalt Nickel <span class=o>)</span>

<span class=c1>## print all elements</span>
<span class=nb>echo</span> <span class=s2>"</span><span class=si>${</span><span class=nv>my_array</span><span class=p>[@]</span><span class=si>}</span><span class=s2>"</span></code></pre></div><div class=highlight><pre class=chroma><code class=language-output data-lang=output>Hydrogen Helium Lithium Beryllium Cobalt Nickel</code></pre></div><h2 id=delete-an-element>Delete an element</h2><p>To delete a single element you’ll need to know the element index. An element can be removed using the <code>unset</code> command:</p><div class=highlight><pre class=chroma><code class=language-sh data-lang=sh><span class=nb>unset</span> my_array<span class=o>[</span>index<span class=o>]</span></code></pre></div><p>Let’s see an example:</p><div class=highlight><pre class=chroma><code class=language-sh data-lang=sh><span class=nb>declare</span> -a <span class=nv>my_array</span><span class=o>=(</span> <span class=s2>"Hydrogen"</span> <span class=s2>"Helium"</span> <span class=s2>"Lithium"</span> <span class=s2>"Beryllium"</span> <span class=o>)</span>

<span class=c1>## remove element</span>
<span class=nb>unset</span> my_array<span class=o>[</span><span class=m>2</span><span class=o>]</span>

<span class=c1>## print all elements</span>
<span class=nb>echo</span> <span class=s2>"</span><span class=si>${</span><span class=nv>my_array</span><span class=p>[@]</span><span class=si>}</span><span class=s2>"</span></code></pre></div><div class=highlight><pre class=chroma><code class=language-output data-lang=output>Hydrogen Helium Beryllium</code></pre></div><h2 id=conclusion>Conclusion</h2><p>By now you should have a good understanding of how to use the bash arrays. We’ve shown you how to create numerically indexed and associative arrays, how to iterate through the arrays, calculate the array length and add and remove elements.</p><p>If you have any question or feedback, feel free to leave a comment.</p><div class="flex flex-wrap my-6"><a href=/tags/bash class="text-sm font-medium bg-indigo-700 hover:bg-indigo-800 mr-2 mt-2 px-4 py-2 rounded text-white tracking-wide">bash</a> <a href=/tags/terminal class="text-sm font-medium bg-indigo-700 hover:bg-indigo-800 mr-2 mt-2 px-4 py-2 rounded text-white tracking-wide">terminal</a></div></div></section></div></div></div></div><div class="w-full absolute hidden -mb-16 flex-grow lg:-mb-0 lg:block lg:pt-0 lg:static sidebar top-16 z-40" id=sidebar><div class=sideblock><div class="w-full flex justify-center content-center"><div class="w-full relative"><ins class="mx-auto adsbygoogle hidden lg:block" data-ad-client=ca-pub-9439755881064125 data-ad-format=auto data-ad-slot=9558702194 data-full-width-responsive=true style=display:block></ins></div></div></div><div class="bg-gray-200 mb-6 p-4 pb-2 related-content"><p class="font-medium mb-3 mb-3 text-xs tracking-tight uppercase xxl:text-sm text-gray-800">Related Tutorials</p><ul class="border-gray-400 border-t mb-0 mt-4 pt-3"><li class="flex mb-2 border-b border-gray-400 pb-2"><a href=https://linuxize.com/post/how-to-read-a-file-line-by-line-in-bash/ class="text-sm font-medium hover:text-gray-900 text-gray-700 truncate">How to Read a File Line By Line in Bash</a></li><li class="flex mb-2 border-b border-gray-400 pb-2"><a href=https://linuxize.com/post/create-a-file-in-linux/ class="text-sm font-medium hover:text-gray-900 text-gray-700 truncate">How to Create a File in Linux</a></li><li class="flex mb-2 border-b border-gray-400 pb-2"><a href=https://linuxize.com/post/bash-heredoc/ class="text-sm font-medium hover:text-gray-900 text-gray-700 truncate">Bash Heredoc</a></li><li class="flex mb-2 border-b border-gray-400 pb-2"><a href=https://linuxize.com/post/how-to-compare-strings-in-bash/ class="text-sm font-medium hover:text-gray-900 text-gray-700 truncate">How to Compare Strings in Bash</a></li><li class="flex mb-2 border-b border-gray-400 pb-2"><a href=https://linuxize.com/post/how-to-copy-files-and-directories-in-linux/ class="text-sm font-medium hover:text-gray-900 text-gray-700 truncate">How to Copy Files and Directories in Linux</a></li><li class="flex mb-2 border-b border-gray-400 pb-2"><a href=https://linuxize.com/post/linux-cd-command/ class="text-sm font-medium hover:text-gray-900 text-gray-700 truncate">Linux cd Command</a></li><li class="flex mb-2 border-b border-gray-400 pb-2"><a href=https://linuxize.com/post/creating-a-self-signed-ssl-certificate/ class="text-sm font-medium hover:text-gray-900 text-gray-700 truncate">Creating a Self-Signed SSL Certificate</a></li><li class="flex mb-2 border-b border-gray-400 pb-2"><a href=https://linuxize.com/post/echo-command-in-linux-with-examples/ class="text-sm font-medium hover:text-gray-900 text-gray-700 truncate">Echo Command in Linux with Examples</a></li><li class="flex mb-2 border-b border-gray-400 pb-2"><a href=https://linuxize.com/post/current-working-directory/ class="text-sm font-medium hover:text-gray-900 text-gray-700 truncate">Determine Your Current Working Directory in Linux Using the pwd Command</a></li><li class="flex mb-2 border-b border-gray-400 pb-2"><a href=https://linuxize.com/post/bash-concatenate-strings/ class="text-sm font-medium hover:text-gray-900 text-gray-700 truncate">Bash Concatenate Strings</a></li></ul></div><div class="flex flex-col -mt-12 lg:block lg:relative lg:sticky lg:top-16 pt-12"><div class=sideblock><div class="hidden affiliate"><a href="https://www.vultr.com/?ref=6812257" class=vultr target=_blank rel=noopener></a> <a href="https://shareasale.com/r.cfm?b=1133389&u=1755182&m=75038&urllink=&afftrack=" class="cloudways mt-8" target=_blank rel=noopener></a></div><div class="w-full flex justify-center content-center"><div class="w-full relative"><ins class="mx-auto adsbygoogle" data-ad-client=ca-pub-9439755881064125 data-ad-format=auto data-ad-slot=7027266996 data-full-width-responsive=true style=display:block></ins></div></div></div></div></div></div></div></article><div class=px-6><style>.bmc-button img{width:27px!important;margin-bottom:1px!important;box-shadow:none!important;border:none!important;vertical-align:middle!important}.bmc-button{line-height:33px!important;height:37px!important;text-decoration:none!important;display:inline-flex!important;color:#fff!important;background-color:#ff813f!important;border-radius:3px!important;border:1px solid transparent!important;padding:1px 9px!important;font-size:16px!important;letter-spacing:.6px!important;box-shadow:0 1px 2px rgba(190,190,190,.5)!important;-webkit-box-shadow:0 1px 2px 2px rgba(190,190,190,.5)!important;margin:0 auto!important;font-weight:700;-webkit-box-sizing:border-box!important;box-sizing:border-box!important;-o-transition:.3s all linear!important;-webkit-transition:.3s all linear!important;-moz-transition:.3s all linear!important;-ms-transition:.3s all linear!important;transition:.3s all linear!important}.bmc-button:active,.bmc-button:focus,.bmc-button:hover{-webkit-box-shadow:0 1px 2px 2px rgba(190,190,190,.5)!important;text-decoration:none!important;box-shadow:0 1px 2px 2px rgba(190,190,190,.5)!important;opacity:.85!important;color:#fff!important}</style><section class="w-full mx-auto border-gray-200 border-t mt-8 pt-8 max-w-article"><div class="p-8 sm:py-8 bg-orange-100"><p class="mx-auto my-0 text-sm lg:text-base max-w-md sm:text-base text-center text-orange-800">If you like our content, please consider buying us a coffee.<br>Thank you for your support!</p><div class="w-full mx-auto flex items-center flex-col justify-between max-w-sm sm:flex-row mt-6"><a href=https://www.buymeacoffee.com/8swZOSU6I class=bmc-button target=_blank><img src=https://www.buymeacoffee.com/assets/img/BMC-btn-logo.svg alt="Buy me a coffee"> <span style=margin-left:5px>Buy me a coffee</span></a></div></div></section><section class="w-full mx-auto border-gray-200 border-t mt-8 pt-8 max-w-article"><div class="bg-gray-200 p-8 sm:py-8"><p class="mx-auto my-0 text-sm lg:text-base max-w-md sm:text-base text-center">Sign up to our newsletter and get our latest tutorials and news straight to your mailbox.</p><form action="https://linuxize.us17.list-manage.com/subscribe/post?u=35cd4cd9d021c25c3dd7cabfd&id=9cfa4c89de" class=pt-8 id=mc-embedded-subscribe-form method=post name=mc-embedded-subscribe-form novalidate><div class="w-full mx-auto flex items-center flex-col justify-between max-w-sm sm:flex-row mb-2"><input class="w-full block bg-white appearance-none border hover:border-gray-700 mb-3 px-4 py-3 rounded sm:mb-0 text-gray-800" name=EMAIL aria-label=email placeholder="Your email..." type=email> <input class=hidden name=b_35cd4cd9d021c25c3dd7cabfd_9cfa4c89de tabindex=-1> <button class="w-full px-4 py-3 rounded bg-indigo-700 hover:bg-indigo-800 sm:ml-4 sm:w-auto text-white tracking-wide" name=subscribe type=submit><span class=text-center>Subscribe</span></button></div><p class="w-full mx-auto my-0 max-w-sm text-sm">We’ll never share your email address or spam you.</p></form></div></section><section class="w-full mx-auto border-gray-200 border-t mt-8 pt-8 max-w-5xl"><div class="flex flex-wrap -mx-4"><a href=https://linuxize.com/post/how-to-read-a-file-line-by-line-in-bash/ class="w-full flex md:mb-0 md:w-1/3 overflow-hidden px-4 mb-8"><div class="w-full flex flex-col h-full"><p class="font-normal text-gray-700 text-xs uppercase">May 16, 2019</p><div class="text-gray-800 mb-2 flex-grow font-normal md:mb-4 text-lg">How to Read a File Line By Line in Bash</div><div><figure class=relative><div class="w-full mx-auto my-0 block relative"><div class=block style=padding-bottom:53%></div><div class="w-full h-full absolute inset-0 m-auto bg-gray-200 overflow-hidden"><img src="data:image/gif;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAYAAAAfFcSJAAAADUlEQVR42mP8+PXHfwAJnAPfCuZXlQAAAABJRU5ErkJggg==" class="w-full h-full absolute inset-0 m-auto lazy lazyload" alt="" data-sizes=auto data-src=/post/how-to-read-a-file-line-by-line-in-bash/featured_hu52e56895a6b02db213abaadcc2ed09e8_45497_600x0_resize_q95_box.jpg data-srcset="
              /post/how-to-read-a-file-line-by-line-in-bash/featured_hu52e56895a6b02db213abaadcc2ed09e8_45497_600x0_resize_q95_box.jpg 600w,
              /post/how-to-read-a-file-line-by-line-in-bash/featured.jpg 1000w
            "><noscript><img src=/post/how-to-read-a-file-line-by-line-in-bash/featured.jpg class="w-full h-full absolute inset-0 m-auto"></noscript></div></div></figure></div></div></a><a href=https://linuxize.com/post/create-a-file-in-linux/ class="w-full flex md:mb-0 md:w-1/3 overflow-hidden px-4 mb-8"><div class="w-full flex flex-col h-full"><p class="font-normal text-gray-700 text-xs uppercase">May 10, 2019</p><div class="text-gray-800 mb-2 flex-grow font-normal md:mb-4 text-lg">How to Create a File in Linux</div><div><figure class=relative><div class="w-full mx-auto my-0 block relative"><div class=block style=padding-bottom:53%></div><div class="w-full h-full absolute inset-0 m-auto bg-gray-200 overflow-hidden"><img src="data:image/gif;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAYAAAAfFcSJAAAADUlEQVR42mP8+PXHfwAJnAPfCuZXlQAAAABJRU5ErkJggg==" class="w-full h-full absolute inset-0 m-auto lazy lazyload" alt="" data-sizes=auto data-src=/post/create-a-file-in-linux/featured_hu8c5c28f3bcb20a87ca198f3e252e0010_19068_600x0_resize_q95_box.jpg data-srcset="
              /post/create-a-file-in-linux/featured_hu8c5c28f3bcb20a87ca198f3e252e0010_19068_600x0_resize_q95_box.jpg 600w,
              /post/create-a-file-in-linux/featured.jpg 1000w
            "><noscript><img src=/post/create-a-file-in-linux/featured.jpg class="w-full h-full absolute inset-0 m-auto"></noscript></div></div></figure></div></div></a><a href=https://linuxize.com/post/bash-heredoc/ class="w-full flex md:mb-0 md:w-1/3 overflow-hidden px-4 mb-0"><div class="w-full flex flex-col h-full"><p class="font-normal text-gray-700 text-xs uppercase">May 9, 2019</p><div class="text-gray-800 mb-2 flex-grow font-normal md:mb-4 text-lg">Bash Heredoc</div><div><figure class=relative><div class="w-full mx-auto my-0 block relative"><div class=block style=padding-bottom:53%></div><div class="w-full h-full absolute inset-0 m-auto bg-gray-200 overflow-hidden"><img src="data:image/gif;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAYAAAAfFcSJAAAADUlEQVR42mP8+PXHfwAJnAPfCuZXlQAAAABJRU5ErkJggg==" class="w-full h-full absolute inset-0 m-auto lazy lazyload" alt="" data-sizes=auto data-src=/post/bash-heredoc/featured_hub2167e39be03f89fa5036391c8cca175_21374_600x0_resize_q95_box.jpg data-srcset="
              /post/bash-heredoc/featured_hub2167e39be03f89fa5036391c8cca175_21374_600x0_resize_q95_box.jpg 600w,
              /post/bash-heredoc/featured.jpg 1000w
            "><noscript><img src=/post/bash-heredoc/featured.jpg class="w-full h-full absolute inset-0 m-auto"></noscript></div></div></figure></div></div></a></div></section><section class="w-full mx-auto relative border-gray-200 border-t max-w-3xl mt-8 pt-16 py-8"><a href=https://linuxize.com/post/bash-arrays/#disqus_thread class="w-full block bg-gray-200 disqus-comment-count disqus-load md:py-8 py-4 text-center" title="Show comments for post">Write a comment</a><div id=disqus_thread></div><noscript>Please enable JavaScript to view the <a href=https://disqus.com/?ref_noscript>comments powered by Disqus.</a></noscript></section></div></main><section class="w-full absolute inset-0 bg-white block h-screen hidden search z-100" id=search-box><div class="flex flex-col min-h-screen"><header class="w-full mx-auto flex items-center h-12 sm:h-16 justify-end px-6 z-10"><a href=# class="h-6 block sm:h-8" id=btn-search-close><svg aria-hidden=true class="h-6 w-6 fill-current inline-block text-gray-900 sm:h-8 sm:w-8"><use xlink:href=/svg/sprite.svg#close></use><title>Close search form</title></svg> <small class="block text-center sm:w-8 w-6">ESC</small></a></header><div class="w-full px-6 flex-grow flex-shrink-0 pb-8 pt-16 sm:pt-24"><div class="flex flex-col mx-auto max-w-screen-xl mb-4 mb-8"><div class=searchbox-container id=searchbox></div><div class=search-results id=search-results></div><div id=hits></div><div id=stats></div><footer class=mt-6><a href=https://algolia.com target=_blank rel="noopener noreferrer" tabindex=-1><svg aria-hidden=true class="inline-block fill-current search-algolia-logo text-gray-700"><use xlink:href=/svg/sprite.svg#search-by-algolia></use><title>Search by Algolia</title></svg></a></footer></div></div></div></section><footer class="w-full px-6 bg-gray-100"><div class="w-full mx-auto flex items-center flex-wrap justify-center max-w-screen-xl md:justify-between md:text-left py-8 text-center"><div class="w-full text-sm mb-2 md:mb-0 md:w-1/2"><div class="w-full block md:flex md:items-center md:w-auto"><div class=md:flex-grow><span class="block text-gray-800 mb-2 md:inline-block md:mb-0 md:mr-8">© 2019 Linuxize.com</span> <a href=/privacy-policy/ class="inline-block text-gray-900 footer-menu-item hover:text-gray-800 md:mt-0 no-underline mr-4">Privacy Policy </a><a href=/contact/ class="inline-block text-gray-900 footer-menu-item hover:text-gray-800 md:mt-0 no-underline mr-0">Contact</a></div></div></div><div class="w-full flex justify-center md:justify-end md:w-1/2"><a href=https://twitter.com/linuxize class="h-6 block mr-2" aria-label=Twitter><svg aria-hidden=true class="h-6 w-6 fill-current inline-block text-gray-900"><use xlink:href=/svg/sprite.svg#twitter></use><title>Twitter</title></svg> </a><a href=https://www.facebook.com/linuxize/ class="h-6 block mr-2" aria-label=Facebook><svg aria-hidden=true class="h-6 w-6 fill-current inline-block text-gray-900"><use xlink:href=/svg/sprite.svg#facebook></use><title>Facebook</title></svg> </a><a href=/index.xml class="h-6 block" aria-label=RSS><svg aria-hidden=true class="h-6 w-6 fill-current inline-block text-gray-900"><use xlink:href=/svg/sprite.svg#rss></use><title>RSS</title></svg></a></div></div></footer></div><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script src=https://cdnjs.cloudflare.com/ajax/libs/algoliasearch/3.32.1/algoliasearchLite.min.js></script><script src=https://cdnjs.cloudflare.com/ajax/libs/instantsearch.js/3.1.1/instantsearch.production.min.js></script><script src=/js/1.fa8206ef9d74fec7591e.js></script><script src=/js/app.1b285cee43d21dd67288.js></script><script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('edmonton.php', '/detroitchicago/edmonton.webp?a=a&cb=0&shcb=31', true, [], true, false, false, false);
__ez.queue.addFile('jellyfish.php', '/porpoiseant/jellyfish.webp?a=a&cb=0&shcb=31', false, [], true, false, false, false);
</script>

<!--Begin comScore Tag--><script>var _comscore=_comscore||[];_comscore.push({c1:"2",c2:"20015427"});(function(){var s=document.createElement("script"),el=document.getElementsByTagName("script")[0];s.async=true;s.src=(document.location.protocol=="https:"?"https://sb":"http://b")+".scorecardresearch.com/beacon.js";el.parentNode.insertBefore(s,el)})();</script><noscript><img src="https://sb.scorecardresearch.com/p?c1=2&c2=20015427&cv=2.0&cj=1"/></noscript><!--End comScore Tag-->
<!--Quantcast Tag--><script type="text/javascript">var _qevents=_qevents||[];(function(){var elem=document.createElement('script');elem.src=(document.location.protocol=="https:"?"https://secure":"http://edge")+".quantserve.com/quant.js";elem.async=true;elem.type="text/javascript";var scpt=document.getElementsByTagName('script')[0];scpt.parentNode.insertBefore(elem,scpt)})();_qevents.push({qacct:"p-31iz6hfFutd16",labels:"Domain.linuxize_com,DomainId.93605"});</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.linuxize_com,DomainId.93605" border="0" height="1" width="1" alt="Quantcast"/></div></noscript><!--End Quantcast tag--></body></html>