<!doctype html><html class=no-js lang=en-us><head><title>How To Install Asterisk on Debian 9 | Linuxize</title><meta charset=utf-8><meta content="IE=edge" http-equiv=X-UA-Compatible><meta content="width=device-width,initial-scale=1,shrink-to-fit=no" name=viewport><meta content=Linuxize name=apple-mobile-web-app-title><meta content=Linuxize name=application-name><meta content=#2271ff name=theme-color><meta content=#2271ff name=msapplication-TileColor><meta content="Asterisk is the most popular and widely adopted open source framework for building communications applications. In this tutorial we will show you how to install Asterisk 15 on Debian 9." name=description><meta content=unsafe-url name=referrer><link href=https://linuxize.com/post/how-to-install-asterisk-on-debian-9/ rel=canonical><meta content="index, follow" name=robots><meta content="Hugo 0.42.2" name=generator><meta content="How To Install Asterisk on Debian 9" property=og:title><meta content="Asterisk is the most popular and widely adopted open source framework for building communications applications. In this tutorial we will show you how to install Asterisk 15 on Debian 9." property=og:description><meta content=article property=og:type><meta content=/post/how-to-install-asterisk-on-debian-9/ property=og:url><meta content=https://linuxize.com/post/how-to-install-asterisk-on-debian-9/featured.jpg property=og:image><meta content="Asterisk is the most popular and widely adopted open source framework for building communications applications. In this tutorial we will show you how to install Asterisk 15 on Debian 9." property=og:image:alt><meta content=2018-09-17T22:31:47+01:00 property=article:published_time><meta content=2018-09-17T22:31:47+01:00 property=article:modified_time><meta content=en property=og:locale><meta content=post property=article:section><meta content=https://www.facebook.com/linuxize property=article:publisher><meta content=debian property=article:tag><meta content=asterisk property=article:tag><meta content=debian,asterisk name=news_keywords><meta content=summary_large_image name=twitter:card><meta content=https://linuxize.com/post/how-to-install-asterisk-on-debian-9/featured.jpg name=twitter:image><meta content="How To Install Asterisk on Debian 9" name=twitter:title><meta content="Asterisk is the most popular and widely adopted open source framework for building communications applications. In this tutorial we will show you how to install Asterisk 15 on Debian 9." name=twitter:description><meta content=@linuxize name=twitter:site><link href=/favicons/apple-touch-icon.png rel=apple-touch-icon sizes=180x180><link href=/favicons/favicon-32x32.png rel=icon sizes=32x32 type=image/png><link href=/favicons/favicon-16x16.png rel=icon sizes=16x16 type=image/png><link href=/favicons/safari-pinned-tab.svg rel=mask-icon color=#2271ff><script type=application/ld+json>{
  "@context": "http://schema.org",
  "@type": "BlogPosting",
  "headline": "How To Install Asterisk on Debian 9",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://linuxize.com/post/how-to-install-asterisk-on-debian-9/"
  },"image": {
     "@type": "ImageObject",
     "url": "https://linuxize.com/post/how-to-install-asterisk-on-debian-9/featured.jpg",
     "width": 1000,
     "height": 530
    },"keywords": "debian, asterisk",
  "wordcount": 846,
  "url": "https://linuxize.com/post/how-to-install-asterisk-on-debian-9/",
  "datePublished": "2018-09-17T22:31:47+01:00",
  "dateModified": "2018-09-17T22:31:47+01:00",
  "publisher": {
    "@type": "Organization","logo": {
    "@type": "imageObject",
      "url": "https://linuxize.com/assets/linuxize-card.png"
    },"name": "Linuxize"
  },

  "author": {
    "@type": "Person",
    "name": "Linuxize"
  },
  "description": "Asterisk is the most popular and widely adopted open source framework for building communications applications. In this tutorial we will show you how to install Asterisk 15 on Debian 9."
}</script><script src=/js/ads.js></script><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-P827G6S');</script><script src=https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js async></script><meta content=#2271ff name=theme-color><link href=/manifest.79f739767e479131c04f7216cce1c084.json rel=manifest><link href="https://fonts.googleapis.com/css?family=IBM+Plex+Sans:300,400,400i,500,700%7CIBM+Plex+Serif:300,400,400i,600,600i" rel=stylesheet><link href=/css/app.955fab4b8c6552781ffc.css rel=stylesheet></head><body class="font-sans kind-page leading-normal section-post text-black type-post"><div class="flex flex-col min-h-screen main-wrap"><header class="w-full px-6 z-10 bg-white border-b border-grey-light fixed linuxize-shadow" id=header><nav class="w-full mx-auto flex items-center h-12 sm:h-16 justify-start"><a href=/ class="block flex flex-no-shrink items-center mr-6 no-underline text-black"><svg aria-hidden=true class="h-6 w-6 fill-current sm:h-8 sm:w-8 mr-2"><use xlink:href=#logo></use><title>Linuxize</title></svg> <span class="hidden font-medium sm:block text-xl tracking-tight">Linuxize</span></a><div class="flex justify-center -mb-px flex-1 min-w-0 text-sm"><div class="hidden font-medium nav-post-title sm:text-lg text-center truncate">How To Install Asterisk on Debian 9</div></div><div class="flex justify-end"><button class="block h-6 sm:h-8" id=btn-search><svg aria-hidden=true class="h-6 w-6 fill-current inline-block text-grey-darkest sm:h-8 sm:w-8"><use xlink:href=#search></use><title>Search</title></svg></button></div></nav></header><main class="w-full px-6 flex-grow flex-no-shrink pb-8 pt-16 sm:pt-24 main"><article class="relative single-post"><div class="mb-4 max-w-xl mx-auto xl:flex xl:max-w-4xl xl:mb-8"><div class="w-full xl:w-1/2 self-auto xxl:flex-no-shrink xxl:w-190"><section class="w-full post-header xl:pr-8"><div class=mb-4><div class="w-full flex justify-center content-center"><div class="w-full relative"><ins class="adsbygoogle mx-auto top-a" data-ad-client=ca-pub-9439755881064125 data-ad-format=horizontal data-ad-slot=4501323511 style=display:block></ins></div></div></div><div class="flex flex-col mb-4 font-medium md:flex-row text-xs uppercase xxl:text-sm"><div class=inline-flex><time class="" datetime=2018-09-17T22:31:47+01:00>September 17, 2018 </time><span class=mx-2>•</span><p>Read in 4 minutes</p></div><span class="hidden md:block mx-2">|</span><p class="text-xs uppercase font-medium xxl:text-sm leading-normal rounded-sm">last updated  <time class="" datetime=2018-09-17T22:31:47+01:00>September 17, 2018</time></p></div><h1 class="mb-4 font-bold leading-none lg:text-5xl text-3xl text-black xl:mb-4 xxl:text-6xl">How To Install Asterisk on Debian 9</h1><div class="mb-4 distro-versions inline-flex items-center"><h3 class="text-xs uppercase font-medium xxl:text-sm leading-normal rounded-sm mr-2">This tutorial is also available for:</h3><a href=/post/how-to-install-asterisk-centos-7/ class="bg-grey-lighter mr-2 text-grey-darker text-xs capitalize font-medium hover:bg-blue hover:text-white leading-normal px-3 py-1 rounded-sm xxl:text-sm">centos 7 </a><a href=/post/how-to-install-asterisk-ubuntu-18.04/ class="bg-grey-lighter mr-2 text-grey-darker text-xs capitalize font-medium hover:bg-blue hover:text-white leading-normal px-3 py-1 rounded-sm xxl:text-sm">ubuntu 18.04</a></div></section></div><div class="w-full xl:w-1/2 bg-grey"><section class="w-full mx-auto max-w-xl"><figure class="relative -mx-6 lg:mx-0"><div class="w-full mx-auto relative block my-0"><div class=block style=padding-bottom:53%></div><div class="w-full h-full absolute m-auto pin overflow-hidden bg-grey-lighter"><img alt="" class="w-full h-full absolute m-auto pin" src=/post/how-to-install-asterisk-on-debian-9/featured.jpg></div></div></figure></section></div></div><section class="w-full mx-auto sticky-element"><section class="w-full mx-auto relative hidden max-w-article xl:block xl:max-w-4xl"><aside class="bg-grey-lighter mb-6 mt-8 p-4 pb-2 table-of-contents xl:absolute xl:mt-0 xl:pin-r xl:text-sm xl:w-48 xxl:w-75"><p class="font-bold mb-3 text-grey-darker xl:text-base">Contents</p><nav id=TableOfContents><ul><li><ul><li><a href=#prerequisites>Prerequisites</a></li><li><a href=#downloading-asterisk>Downloading Asterisk</a></li><li><a href=#installing-asterisk-dependencies>Installing Asterisk Dependencies</a></li><li><a href=#installing-asterisk>Installing Asterisk</a></li><li><a href=#creating-asterisk-user>Creating Asterisk User</a></li><li><a href=#starting-asterisk>Starting Asterisk</a></li><li><a href=#configuring-firewall>Configuring Firewall</a></li><li><a href=#conclusion>Conclusion</a></li></ul></li></ul></nav><p class="font-bold mb-3 text-grey-darker xl:text-base border-grey-light border-t mt-4 pt-4">Share</p><section class="w-full mx-auto"><nav class="flex flex-wrap"><a href="https://twitter.com/share?text=How%20To%20Install%20Asterisk%20on%20Debian%209&url=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-install-asterisk-on-debian-9%2f" class="h-6 w-6 mb-4 mr-3" target=_blank><svg aria-hidden=true class="h-6 w-6 fill-current inline-block hover:text-blue text-gray-light"><use xlink:href=#twitter></use><title>Share on Twitter</title></svg> </a><a href="https://www.facebook.com/sharer/sharer.php?caption=How%20To%20Install%20Asterisk%20on%20Debian%209&u=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-install-asterisk-on-debian-9%2f" class="h-6 w-6 mb-4 mr-3" target=_blank><svg aria-hidden=true class="h-6 w-6 fill-current inline-block hover:text-blue text-gray-light"><use xlink:href=#facebook></use><title>Share on Facebook</title></svg> </a><a href="https://pinterest.com/pin/create/button/?url=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-install-asterisk-on-debian-9%2f&media=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-install-asterisk-on-debian-9%2ffeatured.jpg&description=How%20To%20Install%20Asterisk%20on%20Debian%209" class="h-6 w-6 mb-4 mr-3" target=_blank><svg aria-hidden=true class="h-6 w-6 fill-current inline-block hover:text-blue text-gray-light"><use xlink:href=#pinterest></use><title>Share on Pinterest</title></svg> </a><a href="https://plus.google.com/share?url=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-install-asterisk-on-debian-9%2f" class="h-6 w-6 mb-4 mr-3" target=_blank><svg aria-hidden=true class="h-6 w-6 fill-current inline-block hover:text-blue text-gray-light"><use xlink:href=#gplus></use><title>Share on Google Plus</title></svg> </a><a href="https://news.ycombinator.com/submitlink?t=How%20To%20Install%20Asterisk%20on%20Debian%209&u=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-install-asterisk-on-debian-9%2f" class="h-6 w-6 mb-4 mr-3" target=_blank><svg aria-hidden=true class="h-6 w-6 fill-current inline-block hover:text-blue text-gray-light"><use xlink:href=#hacker-news></use><title>Submit to Hacker News</title></svg> </a><a href="/cdn-cgi/l/email-protection#82bdf1f7e0e8e7e1f6bfcaedf5a7b0b2d6eda7b0b2cbecf1f6e3eeeea7b0b2c3f1f6e7f0ebf1e9a7b0b2edeca7b0b2c6e7e0ebe3eca7b0b2bba4e0ede6fbbfc1eae7e1e9a7b0b2edf7f6a7b0b2f6eaebf1a7b0b2e3f0f6ebe1eee7b8a7b2c3a7b2c3eaf6f6f2f1a7b1e3a7b0e4a7b0e4eeebecf7faebf8e7ace1edefa7b0e4f2edf1f6a7b0e4eaedf5aff6edafebecf1f6e3eeeeafe3f1f6e7f0ebf1e9afedecafe6e7e0ebe3ecafbba7b0e4" class="h-6 w-6 mb-4" target=_blank><svg aria-hidden=true class="h-6 w-6 fill-current inline-block hover:text-blue text-gray-light"><use xlink:href=#email></use><title>Share with Email</title></svg></a></nav></section></aside></section></section><section class="w-full mx-auto max-w-article markdown"><aside class="relative aside-wrapper"><div class="w-full mx-auto sideblock sticky"><div class="xl:absolute xxl:w-75 sideblock-content xl:-ml-52 xl:pin-l xl:w-40 xxl:-ml-89"><div class="hidden affiliate"><a href="https://www.vultr.com/?ref=6812257" class=vultr target=_blank></a> <a href="https://shareasale.com/r.cfm?b=1133389&u=1755182&m=75038&urllink=&afftrack=" class="cloudways mt-8" target=_blank></a></div><div class="w-full flex justify-center content-center"><div class="w-full relative"><ins class="adsbygoogle mx-auto" data-ad-client=ca-pub-9439755881064125 data-ad-format=auto data-ad-slot=9558702194 style=display:block></ins></div></div></div></div></aside><p>Asterisk is the most popular and widely adopted open source framework for building communications applications. It is used by individuals, small businesses, large enterprises and governments worldwide.</p><p>Asterisk features include conference calling, voicemail, music on hold, call transfer, call queuing, call recording, database store/retrieve and much more.</p><p>In this tutorial we will show you how to install Asterisk 15 on Debian 9.</p><div class="bg-yellow-lightest border-l-4 border-yellow-light my-6 note p-6 text-yellow-darkest"><div class=flex><div class="w-full text-sm font-sans"><p>An older version of Asterisk (version 13) is available in the Debian software repository and can be installed with <code>apt install asterisk</code>.</p></div></div></div><h2 id=prerequisites>Prerequisites</h2><p>Before continuing with this tutorial, make sure you are logged in as a <a href=/post/how-to-create-a-sudo-user-on-debian/ >user with sudo privileges</a>.</p><p>Update your Debian server and install the packages required to download and build Asterisk:</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash>sudo apt update <span class=o>&&</span> sudo apt upgrade
sudo apt install wget build-essential subversion</code></pre></div><h2 id=downloading-asterisk>Downloading Asterisk</h2><p>At the time of writing this article, the latest stable version of Asterisk is version 15.</p><p>Change to the <code>/usr/src</code> directory and download the Asterisk source code with the following commands:</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash><span class=nb>cd</span> /usr/src/
sudo wget http://downloads.asterisk.org/pub/telephony/asterisk/asterisk-15-current.tar.gz</code></pre></div><p>After the download is complete, use the <a href=/post/how-to-create-and-extract-archives-using-the-tar-command-in-linux/ >tar command</a> to extract the archive:</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash>sudo tar zxf asterisk-15-current.tar.gz</code></pre></div><p>Make sure you change to the Asterisk source directory before continuing with the next steps:</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash><span class=nb>cd</span> asterisk-15.*/</code></pre></div><h2 id=installing-asterisk-dependencies>Installing Asterisk Dependencies</h2><p>Run the following script to download the MP3 sources which are required to build the MP3 module and use MP3 files:</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash>sudo contrib/scripts/get_mp3_source.sh</code></pre></div><p>Next, run the <code>install_prereq</code> script to resolve all of the dependencies on your Debian system:</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash>sudo contrib/scripts/install_prereq install</code></pre></div><p>The script will install all necessary packages and upon successful completion, it will print the following message:</p><div class=highlight><pre class=chroma><code class=language-output data-lang=output>#############################################
## install completed successfully
#############################################</code></pre></div><p>Here you will see the default ITU-T telephone code of 61. But in our case if you are in North America as I am you will want to change it to 1</p><div><small class=text-grey><small>Advertisement</small></small></div><div class="w-full flex justify-center content-center"><div class="w-full relative"><ins class=adsbygoogle data-ad-client=ca-pub-9439755881064125 data-ad-format=fluid data-ad-slot=5120214995 style=display:block data-ad-layout=in-article></ins></div></div><h2 id=installing-asterisk>Installing Asterisk</h2><p>Run the <code>configure</code> script which will get the Asterisk code ready to compile:</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash>sudo ./configure</code></pre></div><p>Upon successful completion, you will see the following output:</p><figure class=relative><div class="w-full mx-auto relative block my-0"><div class=block style=padding-bottom:68.47935548841893%></div><div class="w-full h-full absolute m-auto pin overflow-hidden text-center"><img alt="" class="" src=/post/how-to-install-asterisk-on-debian-9/configure-asterisk.jpg data-action=zoom></div></div></figure><p>The next step is to select the modules you want to compile and install. Access the Menuselect system, by typing:</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash>sudo make menuselect</code></pre></div><p>We have already downloaded the MP3 source files and now we need to tell Asterisk to build the MP3 module by selecting <code>format_mp3</code>:</p><figure class=relative><div class="w-full mx-auto relative block my-0"><div class=block style=padding-bottom:68.91788181120491%></div><div class="w-full h-full absolute m-auto pin overflow-hidden text-center"><img alt="" class="" src=/post/how-to-install-asterisk-on-debian-9/asterisk-mp3.jpg data-action=zoom></div></div></figure><p>Once you are finished, press <code>F12</code> to save and exit, or switch to the <code>Save and Exit</code> button and press <code>Enter</code>.</p><p>Start the compilation process using the <code>make</code> command:</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash>sudo make -j2</code></pre></div><div class="bg-yellow-lightest border-l-4 border-yellow-light my-6 note p-6 text-yellow-darkest"><div class=flex><div class="w-full text-sm font-sans"><p>The compilation may take some time, depending on your system. You can modify the <code>-j</code> flag according the number of cores your processor.</p></div></div></div><p>Once the build process is completed, you will be presented with the following message:</p><figure class=relative><div class="w-full mx-auto relative block my-0"><div class=block style=padding-bottom:14.602215508559919%></div><div class="w-full h-full absolute m-auto pin overflow-hidden text-center"><img alt="" class="" src=/post/how-to-install-asterisk-on-debian-9/compile-asterisk.jpg data-action=zoom></div></div></figure><p>Install Asterisk and its modules by typing:</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash>sudo make install</code></pre></div><p>When the installation is completed you will be presented with the following message:</p><figure class=relative><div class="w-full mx-auto relative block my-0"><div class=block style=padding-bottom:62.94058408862034%></div><div class="w-full h-full absolute m-auto pin overflow-hidden text-center"><img alt="" class="" src=/post/how-to-install-asterisk-on-debian-9/install-asterisk.jpg data-action=zoom></div></div></figure><p>Now that Asterisk is installed, the next step is to install the sample configuration files.</p><p>You can install either the generic configuration files with sample documentation by running:</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash>sudo make samples</code></pre></div><p>Or install the basic PBX configuration files:</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash>sudo make basic-pbx</code></pre></div><p>The last step is to install the Asterisk init script by typing:</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash>sudo make config</code></pre></div><p>You can also run <code>ldconfig</code> to update the shared libraries cache:</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash>sudo ldconfig</code></pre></div><h2 id=creating-asterisk-user>Creating Asterisk User</h2><p>By default Asterisk runs as a root user. For security reasons we will create a new system user and configure Asterisk to run as the newly created user.</p><p>Create a new system user named <code>asterisk</code> by issuing the following command:</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash>sudo adduser --system --group --home /var/lib/asterisk --no-create-home --gecos <span class=s2>"Asterisk PBX"</span> asterisk</code></pre></div><p>To configure Asterisk to run as <code>asterisk</code> user, open the <code>/etc/default/asterisk</code> file</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash>sudo nano /etc/default/asterisk</code></pre></div><p>And uncomment the following two lines:</p><div class=code-label>/etc/default/asterisk</div><div class=highlight><pre class=chroma><code class=language-config data-lang=config>AST_USER="asterisk"
AST_GROUP="asterisk"</code></pre></div><p>Add the <code>asterisk</code> user to the <code>dialout</code> and <code>audio</code> groups:</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash>sudo usermod -a -G dialout,audio asterisk</code></pre></div><p>Change the ownership of all asterisk files and directories so the user asterisk can access those files:</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash>sudo chown -R asterisk: /var/<span class=o>{</span>lib,log,run,spool<span class=o>}</span>/asterisk /usr/lib/asterisk /etc/asterisk
sudo chmod -R <span class=m>750</span> /var/<span class=o>{</span>lib,log,run,spool<span class=o>}</span>/asterisk /usr/lib/asterisk /etc/asterisk</code></pre></div><h2 id=starting-asterisk>Starting Asterisk</h2><p>Now that we are all set up, start the Asterisk service by typing:</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash>sudo systemctl start asterisk</code></pre></div><p>To verify that Asterisk is running, connect to the Asterisk command line interface (CLI) by typing:</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash>sudo asterisk -vvvr</code></pre></div><p>You’ll see the default Asterisk CLI prompt:</p><figure class=relative><div class="w-full mx-auto relative block my-0"><div class=block style=padding-bottom:27.190332326283986%></div><div class="w-full h-full absolute m-auto pin overflow-hidden text-center"><img alt="" class="" src=/post/how-to-install-asterisk-on-debian-9/asterisk-cli.jpg data-action=zoom></div></div></figure><p>Type <code>exit</code> or press <code>CTRL+C</code> to exit the Asterisk CLI.</p><p>The last step is to enable Asterisk service to start on boot:</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash>sudo systemctl <span class=nb>enable</span> asterisk</code></pre></div><h2 id=configuring-firewall>Configuring Firewall</h2><p>By default, SIP uses the UDP port 5060, to open the port run:</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash>iptables -A INPUT -p udp -m udp --dport <span class=m>5060</span> -j ACCEPT </code></pre></div><p>If you enabled the Real Time Protocol (RTP) then you also need to open the following port range:</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash>iptables -A INPUT -p udp -m udp --dport <span class=m>10000</span>:20000 -j ACCEPT </code></pre></div><p>Feel free to adjust the firewall according to your need.</p><h2 id=conclusion>Conclusion</h2><p>In this guide we have shown you how to install the latest Asterisk version from source on your Debian system.</p><p>You should now check the <a href=httpsS://wiki.asterisk.org/wiki/display/AST/Home>Asterisk Documentation</a> and learn more about how to configure and use Asterisk.</p><p>If you hit a problem or have a feedback, leave a comment below.</p><div class="w-full flex justify-center content-center"><div class="w-full relative"><ins class="adsbygoogle mx-auto" data-ad-client=ca-pub-9439755881064125 data-ad-format=auto data-ad-slot=7027266996 style=display:block></ins></div></div><div class="flex flex-wrap mt-6"><a href=/tags/debian class="bg-grey-lighter mr-2 text-grey-darker text-xs hover:bg-grey-light mt-2 px-4 py-2 rounded">debian</a> <a href=/tags/asterisk class="bg-grey-lighter mr-2 text-grey-darker text-xs hover:bg-grey-light mt-2 px-4 py-2 rounded">asterisk</a></div></section></article><section class="w-full mx-auto border-grey-lighter border-t mt-8 pt-8 max-w-article"><div class="bg-grey-lighter p-8 sm:py-16"><p class="text-lg lg:text-2xl max-w-md mx-auto my-0 sm:text-xl text-center">Sign up to our newsletter and get our latest tutorials and news straight to your mailbox.</p><form action="https://linuxize.us17.list-manage.com/subscribe/post?u=35cd4cd9d021c25c3dd7cabfd&id=9cfa4c89de" class=pt-8 id=mc-embedded-subscribe-form method=post name=mc-embedded-subscribe-form novalidate target=_blank><div class="w-full mx-auto flex items-center flex-col justify-between max-w-sm mb-2 sm:flex-row"><input class="w-full px-4 py-3 rounded appearance-none bg-white block border hover:border-grey-dark mb-3 sm:mb-0 text-grey-darker" name=EMAIL placeholder="Your email..." type=email> <input class=hidden name=b_35cd4cd9d021c25c3dd7cabfd_9cfa4c89de tabindex=-1> <button class="w-full px-4 py-3 rounded bg-blue hover:bg-blue-dark sm:ml-4 sm:w-auto text-white" name=subscribe type=submit><span class=text-center>Subscribe</span></button></div><p class="w-full mx-auto my-0 max-w-sm text-sm">We’ll never share your email address or spam you.</p></form></div></section><div class="w-full mx-auto border-grey-lighter border-t mt-8 pt-8 max-w-xl justify-center"><a href="https://shareasale.com/r.cfm?b=1144537&u=1755182&m=41388&urllink=&afftrack=" class="block mx-auto wp-engine"></a></div><section class="w-full mx-auto border-grey-lighter border-t mt-8 pt-8 max-w-xl"><div class="flex flex-wrap -mx-4"><a href=https://linuxize.com/post/how-to-install-mariadb-on-debian-9/ class="w-full flex md:mb-0 md:w-1/3 overflow-hidden px-4 mb-8"><div class="w-full h-full flex flex-col"><p class="text-xs uppercase font-normal text-grey-dark">Sep 12, 2018</p><div class="font-normal flex-grow mb-2 md:mb-4 text-black text-lg">How to Install MariaDB on Debian 9</div><div><figure class=relative><div class="w-full mx-auto relative block my-0"><div class=block style=padding-bottom:53%></div><div class="w-full h-full absolute m-auto pin overflow-hidden bg-grey-lighter"><img alt="" class="w-full h-full absolute m-auto pin" src=/post/how-to-install-mariadb-on-debian-9/featured.jpg></div></div></figure></div></div></a><a href=https://linuxize.com/post/how-to-install-postgresql-on-debian-9/ class="w-full flex md:mb-0 md:w-1/3 overflow-hidden px-4 mb-8"><div class="w-full h-full flex flex-col"><p class="text-xs uppercase font-normal text-grey-dark">Sep 4, 2018</p><div class="font-normal flex-grow mb-2 md:mb-4 text-black text-lg">How to Install PostgreSQL on Debian 9</div><div><figure class=relative><div class="w-full mx-auto relative block my-0"><div class=block style=padding-bottom:53%></div><div class="w-full h-full absolute m-auto pin overflow-hidden bg-grey-lighter"><img alt="" class="w-full h-full absolute m-auto pin" src=/post/how-to-install-postgresql-on-debian-9/featured.jpg></div></div></figure></div></div></a><a href=https://linuxize.com/post/how-to-set-up-apache-virtual-hosts-on-debian-9/ class="w-full flex md:mb-0 md:w-1/3 overflow-hidden px-4 mb-0"><div class="w-full h-full flex flex-col"><p class="text-xs uppercase font-normal text-grey-dark">Sep 2, 2018</p><div class="font-normal flex-grow mb-2 md:mb-4 text-black text-lg">How To Set Up Apache Virtual Hosts on Debian 9</div><div><figure class=relative><div class="w-full mx-auto relative block my-0"><div class=block style=padding-bottom:53%></div><div class="w-full h-full absolute m-auto pin overflow-hidden bg-grey-lighter"><img alt="" class="w-full h-full absolute m-auto pin" src=/post/how-to-set-up-apache-virtual-hosts-on-debian-9/featured.jpg></div></div></figure></div></div></a></div></section><section class="w-full mx-auto relative border-grey-lighter border-t max-w-lg mt-8 pt-16 py-8"><a href=https://linuxize.com/post/how-to-install-asterisk-on-debian-9/#disqus_thread class="w-full disqus-comment-count bg-grey-lighter block disqus-load md:py-8 py-4 text-center" title="Show comments for post">Write a comment</a><div id=disqus_thread></div><noscript>Please enable JavaScript to view the <a href=https://disqus.com/?ref_noscript>comments powered by Disqus.</a></noscript></section></main><section class="w-full absolute pin bg-white block h-screen invisible search z-50" hidden id=search><div class="flex flex-col min-h-screen"><header class="w-full mx-auto flex items-center h-12 sm:h-16 justify-end px-6 z-10"><a href=# class="block h-6 sm:h-8" id=btn-search-close><svg aria-hidden=true class="h-6 w-6 fill-current inline-block text-grey-darkest sm:h-8 sm:w-8 -mb-2"><use xlink:href=#close></use><title>Close search form</title></svg> <small class="block text-center sm:w-8 w-6">ESC</small></a></header><div class="w-full px-6 flex-grow flex-no-shrink pb-8 pt-16 sm:pt-24"><div class="flex flex-col mb-4 max-w-xl mb-8 mx-auto"><input class="w-full appearance-none bg-transparent focus:outline-0 font-medium md:text-3xl placeholder-grey-dark search-input sm:text-2xl text-grey-darkest text-xl" placeholder="Type to search" autocomplete=off id=search-input><div class=search-results id=search-results></div><div id=hits></div><div id=stats></div><footer class=mt-6><a href=https://algolia.com target=_blank rel="noopener noreferrer" tabindex=-1><svg aria-hidden=true class="inline-block fill-current search-algolia-logo text-grey-dark"><use xlink:href=#search-by-algolia></use><title>Search by Algolia</title></svg></a></footer></div></div></div></section><footer class="w-full px-6 bg-grey-lightest"><div class="w-full mx-auto flex items-center flex-wrap justify-center max-w-xl md:justify-between md:text-left py-8 text-center"><div class="w-full text-sm mb-2 md:mb-0 md:w-1/2"><div class="w-full md:flex block md:items-center md:w-auto"><div class=md:flex-grow><span class="block mb-2 md:inline-block md:mb-0 md:mr-8 text-grey-dark">© 2018 Linuxize.com</span> <a href=/privacy-policy/ class="inline-block text-grey-darkest footer-menu-item hover:text-grey-darker md:mt-0 no-underline mr-4">Privacy Policy </a><a href=/contact/ class="inline-block text-grey-darkest footer-menu-item hover:text-grey-darker md:mt-0 no-underline mr-0">Contact</a></div></div></div><div class="w-full flex justify-center md:justify-end md:w-1/2"><a href=https://twitter.com/linuxize class="block h-6 mr-2"><svg aria-hidden=true class="h-6 w-6 fill-current inline-block text-grey-darkest"><use xlink:href=#twitter></use><title>Twitter</title></svg> </a><a href=https://www.facebook.com/linuxize/ class="block h-6 mr-2"><svg aria-hidden=true class="h-6 w-6 fill-current inline-block text-grey-darkest"><use xlink:href=#facebook></use><title>Facebook</title></svg> </a><a href=/index.xml class="block h-6"><svg aria-hidden=true class="h-6 w-6 fill-current inline-block text-grey-darkest"><use xlink:href=#rss></use><title>RSS</title></svg></a></div></div></footer></div><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script src=https://cdnjs.cloudflare.com/ajax/libs/instantsearch.js/2.7.4/instantsearch.min.js></script><script src=/js/1.ec43b2c142f6ca069006.js></script><script src=/js/app.955fab4b8c6552781ffc.js></script></body></html>