<!doctype html><html class=no-js lang=en-us><head><title>How to check your CentOS Version | Linuxize</title><meta charset=utf-8><meta content="IE=edge" http-equiv=X-UA-Compatible><meta content="width=device-width,initial-scale=1,shrink-to-fit=no" name=viewport><meta content=Linuxize name=apple-mobile-web-app-title><meta content=Linuxize name=application-name><meta content=#2271ff name=theme-color><meta content=#2271ff name=msapplication-TileColor><meta content="In this tutorial, we’ll show you how to find your CentOS version. There are several ways to check what version of CentOS you are running." name=description><meta content=unsafe-url name=referrer><link href=https://linuxize.com/post/how-to-check-your-centos-version/ rel=canonical><meta content="index, follow" name=robots><meta content="Hugo 0.42.1" name=generator><meta content="How to check your CentOS Version" property=og:title><meta content="In this tutorial, we’ll show you how to find your CentOS version. There are several ways to check what version of CentOS you are running." property=og:description><meta content=article property=og:type><meta content=/post/how-to-check-your-centos-version/ property=og:url><meta content=https://linuxize.com/post/how-to-check-your-centos-version/featured.jpg property=og:image><meta content="In this tutorial, we’ll show you how to find your CentOS version. There are several ways to check what version of CentOS you are running." property=og:image:alt><meta content=2018-08-18T20:55:47+01:00 property=article:published_time><meta content=2018-08-18T20:55:47+01:00 property=article:modified_time><meta content=en property=og:locale><meta content=post property=article:section><meta content=https://www.facebook.com/linuxize property=article:publisher><meta content=centos property=article:tag><meta content=terminal property=article:tag><meta content=centos,terminal name=news_keywords><meta content=summary_large_image name=twitter:card><meta content=https://linuxize.com/post/how-to-check-your-centos-version/featured.jpg name=twitter:image><meta content="How to check your CentOS Version" name=twitter:title><meta content="In this tutorial, we’ll show you how to find your CentOS version. There are several ways to check what version of CentOS you are running." name=twitter:description><meta content=@linuxize name=twitter:site><link href=/favicons/apple-touch-icon.png rel=apple-touch-icon sizes=180x180><link href=/favicons/favicon-32x32.png rel=icon sizes=32x32 type=image/png><link href=/favicons/favicon-16x16.png rel=icon sizes=16x16 type=image/png><link href=/favicons/safari-pinned-tab.svg rel=mask-icon color=#2271ff><script type=application/ld+json>{
  "@context": "http://schema.org",
  "@type": "BlogPosting",
  "headline": "How to check your CentOS Version",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://linuxize.com/post/how-to-check-your-centos-version/"
  },"image": {
     "@type": "ImageObject",
     "url": "https://linuxize.com/post/how-to-check-your-centos-version/featured.jpg",
     "width": 1000,
     "height": 530
    },"keywords": "centos, terminal",
  "wordcount": 448,
  "url": "https://linuxize.com/post/how-to-check-your-centos-version/",
  "datePublished": "2018-08-18T20:55:47+01:00",
  "dateModified": "2018-08-18T20:55:47+01:00",
  "publisher": {
    "@type": "Organization","logo": {
    "@type": "imageObject",
      "url": "https://linuxize.com/assets/linuxize-card.png"
    },"name": "Linuxize"
  },

  "author": {
    "@type": "Person",
    "name": "Linuxize"
  },
  "description": "In this tutorial, we’ll show you how to find your CentOS version. There are several ways to check what version of CentOS you are running."
}</script><script src=/js/ads.js></script><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-P827G6S');</script><script src=https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js async></script><meta content=#2271ff name=theme-color><link href=/manifest.79f739767e479131c04f7216cce1c084.json rel=manifest><link href="https://fonts.googleapis.com/css?family=IBM+Plex+Sans:300,400,400i,500,700%7CIBM+Plex+Serif:300,400,400i,600,600i" rel=stylesheet><link href=/css/app.8baac5a545a763d50b01.css rel=stylesheet></head><body class="font-sans kind-page leading-normal section-post text-black type-post"><div class="flex flex-col min-h-screen main-wrap"><header class="w-full px-6 z-10 bg-white border-b border-grey-light fixed linuxize-shadow" id=header><nav class="w-full mx-auto flex items-center h-12 sm:h-16 justify-start"><a href=/ class="flex items-center block flex-no-shrink mr-6 no-underline text-black"><svg aria-hidden=true class="h-6 w-6 fill-current sm:h-8 sm:w-8 mr-2"><use xlink:href=#logo></use><title>Linuxize</title></svg> <span class="hidden font-medium sm:block text-xl tracking-tight">Linuxize</span></a><div class="flex justify-center -mb-px flex-1 min-w-0 text-sm"><div class="hidden font-medium nav-post-title sm:text-lg text-center truncate">How to check your CentOS Version</div></div><div class="flex justify-end"><button class="block h-6 sm:h-8" id=btn-search><svg aria-hidden=true class="h-6 w-6 fill-current inline-block text-grey-darkest sm:h-8 sm:w-8"><use xlink:href=#search></use><title>Search</title></svg></button></div></nav></header><main class="w-full px-6 flex-grow flex-no-shrink pb-8 pt-16 sm:pt-24 main"><article class="single-post relative"><div class="mx-auto max-w-xl mb-4 xl:flex xl:max-w-4xl xl:mb-8"><div class="w-full xl:w-1/2 self-auto xxl:flex-no-shrink xxl:w-190"><section class="w-full post-header xl:pr-8"><div class=mb-4><div class="w-full flex justify-center content-center"><div class="w-full relative"><ins class="mx-auto adsbygoogle top-a" data-ad-client=ca-pub-9439755881064125 data-ad-format=horizontal data-ad-slot=4501323511 style=display:block></ins></div></div></div><div class="flex flex-col mb-4 font-medium md:flex-row text-xs uppercase xxl:text-sm"><div class=inline-flex><time class="" datetime=2018-08-18T20:55:47+01:00>August 18, 2018 </time><span class=mx-2>•</span><p>Read in 3 minutes</p></div><span class="hidden md:block mx-2">|</span><p class="text-xs uppercase font-medium xxl:text-sm leading-normal rounded-sm">last updated  <time class="" datetime=2018-08-18T20:55:47+01:00>August 18, 2018</time></p></div><h1 class="mb-4 font-bold leading-none lg:text-5xl text-3xl text-black xl:mb-4 xxl:text-6xl">How to check your CentOS Version</h1><div class="mb-4 distro-versions inline-flex items-center"><h3 class="text-xs uppercase font-medium xxl:text-sm leading-normal rounded-sm mr-2">This tutorial is also available for:</h3><a href=/post/how-to-check-your-ubuntu-version/ class="bg-grey-lighter mr-2 text-grey-darker text-xs capitalize font-medium hover:bg-blue hover:text-white leading-normal px-3 py-1 rounded-sm xxl:text-sm">ubuntu</a></div></section></div><div class="w-full xl:w-1/2 bg-grey"><section class="w-full mx-auto max-w-xl"><figure class="-mx-6 lg:mx-0 relative"><div class="w-full mx-auto relative block my-0"><div class=block style=padding-bottom:53%></div><div class="w-full h-full absolute m-auto pin overflow-hidden bg-grey-lighter"><img alt="" class="w-full h-full absolute m-auto pin" src=/post/how-to-check-your-centos-version/featured.jpg></div></div></figure></section></div></div><section class="w-full mx-auto sticky-element"><section class="w-full mx-auto relative hidden max-w-article xl:block xl:max-w-4xl"><aside class="bg-grey-lighter mb-6 mt-8 p-4 pb-2 table-of-contents xl:absolute xl:mt-0 xl:pin-r xl:text-sm xl:w-48 xxl:w-75"><p class="font-bold mb-3 text-grey-darker xl:text-base">Contents</p><nav id=TableOfContents><ul><li><ul><li><a href=#commands-to-check-centos-version>Commands to check CentOS version</a><ul><li><a href=#check-your-centos-version-using-the-lsb-release-command>Check your CentOS version using the <code>lsb_release</code> command</a></li><li><a href=#check-your-centos-version-using-the-rpm-command>Check your CentOS version using the <code>rpm</code> command</a></li><li><a href=#check-your-centos-version-using-the-etc-centos-release-file>Check your CentOS version using the <code>/etc/centos-release</code> file</a></li><li><a href=#check-your-centos-version-using-the-etc-os-release-file>Check your CentOS version using the <code>/etc/os-release</code> file</a></li><li><a href=#check-your-centos-version-using-the-hostnamectl-command>Check your CentOS version using the <code>hostnamectl</code> command</a></li></ul></li><li><a href=#conclusion>Conclusion</a></li></ul></li></ul></nav><p class="font-bold mb-3 text-grey-darker xl:text-base border-grey-light border-t mt-4 pt-4">Share</p><section class="w-full mx-auto"><nav class="flex flex-wrap"><a href="https://twitter.com/share?text=How%20to%20check%20your%20CentOS%20Version&url=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-check-your-centos-version%2f" class="h-6 w-6 mb-4 mr-3" target=_blank><svg aria-hidden=true class="h-6 w-6 fill-current inline-block hover:text-blue text-gray-light"><use xlink:href=#twitter></use><title>Share on Twitter</title></svg> </a><a href="https://www.facebook.com/sharer/sharer.php?caption=How%20to%20check%20your%20CentOS%20Version&u=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-check-your-centos-version%2f" class="h-6 w-6 mb-4 mr-3" target=_blank><svg aria-hidden=true class="h-6 w-6 fill-current inline-block hover:text-blue text-gray-light"><use xlink:href=#facebook></use><title>Share on Facebook</title></svg> </a><a href="https://pinterest.com/pin/create/button/?url=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-check-your-centos-version%2f&media=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-check-your-centos-version%2ffeatured.jpg&description=How%20to%20check%20your%20CentOS%20Version" class="h-6 w-6 mb-4 mr-3" target=_blank><svg aria-hidden=true class="h-6 w-6 fill-current inline-block hover:text-blue text-gray-light"><use xlink:href=#pinterest></use><title>Share on Pinterest</title></svg> </a><a href="https://plus.google.com/share?url=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-check-your-centos-version%2f" class="h-6 w-6 mb-4 mr-3" target=_blank><svg aria-hidden=true class="h-6 w-6 fill-current inline-block hover:text-blue text-gray-light"><use xlink:href=#gplus></use><title>Share on Google Plus</title></svg> </a><a href="https://news.ycombinator.com/submitlink?t=How%20to%20check%20your%20CentOS%20Version&u=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-check-your-centos-version%2f" class="h-6 w-6 mb-4 mr-3" target=_blank><svg aria-hidden=true class="h-6 w-6 fill-current inline-block hover:text-blue text-gray-light"><use xlink:href=#hacker-news></use><title>Submit to Hacker News</title></svg> </a><a href="/cdn-cgi/l/email-protection#7a45090f18101f190e4732150d5f484a0e155f484a19121f19115f484a03150f085f484a391f140e35295f484a2c1f08091315145c18151e034739121f19115f484a150f0e5f484a0e1213095f484a1b080e1319161f405f4a3b5f4a3b120e0e0a095f491b5f481c5f481c1613140f0213001f541915175f481c0a15090e5f481c12150d570e155719121f19115703150f0857191f140e1509570c1f08091315145f481c" class="h-6 w-6 mb-4" target=_blank><svg aria-hidden=true class="h-6 w-6 fill-current inline-block hover:text-blue text-gray-light"><use xlink:href=#email></use><title>Share with Email</title></svg></a></nav></section></aside></section></section><section class="w-full mx-auto max-w-article markdown"><aside class="aside-wrapper relative"><div class="w-full mx-auto sideblock sticky"><div class="xl:absolute xxl:w-75 sideblock-content xl:-ml-52 xl:pin-l xl:w-40 xxl:-ml-89"><div class="hidden affiliate"><a href="https://www.vultr.com/?ref=6812257" class=vultr target=_blank></a> <a href="https://shareasale.com/r.cfm?b=1133389&u=1755182&m=75038&urllink=&afftrack=" class="cloudways mt-8" target=_blank></a></div><div class="w-full flex justify-center content-center"><div class="w-full relative"><ins class="mx-auto adsbygoogle" data-ad-client=ca-pub-9439755881064125 data-ad-format=auto data-ad-slot=9558702194 style=display:block></ins></div></div></div></div></aside><p>At the time of writing, CentOS Linux has 3 major active released branches, CentOS 5, CentOS 6, and CentOS 7.</p><p>In this tutorial, we’ll show you how to find your CentOS version. There are several ways to check what version of CentOS you are running.</p><h2 id=commands-to-check-centos-version>Commands to check CentOS version</h2><h3 id=check-your-centos-version-using-the-lsb-release-command>Check your CentOS version using the <code>lsb_release</code> command</h3><p>The <code>lsb_release</code> command displays Linux Standard Base (LSB) information about your Linux distribution.</p><p>This is the preferred method and will work no matter what CentOS version you are running.</p><p>Open your terminal and type the following command:</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash>lsb_release -a</code></pre></div><figure class=relative><div class="w-full mx-auto relative block my-0"><div class=block style=padding-bottom:18.109339407744876%></div><div class="w-full h-full absolute m-auto pin overflow-hidden text-center"><img alt="" class="" src=/post/how-to-check-your-centos-version/check-centos-version.jpg data-action=zoom></div></div></figure><p>Your CentOS version will be shown on the Description line. As you can see from the output above I am using CentOS Linux release 7.5.1804.</p><p><em>What does the version number <code>7.5.1804</code> mean?</em></p><ul><li><code>7</code> is the major CentOS branch.</li><li><code>7.5</code> is the latest minor version of CentOS 7.</li><li><code>1804</code> is the date code of the minor versions, 1804 means April 2018. This number is used to indicate when the release happened.</li></ul><div class="bg-yellow-lightest border-l-4 border-yellow-light my-6 note p-6 text-yellow-darkest"><div class=flex><div class="w-full text-sm font-sans"><p>If you get a message saying <code>bash: lsb_release: command not found...</code>, it means that the package <code>redhat-lsb-core</code> is not installed on your system. You can easily install it with: <code>sudo yum install redhat-lsb-core</code></p></div></div></div><h3 id=check-your-centos-version-using-the-rpm-command>Check your CentOS version using the <code>rpm</code> command</h3><p><code>rpm</code> (Red Hat Package Manager) is a package management tool for Red Hat based systems such as RHEL, CentOS and Fedora.</p><p>You can use the <code>rpm</code> tool to display information about the <code>centos-release</code> package, which includes the CentOS version in its name:</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash>rpm --query centos-release</code></pre></div><div class=highlight><pre class=chroma><code class=language-output data-lang=output>centos-release-7-5.1804.4.el7.centos.x86_64</code></pre></div><h3 id=check-your-centos-version-using-the-etc-centos-release-file>Check your CentOS version using the <code>/etc/centos-release</code> file</h3><p>The <code>/etc/centos-release</code> file is provided by the <code>centos-release</code> package.</p><p>To find your CentOS version enter the following command:</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash>cat /etc/centos-release</code></pre></div><div class=highlight><pre class=chroma><code class=language-output data-lang=output>CentOS Linux release 7.5.1804 (Core) </code></pre></div><h3 id=check-your-centos-version-using-the-etc-os-release-file>Check your CentOS version using the <code>/etc/os-release</code> file</h3><p>The <code>/etc/os-release</code> file is present on all systems running systemd.</p><p>This method will work only if you have CentOS 7:</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash>cat /etc/os-release</code></pre></div><div class=highlight><pre class=chroma><code class=language-output data-lang=output>NAME="CentOS Linux"
VERSION="7 (Core)"
ID="centos"
ID_LIKE="rhel fedora"
VERSION_ID="7"
PRETTY_NAME="CentOS Linux 7 (Core)"
ANSI_COLOR="0;31"
CPE_NAME="cpe:/o:centos:centos:7"
HOME_URL="https://www.centos.org/"
BUG_REPORT_URL="https://bugs.centos.org/"

CENTOS_MANTISBT_PROJECT="CentOS-7"
CENTOS_MANTISBT_PROJECT_VERSION="7"
REDHAT_SUPPORT_PRODUCT="centos"
REDHAT_SUPPORT_PRODUCT_VERSION="</code></pre></div><h3 id=check-your-centos-version-using-the-hostnamectl-command>Check your CentOS version using the <code>hostnamectl</code> command</h3><p><code>hostnamectl</code> is a command that allows you to set the hostname but you can also use it to find your CentOS branch.</p><p>This method will work only if you have CentOS 7:</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash>hostnamectl</code></pre></div><div class=highlight><pre class=chroma><code class=language-output data-lang=output>   Static hostname: localhost.localdomain
         Icon name: computer-vm
           Chassis: vm
        Machine ID: 2849f743fbe74706abaa6cb8b2ae5377
           Boot ID: 8259a43c6265465884920ac6d762ed5e
    Virtualization: kvm
  Operating System: CentOS Linux 7 (Core)
       CPE OS Name: cpe:/o:centos:centos:7
            Kernel: Linux 3.10.0-862.9.1.el7.x86_64
      Architecture: x86-64</code></pre></div><div><small class=text-grey><small>Advertisement</small></small></div><div class="w-full flex justify-center content-center"><div class="w-full relative"><ins class=adsbygoogle data-ad-client=ca-pub-9439755881064125 data-ad-format=fluid data-ad-slot=5120214995 style=display:block data-ad-layout=in-article></ins></div></div><h2 id=conclusion>Conclusion</h2><p>In this guide we have shown you how to find the version of CentOS installed on your system.</p><p>For more information on CentOS releases visit the <a href=https://en.wikipedia.org/wiki/CentOS#CentOS_releases>Wiki CentOS Releases</a> page.</p><p>Feel free to leave a comment if you have any questions.</p><div class="w-full flex justify-center content-center"><div class="w-full relative"><ins class="mx-auto adsbygoogle" data-ad-client=ca-pub-9439755881064125 data-ad-format=auto data-ad-slot=7027266996 style=display:block></ins></div></div><div class="flex flex-wrap mt-6"><a href=/tags/centos class="bg-grey-lighter mr-2 text-grey-darker text-xs hover:bg-grey-light mt-2 px-4 py-2 rounded">centos</a> <a href=/tags/terminal class="bg-grey-lighter mr-2 text-grey-darker text-xs hover:bg-grey-light mt-2 px-4 py-2 rounded">terminal</a></div></section></article><section class="w-full mx-auto border-grey-lighter border-t mt-8 pt-8 max-w-article"><div class="bg-grey-lighter p-8 sm:py-16"><p class="mx-auto my-0 lg:text-2xl max-w-md sm:text-xl text-center text-lg">Sign up to our newsletter and get our latest tutorials and news straight to your mailbox.</p><form action="https://linuxize.us17.list-manage.com/subscribe/post?u=35cd4cd9d021c25c3dd7cabfd&id=9cfa4c89de" class=pt-8 id=mc-embedded-subscribe-form method=post name=mc-embedded-subscribe-form novalidate target=_blank><div class="w-full mx-auto flex items-center flex-col justify-between max-w-sm mb-2 sm:flex-row"><input class="w-full px-4 py-3 rounded appearance-none bg-white block border hover:border-grey-dark mb-3 sm:mb-0 text-grey-darker" name=EMAIL placeholder="Your email..." type=email> <input class=hidden name=b_35cd4cd9d021c25c3dd7cabfd_9cfa4c89de tabindex=-1> <button class="w-full px-4 py-3 rounded bg-blue hover:bg-blue-dark sm:ml-4 sm:w-auto text-white" name=subscribe type=submit><span class=text-center>Subscribe</span></button></div><p class="w-full mx-auto my-0 max-w-sm text-sm">We’ll never share your email address or spam you.</p></form></div></section><div class="w-full mx-auto border-grey-lighter border-t mt-8 pt-8 max-w-xl justify-center"><a href="https://shareasale.com/r.cfm?b=1144537&u=1755182&m=41388&urllink=&afftrack=" class="mx-auto wp-engine block"></a></div><section class="w-full mx-auto border-grey-lighter border-t mt-8 pt-8 max-w-xl"><div class="flex flex-wrap -mx-4"><a href=https://linuxize.com/post/how-to-set-up-apache-virtual-hosts-on-centos-7/ class="w-full flex md:mb-0 md:w-1/3 overflow-hidden px-4 mb-8"><div class="w-full flex flex-col h-full"><p class="text-xs uppercase font-normal text-grey-dark">Aug 17, 2018</p><div class="font-normal flex-grow mb-2 md:mb-4 text-black text-lg">How to Set Up Apache Virtual Hosts on CentOS 7</div><div><figure class=relative><div class="w-full mx-auto relative block my-0"><div class=block style=padding-bottom:53%></div><div class="w-full h-full absolute m-auto pin overflow-hidden bg-grey-lighter"><img alt="" class="w-full h-full absolute m-auto pin" src=/post/how-to-set-up-apache-virtual-hosts-on-centos-7/featured.jpg></div></div></figure></div></div></a><a href=https://linuxize.com/post/how-to-disable-selinux-on-centos-7/ class="w-full flex md:mb-0 md:w-1/3 overflow-hidden px-4 mb-8"><div class="w-full flex flex-col h-full"><p class="text-xs uppercase font-normal text-grey-dark">Aug 14, 2018</p><div class="font-normal flex-grow mb-2 md:mb-4 text-black text-lg">How to Disable SELinux on CentOS 7</div><div><figure class=relative><div class="w-full mx-auto relative block my-0"><div class=block style=padding-bottom:53%></div><div class="w-full h-full absolute m-auto pin overflow-hidden bg-grey-lighter"><img alt="" class="w-full h-full absolute m-auto pin" src=/post/how-to-disable-selinux-on-centos-7/featured.jpg></div></div></figure></div></div></a><a href=https://linuxize.com/post/how-to-install-asterisk-on-centos-7/ class="w-full flex md:mb-0 md:w-1/3 overflow-hidden px-4 mb-0"><div class="w-full flex flex-col h-full"><p class="text-xs uppercase font-normal text-grey-dark">Aug 13, 2018</p><div class="font-normal flex-grow mb-2 md:mb-4 text-black text-lg">How To Install Asterisk on CentOS 7</div><div><figure class=relative><div class="w-full mx-auto relative block my-0"><div class=block style=padding-bottom:53%></div><div class="w-full h-full absolute m-auto pin overflow-hidden bg-grey-lighter"><img alt="" class="w-full h-full absolute m-auto pin" src=/post/how-to-install-asterisk-on-centos-7/featured.jpg></div></div></figure></div></div></a></div></section><section class="w-full mx-auto relative border-grey-lighter border-t max-w-lg mt-8 pt-16 py-8"><a href=https://linuxize.com/post/how-to-check-your-centos-version/#disqus_thread class="w-full disqus-comment-count bg-grey-lighter block disqus-load md:py-8 py-4 text-center" title="Show comments for post">Write a comment</a><div id=disqus_thread></div><noscript>Please enable JavaScript to view the <a href=https://disqus.com/?ref_noscript>comments powered by Disqus.</a></noscript></section></main><section class="w-full absolute pin bg-white block h-screen invisible search z-50" hidden id=search><div class="flex flex-col min-h-screen"><header class="w-full mx-auto flex items-center h-12 sm:h-16 justify-end px-6 z-10"><a href=# class="block h-6 sm:h-8" id=btn-search-close><svg aria-hidden=true class="h-6 w-6 fill-current inline-block text-grey-darkest sm:h-8 sm:w-8 -mb-2"><use xlink:href=#close></use><title>Close search form</title></svg> <small class="block text-center sm:w-8 w-6">ESC</small></a></header><div class="w-full px-6 flex-grow flex-no-shrink pb-8 pt-16 sm:pt-24"><div class="mx-auto max-w-xl flex flex-col mb-4 mb-8"><input class="w-full appearance-none bg-transparent focus:outline-0 font-medium md:text-3xl placeholder-grey-dark search-input sm:text-2xl text-grey-darkest text-xl" placeholder="Type to search" autocomplete=off id=search-input><div class=search-results id=search-results></div><div id=hits></div><div id=stats></div><footer class=mt-6><a href=https://algolia.com target=_blank rel="noopener noreferrer" tabindex=-1><svg aria-hidden=true class="inline-block fill-current search-algolia-logo text-grey-dark"><use xlink:href=#search-by-algolia></use><title>Search by Algolia</title></svg></a></footer></div></div></div></section><footer class="w-full px-6 bg-grey-lightest"><div class="w-full mx-auto flex items-center flex-wrap justify-center max-w-xl md:justify-between md:text-left py-8 text-center"><div class="w-full text-sm mb-2 md:mb-0 md:w-1/2"><div class="w-full md:flex block md:items-center md:w-auto"><div class=md:flex-grow><span class="block mb-2 md:inline-block md:mb-0 md:mr-8 text-grey-dark">© 2018 Linuxize.com</span> <a href=/privacy-policy/ class="inline-block text-grey-darkest footer-menu-item hover:text-grey-darker md:mt-0 no-underline mr-4">Privacy Policy </a><a href=/contact/ class="inline-block text-grey-darkest footer-menu-item hover:text-grey-darker md:mt-0 no-underline mr-0">Contact</a></div></div></div><div class="w-full flex justify-center md:justify-end md:w-1/2"><a href=https://twitter.com/linuxize class="block h-6 mr-2"><svg aria-hidden=true class="h-6 w-6 fill-current inline-block text-grey-darkest"><use xlink:href=#twitter></use><title>Twitter</title></svg> </a><a href=https://www.facebook.com/linuxize/ class="block h-6 mr-2"><svg aria-hidden=true class="h-6 w-6 fill-current inline-block text-grey-darkest"><use xlink:href=#facebook></use><title>Facebook</title></svg> </a><a href=/index.xml class="block h-6"><svg aria-hidden=true class="h-6 w-6 fill-current inline-block text-grey-darkest"><use xlink:href=#rss></use><title>RSS</title></svg></a></div></div></footer></div><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script src=https://cdnjs.cloudflare.com/ajax/libs/instantsearch.js/2.7.4/instantsearch.min.js></script><script src=/js/1.7dd90319a322552eafab.js></script><script src=/js/app.8baac5a545a763d50b01.js></script></body></html>