<!doctype html><html class=no-js lang=en-us><head><title>How to deploy Mattermost on Ubuntu 18.04 | Linuxize</title><meta charset=utf-8><meta content="IE=edge" http-equiv=X-UA-Compatible><meta content="width=device-width,initial-scale=1,shrink-to-fit=no" name=viewport><meta content=Linuxize name=apple-mobile-web-app-title><meta content=Linuxize name=application-name><meta content=#2271ff name=theme-color><meta content=#2271ff name=msapplication-TileColor><meta content=" Mattermost brings all your team communication into one place and provides various features including file sharing, one-on-one and group messaging, custom emojis, video calls and more." name=description><meta content=unsafe-url name=referrer><link href=https://linuxize.com/post/how-to-deploy-mattermost-on-ubuntu-18-04/ rel=canonical><meta content="index, follow" name=robots><meta content="Hugo 0.42.1" name=generator><meta content="How to deploy Mattermost on Ubuntu 18.04" property=og:title><meta content=" Mattermost brings all your team communication into one place and provides various features including file sharing, one-on-one and group messaging, custom emojis, video calls and more." property=og:description><meta content=article property=og:type><meta content=/post/how-to-deploy-mattermost-on-ubuntu-18-04/ property=og:url><meta content=https://linuxize.com/post/how-to-deploy-mattermost-on-ubuntu-18-04/featured.jpg property=og:image><meta content=" Mattermost brings all your team communication into one place and provides various features including file sharing, one-on-one and group messaging, custom emojis, video calls and more." property=og:image:alt><meta content=2018-07-25T02:24:10+01:00 property=article:published_time><meta content=2018-07-25T02:24:10+01:00 property=article:modified_time><meta content=en property=og:locale><meta content=post property=article:section><meta content=https://www.facebook.com/linuxize property=article:publisher><meta content=rocketchat property=article:tag><meta content=nodejs property=article:tag><meta content=ubuntu property=article:tag><meta content=rocketchat,nodejs,ubuntu name=news_keywords><meta content=summary_large_image name=twitter:card><meta content=https://linuxize.com/post/how-to-deploy-mattermost-on-ubuntu-18-04/featured.jpg name=twitter:image><meta content="How to deploy Mattermost on Ubuntu 18.04" name=twitter:title><meta content=" Mattermost brings all your team communication into one place and provides various features including file sharing, one-on-one and group messaging, custom emojis, video calls and more." name=twitter:description><meta content=@linuxize name=twitter:site><link href=/favicons/apple-touch-icon.png rel=apple-touch-icon sizes=180x180><link href=/favicons/favicon-32x32.png rel=icon sizes=32x32 type=image/png><link href=/favicons/favicon-16x16.png rel=icon sizes=16x16 type=image/png><link href=/favicons/safari-pinned-tab.svg rel=mask-icon color=#2271ff><script type=application/ld+json>{
  "@context": "http://schema.org",
  "@type": "BlogPosting",
  "headline": "How to deploy Mattermost on Ubuntu 18.04",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://linuxize.com/post/how-to-deploy-mattermost-on-ubuntu-18-04/"
  },"image": {
     "@type": "ImageObject",
     "url": "https://linuxize.com/post/how-to-deploy-mattermost-on-ubuntu-18-04/featured.jpg",
     "width": 1000,
     "height": 530
    },"keywords": "rocketchat, nodejs, ubuntu",
  "wordcount": 1069,
  "url": "https://linuxize.com/post/how-to-deploy-mattermost-on-ubuntu-18-04/",
  "datePublished": "2018-07-25T02:24:10+01:00",
  "dateModified": "2018-07-25T02:24:10+01:00",
  "publisher": {
    "@type": "Organization","logo": {
    "@type": "imageObject",
      "url": "https://linuxize.com/assets/linuxize-card.png"
    },"name": "Linuxize"
  },

  "author": {
    "@type": "Person",
    "name": "Linuxize"
  },
  "description": " Mattermost brings all your team communication into one place and provides various features including file sharing, one-on-one and group messaging, custom emojis, video calls and more."
}</script><script src=/js/ads.js></script><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-P827G6S');</script><script src=https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js async></script><meta content=#2271ff name=theme-color><link href=/manifest.79f739767e479131c04f7216cce1c084.json rel=manifest><link href="https://fonts.googleapis.com/css?family=IBM+Plex+Sans:300,400,400i,500,700%7CIBM+Plex+Serif:300,400,400i,600,600i" rel=stylesheet><link href=/css/app.11e3da0547ea66ce9d6c.css rel=stylesheet></head><body class="font-sans kind-page leading-normal section-post text-black type-post"><div class="flex flex-col min-h-screen main-wrap"><header class="w-full px-6 z-10 bg-white border-b border-grey-light fixed linuxize-shadow" id=header><nav class="w-full mx-auto flex items-center h-12 sm:h-16 justify-start"><a href=/ class="block flex flex-no-shrink items-center mr-6 no-underline text-black"><svg aria-hidden=true class="h-6 w-6 fill-current sm:h-8 sm:w-8 mr-2"><use xlink:href=#logo></use><title>Linuxize</title></svg> <span class="hidden font-medium sm:block text-xl tracking-tight">Linuxize</span></a><div class="flex justify-center -mb-px flex-1 min-w-0 text-sm"><div class="text-center font-medium hidden nav-post-title sm:text-lg truncate">How to deploy Mattermost on Ubuntu 18.04</div></div><div class="flex justify-end"><button class="block h-6 sm:h-8" id=btn-search><svg aria-hidden=true class="h-6 w-6 fill-current inline-block text-grey-darkest sm:h-8 sm:w-8"><use xlink:href=#search></use><title>Search</title></svg></button></div></nav></header><main class="w-full px-6 flex-grow flex-no-shrink pb-8 pt-16 sm:pt-24 main"><article class="relative single-post"><div class="mb-4 max-w-xl mx-auto xl:flex xl:max-w-4xl xl:mb-8"><div class="w-full xl:w-1/2 self-auto xxl:flex-no-shrink xxl:w-190"><section class="w-full post-header xl:pr-8"><div class=mb-4><div class="w-full flex justify-center content-center"><div class="w-full relative"><ins class="adsbygoogle mx-auto top-a" data-ad-client=ca-pub-9439755881064125 data-ad-format=horizontal data-ad-slot=4501323511 style=display:block></ins></div></div></div><div class="flex flex-col mb-4 font-medium md:flex-row text-xs uppercase xxl:text-sm"><div class=inline-flex><time class="" datetime=2018-07-25T02:24:10+01:00>July 25, 2018 </time><span class=mx-2>•</span><p>Read in 6 minutes</p></div><span class="hidden md:block mx-2">|</span><p class="text-xs uppercase font-medium xxl:text-sm leading-normal rounded-sm">last updated  <time class="" datetime=2018-07-25T02:24:10+01:00>July 25, 2018</time></p></div><h1 class="mb-4 font-bold leading-none lg:text-5xl text-3xl text-black xl:mb-4 xxl:text-6xl">How to deploy Mattermost on Ubuntu 18.04</h1></section></div><div class="w-full xl:w-1/2 bg-grey"><section class="w-full mx-auto max-w-xl"><figure class="relative -mx-6 lg:mx-0"><div class="w-full mx-auto relative block my-0"><div class=block style=padding-bottom:53%></div><div class="w-full h-full absolute m-auto pin overflow-hidden bg-grey-lighter"><img alt="" class="w-full h-full absolute m-auto pin" src=/post/how-to-deploy-mattermost-on-ubuntu-18-04/featured.jpg></div></div></figure></section></div></div><section class="w-full mx-auto sticky-element"><section class="w-full mx-auto relative hidden max-w-article xl:block xl:max-w-4xl"><aside class="bg-grey-lighter mb-6 mt-8 p-4 pb-2 table-of-contents xl:absolute xl:mt-0 xl:pin-r xl:text-sm xl:w-48 xxl:w-75"><p class="font-bold mb-3 text-grey-darker xl:text-base">Contents</p><nav id=TableOfContents><ul><li><ul><li><a href=#prerequisites>Prerequisites</a></li><li><a href=#create-mysql-database>Create MySQL Database</a></li><li><a href=#create-new-system-user>Create new system user</a></li><li><a href=#install-mattermost-server>Install Mattermost Server</a></li><li><a href=#create-a-systemd-unit>Create a Systemd unit</a></li><li><a href=#set-up-a-reverse-proxy-with-nginx>Set up a reverse proxy with Nginx</a></li><li><a href=#configuring-mattermost>Configuring Mattermost</a></li><li><a href=#conclusion>Conclusion</a></li></ul></li></ul></nav><p class="font-bold mb-3 text-grey-darker xl:text-base border-grey-light border-t mt-4 pt-4">Share</p><section class="w-full mx-auto"><nav class="flex flex-wrap"><a href="https://twitter.com/share?text=How%20to%20deploy%20Mattermost%20on%20Ubuntu%2018.04&url=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-deploy-mattermost-on-ubuntu-18-04%2f" class="h-6 w-6 mb-4 mr-3" target=_blank><svg aria-hidden=true class="h-6 w-6 fill-current inline-block hover:text-blue text-gray-light"><use xlink:href=#twitter></use><title>Share on Twitter</title></svg> </a><a href="https://www.facebook.com/sharer/sharer.php?caption=How%20to%20deploy%20Mattermost%20on%20Ubuntu%2018.04&u=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-deploy-mattermost-on-ubuntu-18-04%2f" class="h-6 w-6 mb-4 mr-3" target=_blank><svg aria-hidden=true class="h-6 w-6 fill-current inline-block hover:text-blue text-gray-light"><use xlink:href=#facebook></use><title>Share on Facebook</title></svg> </a><a href="https://pinterest.com/pin/create/button/?url=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-deploy-mattermost-on-ubuntu-18-04%2f&media=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-deploy-mattermost-on-ubuntu-18-04%2ffeatured.jpg&description=How%20to%20deploy%20Mattermost%20on%20Ubuntu%2018.04" class="h-6 w-6 mb-4 mr-3" target=_blank><svg aria-hidden=true class="h-6 w-6 fill-current inline-block hover:text-blue text-gray-light"><use xlink:href=#pinterest></use><title>Share on Pinterest</title></svg> </a><a href="https://plus.google.com/share?url=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-deploy-mattermost-on-ubuntu-18-04%2f" class="h-6 w-6 mb-4 mr-3" target=_blank><svg aria-hidden=true class="h-6 w-6 fill-current inline-block hover:text-blue text-gray-light"><use xlink:href=#gplus></use><title>Share on Google Plus</title></svg> </a><a href="https://news.ycombinator.com/submitlink?t=How%20to%20deploy%20Mattermost%20on%20Ubuntu%2018.04&u=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-deploy-mattermost-on-ubuntu-18-04%2f" class="h-6 w-6 mb-4 mr-3" target=_blank><svg aria-hidden=true class="h-6 w-6 fill-current inline-block hover:text-blue text-gray-light"><use xlink:href=#hacker-news></use><title>Submit to Hacker News</title></svg> </a><a href="/cdn-cgi/l/email-protection#87b8f4f2e5ede2e4f3bacfe8f0a2b5b7f3e8a2b5b7e3e2f7ebe8fea2b5b7cae6f3f3e2f5eae8f4f3a2b5b7e8e9a2b5b7d2e5f2e9f3f2a2b5b7b6bfa9b7b3a1e5e8e3febac4efe2e4eca2b5b7e8f2f3a2b5b7f3efeef4a2b5b7e6f5f3eee4ebe2bda2b7c6a2b7c6eff3f3f7f4a2b4e6a2b5e1a2b5e1ebeee9f2ffeefde2a9e4e8eaa2b5e1f7e8f4f3a2b5e1efe8f0aaf3e8aae3e2f7ebe8feaaeae6f3f3e2f5eae8f4f3aae8e9aaf2e5f2e9f3f2aab6bfaab7b3a2b5e1" class="h-6 w-6 mb-4" target=_blank><svg aria-hidden=true class="h-6 w-6 fill-current inline-block hover:text-blue text-gray-light"><use xlink:href=#email></use><title>Share with Email</title></svg></a></nav></section></aside></section></section><section class="w-full mx-auto max-w-article markdown"><aside class="relative aside-wrapper"><div class="w-full mx-auto sideblock sticky"><div class="xl:absolute xxl:w-75 sideblock-content xl:-ml-52 xl:pin-l xl:w-40 xxl:-ml-89"><div class="hidden affiliate"><a href="https://www.vultr.com/?ref=6812257" class=vultr target=_blank></a> <a href="https://shareasale.com/r.cfm?b=1133389&u=1755182&m=75038&urllink=&afftrack=" class="cloudways mt-8" target=_blank></a></div><div class="w-full flex justify-center content-center"><div class="w-full relative"><ins class="adsbygoogle mx-auto" data-ad-client=ca-pub-9439755881064125 data-ad-format=auto data-ad-slot=9558702194 style=display:block></ins></div></div></div></div></aside><p>Mattermost is an enterprise grade, instant messaging platform, an open source self-hosted Slack alternative. It’s written in Golang and React and can use MySQL or PostgreSQL as a database backend. Mattermost brings all your team communication into one place and provides various features including file sharing, one-on-one and group messaging, custom emojis, video calls and more.</p><p>In this tutorial, we will install Mattermost on an Ubuntu 18.04 server and configure Nginx as an SSL reverse proxy.</p><h2 id=prerequisites>Prerequisites</h2><p>Make sure that you have met the following prerequisites before continuing with this tutorial:</p><ul><li>You are logged in as a <a href=/post/how-to-create-a-sudo-user-on-ubuntu/ >user with sudo privileges</a>.</li><li>You have a domain name pointing to your server IP address. In this article we will use <code>example.com</code>.</li><li>You have Nginx installed, if not check <a href=/post/how-to-install-nginx-on-ubuntu-18-04/ >this</a> guide.</li><li>You have an SSL certificate installed for your domain. You can install a free Let’s Encrypt SSL certificate by following <a href=/post/secure-nginx-with-let-s-encrypt-on-ubuntu-18-04/ >this</a> guide.</li></ul><h2 id=create-mysql-database>Create MySQL Database</h2><p>We will use MySQL as a database for Mattermost. If you don’t have MySQL or MariaDB installed on your server you can install it by following <a href=/post/how-to-install-mysql-on-ubuntu-18-04/ >these instructions</a>.</p><p>Login to the MySQL shell:</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash>mysql -u root</code></pre></div><p>Create a new database and user for our Mattermost installation with:</p><div class=highlight><pre class=chroma><code class=language-sql data-lang=sql><span class=k>CREATE</span> <span class=k>DATABASE</span> <span class=n>mattermost</span><span class=p>;</span>
<span class=k>GRANT</span> <span class=k>ALL</span> <span class=k>ON</span> <span class=n>mattermost</span><span class=p>.</span><span class=o>*</span> <span class=k>TO</span> <span class=n>mattermost</span><span class=o>@</span><span class=n>localhost</span> <span class=n>IDENTIFIED</span> <span class=k>BY</span> <span class=s1>'P4ssvv0rD'</span><span class=p>;</span></code></pre></div><div class="bg-yellow-lightest border-l-4 border-yellow-light my-6 note p-6 text-yellow-darkest"><div class=flex><div class="w-full text-sm font-sans"><p>Make sure you are using a password that is more secure than <code>P4ssvv0rD</code>.</p></div></div></div><h2 id=create-new-system-user>Create new system user</h2><p>Create a new user and group that will run our Mattermost instance. We will name the user <code>mattermost</code>:</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash>sudo useradd -U -M -d /opt/mattermost mattermost</code></pre></div><h2 id=install-mattermost-server>Install Mattermost Server</h2><p>At the time of the writing of this article the latest stable version of Mattermost is version 5.1.0. Download the archive with curl:</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash>sudo curl -L https://releases.mattermost.com/5.1.0/mattermost-5.1.0-linux-amd64.tar.gz -o /tmp/mattermost.tar.gz</code></pre></div><p>Once the download is complete extract the archive and move it to the <code>/opt</code> directory</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash>sudo tar zxf /tmp/mattermost.tar.gz -C /opt</code></pre></div><p>Create the storage directory for files:</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash>sudo mkdir -p /opt/mattermost/data</code></pre></div><p>Change the directory ownership to the <code>mattermost</code> user:</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash>sudo chown -R mattermost: /opt/mattermost</code></pre></div><p>Open the <code>/opt/mattermost/config/config.json</code> file, set the database driver to <code>mysql</code> and enter the database information:</p><div class=code-label>/opt/mattermost/config/config.json</div><div class=highlight><pre class=chroma><code class=language-json data-lang=json><span class=s2>"SqlSettings"</span><span class=err>:</span> <span class=p>{</span>
<span class=hl>    <span class=nt>"DriverName"</span><span class=p>:</span> <span class=s2>"mysql"</span><span class=p>,</span>
</span><span class=hl>    <span class=nt>"DataSource"</span><span class=p>:</span> <span class=s2>"mattermost:<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="1242266161646422605652667162">[email&#160;protected]</a>(localhost:3306)/mattermost?charset=utf8mb4,utf8&readTimeout=30s&writeTimeout=30s"</span><span class=p>,</span></span></code></pre></div><p>To make sure that our Mattermost instance works as expected we will test the Mattermost server. Change into the <code>/opt/mattermost</code> directory and start the server with the following commands:</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash><span class=nb>cd</span> /opt/mattermost
sudo -u mattermost bin/mattermost</code></pre></div><p>If everything works well, the server will start and the output will look something like this :</p><div class=highlight><pre class=chroma><code class=language-output data-lang=output>{"level":"info","ts":1532546921.941638,"caller":"app/server.go:115","msg":"Starting Server..."}
{"level":"info","ts":1532546921.9421031,"caller":"app/server.go:154","msg":"Server is listening on [::]:8065"}
{"level":"info","ts":1532546921.9541554,"caller":"app/web_hub.go:75","msg":"Starting 2 websocket hubs"}</code></pre></div><p>We can now stop the Mattermost server with <code>CTRL+C</code> and continue with the next steps.</p><div><small class=text-grey><small>Advertisement</small></small></div><div class="w-full flex justify-center content-center"><div class="w-full relative"><ins class=adsbygoogle data-ad-client=ca-pub-9439755881064125 data-ad-format=fluid data-ad-slot=5120214995 style=display:block data-ad-layout=in-article></ins></div></div><h2 id=create-a-systemd-unit>Create a Systemd unit</h2><p>In order to run our Mattermost instance as a service we will create a <code>mattermost.service</code> unit file in the <code>/etc/systemd/system/</code> directory.</p><p>Open your text editor and create the following file:</p><div class=code-label>/etc/systemd/system/mattermost.service</div><div class=highlight><pre class=chroma><code class=language-ini data-lang=ini><span class=k>[Unit]</span>
<span class=na>Description</span><span class=o>=</span><span class=s>Mattermost</span>
<span class=na>After</span><span class=o>=</span><span class=s>network.target</span>
<span class=na>After</span><span class=o>=</span><span class=s>mysql.service</span>
<span class=na>Requires</span><span class=o>=</span><span class=s>mysql.service</span>

<span class=k>[Service]</span>
<span class=na>Type</span><span class=o>=</span><span class=s>notify</span>
<span class=na>ExecStart</span><span class=o>=</span><span class=s>/opt/mattermost/bin/mattermost</span>
<span class=na>TimeoutStartSec</span><span class=o>=</span><span class=s>3600</span>
<span class=na>Restart</span><span class=o>=</span><span class=s>always</span>
<span class=na>RestartSec</span><span class=o>=</span><span class=s>10</span>
<span class=na>WorkingDirectory</span><span class=o>=</span><span class=s>/opt/mattermost</span>
<span class=na>User</span><span class=o>=</span><span class=s>mattermost</span>
<span class=na>Group</span><span class=o>=</span><span class=s>mattermost</span>
<span class=na>LimitNOFILE</span><span class=o>=</span><span class=s>49152</span>

<span class=k>[Install]</span>
<span class=na>WantedBy</span><span class=o>=</span><span class=s>mysql.service</span></code></pre></div><p>Notify systemd that we have created a new unit file and start the Mattermost service with the following commands:</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash>sudo systemctl daemon-reload
sudo systemctl start mattermost</code></pre></div><p>We can now check the service status with:</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash>sudo systemctl status mattermost</code></pre></div><div class=highlight><pre class=chroma><code class=language-output data-lang=output>● mattermost.service - Mattermost
   Loaded: loaded (/etc/systemd/system/mattermost.service; disabled; ven
   Active: active (running) since Wed 2018-07-25 18:39:05 UTC; 41s ago
 Main PID: 3091 (mattermost)
    Tasks: 18 (limit: 507)
   CGroup: /system.slice/mattermost.service
           ├─3091 /opt/mattermost/bin/mattermost</code></pre></div><p>If there are no errors, enable the Mattermost service to automatically start at boot time:</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash>sudo systemctl <span class=nb>enable</span> mattermost</code></pre></div><h2 id=set-up-a-reverse-proxy-with-nginx>Set up a reverse proxy with Nginx</h2><p>If you followed our <a href=/post/how-to-install-nginx-on-ubuntu-18-04/ >how to install Nginx on Ubuntu 18.04</a> and <a href=/post/secure-nginx-with-let-s-encrypt-on-ubuntu-18-04/ >how to secure Nginx with Let’s Encrypt on Ubuntu 18.04</a> guides you should already have Nginx installed and configured with SSL certificate.</p><p>Now we need to set up a new server block for the Mattermost instance. Open your text editor and create the following file:</p><div class=code-label>/etc/nginx/conf.d/example.com.conf</div><div class=highlight><pre class=chroma><code class=language-nginx data-lang=nginx><span class=k>proxy_cache_path</span> <span class=s>/var/cache/nginx</span> <span class=s>levels=1:2</span> <span class=s>keys_zone=mattermost_cache:10m</span> <span class=s>max_size=3g</span> <span class=s>inactive=120m</span> <span class=s>use_temp_path=off</span><span class=p>;</span>

<span class=k>upstream</span> <span class=s>mattermost_backend</span> <span class=p>{</span>
  <span class=kn>server</span> <span class=n>127.0.0.1</span><span class=p>:</span><span class=mi>8065</span><span class=p>;</span>
<span class=p>}</span>

<span class=k>server</span> <span class=p>{</span>
    <span class=kn>listen</span> <span class=mi>80</span><span class=p>;</span>
    <span class=kn>server_name</span> <span class=s>example.com</span> <span class=s>www.example.com</span><span class=p>;</span>

    <span class=kn>include</span> <span class=s>snippets/letsencrypt.conf</span><span class=p>;</span>
    <span class=kn>return</span> <span class=mi>301</span> <span class=s>https://example.com</span><span class=nv>$request_uri</span><span class=p>;</span>
<span class=p>}</span>

<span class=k>server</span> <span class=p>{</span>
    <span class=kn>listen</span> <span class=mi>443</span> <span class=s>ssl</span> <span class=s>http2</span><span class=p>;</span>
    <span class=kn>server_name</span> <span class=s>www.example.com</span><span class=p>;</span>

    <span class=kn>ssl_certificate</span> <span class=s>/etc/letsencrypt/live/example.com/fullchain.pem</span><span class=p>;</span>
    <span class=kn>ssl_certificate_key</span> <span class=s>/etc/letsencrypt/live/example.com/privkey.pem</span><span class=p>;</span>
    <span class=kn>ssl_trusted_certificate</span> <span class=s>/etc/letsencrypt/live/example.com/chain.pem</span><span class=p>;</span>
    <span class=kn>include</span> <span class=s>snippets/ssl.conf</span><span class=p>;</span>

    <span class=kn>return</span> <span class=mi>301</span> <span class=s>https://example.com</span><span class=nv>$request_uri</span><span class=p>;</span>
<span class=p>}</span>

<span class=k>server</span> <span class=p>{</span>
    <span class=kn>listen</span> <span class=mi>443</span> <span class=s>ssl</span> <span class=s>http2</span><span class=p>;</span>
    <span class=kn>server_name</span> <span class=s>example.com</span><span class=p>;</span>

    <span class=kn>ssl_certificate</span> <span class=s>/etc/letsencrypt/live/example.com/fullchain.pem</span><span class=p>;</span>
    <span class=kn>ssl_certificate_key</span> <span class=s>/etc/letsencrypt/live/example.com/privkey.pem</span><span class=p>;</span>
    <span class=kn>ssl_trusted_certificate</span> <span class=s>/etc/letsencrypt/live/example.com/chain.pem</span><span class=p>;</span>
    <span class=kn>include</span> <span class=s>snippets/ssl.conf</span><span class=p>;</span>

    <span class=kn>access_log</span> <span class=s>/var/log/nginx/example.com-access.log</span><span class=p>;</span>
    <span class=kn>error_log</span> <span class=s>/var/log/nginx/example.com-error.log</span><span class=p>;</span>

    <span class=kn>location</span> <span class=p>~</span> <span class=sr>/api/v[0-9]+/(users/)?websocket$</span> <span class=p>{</span>
       <span class=kn>proxy_set_header</span> <span class=s>Upgrade</span> <span class=nv>$http_upgrade</span><span class=p>;</span>
       <span class=kn>proxy_set_header</span> <span class=s>Connection</span> <span class=s>"upgrade"</span><span class=p>;</span>
       <span class=kn>client_max_body_size</span> <span class=s>50M</span><span class=p>;</span>
       <span class=kn>proxy_set_header</span> <span class=s>Host</span> <span class=nv>$http_host</span><span class=p>;</span>
       <span class=kn>proxy_set_header</span> <span class=s>X-Real-IP</span> <span class=nv>$remote_addr</span><span class=p>;</span>
       <span class=kn>proxy_set_header</span> <span class=s>X-Forwarded-For</span> <span class=nv>$proxy_add_x_forwarded_for</span><span class=p>;</span>
       <span class=kn>proxy_set_header</span> <span class=s>X-Forwarded-Proto</span> <span class=nv>$scheme</span><span class=p>;</span>
       <span class=kn>proxy_set_header</span> <span class=s>X-Frame-Options</span> <span class=s>SAMEORIGIN</span><span class=p>;</span>
       <span class=kn>proxy_buffers</span> <span class=mi>256</span> <span class=mi>16k</span><span class=p>;</span>
       <span class=kn>proxy_buffer_size</span> <span class=mi>16k</span><span class=p>;</span>
       <span class=kn>proxy_read_timeout</span> <span class=s>600s</span><span class=p>;</span>
       <span class=kn>proxy_pass</span> <span class=s>http://mattermost_backend</span><span class=p>;</span>
    <span class=p>}</span>

    <span class=kn>location</span> <span class=s>/</span> <span class=p>{</span>
       <span class=kn>proxy_http_version</span> <span class=mi>1</span><span class=s>.1</span><span class=p>;</span>
       <span class=kn>client_max_body_size</span> <span class=s>50M</span><span class=p>;</span>
       <span class=kn>proxy_set_header</span> <span class=s>Connection</span> <span class=s>""</span><span class=p>;</span>
       <span class=kn>proxy_set_header</span> <span class=s>Host</span> <span class=nv>$http_host</span><span class=p>;</span>
       <span class=kn>proxy_set_header</span> <span class=s>X-Real-IP</span> <span class=nv>$remote_addr</span><span class=p>;</span>
       <span class=kn>proxy_set_header</span> <span class=s>X-Forwarded-For</span> <span class=nv>$proxy_add_x_forwarded_for</span><span class=p>;</span>
       <span class=kn>proxy_set_header</span> <span class=s>X-Forwarded-Proto</span> <span class=nv>$scheme</span><span class=p>;</span>
       <span class=kn>proxy_set_header</span> <span class=s>X-Frame-Options</span> <span class=s>SAMEORIGIN</span><span class=p>;</span>
       <span class=kn>proxy_buffers</span> <span class=mi>256</span> <span class=mi>16k</span><span class=p>;</span>
       <span class=kn>proxy_buffer_size</span> <span class=mi>16k</span><span class=p>;</span>
       <span class=kn>proxy_read_timeout</span> <span class=s>600s</span><span class=p>;</span>
       <span class=kn>proxy_cache</span> <span class=s>mattermost_cache</span><span class=p>;</span>
       <span class=kn>proxy_cache_revalidate</span> <span class=no>on</span><span class=p>;</span>
       <span class=kn>proxy_cache_min_uses</span> <span class=mi>2</span><span class=p>;</span>
       <span class=kn>proxy_cache_use_stale</span> <span class=s>timeout</span><span class=p>;</span>
       <span class=kn>proxy_cache_lock</span> <span class=no>on</span><span class=p>;</span>
       <span class=kn>proxy_pass</span> <span class=s>http://mattermost_backend</span><span class=p>;</span>
    <span class=p>}</span>
<span class=p>}</span></code></pre></div><p>Reload the Nginx service for changes to take effect:</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash>sudo systemctl reload nginx</code></pre></div><h2 id=configuring-mattermost>Configuring Mattermost</h2><p>Open your browser, type your domain and you’ll be redirected to the sugnup page.</p><p>Enter your email, choose a username and password and click on the <code>Create Account</code> button to create your first account.</p><figure class=relative><div class="w-full mx-auto relative block my-0"><div class=block style=padding-bottom:83.12101910828025%></div><div class="w-full h-full absolute m-auto pin overflow-hidden text-center"><img alt="" class="" src=/post/how-to-deploy-mattermost-on-ubuntu-18-04/Mattermost-create-account.png data-action=zoom></div></div></figure><p>The first created user in the system will have administrator privileges.</p><p>In the next step the configuration wizard will ask you to create a new team.</p><figure class=relative><div class="w-full mx-auto relative block my-0"><div class=block style=padding-bottom:47.798066595059076%></div><div class="w-full h-full absolute m-auto pin overflow-hidden text-center"><img alt="" class="" src=/post/how-to-deploy-mattermost-on-ubuntu-18-04/Mattermost-create-team.png data-action=zoom></div></div></figure><p>Click on <code>Create a new team</code> link, enter your first team and click on the <code>Next</code> button.</p><figure class=relative><div class="w-full mx-auto relative block my-0"><div class=block style=padding-bottom:47.89029535864979%></div><div class="w-full h-full absolute m-auto pin overflow-hidden text-center"><img alt="" class="" src=/post/how-to-deploy-mattermost-on-ubuntu-18-04/Mattermost-team-name.png data-action=zoom></div></div></figure><p>In the next step you’ll be asked to choose the web address of your new team:</p><figure class=relative><div class="w-full mx-auto relative block my-0"><div class=block style=padding-bottom:60.33755274261603%></div><div class="w-full h-full absolute m-auto pin overflow-hidden text-center"><img alt="" class="" src=/post/how-to-deploy-mattermost-on-ubuntu-18-04/Mattermost-team-url.png data-action=zoom></div></div></figure><p>Click on the <code>Finish</code> button and you will be redirected to the Mattermost dashboard , logged in as an administrator.</p><figure class=relative><div class="w-full mx-auto relative block my-0"><div class=block style=padding-bottom:63.1578947368421%></div><div class="w-full h-full absolute m-auto pin overflow-hidden text-center"><img alt="" class="" src=/post/how-to-deploy-mattermost-on-ubuntu-18-04/Mattermost-dashboard.png data-action=zoom></div></div></figure><p>Open the System Console, by clicking on your username at the top of the navigation panel, and in the new menu that opens, click on the <code>System Console</code> link.</p><p>Set the site URL by going to Settings General → Configuration.</p><figure class=relative><div class="w-full mx-auto relative block my-0"><div class=block style=padding-bottom:40.788072417465386%></div><div class="w-full h-full absolute m-auto pin overflow-hidden text-center"><img alt="" class="" src=/post/how-to-deploy-mattermost-on-ubuntu-18-04/Mattermost-site-url.png data-action=zoom></div></div></figure><p>To enable email notifications go to Notifications → Email, change the <code>Enable Email Notifications</code> value from <code>false</code> to <code>true</code> and enter your SMTP parameters.</p><figure class=relative><div class="w-full mx-auto relative block my-0"><div class=block style=padding-bottom:32.97872340425532%></div><div class="w-full h-full absolute m-auto pin overflow-hidden text-center"><img alt="" class="" src=/post/how-to-deploy-mattermost-on-ubuntu-18-04/Mattermost-email-notifications.png data-action=zoom></div></div></figure><p>You can use any popular transactional email services such as SendinBlue, SendGrid, Amazon SES, Mandrill, Mailgun, Mailjet, and Postmark or you can set up your own mail server by following <a href=/series/setting-up-and-configuring-a-mail-server/ >this</a> tutorial.</p><p>Finally we need to restart the Mattermost service for changes to take effect:</p><div class=highlight><pre class=chroma><code class=language-bash data-lang=bash>sudo systemctl restart mattermost</code></pre></div><h2 id=conclusion>Conclusion</h2><p>You have successfully installed Mattermost on your Ubuntu 18.04 server and setup Nginx as a reverse proxy. You can now start using Mattermost to collaborate with your team.</p><p>If you are facing any problem with the installation, feel free to leave a comment.</p><div class="w-full flex justify-center content-center"><div class="w-full relative"><ins class="adsbygoogle mx-auto" data-ad-client=ca-pub-9439755881064125 data-ad-format=auto data-ad-slot=7027266996 style=display:block></ins></div></div><div class="flex flex-wrap mt-6"><a href=/tags/rocketchat class="bg-grey-lighter hover:bg-grey-light mr-2 mt-2 px-4 py-2 rounded text-grey-darker text-xs">rocketchat</a> <a href=/tags/nodejs class="bg-grey-lighter hover:bg-grey-light mr-2 mt-2 px-4 py-2 rounded text-grey-darker text-xs">nodejs</a> <a href=/tags/ubuntu class="bg-grey-lighter hover:bg-grey-light mr-2 mt-2 px-4 py-2 rounded text-grey-darker text-xs">ubuntu</a></div></section></article><section class="w-full mx-auto border-grey-lighter border-t mt-8 pt-8 max-w-article"><div class="bg-grey-lighter p-8 sm:py-16"><p class="text-center mx-auto lg:text-2xl max-w-md my-0 sm:text-xl text-lg">Sign up to our newsletter and get our latest tutorials and news straight to your mailbox.</p><form action="https://linuxize.us17.list-manage.com/subscribe/post?u=35cd4cd9d021c25c3dd7cabfd&id=9cfa4c89de" class=pt-8 id=mc-embedded-subscribe-form method=post name=mc-embedded-subscribe-form novalidate target=_blank><div class="w-full mx-auto flex items-center flex-col justify-between max-w-sm mb-2 sm:flex-row"><input class="w-full px-4 py-3 rounded appearance-none bg-white block border hover:border-grey-dark mb-3 sm:mb-0 text-grey-darker" name=EMAIL placeholder="Your email..." type=email> <input class=hidden name=b_35cd4cd9d021c25c3dd7cabfd_9cfa4c89de tabindex=-1> <button class="w-full px-4 py-3 rounded bg-blue hover:bg-blue-dark sm:ml-4 sm:w-auto text-white" name=subscribe type=submit><span class=text-center>Subscribe</span></button></div><p class="w-full mx-auto my-0 max-w-sm text-sm">We’ll never share your email address or spam you.</p></form></div></section><div class="w-full mx-auto border-grey-lighter border-t mt-8 pt-8 max-w-xl justify-center"><a href="https://shareasale.com/r.cfm?b=1144537&u=1755182&m=41388&urllink=&afftrack=" class="block mx-auto wp-engine"></a></div><section class="w-full mx-auto border-grey-lighter border-t mt-8 pt-8 max-w-xl"><div class="flex flex-wrap -mx-4"><a href=https://linuxize.com/post/how-to-deploy-rocket-chat-on-ubuntu-18-04/ class="w-full flex md:mb-0 md:w-1/3 overflow-hidden px-4 mb-8"><div class="w-full h-full flex flex-col"><p class="text-xs uppercase font-normal text-grey-dark">Jun 15, 2018</p><div class="font-normal flex-grow mb-2 md:mb-4 text-black text-lg">How to Deploy Rocket.Chat on Ubuntu 18.04</div><div><figure class=relative><div class="w-full mx-auto relative block my-0"><div class=block style=padding-bottom:53%></div><div class="w-full h-full absolute m-auto pin overflow-hidden bg-grey-lighter"><img alt="" class="w-full h-full absolute m-auto pin" src=/post/how-to-deploy-rocket-chat-on-ubuntu-18-04/featured.jpg></div></div></figure></div></div></a><a href=https://linuxize.com/post/how-to-deploy-mattermost-on-centos-7/ class="w-full flex md:mb-0 md:w-1/3 overflow-hidden px-4 mb-8"><div class="w-full h-full flex flex-col"><p class="text-xs uppercase font-normal text-grey-dark">Apr 21, 2018</p><div class="font-normal flex-grow mb-2 md:mb-4 text-black text-lg">How to deploy Mattermost on CentOS 7</div><div><figure class=relative><div class="w-full mx-auto relative block my-0"><div class=block style=padding-bottom:53%></div><div class="w-full h-full absolute m-auto pin overflow-hidden bg-grey-lighter"><img alt="" class="w-full h-full absolute m-auto pin" src=/post/how-to-deploy-mattermost-on-centos-7/featured.jpg></div></div></figure></div></div></a><a href=https://linuxize.com/post/how-to-deploy-rocket-chat-on-centos-7/ class="w-full flex md:mb-0 md:w-1/3 overflow-hidden px-4 mb-0"><div class="w-full h-full flex flex-col"><p class="text-xs uppercase font-normal text-grey-dark">Apr 10, 2018</p><div class="font-normal flex-grow mb-2 md:mb-4 text-black text-lg">How to deploy Rocket.Chat on CentOS 7</div><div><figure class=relative><div class="w-full mx-auto relative block my-0"><div class=block style=padding-bottom:53%></div><div class="w-full h-full absolute m-auto pin overflow-hidden bg-grey-lighter"><img alt="" class="w-full h-full absolute m-auto pin" src=/post/how-to-deploy-rocket-chat-on-centos-7/featured.jpg></div></div></figure></div></div></a></div></section><section class="w-full mx-auto relative border-grey-lighter border-t max-w-lg mt-8 pt-16 py-8"><a href=https://linuxize.com/post/how-to-deploy-mattermost-on-ubuntu-18-04/#disqus_thread class="w-full disqus-comment-count bg-grey-lighter block disqus-load md:py-8 py-4 text-center" title="Show comments for post">Write a comment</a><div id=disqus_thread></div><noscript>Please enable JavaScript to view the <a href=https://disqus.com/?ref_noscript>comments powered by Disqus.</a></noscript></section></main><section class="w-full absolute pin bg-white block h-screen invisible search z-50" hidden id=search><div class="flex flex-col min-h-screen"><header class="w-full mx-auto flex items-center h-12 sm:h-16 justify-end px-6 z-10"><a href=# class="block h-6 sm:h-8" id=btn-search-close><svg aria-hidden=true class="h-6 w-6 fill-current inline-block text-grey-darkest sm:h-8 sm:w-8 -mb-2"><use xlink:href=#close></use><title>Close search form</title></svg> <small class="block text-center sm:w-8 w-6">ESC</small></a></header><div class="w-full px-6 flex-grow flex-no-shrink pb-8 pt-16 sm:pt-24"><div class="flex flex-col mb-4 max-w-xl mb-8 mx-auto"><input class="w-full appearance-none bg-transparent focus:outline-0 font-medium md:text-3xl placeholder-grey-dark search-input sm:text-2xl text-grey-darkest text-xl" placeholder="Type to search" autocomplete=off id=search-input><div class=search-results id=search-results></div><div id=hits></div><div id=stats></div><footer class=mt-6><a href=https://algolia.com target=_blank rel="noopener noreferrer" tabindex=-1><svg aria-hidden=true class="inline-block fill-current search-algolia-logo text-grey-dark"><use xlink:href=#search-by-algolia></use><title>Search by Algolia</title></svg></a></footer></div></div></div></section><footer class="w-full px-6 bg-grey-lightest"><div class="w-full mx-auto flex items-center flex-wrap justify-center max-w-xl md:justify-between md:text-left py-8 text-center"><div class="w-full text-sm mb-2 md:mb-0 md:w-1/2"><div class="w-full md:flex block md:items-center md:w-auto"><div class=md:flex-grow><span class="block mb-2 md:inline-block md:mb-0 md:mr-8 text-grey-dark">© 2018 Linuxize.com</span> <a href=/privacy-policy/ class="inline-block text-grey-darkest footer-menu-item hover:text-grey-darker md:mt-0 no-underline mr-4">Privacy Policy </a><a href=/contact/ class="inline-block text-grey-darkest footer-menu-item hover:text-grey-darker md:mt-0 no-underline mr-0">Contact</a></div></div></div><div class="w-full flex justify-center md:justify-end md:w-1/2"><a href=https://twitter.com/linuxize class="block h-6 mr-2"><svg aria-hidden=true class="h-6 w-6 fill-current inline-block text-grey-darkest"><use xlink:href=#twitter></use><title>Twitter</title></svg> </a><a href=https://www.facebook.com/linuxize/ class="block h-6 mr-2"><svg aria-hidden=true class="h-6 w-6 fill-current inline-block text-grey-darkest"><use xlink:href=#facebook></use><title>Facebook</title></svg> </a><a href=/index.xml class="block h-6"><svg aria-hidden=true class="h-6 w-6 fill-current inline-block text-grey-darkest"><use xlink:href=#rss></use><title>RSS</title></svg></a></div></div></footer></div><script data-cfasync="false" src="/cdn-cgi/scripts/f2bf09f8/cloudflare-static/email-decode.min.js"></script><script src=https://cdnjs.cloudflare.com/ajax/libs/instantsearch.js/2.7.4/instantsearch.min.js></script><script src=/js/1.fc5bb285708b06e05ba5.js></script><script src=/js/app.11e3da0547ea66ce9d6c.js></script></body></html>