<!doctype html><html class=no-js lang=en-us><head><meta charset=utf-8>
<script data-cfasync='false' data-pagespeed-no-defer>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</script><script data-cfasync='false' data-pagespeed-no-defer>__ez.pel=function(){var z=[],i="/porpoiseant/army.gif";function t(e,i,t,d,_,o,n){if(__ez.dot.isDefined(e,e.getSlotElementId)){var a=parseInt(e.getTargeting("ap")[0]),r=function(e){var i=0;try{var t=e.getTargetingMap(),d=e.getSlotElementId();if(-1===d.indexOf("div-gpt-ad"))return i;if(void 0!==t)for(var _ in t)if(-1!==_.indexOf("iid")&&void 0!==t[_][0]){i=t[_][0];break}}catch(e){}return i}(e),s=e.getSlotElementId(),p=parseInt(e.getTargeting("compid")[0]),g=0,v=0;if("object"==typeof _ezim_d){var m=e.getAdUnitPath().split("/").pop();void 0!==_ezim_d[m]&&(void 0!==_ezim_d[m].creative_id&&(v=_ezim_d[m].creative_id),void 0!==_ezim_d[m].line_item_id&&(g=_ezim_d[m].line_item_id))}__ez.dot.isDefined(r,s)&&__ez.dot.isValid(i)&&z.push({type:"impression",impression_id:r,domain_id:__ez.dot.getDID(),unit:s,t_epoch:__ez.dot.getEpoch(0),revenue:t,est_revenue:d,ad_position:a,ad_size:"",bid_floor_filled:_,bid_floor_prev:o,stat_source_id:n,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:p,line_item_id:g,creative_id:v,data:__ez.dot.dataToStr(i)})}}function d(){if(void 0===document.visibilityState||"prerender"!==document.visibilityState){if(__ez.dot.isDefined(z)&&0<z.length){var e=__ez.dot.getURL(i)+"?orig="+(!0===__ez.template.isOrig?1:0)+"&sts="+btoa(JSON.stringify(z));void 0!==window.isAmp&&isAmp&&void 0!==window._ezaq&&_ezaq.hasOwnProperty("domain_id")&&(e+="&visit_uuid="+_ezaq.visit_uuid),(new Image).src=e}z=[]}}return{Add:t,AddAndFire:function(e,i){t(e,i,0,0,0,0,0),d()},AddById:function(e,i){var t=e.split("/");if(__ez.dot.isDefined(e)&&3===t.length&&__ez.dot.isValid(i)){var d=t[0],_=t[2];z.push({type:"impression",impression_id:_,domain_id:__ez.dot.getDID(),unit:d,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(i)})}},Fire:d}}();var EzoicPixel=function(){this.pixels=[],this.pixelUrl="/ezoic/e.gif",("undefined"!=typeof ezJsu&&!0===ezJsu||"undefined"!=typeof _ez_sa&&!0===_ez_sa||void 0!==window.isAmp&&!0===isAmp||"undefined"!=typeof ezWp&&!0===ezWp)&&(this.pixelUrl="//g.ezoic.net"+this.pixelUrl),this.tEpoch=0,"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("t_epoch")&&(this.tEpoch=_ezaq.t_epoch)},EzoicPixelData=function(i,e){this.name=i,this.val=e};EzoicPixel.prototype={constructor:EzoicPixel,AddAndFireImpPixel:function(i,e){this.AddImpPixel(i,e,0,0,0,0,0),this.FirePixels()},AddAndFirePVPixel:function(i,e){this.AddPVPixel(i,e),this.FirePixels()},AddImpPixel:function(i,e,t,n,o,a,r){if(this.isDefined(i,i.getSlotElementId)){var d=parseInt(i.getTargeting("ap")[0]),s=i.getSizes()[0],p=s.l.toString()+"x"+s.j.toString(),l="0",h="XX";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(l=_ezaq.domain_id.toString()),"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("country")&&(h=_ezaq.country);var f=this.getSlotIID(i),c=i.getSlotElementId();this.isDefined(f,c)&&this.validateData(e)&&(e=this.convertDataToStr(e),this.pixels.push({type:"impression",impression_id:f,domain_id:l,unit:c,t_epoch:this.tEpoch,revenue:t,est_revenue:n,ad_position:d,ad_size:p,bid_floor_filled:o,bid_floor_prev:a,stat_source_id:r,country_code:h,data:e}))}},AddImpPixelById:function(i,e){var t="0";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(t=_ezaq.domain_id.toString());var n=i.split("/");if(this.isDefined(i)&&3===n.length&&this.validateData(e)){var o=n[0],a=n[2];e=this.convertDataToStr(e),this.pixels.push({type:"impression",impression_id:a,domain_id:t,unit:o,t_epoch:this.tEpoch,data:e})}},AddPVPixel:function(i,e){var t="0";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(t=_ezaq.domain_id.toString()),this.isDefined(i)&&this.validateData(e)&&(e=this.convertDataToStr(e),this.pixels.push({type:"pageview",pageview_id:i,domain_id:t,t_epoch:this.tEpoch,data:e}))},FirePixels:function(){void 0!==document.visibilityState&&"prerender"===document.visibilityState||(this.isDefined(this.pixels)&&this.pixels.length>0&&((new Image).src=this.pixelUrl+"?orig="+(!0===__ez.template.isOrig?1:0)+"&pixels="+encodeURIComponent(JSON.stringify(this.pixels))),this.pixels=[])},NewData:function(i,e){return new EzoicPixelData(i,e)},convertDataToStr:function(i){if(void 0===i)return[];try{for(var e in i)i[e].val=i[e].val+""}catch(i){}return i},getSlotIID:function(i){var e=0;try{var t=i.getTargetingMap();if(-1===i.getSlotElementId().indexOf("div-gpt-ad"))return e;if(void 0!==t)for(var n in t)if(-1!==n.indexOf("iid")&&void 0!==t[n][0]){e=t[n][0];break}}catch(i){}return e},isDefined:function(){for(var i=0;i<arguments.length;i++)if(void 0===arguments[i]||null===arguments[i])return console.error("Argument not defined. ",arguments),!1;return!0},validateData:function(i){for(var e=0;e<i.length;e++)if(i[e]instanceof EzoicPixelData==!1)return console.error("Invalid pixelData. ",i[e]),!1;return!0}};</script><title>How to Install and Configure Samba on CentOS 7 | Linuxize</title><meta content="IE=edge" http-equiv=X-UA-Compatible><meta content="width=device-width,initial-scale=1,shrink-to-fit=no" name=viewport><meta content=Linuxize name=apple-mobile-web-app-title><meta content=Linuxize name=application-name><meta content=#2271ff name=theme-color><meta content=#2271ff name=msapplication-TileColor><meta content="In this tutorial we will show how to install Samba on CentOS 7 and configure it as a standalone server to provide file sharing across different operating systems over a network." name=description><meta content=unsafe-url name=referrer><link href=https://linuxize.com/post/how-to-install-and-configure-samba-on-centos-7/ rel=canonical><meta content="index, follow" name=robots><meta content="Hugo 0.54.0" name=generator><meta content="How to Install and Configure Samba on CentOS 7" property=og:title><meta content="In this tutorial we will show how to install Samba on CentOS 7 and configure it as a standalone server to provide file sharing across different operating systems over a network." property=og:description><meta content=article property=og:type><meta content=/post/how-to-install-and-configure-samba-on-centos-7/ property=og:url><meta content=https://linuxize.com/post/how-to-install-and-configure-samba-on-centos-7/featured.jpg property=og:image><meta content="In this tutorial we will show how to install Samba on CentOS 7 and configure it as a standalone server to provide file sharing across different operating systems over a network." property=og:image:alt><meta content=2019-02-27T20:24:10+01:00 property=article:published_time><meta content=2019-02-27T20:24:10+01:00 property=article:modified_time><meta content=en property=og:locale><meta content=post property=article:section><meta content=https://www.facebook.com/linuxize property=article:publisher><meta content=samba property=article:tag><meta content=centos property=article:tag><meta content=samba,centos name=news_keywords><meta content=summary_large_image name=twitter:card><meta content=https://linuxize.com/post/how-to-install-and-configure-samba-on-centos-7/featured.jpg name=twitter:image><meta content="How to Install and Configure Samba on CentOS 7" name=twitter:title><meta content="In this tutorial we will show how to install Samba on CentOS 7 and configure it as a standalone server to provide file sharing across different operating systems over a network." name=twitter:description><meta content=@linuxize name=twitter:site><link href=/favicons/apple-touch-icon.png rel=apple-touch-icon sizes=180x180><link href=/favicons/favicon-32x32.png rel=icon sizes=32x32 type=image/png><link href=/favicons/favicon-16x16.png rel=icon sizes=16x16 type=image/png><link href=/favicons/safari-pinned-tab.svg rel=mask-icon color=#2271ff><script type=application/ld+json>{
  "@context": "http://schema.org",
  "@type": "BlogPosting",
  "headline": "How to Install and Configure Samba on CentOS 7",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://linuxize.com/post/how-to-install-and-configure-samba-on-centos-7/"
  },"image": {
     "@type": "ImageObject",
     "url": "https://linuxize.com/post/how-to-install-and-configure-samba-on-centos-7/featured.jpg",
     "width": 1000,
     "height": 530
    },"keywords": "samba, centos",
  "wordcount": 1715,
  "url": "https://linuxize.com/post/how-to-install-and-configure-samba-on-centos-7/",
  "datePublished": "2019-02-27T20:24:10+01:00",
  "dateModified": "2019-02-27T20:24:10+01:00",
  "publisher": {
    "@type": "Organization","logo": {
    "@type": "imageObject",
      "url": "https://linuxize.com/assets/linuxize-card.png"
    },"name": "Linuxize"
  },

  "author": {
    "@type": "Person",
    "name": "Linuxize"
  },
  "description": "In this tutorial we will show how to install Samba on CentOS 7 and configure it as a standalone server to provide file sharing across different operating systems over a network."
}</script><script src=/js/ads.js></script><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-P827G6S');</script><script src=https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js async></script><script>(adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-9439755881064125",
          enable_page_level_ads: true
     });</script><meta content=#2271ff name=theme-color><link href=/manifest.79f739767e479131c04f7216cce1c084.json rel=manifest><link href="https://fonts.googleapis.com/css?family=IBM+Plex+Sans:300,400,400i,500,700%7CIBM+Plex+Serif:300,400,400i,600,600i" rel=stylesheet><link href=/css/app.721ba99e6cbf7ca307fc.css rel=stylesheet>
<script data-cfasync="false" type="text/javascript">window.google_analytics_uacct = "UA-124335151-13";</script>
<script data-cfasync="false" type="text/javascript">
var _gaq = _gaq || [];
_gaq.push(['e._setAccount', 'UA-124335151-13']);
_gaq.push(['f._setAccount', 'UA-38339005-1']);
_gaq.push(['e._setDomainName', 'linuxize.com']);
_gaq.push(['f._setDomainName', 'linuxize.com']);
_gaq.push(['e._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['e._setCustomVar',2,'t','126',3]);
_gaq.push(['e._setCustomVar',3,'rid','0',2]);
_gaq.push(['e._setCustomVar',4,'bra','mod54',3]);
_gaq.push(['e._setAllowAnchor',true]);
_gaq.push(['e._setSiteSpeedSampleRate', 10]);
_gaq.push(['f._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['f._setCustomVar',2,'domain','linuxize.com',3]);
_gaq.push(['f._setSiteSpeedSampleRate', 20]);
_gaq.push(['e._trackPageview']);
_gaq.push(['f._trackPageview']);


(function() {
 var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
 ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
 var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
})();
</script>
<script type="text/javascript">var ezouid = "1";</script><base href="https://linuxize.com/post/how-to-install-and-configure-samba-on-centos-7/"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script type='text/javascript'>
var soc_app_id = '0';
var did = 93605;
var ezdomain = 'linuxize.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":93605,"engaged_time_visit":0,"ezcache_level":1,"forensiq_score":-1,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"5c34ff03-255f-4542-5d1e-3d59c8c179ee","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_time_orig":6,"serverid":"52.201.213.56:6742","state":"VA","t_epoch":1551410105,"template_id":126,"time_on_site_visit":0,"url":"https://linuxize.com/post/how-to-install-and-configure-samba-on-centos-7/","user_id":0,"word_count":2021,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script><script data-cfasync='false' type="text/javascript" src="/detroitchicago/rochester.js?cb=182-0&v=8" async></script>
<script data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl() {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_93605=" + new Date().getTime() + "|5c34ff03-255f-4542-5d1e-3d59c8c179ee; " + expires, 3);
}
function attach_ezolpl() {
    if(window.attachEvent) {
        window.attachEvent('onload', create_ezolpl);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl();
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl;
        }
    }
}
attach_ezolpl();
</script></head><body class="font-sans kind-page leading-normal section-post text-black type-post"><div class="flex flex-col min-h-screen main-wrap"><header class="w-full px-6 z-10 bg-white border-b border-grey-light fixed linuxize-shadow" id=header><nav class="w-full mx-auto flex items-center h-12 sm:h-16 justify-start"><a href=/ class="block flex flex-no-shrink items-center mr-6 no-underline text-black" aria-label=Linuxize.com><svg aria-hidden=true class="h-6 w-6 fill-current sm:h-8 sm:w-8 mr-2"><use xlink:href=/svg/sprite.svg#logo></use><title>Linuxize</title></svg> <span class="font-medium hidden sm:block text-xl tracking-tight">Linuxize</span></a><div class="flex -mb-px flex-1 min-w-0 text-sm"><a href=/tags/ubuntu/ class="hover:text-grey-darkest hidden mr-4 no-underline sm:block text-grey-darker"><span class="inline-block font-bold md:py-6 py-3 sm:py-4">Ubuntu </span></a><a href=/tags/centos/ class="hover:text-grey-darkest hidden mr-4 no-underline sm:block text-grey-darker"><span class="inline-block font-bold md:py-6 py-3 sm:py-4">Centos </span></a><a href=/tags/debian/ class="hover:text-grey-darkest hidden mr-4 no-underline sm:block text-grey-darker"><span class="inline-block font-bold md:py-6 py-3 sm:py-4">Debian </span></a><a href=/tags/terminal/ class="hover:text-grey-darkest hidden mr-4 no-underline sm:block text-grey-darker"><span class="inline-block font-bold md:py-6 py-3 sm:py-4">Linux Commands </span></a><a href=/series/ class="hover:text-grey-darkest hidden mr-4 no-underline sm:block text-grey-darker mr-0"><span class="inline-block font-bold md:py-6 py-3 sm:py-4">Series</span></a></div><div class="flex justify-end"><button class="block h-6 sm:h-8" aria-label=Search id=btn-search><svg aria-hidden=true class="h-6 w-6 fill-current inline-block text-grey-darkest sm:h-8 sm:w-8"><use xlink:href=/svg/sprite.svg#search></use><title>Search</title></svg></button></div></nav></header><main class="w-full flex-grow flex-no-shrink pb-8 pt-16 sm:pt-24 main"><article class="relative single-post"><div class="w-full mx-auto px-6 max-w-screen-2xl"><div class="mb-6 lg:ml-0 lg:mr-auto lg:pr-6 max-w-lg mx-auto xl:max-w-full xl:mx-0 xl:pr-8"><div class="flex mb-2 flex-col font-medium md:flex-row text-xs uppercase"><div class=inline-flex><time class="" datetime=2019-02-27T20:24:10+01:00>February 27, 2019 </time><span class=mx-2>•</span><p>Read in 9 minutes</p></div><span class="hidden md:block mx-2">|</span><p class="font-medium leading-normal rounded-sm text-xs uppercase">last updated  <time class="" datetime=2019-02-27T20:24:10+01:00>February 27, 2019</time></p></div><div class=post-header><h1 class="mb-4 font-bold leading-none lg:text-3xl text-2xl text-black xl:mb-8 xxl:text-4xl">How to Install and Configure Samba on CentOS 7</h1></div></div><div class=lg:flex><div class="w-full lg:max-h-full lg:overflow-visible lg:static min-h-screen"><div class=flex><div class="w-full pb-8"><div class="flex flex-col xl:flex-relative xl:flex-row"><aside class="w-full block lg:hidden sidebar2 xl:block" id=sidebar2><div class="w-full flex justify-center content-center"><div class="w-full relative"><ins class="hidden adsbygoogle mx-auto sidebar2-as xl:block" data-ad-client=ca-pub-9439755881064125 data-ad-format=horizontal,rectangle data-ad-slot=4501323511 style=display:block data-full-width-responsive=true></ins></div></div><div class="hidden flex-col justify-between xl:flex distro-versions"><div class="mb-6 p-4 pb-2 toc bg-blue"><p class="font-medium mb-3 text-xs tracking-tight uppercase xxl:text-sm text-white">This tutorial is also available for</p><div class="w-full distro-versions flex-wrap inline-flex items-center mb-4"><a href=/post/how-to-install-and-configure-samba-on-ubuntu-18-04/ class="w-full mb-2 bg-blue-dark capitalize font-medium hover:bg-blue-darkest leading-normal px-3 py-1 rounded-sm text-center text-white text-xs xxl:mr-2 xxl:text-sm">ubuntu 18.04</a></div></div></div><div class="w-full -mt-12 flex-col hidden justify-between pb-4 pt-12 sticky top-16 xl:flex"><div class="bg-grey-lighter mb-6 p-4 pb-2 table-of-contents toc"><p class="font-medium mb-3 mb-3 text-xs tracking-tight uppercase xxl:text-sm text-grey-darker">Contents</p><nav id=TableOfContents><ul><li><ul><li><a href=#prerequisites>Prerequisites</a></li><li><a href=#installing-samba-on-centos>Installing Samba on CentOS</a></li><li><a href=#configuring-firewall>Configuring Firewall</a></li><li><a href=#creating-samba-users-and-directory-structure>Creating Samba Users and Directory Structure</a><ul><li><a href=#creating-samba-users>Creating Samba Users</a></li></ul></li><li><a href=#configuring-samba-shares>Configuring Samba Shares</a></li><li><a href=#connecting-to-a-samba-share-from-linux>Connecting to a Samba Share from Linux</a><ul><li><a href=#using-the-smbclient-client>Using the smbclient client</a></li><li><a href=#mounting-the-samba-share>Mounting the Samba share</a></li><li><a href=#using-gui>Using GUI</a></li></ul></li><li><a href=#connecting-to-a-samba-share-from-macos>Connecting to a Samba Share from macOS</a></li><li><a href=#connecting-to-a-samba-share-from-windows>Connecting to a Samba Share from Windows</a></li><li><a href=#conclusion>Conclusion</a></li></ul></li></ul></nav><p class="font-medium mb-3 mb-3 text-xs tracking-tight uppercase xxl:text-sm border-grey-light border-t mt-4 pt-4">Share</p><section class="w-full mx-auto"><nav class="flex flex-wrap"><a href="https://twitter.com/share?text=How%20to%20Install%20and%20Configure%20Samba%20on%20CentOS%207&url=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-install-and-configure-samba-on-centos-7%2f" class="h-6 w-6 mb-4 mr-3" rel=noopener target=_blank><svg aria-hidden=true class="h-6 w-6 fill-current inline-block hover:text-blue text-gray-light"><use xlink:href=/svg/sprite.svg#twitter></use><title>Share on Twitter</title></svg> </a><a href="https://www.facebook.com/sharer/sharer.php?caption=How%20to%20Install%20and%20Configure%20Samba%20on%20CentOS%207&u=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-install-and-configure-samba-on-centos-7%2f" class="h-6 w-6 mb-4 mr-3" rel=noopener target=_blank><svg aria-hidden=true class="h-6 w-6 fill-current inline-block hover:text-blue text-gray-light"><use xlink:href=/svg/sprite.svg#facebook></use><title>Share on Facebook</title></svg> </a><a href="https://pinterest.com/pin/create/button/?url=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-install-and-configure-samba-on-centos-7%2f&media=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-install-and-configure-samba-on-centos-7%2ffeatured.jpg&description=How%20to%20Install%20and%20Configure%20Samba%20on%20CentOS%207" class="h-6 w-6 mb-4 mr-3" rel=noopener target=_blank><svg aria-hidden=true class="h-6 w-6 fill-current inline-block hover:text-blue text-gray-light"><use xlink:href=/svg/sprite.svg#pinterest></use><title>Share on Pinterest</title></svg> </a><a href="https://plus.google.com/share?url=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-install-and-configure-samba-on-centos-7%2f" class="h-6 w-6 mb-4 mr-3" rel=noopener target=_blank><svg aria-hidden=true class="h-6 w-6 fill-current inline-block hover:text-blue text-gray-light"><use xlink:href=/svg/sprite.svg#gplus></use><title>Share on Google Plus</title></svg> </a><a href="https://news.ycombinator.com/submitlink?t=How%20to%20Install%20and%20Configure%20Samba%20on%20CentOS%207&u=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-install-and-configure-samba-on-centos-7%2f" class="h-6 w-6 mb-4 mr-3" rel=noopener target=_blank><svg aria-hidden=true class="h-6 w-6 fill-current inline-block hover:text-blue text-gray-light"><use xlink:href=/svg/sprite.svg#hacker-news></use><title>Submit to Hacker News</title></svg> </a><a href="/cdn-cgi/l/email-protection#27185452454d4244531a6f485002151753480215176e495453464b4b021517464943021517644849414e4052554202151774464a4546021517484902151764424953687402151710014548435e1a644f42444c021517485253021517534f4e540215174655534e444b421d0217660217664f535357540214460215410215414b4e49525f4e5d420944484a021541574854530215414f48500a53480a4e495453464b4b0a4649430a444849414e405255420a54464a45460a48490a4442495348540a10021541" class="h-6 w-6 mb-4" rel=noopener target=_blank><svg aria-hidden=true class="h-6 w-6 fill-current inline-block hover:text-blue text-gray-light"><use xlink:href=/svg/sprite.svg#email></use><title>Share with Email</title></svg></a></nav></section></div></div></aside><section class="w-full mx-auto lg:ml-0 lg:mr-auto lg:pr-6 min-w-0 xl:mx-0 xl:px-8 xl:w-full"><figure class="relative -mx-6 lg:mx-0 mb-6"><div class="w-full mx-auto my-0 block relative"><div class=block style=padding-bottom:53%></div><div class="w-full h-full absolute m-auto pin overflow-hidden bg-grey-lighter"><img class="w-full h-full absolute m-auto pin lazy lazyload" src="data:image/gif;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAYAAAAfFcSJAAAADUlEQVR42mP8+PXHfwAJnAPfCuZXlQAAAABJRU5ErkJggg==" alt="" data-sizes=auto data-src=/post/how-to-install-and-configure-samba-on-centos-7/featured_hu890bd9f8cec090937392e0645cbbd804_76797_600x0_resize_q95_box.jpg data-srcset="
              /post/how-to-install-and-configure-samba-on-centos-7/featured_hu890bd9f8cec090937392e0645cbbd804_76797_600x0_resize_q95_box.jpg 600w,
              /post/how-to-install-and-configure-samba-on-centos-7/featured.jpg 1000w
            "><noscript><img class="w-full h-full absolute m-auto pin" src=/post/how-to-install-and-configure-samba-on-centos-7/featured.jpg></noscript></div></div></figure><div class=markdown><p>Samba is a free and open-source re-implementation of the <a href=https://docs.microsoft.com/en-us/windows/desktop/FileIO/microsoft-smb-protocol-and-cifs-protocol-overview>SMB/CIFS network file sharing protocol</a> that allows end users to access files, printers, and other shared resources.</p><p>In this tutorial, we will show how to install Samba on CentOS 7 and configure it as a standalone server to provide file sharing across different operating systems over a network.</p><p>We’ll create the following Samba shares and users.</p><p>Users:</p><ul><li><strong>sadmin</strong> - An administrative user with read and write access to all shares.</li><li><strong>josh</strong> - A regular user with its own private file share.</li></ul><p>Shares:</p><ul><li><strong>users</strong> - This share will be accessible with read/write permissions by all users.</li><li><strong>josh</strong> - This share will be accessible with read/write permissions only by users josh and sadmin.</li></ul><p>The file shares will be accessible from all devices on your network. Later in the tutorial, we will also provide detailed instructions on how to connect to the Samba server from Linux, Windows and macOS clients.</p><h2 id=prerequisites>Prerequisites</h2><p>Before you begin, make sure you are logged in to your CentOS 7 system as a <a href=/post/create-a-sudo-user-on-centos/ >user with sudo privileges</a>.</p><h2 id=installing-samba-on-centos>Installing Samba on CentOS</h2><p>Samba is available from the standard CentOS repositories. To install it on your CentOS system run the following command:</p><div class=highlight><pre class=chroma><code class=language-console-bash data-lang=console-bash>sudo yum install samba samba-client</code></pre></div><p>Once the installation is completed, start the Samba services and enable them to start automatically on system boot:</p><div class=highlight><pre class=chroma><code class=language-console-bash data-lang=console-bash>sudo systemctl start smb.service
sudo systemctl start nmb.service</code></pre></div><div class=highlight><pre class=chroma><code class=language-console-bash data-lang=console-bash>sudo systemctl enable smb.service
sudo systemctl enable nmb.service</code></pre></div><p>The <code>smbd</code> service provides file sharing and printing services and listens on TCP ports 139 and 445. The <code>nmbd</code> service provides NetBIOS over IP naming services to clients and listens on UDP port 137.</p><h2 id=configuring-firewall>Configuring Firewall</h2><p>Now that Samba is installed and running on your CentOS machine, you’ll need to [configure your firewall](/post/how-to-setup-a-firewall-with-firewalld-on-centos-7/ and open the necessary ports. To do so, run the following commands:</p><div class=highlight><pre class=chroma><code class=language-console-bash data-lang=console-bash>firewall-cmd --permanent --zone=public --add-service=samba
firewall-cmd --zone=public --add-service=samba</code></pre></div><div class="w-full flex justify-center content-center"><div class="w-full relative"><ins class=adsbygoogle data-ad-client=ca-pub-9439755881064125 data-ad-format=fluid data-ad-slot=5120214995 style=display:block data-ad-layout=in-article></ins></div></div><h2 id=creating-samba-users-and-directory-structure>Creating Samba Users and Directory Structure</h2><p>For easier maintainability and flexibility instead of using the standard home directories (<code>/home/user</code>) all Samba directories and data will be located in the <code>/samba</code> directory.</p><p>Start by creating the <code>/samba</code> directory:</p><div class=highlight><pre class=chroma><code class=language-console-bash data-lang=console-bash>sudo mkdir /samba</code></pre></div><p>Create a new group named <code>sambashare</code>. Later we will add all Samba users to this group.</p><div class=highlight><pre class=chroma><code class=language-console-bash data-lang=console-bash>sudo groupadd sambashare </code></pre></div><p>Set the <code>/samba</code> directory group ownership to <code>sambashare</code>:</p><div class=highlight><pre class=chroma><code class=language-console-bash data-lang=console-bash>sudo chgrp sambashare /samba</code></pre></div><p>Samba uses Linux users and group permission system but it has its own authentication mechanism separate from the standard Linux authentication. We will create the users using the standard Linux <code>useradd</code> tool and then set the user password with the <code>smbpasswd</code> utility.</p><p>As we mentioned in the introduction, we’ll <a href=/post/how-to-create-users-in-linux-using-the-useradd-command/ >create a regular user</a> that will have access to its private file share and one administrative account with read and write access to all shares on the Samba server.</p><h3 id=creating-samba-users>Creating Samba Users</h3><p>To create a new user named <code>josh</code>, use the following command:</p><div class=highlight><pre class=chroma><code class=language-console-bash data-lang=console-bash>sudo useradd -M -d /samba/josh -s /usr/sbin/nologin -G sambashare josh</code></pre></div><p>The <code>useradd</code> options have the following meanings:</p><ul><li><code>-M</code> -do not create the user’s home directory. We’ll manually create this directory.</li><li><code>-d /samba/josh</code> - set the user’s home directory to <code>/samba/josh</code>.</li><li><code>-s /usr/sbin/nologin</code> - disable shell access for this user.</li><li><code>-G sambashare</code> - add the user to the <code>sambashare</code> group.</li></ul><p><a href=/post/how-to-create-directories-in-linux-with-the-mkdir-command/ >Create the user’s home directory</a> and set the directory ownership to user <code>josh</code> and group <code>sambashare</code>:</p><div class=highlight><pre class=chroma><code class=language-console-bash data-lang=console-bash>sudo mkdir /samba/josh
sudo chown josh:sambashare /samba/josh</code></pre></div><p>The following command will add the setgid bit to the <code>/samba/josh</code> directory so the newly created files in this directory will inherit the group of the parent directory. This way, no matter which user creates a new file, the file will have group-owner of <code>sambashare</code>. For example, if you don’t set the directory’s permissions to <code>2770</code> and the <code>sadmin</code> user creates a new file the user <code>josh</code> will not be able to read/write to this file.</p><div class=highlight><pre class=chroma><code class=language-console-bash data-lang=console-bash>sudo chmod 2770 /samba/josh</code></pre></div><p>Add the <code>josh</code> user account to the Samba database by setting the user password:</p><div class=highlight><pre class=chroma><code class=language-console-bash data-lang=console-bash>sudo smbpasswd -a josh</code></pre></div><p>You will be prompted to enter and confirm the user password.</p><div class=highlight><pre class=chroma><code class=language-output data-lang=output>New SMB password:
Retype new SMB password:
Added user josh.</code></pre></div><p>Once the password is set, enable the Samba account by typing:</p><div class=highlight><pre class=chroma><code class=language-console-bash data-lang=console-bash>sudo smbpasswd -e josh</code></pre></div><div class=highlight><pre class=chroma><code class=language-output data-lang=output>Enabled user josh.</code></pre></div><p>To create another user repeat the same process as when creating the user <code>josh</code>.</p><p>Next, let’s create a user and group <code>sadmin</code>. All members of this group will have administrative permissions. Later if you want to grant administrative permissions to another user simply <a href=/post/how-to-add-user-to-group-in-linux/ >add that user to the <code>sadmin</code> group</a>.</p><p>Create the administrative user by typing:</p><div class=highlight><pre class=chroma><code class=language-console-bash data-lang=console-bash>sudo useradd -M -d /samba/users -s /usr/sbin/nologin -G sambashare sadmin</code></pre></div><p>The command above will also create a group <code>sadmin</code> and add the user to both <code>sadmin</code> and <code>sambashare</code> groups.</p><p>Set a password and enable the user:</p><div class=highlight><pre class=chroma><code class=language-console-bash data-lang=console-bash>sudo smbpasswd -a sadmin
sudo smbpasswd -e sadmin</code></pre></div><p>Next, create the <code>Users</code> share directory:</p><div class=highlight><pre class=chroma><code class=language-console-bash data-lang=console-bash>sudo mkdir /samba/users</code></pre></div><p><a href=/post/linux-chown-command/ >Set the directory ownership</a> to user <code>sadmin</code> and group <code>sambashare</code>:</p><div class=highlight><pre class=chroma><code class=language-console-bash data-lang=console-bash>sudo chown sadmin:sambashare /samba/users</code></pre></div><p>This directory will be accessible by all authenticated users. The following command configures write/read access to members of the <code>sambashare</code> group in the <code>/samba/users</code> directory:</p><div class=highlight><pre class=chroma><code class=language-console-bash data-lang=console-bash>sudo chmod 2770 /samba/users</code></pre></div><h2 id=configuring-samba-shares>Configuring Samba Shares</h2><p>Open the Samba configuration file and append the sections:</p><div class=highlight><pre class=chroma><code class=language-console-bash data-lang=console-bash>sudo nano /etc/samba/smb.conf</code></pre></div><div class=code-label>/etc/samba/smb.conf</div><div class=highlight><pre class=chroma><code class=language-config data-lang=config>[users]
    path = /samba/users
    browseable = yes
    read only = no
    force create mode = 0660
    force directory mode = 2770
    valid users = @sambashare @sadmin

[josh]
    path = /samba/josh
    browseable = no
    read only = no
    force create mode = 0660
    force directory mode = 2770
    valid users = josh @sadmin</code></pre></div><p>The options have the following meanings:</p><ul><li><code>[users]</code> and <code>[josh]</code> - The names of the shares that you will use when logging in.</li><li><code>path</code> - The path to the share.</li><li><code>browseable</code> - Whether the share should be listed in the available shares list. By setting to <code>no</code> other users will not be able to see the share.</li><li><code>read only</code> - Whether the users specified in the <code>valid users</code> list are able to write to this share.</li><li><code>force create mode</code> - Sets the permissions for the newly created files in this share.</li><li><code>force directory mode</code> - Sets the permissions for the newly created directories in this share.</li><li><code>valid users</code> - A list of users and groups that are allowed to access the share. Groups are prefixed with the <code>@</code> symbol.<br></li></ul><p>For more information about available options see the <a href=https://www.samba.org/samba/docs/current/man-html/smb.conf.5.html>Samba configuration file</a> documentation page.</p><p>Once done, restart the Samba services with:</p><div class=highlight><pre class=chroma><code class=language-console-bash data-lang=console-bash>sudo systemctl restart smb.service
sudo systemctl restart nmb.service</code></pre></div><p>In the following sections, we will show you how to connect to a Samba share from Linux, macOS and Windows clients.</p><h2 id=connecting-to-a-samba-share-from-linux>Connecting to a Samba Share from Linux</h2><p>Linux users can access the samba share from the command line, using the file manager or mount the Samba share.</p><h3 id=using-the-smbclient-client>Using the smbclient client</h3><p><code>smbclient</code> is a tool that allows you to access Samba from the command line. The <code>smbclient</code> package is not pre-installed on most Linux distros so you will need to install it with your distribution package manager.</p><p>To install <code>smbclient</code> on Ubuntu and Debian run:</p><div class=highlight><pre class=chroma><code class=language-console-bash data-lang=console-bash>sudo apt install smbclient</code></pre></div><p>To install <code>smbclient</code> on CentOS and Fedora run:</p><div class=highlight><pre class=chroma><code class=language-console-bash data-lang=console-bash>sudo yum install samba-client</code></pre></div><p>The syntax to access a Samba share is as follows:</p><div class=highlight><pre class=chroma><code class=language-console-bash data-lang=console-bash>mbclient //samba_hostname_or_server_ip/share_name -U username</code></pre></div><p>For example to connect to a share named <code>josh</code> on a Samba server with IP address <code>192.168.121.118</code> as user <code>josh</code> you would run:</p><div class=highlight><pre class=chroma><code class=language-console-bash data-lang=console-bash>smbclient //192.168.121.118/josh -U josh</code></pre></div><p>You will be prompted to enter the user password.</p><div class=highlight><pre class=chroma><code class=language-output data-lang=output>Enter WORKGROUP\josh's password:</code></pre></div><p>Once you enter the password you will be logged into the Samba command line interface.</p><div class=highlight><pre class=chroma><code class=language-output data-lang=output>Try "help" to get a list of possible commands.
smb: \></code></pre></div><h3 id=mounting-the-samba-share>Mounting the Samba share</h3><p>To <a href=/post/how-to-mount-and-unmount-file-systems-in-linux/ >mount</a> a Samba share on Linux first you need to install the <code>cifs-utils</code> package.</p><p>On Ubuntu and Debian run:</p><div class=highlight><pre class=chroma><code class=language-console-bash data-lang=console-bash>sudo apt install cifs-utils</code></pre></div><p>On CentOS and Fedora run:</p><div class=highlight><pre class=chroma><code class=language-console-bash data-lang=console-bash>sudo yum install cifs-utils</code></pre></div><p>Next, create a mount point:</p><div class=highlight><pre class=chroma><code class=language-console-bash data-lang=console-bash>sudo mkdir /mnt/smbmount</code></pre></div><p>Mount the share using the following command:</p><div class=highlight><pre class=chroma><code class=language-console-bash data-lang=console-bash>sudo mount -t cifs -o username=username //samba_hostname_or_server_ip/sharename /mnt/smbmount</code></pre></div><p>For example to mount a share named <code>josh</code> on a Samba server with IP address <code>192.168.121.118</code> as user <code>josh</code> to the <code>/mnt/smbmount</code> mount point you would run:</p><div class=highlight><pre class=chroma><code class=language-console-bash data-lang=console-bash>sudo mount -t cifs -o username=josh //192.168.121.118/josh /mnt/smbmount</code></pre></div><p>You will be prompted to enter the user password.</p><div class=highlight><pre class=chroma><code class=language-output data-lang=output>Password for <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="ec86839f84ac">[email&#160;protected]</a>//192.168.121.118/josh:  ********</code></pre></div><h3 id=using-gui>Using GUI</h3><p>Files, the default file manager in Gnome has a built-in option to access Samba shares.</p><ol><li>Open Files and click on “Other Locations” in the sidebar.</li><li>In “Connect to Server”, enter the address of the Samba share in the following format <code>smb://samba_hostname_or_server_ip/sharename</code>.</li><li>Click “Connect” and the following screen will appear:<figure class=relative><div class="w-full mx-auto my-0 block relative"><div class=block style=padding-bottom:75%></div><div class="w-full h-full absolute m-auto pin overflow-hidden text-center"><img class=lazyload src="data:image/gif;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAYAAAAfFcSJAAAADUlEQVR42mP8+PXHfwAJnAPfCuZXlQAAAABJRU5ErkJggg==" alt="" data-sizes=auto data-src=/post/how-to-install-and-configure-samba-on-centos-7/gnome-samba-login_hubf92fbd18c09780f23c3a9b1908727ae_85917_600x0_resize_q75_box.jpg data-srcset="
              /post/how-to-install-and-configure-samba-on-centos-7/gnome-samba-login_hubf92fbd18c09780f23c3a9b1908727ae_85917_600x0_resize_q75_box.jpg 600w,
              /post/how-to-install-and-configure-samba-on-centos-7/gnome-samba-login.jpg 1024w
            " data-action=zoom><noscript><img class="w-full h-full absolute m-auto pin" src=/post/how-to-install-and-configure-samba-on-centos-7/gnome-samba-login.jpg></noscript></div></div></figure></li><li>Select “Registered User”, enter the Samba username and password and click “Connect”.</li><li>The files on the Samba server will be shown.<figure class=relative><div class="w-full mx-auto my-0 block relative"><div class=block style=padding-bottom:75%></div><div class="w-full h-full absolute m-auto pin overflow-hidden text-center"><img class=lazyload src="data:image/gif;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAYAAAAfFcSJAAAADUlEQVR42mP8+PXHfwAJnAPfCuZXlQAAAABJRU5ErkJggg==" alt="" data-sizes=auto data-src=/post/how-to-install-and-configure-samba-on-centos-7/gnome-samba-files_hubc8b0e02bf793ee19957a1e05433b1c5_59671_600x0_resize_q75_box.jpg data-srcset="
              /post/how-to-install-and-configure-samba-on-centos-7/gnome-samba-files_hubc8b0e02bf793ee19957a1e05433b1c5_59671_600x0_resize_q75_box.jpg 600w,
              /post/how-to-install-and-configure-samba-on-centos-7/gnome-samba-files.jpg 1024w
            " data-action=zoom><noscript><img class="w-full h-full absolute m-auto pin" src=/post/how-to-install-and-configure-samba-on-centos-7/gnome-samba-files.jpg></noscript></div></div></figure></li></ol><h2 id=connecting-to-a-samba-share-from-macos>Connecting to a Samba Share from macOS</h2><p>In macOS, you can access the Samba Shares either from the command line or using the default macOS file manager Finder. The following steps show how to access the share using Finder.</p><ol><li>Open “Finder”, select “Go” and click “Connect To”.</li><li>In “Connect To”, enter the address of the Samba share in the following format <code>smb://samba_hostname_or_server_ip/sharename</code>.<figure class=relative><div class="w-full mx-auto my-0 block relative"><div class=block style=padding-bottom:75%></div><div class="w-full h-full absolute m-auto pin overflow-hidden text-center"><img class=lazyload src="data:image/gif;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAYAAAAfFcSJAAAADUlEQVR42mP8+PXHfwAJnAPfCuZXlQAAAABJRU5ErkJggg==" alt="" data-sizes=auto data-src=/post/how-to-install-and-configure-samba-on-centos-7/macos-samba-connect_huf8ecd2dfcdd6424e0ccf1866243a8518_136879_600x0_resize_q75_box.jpg data-srcset="
              /post/how-to-install-and-configure-samba-on-centos-7/macos-samba-connect_huf8ecd2dfcdd6424e0ccf1866243a8518_136879_600x0_resize_q75_box.jpg 600w,
              /post/how-to-install-and-configure-samba-on-centos-7/macos-samba-connect.jpg 1024w
            " data-action=zoom><noscript><img class="w-full h-full absolute m-auto pin" src=/post/how-to-install-and-configure-samba-on-centos-7/macos-samba-connect.jpg></noscript></div></div></figure></li><li>Click “Connect” and the following screen will appear:<figure class=relative><div class="w-full mx-auto my-0 block relative"><div class=block style=padding-bottom:75%></div><div class="w-full h-full absolute m-auto pin overflow-hidden text-center"><img class=lazyload src="data:image/gif;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAYAAAAfFcSJAAAADUlEQVR42mP8+PXHfwAJnAPfCuZXlQAAAABJRU5ErkJggg==" alt="" data-sizes=auto data-src=/post/how-to-install-and-configure-samba-on-centos-7/macos-samba-login_hu08e65ee437a6e9bbf2c8064fc101a474_143269_600x0_resize_q75_box.jpg data-srcset="
              /post/how-to-install-and-configure-samba-on-centos-7/macos-samba-login_hu08e65ee437a6e9bbf2c8064fc101a474_143269_600x0_resize_q75_box.jpg 600w,
              /post/how-to-install-and-configure-samba-on-centos-7/macos-samba-login.jpg 1024w
            " data-action=zoom><noscript><img class="w-full h-full absolute m-auto pin" src=/post/how-to-install-and-configure-samba-on-centos-7/macos-samba-login.jpg></noscript></div></div></figure></li><li>Select “Registered User”, enter the Samba username and password and click “Connect”.</li><li>The files on the Samba server will be shown.<figure class=relative><div class="w-full mx-auto my-0 block relative"><div class=block style=padding-bottom:75%></div><div class="w-full h-full absolute m-auto pin overflow-hidden text-center"><img class=lazyload src="data:image/gif;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAYAAAAfFcSJAAAADUlEQVR42mP8+PXHfwAJnAPfCuZXlQAAAABJRU5ErkJggg==" alt="" data-sizes=auto data-src=/post/how-to-install-and-configure-samba-on-centos-7/macos-samba-files_hu57ff4d2e475b5fefa69ba38041de24f1_123599_600x0_resize_q75_box.jpg data-srcset="
              /post/how-to-install-and-configure-samba-on-centos-7/macos-samba-files_hu57ff4d2e475b5fefa69ba38041de24f1_123599_600x0_resize_q75_box.jpg 600w,
              /post/how-to-install-and-configure-samba-on-centos-7/macos-samba-files.jpg 1024w
            " data-action=zoom><noscript><img class="w-full h-full absolute m-auto pin" src=/post/how-to-install-and-configure-samba-on-centos-7/macos-samba-files.jpg></noscript></div></div></figure></li></ol><h2 id=connecting-to-a-samba-share-from-windows>Connecting to a Samba Share from Windows</h2><p>Windows users also have an option to connect to the Samba share from both command line and GUI. The steps below show how to access the share using the Windows File Explorer.</p><ol><li>Open up File Explorer and in the left pane right-click on “This PC”.</li><li>Select “Choose a custom network location” and then click “Next”.</li><li>In “Internet or network address”, enter the address of the Samba share in the following format <code>\\samba_hostname_or_server_ip\sharename</code>.<figure class=relative><div class="w-full mx-auto my-0 block relative"><div class=block style=padding-bottom:75%></div><div class="w-full h-full absolute m-auto pin overflow-hidden text-center"><img class=lazyload src="data:image/gif;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAYAAAAfFcSJAAAADUlEQVR42mP8+PXHfwAJnAPfCuZXlQAAAABJRU5ErkJggg==" alt="" data-sizes=auto data-src=/post/how-to-install-and-configure-samba-on-centos-7/windows-samba-connect_huef62cfe83270c8faef96f4a590c74049_107684_600x0_resize_q75_box.jpg data-srcset="
              /post/how-to-install-and-configure-samba-on-centos-7/windows-samba-connect_huef62cfe83270c8faef96f4a590c74049_107684_600x0_resize_q75_box.jpg 600w,
              /post/how-to-install-and-configure-samba-on-centos-7/windows-samba-connect.jpg 1024w
            " data-action=zoom><noscript><img class="w-full h-full absolute m-auto pin" src=/post/how-to-install-and-configure-samba-on-centos-7/windows-samba-connect.jpg></noscript></div></div></figure></li><li>Click “Next” and you will be prompted to enter the login credentials as shown below:<figure class=relative><div class="w-full mx-auto my-0 block relative"><div class=block style=padding-bottom:75%></div><div class="w-full h-full absolute m-auto pin overflow-hidden text-center"><img class=lazyload src="data:image/gif;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAYAAAAfFcSJAAAADUlEQVR42mP8+PXHfwAJnAPfCuZXlQAAAABJRU5ErkJggg==" alt="" data-sizes=auto data-src=/post/how-to-install-and-configure-samba-on-centos-7/windows-samba-login_hu6e62eb82742c9984100a57b12ed4b978_108686_600x0_resize_q75_box.jpg data-srcset="
              /post/how-to-install-and-configure-samba-on-centos-7/windows-samba-login_hu6e62eb82742c9984100a57b12ed4b978_108686_600x0_resize_q75_box.jpg 600w,
              /post/how-to-install-and-configure-samba-on-centos-7/windows-samba-login.jpg 1024w
            " data-action=zoom><noscript><img class="w-full h-full absolute m-auto pin" src=/post/how-to-install-and-configure-samba-on-centos-7/windows-samba-login.jpg></noscript></div></div></figure></li><li>In the next window, you can type a custom name for the network location. The default one will be picked up by the Samba server.<figure class=relative><div class="w-full mx-auto my-0 block relative"><div class=block style=padding-bottom:75%></div><div class="w-full h-full absolute m-auto pin overflow-hidden text-center"><img class=lazyload src="data:image/gif;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAYAAAAfFcSJAAAADUlEQVR42mP8+PXHfwAJnAPfCuZXlQAAAABJRU5ErkJggg==" alt="" data-sizes=auto data-src=/post/how-to-install-and-configure-samba-on-centos-7/windows-samba-name_hu2dcc3ed21c44f154e7efb0bf4276ef90_112584_600x0_resize_q75_box.jpg data-srcset="
              /post/how-to-install-and-configure-samba-on-centos-7/windows-samba-name_hu2dcc3ed21c44f154e7efb0bf4276ef90_112584_600x0_resize_q75_box.jpg 600w,
              /post/how-to-install-and-configure-samba-on-centos-7/windows-samba-name.jpg 1024w
            " data-action=zoom><noscript><img class="w-full h-full absolute m-auto pin" src=/post/how-to-install-and-configure-samba-on-centos-7/windows-samba-name.jpg></noscript></div></div></figure></li><li>Click “Next” to move to the last screen of the connection setup wizard.</li><li>Click “Finish” and the files on the Samba server will be shown.<figure class=relative><div class="w-full mx-auto my-0 block relative"><div class=block style=padding-bottom:75%></div><div class="w-full h-full absolute m-auto pin overflow-hidden text-center"><img class=lazyload src="data:image/gif;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAYAAAAfFcSJAAAADUlEQVR42mP8+PXHfwAJnAPfCuZXlQAAAABJRU5ErkJggg==" alt="" data-sizes=auto data-src=/post/how-to-install-and-configure-samba-on-centos-7/windows-samba-files_hu0260a0b5798c4ec6b598cf4ab9f8b41e_89209_600x0_resize_q75_box.jpg data-srcset="
              /post/how-to-install-and-configure-samba-on-centos-7/windows-samba-files_hu0260a0b5798c4ec6b598cf4ab9f8b41e_89209_600x0_resize_q75_box.jpg 600w,
              /post/how-to-install-and-configure-samba-on-centos-7/windows-samba-files.jpg 1024w
            " data-action=zoom><noscript><img class="w-full h-full absolute m-auto pin" src=/post/how-to-install-and-configure-samba-on-centos-7/windows-samba-files.jpg></noscript></div></div></figure></li></ol><h2 id=conclusion>Conclusion</h2><p>In this tutorial, you have learned how to install a Samba server on CentOS 7 and create different types of shared and users. We have also shown you how to connect to the Samba server from Linux, macOS and Windows devices.</p><div class="flex flex-wrap my-6"><a href=/tags/samba class="font-medium text-sm bg-indigo-dark hover:bg-indigo-darker mr-2 mt-2 px-4 py-2 rounded text-white tracking-wide">samba</a> <a href=/tags/centos class="font-medium text-sm bg-indigo-dark hover:bg-indigo-darker mr-2 mt-2 px-4 py-2 rounded text-white tracking-wide">centos</a></div></div></section></div></div></div></div><div class="w-full absolute -mb-16 flex-grow hidden lg:-mb-0 lg:block lg:pt-0 lg:static sidebar top-16 z-90" id=sidebar><div class=sideblock><div class="w-full flex justify-center content-center"><div class="w-full relative"><ins class="hidden adsbygoogle mx-auto lg:block" data-ad-client=ca-pub-9439755881064125 data-ad-format=auto data-ad-slot=9558702194 style=display:block data-full-width-responsive=true></ins></div></div></div><div class="bg-grey-lighter mb-6 p-4 pb-2 related-content"><p class="font-medium mb-3 mb-3 text-xs tracking-tight uppercase xxl:text-sm text-grey-darker">Related Tutorials</p><ul class="border-grey-light border-t list-reset mb-0 mt-4 pt-3"><li class="flex mb-2 border-b border-grey-light pb-2"><a href=https://linuxize.com/post/how-to-add-and-delete-users-on-centos-7/ class="font-medium text-sm hover:text-grey-darkest text-grey-dark truncate">How to Add and Delete Users on CentOS 7</a></li><li class="flex mb-2 border-b border-grey-light pb-2"><a href=https://linuxize.com/post/how-to-enable-epel-repository-on-centos/ class="font-medium text-sm hover:text-grey-darkest text-grey-dark truncate">How to Enable the EPEL repository on CentOS</a></li><li class="flex mb-2 border-b border-grey-light pb-2"><a href=https://linuxize.com/post/how-to-list-installed-packages-on-centos/ class="font-medium text-sm hover:text-grey-darkest text-grey-dark truncate">How to List Installed Packages on CentOS</a></li><li class="flex mb-2 border-b border-grey-light pb-2"><a href=https://linuxize.com/post/how-to-install-teamviewer-on-centos-7/ class="font-medium text-sm hover:text-grey-darkest text-grey-dark truncate">How to Install TeamViewer on CentOS 7</a></li><li class="flex mb-2 border-b border-grey-light pb-2"><a href=https://linuxize.com/post/how-to-set-or-change-timezone-on-centos-7/ class="font-medium text-sm hover:text-grey-darkest text-grey-dark truncate">How To Set or Change Timezone on CentOS 7</a></li><li class="flex mb-2 border-b border-grey-light pb-2"><a href=https://linuxize.com/post/how-to-create-a-bootable-centos-7-usb-stick/ class="font-medium text-sm hover:text-grey-darkest text-grey-dark truncate">How to Create Bootable CentOS USB Stick on Windows</a></li><li class="flex mb-2 border-b border-grey-light pb-2"><a href=https://linuxize.com/post/how-to-install-opencv-on-centos-7/ class="font-medium text-sm hover:text-grey-darkest text-grey-dark truncate">How to Install OpenCV on CentOS 7</a></li><li class="flex mb-2 border-b border-grey-light pb-2"><a href=https://linuxize.com/post/how-to-install-and-configure-samba-on-ubuntu-18-04/ class="font-medium text-sm hover:text-grey-darkest text-grey-dark truncate">How to Install and Configure Samba on Ubuntu 18.04</a></li><li class="flex mb-2 border-b border-grey-light pb-2"><a href=https://linuxize.com/post/how-to-install-minecraft-server-on-centos-7/ class="font-medium text-sm hover:text-grey-darkest text-grey-dark truncate">How to Install Minecraft Server on CentOS 7</a></li><li class="flex mb-2 border-b border-grey-light pb-2"><a href=https://linuxize.com/post/how-to-install-wordpress-with-apache-on-centos-7/ class="font-medium text-sm hover:text-grey-darkest text-grey-dark truncate">How to Install WordPress with Apache on CentOS 7</a></li></ul></div><div class="flex flex-col -mt-12 lg:block lg:relative lg:sticky lg:top-16 pt-12"><div class=sideblock><div class="hidden affiliate"><a href="https://www.vultr.com/?ref=6812257" class=vultr rel=noopener target=_blank></a> <a href="https://shareasale.com/r.cfm?b=1133389&u=1755182&m=75038&urllink=&afftrack=" class="cloudways mt-8" rel=noopener target=_blank></a></div><div class="w-full flex justify-center content-center"><div class="w-full relative"><ins class="adsbygoogle mx-auto" data-ad-client=ca-pub-9439755881064125 data-ad-format=auto data-ad-slot=7027266996 style=display:block data-full-width-responsive=true></ins></div></div></div></div></div></div></div></article><div class=px-6><section class="w-full mx-auto border-grey-lighter border-t mt-8 pt-8 max-w-article"><div class="bg-grey-lighter p-8 sm:py-8"><p class="text-lg lg:text-2xl max-w-md mx-auto my-0 sm:text-xl text-center">Sign up to our newsletter and get our latest tutorials and news straight to your mailbox.</p><form action="https://linuxize.us17.list-manage.com/subscribe/post?u=35cd4cd9d021c25c3dd7cabfd&id=9cfa4c89de" class=pt-8 id=mc-embedded-subscribe-form method=post name=mc-embedded-subscribe-form novalidate><div class="w-full mx-auto flex items-center flex-col justify-between max-w-sm mb-2 sm:flex-row"><input class="w-full block bg-white appearance-none border hover:border-grey-dark mb-3 px-4 py-3 rounded sm:mb-0 text-grey-darker" name=EMAIL aria-label=email placeholder="Your email..." type=email> <input class=hidden name=b_35cd4cd9d021c25c3dd7cabfd_9cfa4c89de tabindex=-1> <button class="w-full px-4 py-3 rounded bg-indigo-dark hover:bg-indigo-darker sm:ml-4 sm:w-auto text-white tracking-wide" name=subscribe type=submit><span class=text-center>Subscribe</span></button></div><p class="w-full mx-auto my-0 max-w-sm text-sm">We’ll never share your email address or spam you.</p></form></div></section><section class="w-full mx-auto border-grey-lighter border-t mt-8 pt-8 max-w-xl"><div class="flex flex-wrap -mx-4"><a href=https://linuxize.com/post/how-to-add-and-delete-users-on-centos-7/ class="w-full flex md:mb-0 md:w-1/3 overflow-hidden px-4 mb-8"><div class="w-full h-full flex flex-col"><p class="uppercase text-xs font-normal text-grey-dark">Feb 24, 2019</p><div class="flex-grow font-normal mb-2 md:mb-4 text-black text-lg">How to Add and Delete Users on CentOS 7</div><div><figure class=relative><div class="w-full mx-auto my-0 block relative"><div class=block style=padding-bottom:53%></div><div class="w-full h-full absolute m-auto pin overflow-hidden bg-grey-lighter"><img class="w-full h-full absolute m-auto pin lazy lazyload" src="data:image/gif;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAYAAAAfFcSJAAAADUlEQVR42mP8+PXHfwAJnAPfCuZXlQAAAABJRU5ErkJggg==" alt="" data-sizes=auto data-src=/post/how-to-add-and-delete-users-on-centos-7/featured_hu1cba4f557ea66a57e367a8a4b622d8dd_62269_600x0_resize_q95_box.jpg data-srcset="
              /post/how-to-add-and-delete-users-on-centos-7/featured_hu1cba4f557ea66a57e367a8a4b622d8dd_62269_600x0_resize_q95_box.jpg 600w,
              /post/how-to-add-and-delete-users-on-centos-7/featured.jpg 1000w
            "><noscript><img class="w-full h-full absolute m-auto pin" src=/post/how-to-add-and-delete-users-on-centos-7/featured.jpg></noscript></div></div></figure></div></div></a><a href=https://linuxize.com/post/how-to-enable-epel-repository-on-centos/ class="w-full flex md:mb-0 md:w-1/3 overflow-hidden px-4 mb-8"><div class="w-full h-full flex flex-col"><p class="uppercase text-xs font-normal text-grey-dark">Feb 23, 2019</p><div class="flex-grow font-normal mb-2 md:mb-4 text-black text-lg">How to Enable the EPEL repository on CentOS</div><div><figure class=relative><div class="w-full mx-auto my-0 block relative"><div class=block style=padding-bottom:53%></div><div class="w-full h-full absolute m-auto pin overflow-hidden bg-grey-lighter"><img class="w-full h-full absolute m-auto pin lazy lazyload" src="data:image/gif;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAYAAAAfFcSJAAAADUlEQVR42mP8+PXHfwAJnAPfCuZXlQAAAABJRU5ErkJggg==" alt="" data-sizes=auto data-src=/post/how-to-enable-epel-repository-on-centos/featured_hu5e6567ab6093e0245416ea775c15db52_40434_600x0_resize_q95_box.jpg data-srcset="
              /post/how-to-enable-epel-repository-on-centos/featured_hu5e6567ab6093e0245416ea775c15db52_40434_600x0_resize_q95_box.jpg 600w,
              /post/how-to-enable-epel-repository-on-centos/featured.jpg 1000w
            "><noscript><img class="w-full h-full absolute m-auto pin" src=/post/how-to-enable-epel-repository-on-centos/featured.jpg></noscript></div></div></figure></div></div></a><a href=https://linuxize.com/post/how-to-list-installed-packages-on-centos/ class="w-full flex md:mb-0 md:w-1/3 overflow-hidden px-4 mb-0"><div class="w-full h-full flex flex-col"><p class="uppercase text-xs font-normal text-grey-dark">Feb 13, 2019</p><div class="flex-grow font-normal mb-2 md:mb-4 text-black text-lg">How to List Installed Packages on CentOS</div><div><figure class=relative><div class="w-full mx-auto my-0 block relative"><div class=block style=padding-bottom:53%></div><div class="w-full h-full absolute m-auto pin overflow-hidden bg-grey-lighter"><img class="w-full h-full absolute m-auto pin lazy lazyload" src="data:image/gif;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAYAAAAfFcSJAAAADUlEQVR42mP8+PXHfwAJnAPfCuZXlQAAAABJRU5ErkJggg==" alt="" data-sizes=auto data-src=/post/how-to-list-installed-packages-on-centos/featured_hu0b36581c872225e7b0d372e88d734396_36578_600x0_resize_q95_box.jpg data-srcset="
              /post/how-to-list-installed-packages-on-centos/featured_hu0b36581c872225e7b0d372e88d734396_36578_600x0_resize_q95_box.jpg 600w,
              /post/how-to-list-installed-packages-on-centos/featured.jpg 1000w
            "><noscript><img class="w-full h-full absolute m-auto pin" src=/post/how-to-list-installed-packages-on-centos/featured.jpg></noscript></div></div></figure></div></div></a></div></section><section class="w-full mx-auto relative border-grey-lighter border-t max-w-lg mt-8 pt-16 py-8"><a href=https://linuxize.com/post/how-to-install-and-configure-samba-on-centos-7/#disqus_thread class="w-full block bg-grey-lighter disqus-comment-count disqus-load md:py-8 py-4 text-center" title="Show comments for post">Write a comment</a><div id=disqus_thread></div><noscript>Please enable JavaScript to view the <a href=https://disqus.com/?ref_noscript>comments powered by Disqus.</a></noscript></section></div></main><section class="w-full absolute pin bg-white block h-screen invisible search z-50" hidden id=search-box><div class="flex flex-col min-h-screen"><header class="w-full mx-auto flex items-center h-12 sm:h-16 justify-end px-6 z-10"><a href=# class="block h-6 sm:h-8" id=btn-search-close><svg aria-hidden=true class="h-6 w-6 fill-current inline-block text-grey-darkest sm:h-8 sm:w-8 -mb-2"><use xlink:href=/svg/sprite.svg#close></use><title>Close search form</title></svg> <small class="block text-center sm:w-8 w-6">ESC</small></a></header><div class="w-full px-6 flex-grow flex-no-shrink pb-8 pt-16 sm:pt-24"><div class="flex flex-col mx-auto max-w-xl mb-4 mb-8"><div class=searchbox-container id=searchbox></div><div class=search-results id=search-results></div><div id=hits></div><div id=stats></div><footer class=mt-6><a href=https://algolia.com rel="noopener noreferrer" target=_blank tabindex=-1><svg aria-hidden=true class="inline-block fill-current search-algolia-logo text-grey-dark"><use xlink:href=/svg/sprite.svg#search-by-algolia></use><title>Search by Algolia</title></svg></a></footer></div></div></div></section><footer class="w-full px-6 bg-grey-lightest"><div class="w-full mx-auto flex items-center flex-wrap justify-center max-w-xl md:justify-between md:text-left py-8 text-center"><div class="w-full mb-2 md:mb-0 md:w-1/2 text-sm"><div class="w-full block md:flex md:items-center md:w-auto"><div class=md:flex-grow><span class="block text-grey-darker mb-2 md:inline-block md:mb-0 md:mr-8">© 2019 Linuxize.com</span> <a href=/privacy-policy/ class="inline-block text-grey-darkest footer-menu-item hover:text-grey-darker md:mt-0 no-underline mr-4">Privacy Policy </a><a href=/contact/ class="inline-block text-grey-darkest footer-menu-item hover:text-grey-darker md:mt-0 no-underline mr-0">Contact</a></div></div></div><div class="w-full flex justify-center md:justify-end md:w-1/2"><a href=https://twitter.com/linuxize class="block h-6 mr-2" aria-label=Twitter><svg aria-hidden=true class="h-6 w-6 fill-current inline-block text-grey-darkest"><use xlink:href=/svg/sprite.svg#twitter></use><title>Twitter</title></svg> </a><a href=https://www.facebook.com/linuxize/ class="block h-6 mr-2" aria-label=Facebook><svg aria-hidden=true class="h-6 w-6 fill-current inline-block text-grey-darkest"><use xlink:href=/svg/sprite.svg#facebook></use><title>Facebook</title></svg> </a><a href=/index.xml class="block h-6" aria-label=RSS><svg aria-hidden=true class="h-6 w-6 fill-current inline-block text-grey-darkest"><use xlink:href=/svg/sprite.svg#rss></use><title>RSS</title></svg></a></div></div></footer></div><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script src=https://cdnjs.cloudflare.com/ajax/libs/instantsearch.js/3.1.1/instantsearch.production.min.js></script><script src=/js/1.d0e8d40250485f44d26f.js></script><script src=/js/app.721ba99e6cbf7ca307fc.js></script><!--Begin comScore Tag--><script>var _comscore=_comscore||[];_comscore.push({c1:"2",c2:"20015427"});(function(){var s=document.createElement("script"),el=document.getElementsByTagName("script")[0];s.async=true;s.src=(document.location.protocol=="https:"?"https://sb":"http://b")+".scorecardresearch.com/beacon.js";el.parentNode.insertBefore(s,el)})();</script><noscript><img src="https://sb.scorecardresearch.com/p?c1=2&c2=20015427&cv=2.0&cj=1"/></noscript><!--End comScore Tag-->
<!--Quantcast Tag--><script type="text/javascript">var _qevents=_qevents||[];(function(){var elem=document.createElement('script');elem.src=(document.location.protocol=="https:"?"https://secure":"http://edge")+".quantserve.com/quant.js";elem.async=true;elem.type="text/javascript";var scpt=document.getElementsByTagName('script')[0];scpt.parentNode.insertBefore(elem,scpt)})();_qevents.push({qacct:"p-31iz6hfFutd16",labels:"Domain.linuxize_com,DomainId.93605"});</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.linuxize_com,DomainId.93605"border="0"height="1"width="1"alt="Quantcast"/></div></noscript><!--End Quantcast tag-->
<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('edmonton.php', '/detroitchicago/edmonton.webp?a=a&cb=0&shcb=31', true, [], true, false, false, false);
__ez.queue.addFile('jellyfish.php', '/porpoiseant/jellyfish.webp?a=a&cb=0&shcb=31', false, [], true, false, false, false);
</script>
</body></html>