<!doctype html><html class="no-js" lang="en-us"><head><meta charset="utf-8">
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=function(){var u=[],i="/porpoiseant/army.gif";function t(e,i,t,_,d,o,n){if(__ez.dot.isDefined(e)&&0!=__ez.dot.isAnyDefined(e.getSlotElementId,e.ElementId)){var r=parseInt(__ez.dot.getTargeting(e,"ap")),a=__ez.dot.getSlotIID(e),s=__ez.dot.getAdUnit(e),p=parseInt(__ez.dot.getTargeting(e,"compid")),z=0,f=0,g=function(e){if("undefined"==typeof _ezim_d)return!1;var i=__ez.dot.getAdUnitPath(e).split("/").pop();if("object"==typeof _ezim_d&&_ezim_d.hasOwnProperty(i))return _ezim_d[i];for(var t in _ezim_d)if(t.split("/").pop()===i)return _ezim_d[t];return!1}(e);"object"==typeof g&&(void 0!==g.creative_id&&(f=g.creative_id),void 0!==g.line_item_id&&(z=g.line_item_id)),__ez.dot.isDefined(a,s)&&__ez.dot.isValid(i)&&u.push({type:"impression",impression_id:a,domain_id:__ez.dot.getDID(),unit:s,t_epoch:__ez.dot.getEpoch(0),revenue:t,est_revenue:_,ad_position:r,ad_size:"",bid_floor_filled:d,bid_floor_prev:o,stat_source_id:n,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:p,line_item_id:z,creative_id:f,data:__ez.dot.dataToStr(i)})}}function _(){if(void 0===document.visibilityState||"prerender"!==document.visibilityState){if(__ez.dot.isDefined(u)&&0<u.length){var e=__ez.dot.getURL(i)+"?orig="+(!0===__ez.template.isOrig?1:0)+"&sts="+btoa(JSON.stringify(u));void 0!==window.isAmp&&isAmp&&void 0!==window._ezaq&&_ezaq.hasOwnProperty("domain_id")&&(e+="&visit_uuid="+_ezaq.visit_uuid),(new Image).src=e}u=[]}}return{Add:t,AddAndFire:function(e,i){t(e,i,0,0,0,0,0),_()},AddById:function(e,i){var t=e.split("/");if(__ez.dot.isDefined(e)&&3===t.length&&__ez.dot.isValid(i)){var _=t[0],d=t[2];u.push({type:"impression",impression_id:d,domain_id:__ez.dot.getDID(),unit:_,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(i)})}},Fire:_,GetPixels:function(){return u}}}();var EzoicPixel=function(){this.pixels=[],this.pixelUrl="/ezoic/e.gif",("undefined"!=typeof ezJsu&&!0===ezJsu||"undefined"!=typeof _ez_sa&&!0===_ez_sa||void 0!==window.isAmp&&!0===isAmp||"undefined"!=typeof ezWp&&!0===ezWp)&&(this.pixelUrl="//g.ezoic.net"+this.pixelUrl),this.tEpoch=0,"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("t_epoch")&&(this.tEpoch=_ezaq.t_epoch)},EzoicPixelData=function(e,i){this.name=e,this.val=i};EzoicPixel.prototype={constructor:EzoicPixel,AddAndFireImpPixel:function(e,i){this.AddImpPixel(e,i,0,0,0,0,0),this.FirePixels()},AddAndFirePVPixel:function(e,i){this.AddPVPixel(e,i),this.FirePixels()},AddImpPixel:function(e,i,t,n,o,a,d){if(0!=__ez.dot.isDefined(e)&&0!=__ez.dot.isAnyDefined(e.getSlotElementId,e.ElementId)){var s=parseInt(__ez.dot.getTargeting(e,"ap")),r=__ez.dot.getSizes(e)[0],_=r.l.toString()+"x"+r.j.toString(),p="0",l="XX";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(p=_ezaq.domain_id.toString()),"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("country")&&(l=_ezaq.country);var h=__ez.dot.getSlotIID(e),c=__ez.dot.getSlotElementId(e);__ez.dot.isDefined(h,c)&&this.validateData(i)&&(i=this.convertDataToStr(i),this.pixels.push({type:"impression",impression_id:h,domain_id:p,unit:c,t_epoch:this.tEpoch,revenue:t,est_revenue:n,ad_position:s,ad_size:_,bid_floor_filled:o,bid_floor_prev:a,stat_source_id:d,country_code:l,data:i}))}},AddImpPixelById:function(e,i){var t="0";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(t=_ezaq.domain_id.toString());var n=e.split("/");if(__ez.dot.isDefined(e)&&3===n.length&&this.validateData(i)){var o=n[0],a=n[2];i=this.convertDataToStr(i),this.pixels.push({type:"impression",impression_id:a,domain_id:t,unit:o,t_epoch:this.tEpoch,data:i})}},AddPVPixel:function(e,i){var t="0";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(t=_ezaq.domain_id.toString()),__ez.dot.isDefined(e)&&this.validateData(i)&&(i=this.convertDataToStr(i),this.pixels.push({type:"pageview",pageview_id:e,domain_id:t,t_epoch:this.tEpoch,data:i}))},FirePixels:function(){void 0!==document.visibilityState&&"prerender"===document.visibilityState||(__ez.dot.isDefined(this.pixels)&&0<this.pixels.length&&((new Image).src=this.pixelUrl+"?orig="+(!0===__ez.template.isOrig?1:0)+"&pixels="+encodeURIComponent(JSON.stringify(this.pixels))),this.pixels=[])},NewData:function(e,i){return new EzoicPixelData(e,i)},convertDataToStr:function(e){if(void 0===e)return[];try{for(var i in e)e[i].val=e[i].val+""}catch(e){}return e},validateData:function(e){for(var i=0;i<e.length;i++)if(e[i]instanceof EzoicPixelData==!1)return console.error("Invalid pixelData. ",e[i]),!1;return!0}};</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">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</script><title>How to Install TeamViewer on Debian 10 | Linuxize</title><meta content="IE=edge" http-equiv="X-UA-Compatible"><meta content="width=device-width,initial-scale=1,shrink-to-fit=no" name="viewport"><meta content="Linuxize" name="apple-mobile-web-app-title"><meta content="Linuxize" name="application-name"><meta content="#2271ff" name="theme-color"><meta content="#2271ff" name="msapplication-TileColor"><meta content="TeamViewer is a cross-platform application that can be used for remote control, desktop sharing, online meetings, and file transfer between computers. This tutorial explains how to install TeamViewer on Debian 10, Buster. " name="description"><meta content="unsafe-url" name="referrer"><link href="https://linuxize.com/post/how-to-install-teamviewer-on-debian-10/" rel="canonical"><meta content="index, follow" name="robots"><meta content="How to Install TeamViewer on Debian 10" property="og:title"><meta content="TeamViewer is a cross-platform application that can be used for remote control, desktop sharing, online meetings, and file transfer between computers. This tutorial explains how to install TeamViewer on Debian 10, Buster. " property="og:description"><meta content="article" property="og:type"><meta content="/post/how-to-install-teamviewer-on-debian-10/" property="og:url"><meta content="https://linuxize.com/post/how-to-install-teamviewer-on-debian-10/featured.jpg" property="og:image"><meta content="http://" property="og:image:secure"><meta content="TeamViewer is a cross-platform application that can be used for remote control, desktop sharing, online meetings, and file transfer between computers. This tutorial explains how to install TeamViewer on Debian 10, Buster. " property="og:image:alt"><meta content="2020-04-16T22:01:47+01:00" property="article:published_time"><meta content="2020-04-16T22:01:47+01:00" property="article:modified_time"><meta content="en" property="og:locale"><meta content="post" property="article:section"><meta content="https://www.facebook.com/linuxize" property="article:publisher"><meta content="teamviewer" property="article:tag"><meta content="debian" property="article:tag"><meta content="teamviewer,debian" name="news_keywords"><meta content="summary_large_image" name="twitter:card"><meta content="https://linuxize.com/post/how-to-install-teamviewer-on-debian-10/featured.jpg" name="twitter:image"><meta content="How to Install TeamViewer on Debian 10" name="twitter:title"><meta content="TeamViewer is a cross-platform application that can be used for remote control, desktop sharing, online meetings, and file transfer between computers. This tutorial explains how to install TeamViewer on Debian 10, Buster. " name="twitter:description"><meta content="@linuxize" name="twitter:site"><link href="/favicons/apple-touch-icon.png" rel="apple-touch-icon" sizes="180x180"><link href="/favicons/favicon-32x32.png" rel="icon" sizes="32x32" type="image/png"><link href="/favicons/favicon-16x16.png" rel="icon" sizes="16x16" type="image/png"><link href="/favicons/safari-pinned-tab.svg" rel="mask-icon" color="#2271ff"><link href="//fonts.gstatic.com" rel="preconnect" crossorigin=""><link href="//fonts.googleapis.com" rel="preconnect" crossorigin=""><link href="//www.googletagmanager.com" rel="preconnect" crossorigin=""><link href="//www.google-analytics.com" rel="preconnect" crossorigin=""><link href="//pagead2.googlesyndication.com" rel="preconnect" crossorigin=""><link href="https://fonts.googleapis.com/css?family=Hind:400,500,600,700|Roboto+Mono:400,400i,700,700i|Roboto:400,400i,500,700,700i&display=swap" rel="stylesheet"><script type="application/ld+json">{
  "@context": "http://schema.org",
  "@type": "BlogPosting",
  "headline": "How to Install TeamViewer on Debian 10",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https:\/\/linuxize.com\/post\/how-to-install-teamviewer-on-debian-10\/"
  },"image": {
     "@type": "ImageObject",
     "url": "https:\/\/linuxize.com\/post\/how-to-install-teamviewer-on-debian-10\/featured.jpg",
     "width":  1001 ,
     "height":  530 
    },"keywords": "teamviewer, debian",
  "wordcount":  367 ,
  "url": "https:\/\/linuxize.com\/post\/how-to-install-teamviewer-on-debian-10\/",
  "datePublished": "2020-04-16T22:01:47+01:00",
  "dateModified": "2020-04-16T22:01:47+01:00",
  "publisher": {
    "@type": "Organization","logo": {
    "@type": "imageObject",
      "url": "https:\/\/linuxize.com\/assets\/linuxize-card.png"
    },"name": "Linuxize"
  },

  "author": {
    "@type": "Person",
    "name": "Linuxize"
  },
  "description": "TeamViewer is a cross-platform application that can be used for remote control, desktop sharing, online meetings, and file transfer between computers. This tutorial explains how to install TeamViewer on Debian 10, Buster. "
}</script><script src="/js/dfp.js" async></script><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-P827G6S');</script><script src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js" async data-ad-client="ca-pub-9439755881064125"></script><link href="/css/app.79d6e3be2d5f37424f1e.css" rel="stylesheet"><meta content="#2271ff" name="theme-color"><link href="/manifest.128dc4ca8d47b9db75ffbc72b588021a.json" rel="manifest">
<script data-ezscrex="false" data-cfasync="false" type="text/javascript">window.google_analytics_uacct = "UA-124335151-13";</script>
<script data-ezscrex="false" data-cfasync="false" type="text/javascript">
var _gaq = _gaq || [];
_gaq.push(['e._setAccount', 'UA-124335151-13']);
_gaq.push(['f._setAccount', 'UA-38339005-1']);
_gaq.push(['e._setDomainName', 'linuxize.com']);
_gaq.push(['f._setDomainName', 'linuxize.com']);
_gaq.push(['e._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['e._setCustomVar',2,'t','126',3]);
_gaq.push(['e._setCustomVar',3,'rid','0',2]);
_gaq.push(['e._setCustomVar',4,'bra','mod87',3]);
_gaq.push(['e._setAllowAnchor',true]);
_gaq.push(['e._setSiteSpeedSampleRate', 10]);
_gaq.push(['f._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['f._setCustomVar',2,'domain','linuxize.com',3]);
_gaq.push(['f._setSiteSpeedSampleRate', 20]);
_gaq.push(['e._trackPageview']);
_gaq.push(['f._trackPageview']);


(function() {
 var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
 ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
 var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
})();
</script>
<script type="text/javascript">var ezouid = "1";</script><base href="https://linuxize.com/post/how-to-install-teamviewer-on-debian-10/"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 93605;
var ezdomain = 'linuxize.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":93605,"engaged_time_visit":0,"ezcache_level":1,"forensiq_score":-1,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"9fb0d91f-2fa4-4845-50ca-4d21e2908c3c","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_time_orig":11,"serverid":"54.159.226.254:6953","state":"VA","t_epoch":1587223221,"template_id":126,"time_on_site_visit":0,"url":"https://linuxize.com/post/how-to-install-teamviewer-on-debian-10/","user_id":0,"word_count":594,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script><script data-ezscrex='false' data-cfasync='false' type="text/javascript" src="/detroitchicago/rochester.js?cb=188-0&v=8" async></script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl() {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_93605=" + new Date().getTime() + "|9fb0d91f-2fa4-4845-50ca-4d21e2908c3c|false; " + expires, 3);
}
function attach_ezolpl() {
    if(window.attachEvent) {
        window.attachEvent('onload', create_ezolpl);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl();
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl;
        }
    }
}
attach_ezolpl();
</script></head><body class="font-sans kind-page leading-normal section-post type-post"><div class="flex flex-col min-h-screen main-wrap"><header class="w-full dark:border-gray-900 border-b border-gray-400 fixed header linuxize-shadow px-6 z-50" id="header"><nav class="w-full mx-auto flex items-center h-12 justify-start md:h-16"><a href="/" class="flex items-center block dark:text-gray-200 flex-shrink-0 logo mr-6 no-underline text-black" aria-label="Linuxize.com"><svg aria-hidden="true" class="mr-2 h-6 fill-current md:h-8 md:w-8 w-6" role="img"><use xlink:href="/svg/sprite.svg#logo"></use></svg> <span class="hidden md:block font-medium text-md tracking-tight">Linuxize</span></a><div class="flex -mb-px flex-1 min-w-0 text-sm"><a href="/tags/ubuntu/" class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 hidden md:block mr-4 no-underline text-gray-800"><span class="inline-block font-bold md:py-4 md:py-6 py-3">Ubuntu </span></a><a href="/tags/centos/" class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 hidden md:block mr-4 no-underline text-gray-800"><span class="inline-block font-bold md:py-4 md:py-6 py-3">Centos </span></a><a href="/tags/debian/" class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 hidden md:block mr-4 no-underline text-gray-800"><span class="inline-block font-bold md:py-4 md:py-6 py-3">Debian </span></a><a href="/tags/terminal/" class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 hidden md:block mr-4 no-underline text-gray-800"><span class="inline-block font-bold md:py-4 md:py-6 py-3">Commands </span></a><a href="/series/" class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 hidden md:block mr-4 no-underline text-gray-800"><span class="inline-block font-bold md:py-4 md:py-6 py-3">Series </span></a><a href="https://www.buymeacoffee.com/8swZOSU6I" class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 hidden md:block mr-4 no-underline text-gray-800 mr-0"><span class="inline-block font-bold md:py-4 md:py-6 py-3">Donate</span></a></div><div class="flex justify-end"><button class="block h-6" id="btn-search" aria-label="Search"><svg aria-hidden="true" class="dark:text-gray-300 inline-block fill-current h-6 w-6 text-gray-900" role="img"><use xlink:href="/svg/sprite.svg#search"></use></svg></button> <button class="ml-2 mode-toggle" id="mode-toggle"><div class="mode-toggle-icons"><svg aria-hidden="true" class="dark:text-gray-300 inline-block fill-current h-6 w-6 text-gray-900" role="img"><use xlink:href="/svg/sprite.svg#moon"></use></svg> <svg aria-hidden="true" class="dark:text-gray-300 inline-block fill-current h-6 w-6 text-gray-900" role="img"><use xlink:href="/svg/sprite.svg#sun"></use></svg></div></button></div></nav></header><main class="w-full flex-grow flex-shrink-0 pb-8 pt-16 sm:pt-24 main"><article class="relative single-post"><div class="w-full mx-auto px-6 post-width"><div class="relative mb-4 post-header xl:mb-8 z-40"><h1 class="font-semibold leading-none lg:text-3xl mb-2 text-2xl xxl:text-4xl">How to Install TeamViewer on Debian 10</h1><div class="flex flex-col dark:text-gray-300 font-medium md:flex-row text-gray-700 text-xs"><div class="inline-flex flex-row"><p class="rounded-sm font-medium leading-normal text-xs"><span>Posted </span><time class="" datetime="2020-04-16T22:01:47+01:00">Apr 16, 2020</time></p><span class="inline-block mx-2">•</span><p>2 min read</p></div></div></div><div class="lg:flex"><div class="w-full lg:max-h-full lg:overflow-visible lg:static min-h-screen"><div class="flex"><div class="w-full pb-8"><div class="flex flex-col xl:flex-relative xl:flex-row"><aside class="w-full block hidden sidebar2 xxl:block" id="sidebar2"><script src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js" async></script><div class="w-full flex justify-center content-center"><div class="w-full relative"><ins class="block hidden adsbygoogle mx-autosidebar2-as xl:block" data-ad-client="ca-pub-9439755881064125" data-ad-format="horizontal,rectangle" data-ad-slot="4501323511" data-full-width-responsive="true"></ins></div></div><script>(adsbygoogle = window.adsbygoogle || []).push({});</script><div class="wrap-collabsible mb-6"><input class="hidden toggle" type="checkbox" id="collapsible"> <label class="flex items-center block bg-indigo-700 cursor-pointer hover:bg-indigo-800 justify-between lbl-toggle px-4 py-2 relative text-white" for="collapsible"><div class="text-sm font-medium tracking-wide"><span>Not using Debian 10?</span><br><span>Choose different OS:</span></div><div class="ml-3"><svg aria-hidden="true" class="inline-block fill-current icon h-5 w-5 white" role="img"><use xlink:href="/svg/sprite.svg#arrow-right"></use></svg></div></label><div class="bg-gray-200 dark:bg-gray-900 collapsible-content"><div class="w-full distro-versions flex-wrap inline-flex items-center pt-2"><div class="w-full px-4 mb-2 pb-2"><a href="/post/how-to-install-teamviewer-on-centos-7/" class="w-full flex block capitalize dark-hover:text-gray-100 dark:text-gray-300 font-medium hover:text-gray-900 leading-normal text-gray-700 text-xs xxl:text-sm"><span class="mr-2"><svg aria-hidden="true" class="inline-block fill-current icon h-3 w-3" role="img"><use xlink:href="/svg/sprite.svg#link"></use></svg> </span><span>centos 7</span></a></div><div class="w-full px-4 mb-2 pb-2"><a href="/post/how-to-install-teamviewer-on-centos-8/" class="w-full flex block capitalize dark-hover:text-gray-100 dark:text-gray-300 font-medium hover:text-gray-900 leading-normal text-gray-700 text-xs xxl:text-sm"><span class="mr-2"><svg aria-hidden="true" class="inline-block fill-current icon h-3 w-3" role="img"><use xlink:href="/svg/sprite.svg#link"></use></svg> </span><span>centos 8</span></a></div><div class="w-full px-4 mb-2 pb-2"><a href="/post/how-to-install-teamviewer-on-debian-10/" class="w-full flex block capitalize dark-hover:text-gray-100 dark:text-gray-300 font-medium hover:text-gray-900 leading-normal text-gray-700 text-xs xxl:text-sm"><span class="mr-2"><svg aria-hidden="true" class="inline-block fill-current icon h-3 w-3" role="img"><use xlink:href="/svg/sprite.svg#link"></use></svg> </span><span>debian 10</span></a></div><div class="w-full px-4 mb-2 pb-2"><a href="/post/how-to-install-teamviewer-on-ubuntu-18-04/" class="w-full flex block capitalize dark-hover:text-gray-100 dark:text-gray-300 font-medium hover:text-gray-900 leading-normal text-gray-700 text-xs xxl:text-sm"><span class="mr-2"><svg aria-hidden="true" class="inline-block fill-current icon h-3 w-3" role="img"><use xlink:href="/svg/sprite.svg#link"></use></svg> </span><span>ubuntu 18.04</span></a></div></div></div></div><div class="w-full -mt-12 flex-col hidden justify-between pb-4 pt-12 sticky top-16 xl:flex"><div class="pb-2 bg-gray-200 dark:bg-gray-900 mb-6 p-4 overflow-auto table-of-contents toc"><p class="uppercase text-xs font-medium mb-3 mb-3 text-gray-800 tracking-tight xxl:text-sm dark:text-gray-200">Contents</p><div class="relative overflow-hidden"><div class="lg:max-h-toc overflow-y-auto scrollbar-thumb-gray scrollbar-thumb-rounded scrollbar-track-gray-lighter scrollbar-w-2 scrolling-touch"><nav id="TableOfContents"><ul><li><a href="#prerequisites">Prerequisites</a></li><li><a href="#installing-teamviewer-on-debian">Installing TeamViewer on Debian</a><ul><li><a href="#1-download-teamviewer">1. Download TeamViewer</a></li><li><a href="#2-install-teamviewer">2. Install TeamViewer</a></li></ul></li><li><a href="#starting-teamviewer">Starting TeamViewer</a></li><li><a href="#updating-teamviewer">Updating TeamViewer</a></li><li><a href="#conclusion">Conclusion</a></li></ul></nav></div></div><div class="flex border-gray-400 border-t dark:border-gray-900 items-center justify-content mb-3 mr-2 pt-4 tracking-tight"><p class="uppercase text-xs font-medium mr-4 xxl:text-sm">Share:</p><section class="w-full mx-auto"><nav class="flex flex-wrap"><a href="https://twitter.com/share?text=How%20to%20Install%20TeamViewer%20on%20Debian%2010&url=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-install-teamviewer-on-debian-10%2f" class="mr-3 h-6 w-6" rel="noopener" target="_blank"><svg aria-hidden="true" class="dark:text-gray-300 inline-block fill-current h-6 w-6 hover:text-blue-600 text-gray-600" role="img"><use xlink:href="/svg/sprite.svg#twitter"></use></svg> </a><a href="https://www.facebook.com/sharer/sharer.php?caption=How%20to%20Install%20TeamViewer%20on%20Debian%2010&u=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-install-teamviewer-on-debian-10%2f" class="mr-3 h-6 w-6" rel="noopener" target="_blank"><svg aria-hidden="true" class="dark:text-gray-300 inline-block fill-current h-6 w-6 hover:text-blue-600 text-gray-600" role="img"><use xlink:href="/svg/sprite.svg#facebook"></use></svg> </a><a href="https://pinterest.com/pin/create/button/?url=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-install-teamviewer-on-debian-10%2f&media=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-install-teamviewer-on-debian-10%2ffeatured.jpg&description=How%20to%20Install%20TeamViewer%20on%20Debian%2010" class="mr-3 h-6 w-6" rel="noopener" target="_blank"><svg aria-hidden="true" class="dark:text-gray-300 inline-block fill-current h-6 w-6 hover:text-blue-600 text-gray-600" role="img"><use xlink:href="/svg/sprite.svg#pinterest"></use></svg> </a><a href="mailto:?subject=How%20to%20Install%20TeamViewer%20on%20Debian%2010&body=Check%20out%20this%20article:%0A%0Ahttps%3a%2f%2flinuxize.com%2fpost%2fhow-to-install-teamviewer-on-debian-10%2f" class="h-6 w-6" rel="noopener" target="_blank"><svg aria-hidden="true" class="dark:text-gray-300 inline-block fill-current h-6 w-6 hover:text-blue-600 text-gray-600" role="img"><use xlink:href="/svg/sprite.svg#email"></use></svg></a></nav></section></div></div></div></aside><section class="w-full mx-auto lg:ml-0 lg:mr-auto lg:pr-6 min-w-0 xl:mx-0 xl:w-full xxl:px-6"><figure class="relative -mx-6 lg:mx-0 mb-6"><div class="w-full mx-auto my-0 block relative"><div class="block" style="padding-bottom:52.947052947052946%"></div><div class="w-full h-full absolute inset-0 m-auto overflow-hidden bg-gray-200"><img alt="" class="w-full h-full absolute inset-0 m-auto lazy lazyload" src="data:image/gif;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAYAAAAfFcSJAAAADUlEQVR42mP8+PXHfwAJnAPfCuZXlQAAAABJRU5ErkJggg==" data-sizes="auto" data-src="/post/how-to-install-teamviewer-on-debian-10/featured_hu2d41654471740dc8c02ca34e62f0e1af_24953_600x0_resize_q95_box.jpg" data-srcset="
              /post/how-to-install-teamviewer-on-debian-10/featured_hu2d41654471740dc8c02ca34e62f0e1af_24953_600x0_resize_q95_box.jpg 600w,
              /post/how-to-install-teamviewer-on-debian-10/featured.jpg 1001w
            "><noscript><img alt="" class="w-full h-full absolute inset-0 m-auto" src="/post/how-to-install-teamviewer-on-debian-10/featured.jpg"></noscript></div></div></figure><div class="markdown"><p><a href="https://www.teamviewer.com">TeamViewer</a> is a cross-platform application that can be used for remote control, desktop sharing, online meetings, and file transfer between computers.</p><p>This tutorial explains how to install TeamViewer on Debian 10, Buster.</p><h2 id="prerequisites">Prerequisites <a href="#prerequisites" class="headline-link" aria-hidden="true">#</a></h2><p>Before continuing with this tutorial, make sure you are logged in as a <a href="https://linuxize.com/post/how-to-create-a-sudo-user-on-debian/">user with sudo privileges</a>.</p><h2 id="installing-teamviewer-on-debian">Installing TeamViewer on Debian <a href="#installing-teamviewer-on-debian" class="headline-link" aria-hidden="true">#</a></h2><p>TeamViewer is proprietary computer software, and it is not included in the default Debian repositories. TeamViewer maintains its own <a href="https://linuxize.com/post/how-to-add-apt-repository-in-ubuntu/">APT repository</a> from which we’ll install the package, and update it when a new version is available.</p><p>Installing TeamViewer on Debian systems is a pretty straightforward process, just complete the steps below.</p><h3 id="1-download-teamviewer">1. Download TeamViewer <a href="#1-download-teamviewer" class="headline-link" aria-hidden="true">#</a></h3><p>Open your terminal either by using the <code>Ctrl+Alt+T</code> keyboard shortcut or by clicking on the terminal icon.</p><p>Use <a href="https://linuxize.com/post/wget-command-examples/"><code>wget</code></a> to download the latest TeamViewer <code>.deb</code> package:</p><pre class="terminal"><code class="terminal-line" prefix="$">wget https://download.teamviewer.com/download/linux/teamviewer_amd64.deb</code></pre><h3 id="2-install-teamviewer">2. Install TeamViewer <a href="#2-install-teamviewer" class="headline-link" aria-hidden="true">#</a></h3><p>Install the downloaded <code>.deb</code> package by typing the following command:</p><pre class="terminal"><code class="terminal-line" prefix="$">sudo apt install ./teamviewer_amd64.deb</code></pre><p>When prompted <code>Do you want to continue? [Y/n]</code>, type <code>Y</code> to continue the installation.</p><h2 id="starting-teamviewer">Starting TeamViewer <a href="#starting-teamviewer" class="headline-link" aria-hidden="true">#</a></h2><p>TeamViewer application can be launched either from the command line by typing <code>teamviewer</code> or by clicking on its icon in the Applications menu.</p><p>When TeamViewer is started for the first time, a window similar to the following will be displayed. Accept the terms in the license agreement by clicking on the “License Agreement” button.</p><figure class="relative"><div class="w-full mx-auto my-0 block relative"><div class="block" style="padding-bottom:82.00192492781521%"></div><div class="w-full h-full absolute inset-0 m-auto overflow-hidden text-center"><img alt="" class="lazyload" src="data:image/gif;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAYAAAAfFcSJAAAADUlEQVR42mP8+PXHfwAJnAPfCuZXlQAAAABJRU5ErkJggg==" data-sizes="auto" data-src="/post/how-to-install-teamviewer-on-debian-10/debian-teamviewer-license-agreement_hu555ef480787c753f23579937b81118e9_103439_600x0_resize_q75_box.jpg" data-srcset="
              /post/how-to-install-teamviewer-on-debian-10/debian-teamviewer-license-agreement_hu555ef480787c753f23579937b81118e9_103439_600x0_resize_q75_box.jpg 600w,
              /post/how-to-install-teamviewer-on-debian-10/debian-teamviewer-license-agreement.jpg 1039w
            " data-action="zoom"><noscript><img alt="" class="w-full h-full absolute inset-0 m-auto" src="/post/how-to-install-teamviewer-on-debian-10/debian-teamviewer-license-agreement.jpg"></noscript></div></div></figure><p>The application will start, and you’ll see something like the following.</p><figure class="relative"><div class="w-full mx-auto my-0 block relative"><div class="block" style="padding-bottom:82.00192492781521%"></div><div class="w-full h-full absolute inset-0 m-auto overflow-hidden text-center"><img alt="" class="lazyload" src="data:image/gif;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAYAAAAfFcSJAAAADUlEQVR42mP8+PXHfwAJnAPfCuZXlQAAAABJRU5ErkJggg==" data-sizes="auto" data-src="/post/how-to-install-teamviewer-on-debian-10/debian-teamviewer-remote-control_hu29fb1e3818d485845099f5539388ba4d_90819_600x0_resize_q75_box.jpg" data-srcset="
              /post/how-to-install-teamviewer-on-debian-10/debian-teamviewer-remote-control_hu29fb1e3818d485845099f5539388ba4d_90819_600x0_resize_q75_box.jpg 600w,
              /post/how-to-install-teamviewer-on-debian-10/debian-teamviewer-remote-control.jpg 1039w
            " data-action="zoom"><noscript><img alt="" class="w-full h-full absolute inset-0 m-auto" src="/post/how-to-install-teamviewer-on-debian-10/debian-teamviewer-remote-control.jpg"></noscript></div></div></figure><p>That’s it. At this point, you have TeamViewer installed on your Debian desktop. You can now connect to your friends or customers’ computers and provide immediate technical assistance.</p><h2 id="updating-teamviewer">Updating TeamViewer <a href="#updating-teamviewer" class="headline-link" aria-hidden="true">#</a></h2><p>During the installation process, the TeamViewer APT repository will be added to your system. Use the <a href="https://linuxize.com/post/linux-cat-command/">`cat</a> command to verify the file contents:</p><pre class="terminal"><code class="terminal-line" prefix="$">cat /etc/apt/sources.list.d/teamviewer.list</code></pre><pre><code class="language-output" data-lang="output">...
deb http://linux.teamviewer.com/deb stable main
# deb http://linux.teamviewer.com/deb preview main
...
</code></pre><p>When a new version is released, you can update your TeamViewer installation through your desktop Software Update tool, or from the command-line.</p><h2 id="conclusion">Conclusion <a href="#conclusion" class="headline-link" aria-hidden="true">#</a></h2><p>We’ve shown you how to install TeamViewer on your Debian 10 desktop machine. With TeamViewer you can connect to any remote machine, and work on it as if you were sitting right in front of the machine.</p><p>Feel free to leave a comment below.</p><div class="flex flex-wrap my-6"><a href="/tags/teamviewer/" class="text-sm font-medium tracking-wide bg-indigo-700 hover:bg-indigo-800 mr-2 mt-2 px-4 py-2 rounded text-white">teamviewer</a> <a href="/tags/debian/" class="text-sm font-medium tracking-wide bg-indigo-700 hover:bg-indigo-800 mr-2 mt-2 px-4 py-2 rounded text-white">debian</a></div></div></section></div></div></div></div><div class="w-full absolute hidden -mb-16 flex-grow lg:-mb-0 lg:block lg:pt-0 lg:static sidebar top-16 z-40" id="sidebar"><div class="pb-2 bg-gray-200 dark:bg-gray-900 mb-6 p-4 related-content"><p class="dark:text-gray-300 font-medium text-xs xxl:text-sm mb-3 mb-3 text-gray-800 tracking-tight uppercase">Related Tutorials</p><ul class="mt-4 border-gray-400 border-t dark:border-gray-800 mb-0 pt-3"><li class="flex border-gray-400 border-b dark:border-gray-800 mb-2 pb-2"><a href="https://linuxize.com/post/how-to-install-teamviewer-on-debian-9/" class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 font-medium text-gray-700 text-sm">How to Install TeamViewer on Debian 9</a></li><li class="flex border-gray-400 border-b dark:border-gray-800 mb-2 pb-2"><a href="https://linuxize.com/post/how-to-setup-a-firewall-with-ufw-on-debian-10/" class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 font-medium text-gray-700 text-sm">How to Set Up a Firewall with UFW on Debian 10</a></li><li class="flex border-gray-400 border-b dark:border-gray-800 mb-2 pb-2"><a href="https://linuxize.com/post/how-to-install-mono-on-debian-10/" class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 font-medium text-gray-700 text-sm">How to Install Mono on Debian 10</a></li><li class="flex border-gray-400 border-b dark:border-gray-800 mb-2 pb-2"><a href="https://linuxize.com/post/how-to-install-visual-studio-code-on-debian-10/" class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 font-medium text-gray-700 text-sm">How to Install Visual Studio Code on Debian 10</a></li><li class="flex border-gray-400 border-b dark:border-gray-800 mb-2 pb-2"><a href="https://linuxize.com/post/how-to-install-skype-on-debian-10/" class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 font-medium text-gray-700 text-sm">How to Install Skype on Debian 10</a></li><li class="flex border-gray-400 border-b dark:border-gray-800 mb-2 pb-2"><a href="https://linuxize.com/post/how-to-set-or-change-timezone-on-debian-10/" class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 font-medium text-gray-700 text-sm">How to Set or Change Timezone on Debian 10</a></li><li class="flex border-gray-400 border-b dark:border-gray-800 mb-2 pb-2"><a href="https://linuxize.com/post/how-to-install-xrdp-on-debian-10/" class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 font-medium text-gray-700 text-sm">How to Install Xrdp Server (Remote Desktop) on Debian 10</a></li></ul></div><div class="flex flex-col -mt-12 lg:block lg:relative lg:sticky lg:top-16 pt-12"><div class="sideblock"><div class="hidden affiliate"><a href="https://www.vultr.com/?ref=8389060-6G" class="vultr" rel="noopener" target="_blank"></a></div><script src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js" async></script><div class="w-full flex justify-center content-center"><div class="w-full relative"><ins class="block mx-auto adsbygoogle" data-ad-client="ca-pub-9439755881064125" data-ad-format="auto" data-ad-slot="7027266996" data-full-width-responsive="true"></ins></div></div><script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></div></div></div></div></article><div class="px-6"><section class="w-full mx-auto border-gray-200 border-t dark:border-gray-900 mt-8 pt-8 max-w-article"><div class="p-8 dark:bg-gray-900 sm:py-8 bg-orange-100"><p class="dark:text-gray-300 lg:text-base max-w-md mx-auto my-0 sm:text-base text-center text-orange-800 text-sm">If you like our content, please consider buying us a coffee.<br>Thank you for your support!</p><div class="w-full mx-auto flex items-center flex-col max-w-sm sm:flex-row justify-center mt-6"><a href="https://www.buymeacoffee.com/8swZOSU6I" class="inline-flex items-center bg-orange-500 font-medium hover:bg-orange-600 px-4 py-2 rounded text-orange-100" rel="noopener" target="_blank"><svg aria-hidden="true" class="inline-block fill-current h-6 w-6 text-gray-900" role="img"><use xlink:href="/svg/sprite.svg#bmc"></use></svg> <span class="uppercase text-xs font-medium ml-2">Buy me a coffee</span></a></div></div></section><section class="w-full mx-auto border-gray-200 border-t dark:border-gray-900 mt-8 pt-8 max-w-article"><div class="bg-gray-200 dark:bg-gray-900 p-8 sm:py-8"><p class="text-sm mx-auto my-0 lg:text-base max-w-md sm:text-base text-center">Sign up to our newsletter and get our latest tutorials and news straight to your mailbox.</p><form action="https://linuxize.us17.list-manage.com/subscribe/post?u=35cd4cd9d021c25c3dd7cabfd&id=9cfa4c89de" class="pt-8" id="mc-embedded-subscribe-form" method="post" name="mc-embedded-subscribe-form" novalidate><div class="w-full mx-auto flex items-center flex-col max-w-sm sm:flex-row justify-between mb-2"><input class="w-full block bg-white appearance-none border hover:border-gray-700 mb-3 px-4 py-3 rounded sm:mb-0 text-gray-800" name="EMAIL" aria-label="email" placeholder="Your email..." type="email"> <input class="hidden" name="b_35cd4cd9d021c25c3dd7cabfd_9cfa4c89de" tabindex="-1"> <button class="w-full px-4 py-3 rounded bg-indigo-700 hover:bg-indigo-800 sm:ml-4 sm:w-auto text-white tracking-wide" name="subscribe" type="submit"><span class="text-center">Subscribe</span></button></div><p class="w-full mx-auto my-0 max-w-sm text-sm">We’ll never share your email address or spam you.</p></form></div></section><section class="w-full mx-auto border-gray-200 border-t dark:border-gray-900 mt-8 pt-8 max-w-5xl"><div class="flex flex-wrap -mx-4"><a href="https://linuxize.com/post/how-to-install-teamviewer-on-debian-9/" class="w-full flex md:mb-0 md:w-1/3 overflow-hidden px-4 mb-8"><div class="w-full h-full flex flex-col"><p class="dark:text-gray-300 uppercase text-xs font-normal text-gray-700">Jun 16, 2019</p><h2 class="dark:text-gray-300 font-medium text-gray-800 flex-grow mb-2 md:mb-4 text-lg">How to Install TeamViewer on Debian 9</h2><div><figure class="relative"><div class="w-full mx-auto my-0 block relative"><div class="block" style="padding-bottom:53%"></div><div class="w-full h-full absolute inset-0 m-auto overflow-hidden bg-gray-200"><img alt="" class="w-full h-full absolute inset-0 m-auto lazy lazyload" src="data:image/gif;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAYAAAAfFcSJAAAADUlEQVR42mP8+PXHfwAJnAPfCuZXlQAAAABJRU5ErkJggg==" data-sizes="auto" data-src="/post/how-to-install-teamviewer-on-debian-9/featured_hu1671d69987c415ddb47e9530e321e61c_40591_600x0_resize_q95_box.jpg" data-srcset="
              /post/how-to-install-teamviewer-on-debian-9/featured_hu1671d69987c415ddb47e9530e321e61c_40591_600x0_resize_q95_box.jpg 600w,
              /post/how-to-install-teamviewer-on-debian-9/featured.jpg 1000w
            "><noscript><img alt="" class="w-full h-full absolute inset-0 m-auto" src="/post/how-to-install-teamviewer-on-debian-9/featured.jpg"></noscript></div></div></figure></div></div></a><a href="https://linuxize.com/post/how-to-setup-a-firewall-with-ufw-on-debian-10/" class="w-full flex md:mb-0 md:w-1/3 overflow-hidden px-4 mb-8"><div class="w-full h-full flex flex-col"><p class="dark:text-gray-300 uppercase text-xs font-normal text-gray-700">Apr 11, 2020</p><h2 class="dark:text-gray-300 font-medium text-gray-800 flex-grow mb-2 md:mb-4 text-lg">How to Set Up a Firewall with UFW on Debian 10</h2><div><figure class="relative"><div class="w-full mx-auto my-0 block relative"><div class="block" style="padding-bottom:53%"></div><div class="w-full h-full absolute inset-0 m-auto overflow-hidden bg-gray-200"><img alt="" class="w-full h-full absolute inset-0 m-auto lazy lazyload" src="data:image/gif;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAYAAAAfFcSJAAAADUlEQVR42mP8+PXHfwAJnAPfCuZXlQAAAABJRU5ErkJggg==" data-sizes="auto" data-src="/post/how-to-setup-a-firewall-with-ufw-on-debian-10/featured_hub11edbe99ea64dce8af19d72fae133cd_129890_600x0_resize_q95_box.jpg" data-srcset="
              /post/how-to-setup-a-firewall-with-ufw-on-debian-10/featured_hub11edbe99ea64dce8af19d72fae133cd_129890_600x0_resize_q95_box.jpg 600w,
              /post/how-to-setup-a-firewall-with-ufw-on-debian-10/featured.jpg 1000w
            "><noscript><img alt="" class="w-full h-full absolute inset-0 m-auto" src="/post/how-to-setup-a-firewall-with-ufw-on-debian-10/featured.jpg"></noscript></div></div></figure></div></div></a><a href="https://linuxize.com/post/how-to-install-mono-on-debian-10/" class="w-full flex md:mb-0 md:w-1/3 overflow-hidden px-4 mb-0"><div class="w-full h-full flex flex-col"><p class="dark:text-gray-300 uppercase text-xs font-normal text-gray-700">Apr 10, 2020</p><h2 class="dark:text-gray-300 font-medium text-gray-800 flex-grow mb-2 md:mb-4 text-lg">How to Install Mono on Debian 10</h2><div><figure class="relative"><div class="w-full mx-auto my-0 block relative"><div class="block" style="padding-bottom:53%"></div><div class="w-full h-full absolute inset-0 m-auto overflow-hidden bg-gray-200"><img alt="" class="w-full h-full absolute inset-0 m-auto lazy lazyload" src="data:image/gif;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAYAAAAfFcSJAAAADUlEQVR42mP8+PXHfwAJnAPfCuZXlQAAAABJRU5ErkJggg==" data-sizes="auto" data-src="/post/how-to-install-mono-on-debian-10/featured_hu8cfaaec1e9c2b5b172cd9ecd7eeee4d7_18463_600x0_resize_q95_box.jpg" data-srcset="
              /post/how-to-install-mono-on-debian-10/featured_hu8cfaaec1e9c2b5b172cd9ecd7eeee4d7_18463_600x0_resize_q95_box.jpg 600w,
              /post/how-to-install-mono-on-debian-10/featured.jpg 1000w
            "><noscript><img alt="" class="w-full h-full absolute inset-0 m-auto" src="/post/how-to-install-mono-on-debian-10/featured.jpg"></noscript></div></div></figure></div></div></a></div></section><section class="w-full mx-auto relative border-gray-200 border-t dark:border-gray-900 max-w-3xl mt-8 pt-16 py-8"><a href="https://linuxize.com/post/how-to-install-teamviewer-on-debian-10/#disqus_thread" class="w-full block bg-gray-200 dark:bg-gray-900 disqus-comment-count disqus-load md:py-8 py-4 text-center" title="Show comments for post">Write a comment</a><div id="disqus_thread"></div><noscript>Please enable JavaScript to view the <a href="https://disqus.com/?ref_noscript">comments powered by Disqus.</a></noscript></section></div></main><section class="w-full absolute inset-0 bg-white block h-screen hidden search z-100" id="search-box"><div class="flex flex-col min-h-screen"><header class="w-full mx-auto flex items-center h-12 justify-end px-6 sm:h-16 z-10"><a href="#" class="block h-6 sm:h-8" id="btn-search-close"><svg aria-hidden="true" class="inline-block fill-current h-6 w-6 text-gray-900 sm:h-8 sm:w-8" role="img"><use xlink:href="/svg/sprite.svg#close"></use></svg> <small class="block text-center sm:w-8 w-6">ESC</small></a></header><div class="w-full px-6 flex-grow flex-shrink-0 pb-8 pt-16 sm:pt-24"><div class="flex flex-col mx-auto max-w-screen-xl mb-4 mb-8"><div class="searchbox-container" id="searchbox"></div><div class="search-results" id="search-results"></div><div id="hits"></div><div id="stats"></div><footer class="mt-6"><a href="https://github.com/algolia/instantsearch.js/" rel="noopener noreferrer" target="_blank" tabindex="-1"><svg aria-hidden="true" class="inline-block fill-current search-algolia-logo text-gray-700" role="img"><use xlink:href="/svg/sprite.svg#search-by-algolia"></use></svg></a></footer></div></div></div></section><footer class="w-full px-6 bg-gray-100 dark:bg-gray-900"><div class="w-full mx-auto flex items-center justify-center flex-wrap lg:justify-between lg:text-left max-w-screen-xl py-8 text-center"><div class="w-full lg:w-1/2 lg:mb-0 mb-2 text-sm"><div class="w-full block lg:flex lg:items-center lg:w-auto"><div class="lg:flex-grow"><span class="dark:text-gray-300 text-gray-800 mb-2 block lg:inline-block lg:mb-0 lg:mr-8">© 2020 Linuxize.com</span> <a href="/privacy-policy/" class="dark:text-gray-300 dark-hover:text-gray-100 no-underline mr-4 footer-menu-item hover:text-gray-800 inline-block lg:mt-0 text-gray-900">Privacy Policy </a><a href="/contact/" class="dark:text-gray-300 dark-hover:text-gray-100 no-underline footer-menu-item hover:text-gray-800 inline-block lg:mt-0 text-gray-900 mr-0">Contact</a></div></div></div><div class="w-full flex justify-center lg:justify-end lg:w-1/2"><a href="https://twitter.com/linuxize" class="block h-6 mr-2" aria-label="Twitter"><svg aria-hidden="true" class="dark:text-gray-300 inline-block fill-current h-6 w-6 text-gray-900" role="img"><use xlink:href="/svg/sprite.svg#twitter"></use></svg> </a><a href="https://www.facebook.com/linuxize/" class="block h-6 mr-2" aria-label="Facebook"><svg aria-hidden="true" class="dark:text-gray-300 inline-block fill-current h-6 w-6 text-gray-900" role="img"><use xlink:href="/svg/sprite.svg#facebook"></use></svg> </a><a href="/index.xml" class="block h-6" aria-label="RSS"><svg aria-hidden="true" class="dark:text-gray-300 inline-block fill-current h-6 w-6 text-gray-900" role="img"><use xlink:href="/svg/sprite.svg#rss"></use></svg></a></div></div></footer></div><script src="https://cdn.jsdelivr.net/npm/algoliasearch@4.0.0/dist/algoliasearch-lite.umd.js" crossorigin="anonymous" integrity="sha256-MfeKq2Aw9VAkaE9Caes2NOxQf6vUa8Av0JqcUXUGkd0="></script><script src="https://cdn.jsdelivr.net/npm/instantsearch.js@4.2.0/dist/instantsearch.production.min.js" crossorigin="anonymous" integrity="sha256-B+gqnZmUVBAmEIiecyayAjKMHpQjJhlNMly7YIxbdfw="></script><script src="/js/1.2e13fc2667685486d1f2.js"></script><script src="/js/app.79d6e3be2d5f37424f1e.js"></script><script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('edmonton.php', '/detroitchicago/edmonton.webp?a=a&cb=0&shcb=32', true, [], true, false, false, false);
__ez.queue.addFile('jellyfish.php', '/porpoiseant/jellyfish.webp?a=a&cb=0&shcb=32', false, [], true, false, false, false);
</script>

<script>var _audins_dom="linuxize_com",_audins_did=93605;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=188-0");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.linuxize_com,DomainId.93605" border="0" height="1" width="1" alt="Quantcast"/></div></noscript><noscript><img src="https://sb.scorecardresearch.com/p?c1=2&c2=20015427&cv=2.0&cj=1"/></noscript>
<script type='text/javascript' data-cfasync='false'>(function(){function b(a){for(var b=0;b<document.styleSheets.length;b++)if(document.styleSheets[b].href==a)return!0;return!1}var a=function(a,b){for(var d=0;d<b.length;d++){var c=b[d];if(0==c.complete||"undefined"!=typeof c.readyState&&4>c.readyState){var g=c.getAttribute("src")||c.currentSrc;"undefined"!=typeof c.readyState&&0==c.readyState?c.addEventListener("loadstart",function(a){var b=a.getAttribute("src")||a.currentSrc;window.ezorqs(a,b)}):(g=c.getAttribute("src")||c.currentSrc,window.ezorqs(c,
	g));c.addEventListener("load",function(a){var b=a.currentTarget.getAttribute("src")||a.srcElement.currentSrc;window.ezorqe(a,b)});c.addEventListener("loadeddata",function(a){var b=a.currentTarget.getAttribute("src")||a.srcElement.currentSrc;window.ezorqe(a,b)});c.addEventListener("error",function(a){var b=a.currentTarget.getAttribute("src")||a.srcElement.currentSrc;window.ezorqe(a,b)})}}};a("img",document.querySelectorAll("img"));a("video",document.querySelectorAll("video"));a("audio",document.querySelectorAll("audio"));
	(function(a){for(var c=0;c<a.length;c++){var d=a[c];if(("preload"==d.getAttribute("rel")||"stylesheet"==d.getAttribute("rel"))&&null!=d.getAttribute("href")&&b(d.getAttribute("href"))){window.ezorqs(d,d.getAttribute("href"));var e=document.createElement("img");e.onerror=function(a){"undefined"!=typeof a.path&&"undefined"!=typeof a.path[0].currentSrc?window.ezorqe(d,a.path[0].currentSrc):"undefined"!=typeof a.srcElement&&"undefined"!=typeof a.srcElement.href&&window.ezorqe(d,a.srcElement.href)};e.src=
	d.getAttribute("href")}}})(document.querySelectorAll("link"));"undefined"!=typeof window.__ez.ssaf&&-1<window.__ez.ssaf.indexOf(16)&&"undefined"!==typeof window.__ez.sshsdef&&!1===window.__ez.sshsdef&&Element.prototype.addEventListener&&("function"==typeof window.onload&&(window.addEventListener("load",window.onload),window.onload=null),"function"==typeof document.onload&&(document.addEventListener.addEventListener("load",document.onload),document.onload=null))})();</script></body></html>