<!doctype html><html class=no-js lang=en-us><head><meta charset=utf-8>
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=function(){var u=[],i="/porpoiseant/army.gif";function t(e,i,t,_,d,o,n){if(__ez.dot.isDefined(e)&&0!=__ez.dot.isAnyDefined(e.getSlotElementId,e.ElementId)){var r=parseInt(__ez.dot.getTargeting(e,"ap")),a=__ez.dot.getSlotIID(e),s=__ez.dot.getAdUnit(e),p=parseInt(__ez.dot.getTargeting(e,"compid")),z=0,f=0,g=function(e){if("undefined"==typeof _ezim_d)return!1;var i=__ez.dot.getAdUnitPath(e).split("/").pop();if("object"==typeof _ezim_d&&_ezim_d.hasOwnProperty(i))return _ezim_d[i];for(var t in _ezim_d)if(t.split("/").pop()===i)return _ezim_d[t];return!1}(e);"object"==typeof g&&(void 0!==g.creative_id&&(f=g.creative_id),void 0!==g.line_item_id&&(z=g.line_item_id)),__ez.dot.isDefined(a,s)&&__ez.dot.isValid(i)&&u.push({type:"impression",impression_id:a,domain_id:__ez.dot.getDID(),unit:s,t_epoch:__ez.dot.getEpoch(0),revenue:t,est_revenue:_,ad_position:r,ad_size:"",bid_floor_filled:d,bid_floor_prev:o,stat_source_id:n,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:p,line_item_id:z,creative_id:f,data:__ez.dot.dataToStr(i)})}}function _(){if(void 0===document.visibilityState||"prerender"!==document.visibilityState){if(__ez.dot.isDefined(u)&&0<u.length){var e=__ez.dot.getURL(i)+"?orig="+(!0===__ez.template.isOrig?1:0)+"&sts="+btoa(JSON.stringify(u));void 0!==window.isAmp&&isAmp&&void 0!==window._ezaq&&_ezaq.hasOwnProperty("domain_id")&&(e+="&visit_uuid="+_ezaq.visit_uuid),(new Image).src=e}u=[]}}return{Add:t,AddAndFire:function(e,i){t(e,i,0,0,0,0,0),_()},AddById:function(e,i){var t=e.split("/");if(__ez.dot.isDefined(e)&&3===t.length&&__ez.dot.isValid(i)){var _=t[0],d=t[2];u.push({type:"impression",impression_id:d,domain_id:__ez.dot.getDID(),unit:_,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(i)})}},Fire:_,GetPixels:function(){return u}}}();var EzoicPixel=function(){this.pixels=[],this.pixelUrl="/ezoic/e.gif",("undefined"!=typeof ezJsu&&!0===ezJsu||"undefined"!=typeof _ez_sa&&!0===_ez_sa||void 0!==window.isAmp&&!0===isAmp||"undefined"!=typeof ezWp&&!0===ezWp)&&(this.pixelUrl="//g.ezoic.net"+this.pixelUrl),this.tEpoch=0,"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("t_epoch")&&(this.tEpoch=_ezaq.t_epoch)},EzoicPixelData=function(e,i){this.name=e,this.val=i};EzoicPixel.prototype={constructor:EzoicPixel,AddAndFireImpPixel:function(e,i){this.AddImpPixel(e,i,0,0,0,0,0),this.FirePixels()},AddAndFirePVPixel:function(e,i){this.AddPVPixel(e,i),this.FirePixels()},AddImpPixel:function(e,i,t,n,o,a,d){if(0!=__ez.dot.isDefined(e)&&0!=__ez.dot.isAnyDefined(e.getSlotElementId,e.ElementId)){var s=parseInt(__ez.dot.getTargeting(e,"ap")),r=__ez.dot.getSizes(e)[0],_=r.l.toString()+"x"+r.j.toString(),p="0",l="XX";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(p=_ezaq.domain_id.toString()),"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("country")&&(l=_ezaq.country);var h=__ez.dot.getSlotIID(e),c=__ez.dot.getSlotElementId(e);__ez.dot.isDefined(h,c)&&this.validateData(i)&&(i=this.convertDataToStr(i),this.pixels.push({type:"impression",impression_id:h,domain_id:p,unit:c,t_epoch:this.tEpoch,revenue:t,est_revenue:n,ad_position:s,ad_size:_,bid_floor_filled:o,bid_floor_prev:a,stat_source_id:d,country_code:l,data:i}))}},AddImpPixelById:function(e,i){var t="0";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(t=_ezaq.domain_id.toString());var n=e.split("/");if(__ez.dot.isDefined(e)&&3===n.length&&this.validateData(i)){var o=n[0],a=n[2];i=this.convertDataToStr(i),this.pixels.push({type:"impression",impression_id:a,domain_id:t,unit:o,t_epoch:this.tEpoch,data:i})}},AddPVPixel:function(e,i){var t="0";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(t=_ezaq.domain_id.toString()),__ez.dot.isDefined(e)&&this.validateData(i)&&(i=this.convertDataToStr(i),this.pixels.push({type:"pageview",pageview_id:e,domain_id:t,t_epoch:this.tEpoch,data:i}))},FirePixels:function(){void 0!==document.visibilityState&&"prerender"===document.visibilityState||(__ez.dot.isDefined(this.pixels)&&0<this.pixels.length&&((new Image).src=this.pixelUrl+"?orig="+(!0===__ez.template.isOrig?1:0)+"&pixels="+encodeURIComponent(JSON.stringify(this.pixels))),this.pixels=[])},NewData:function(e,i){return new EzoicPixelData(e,i)},convertDataToStr:function(e){if(void 0===e)return[];try{for(var i in e)e[i].val=e[i].val+""}catch(e){}return e},validateData:function(e){for(var i=0;i<e.length;i++)if(e[i]instanceof EzoicPixelData==!1)return console.error("Invalid pixelData. ",e[i]),!1;return!0}};</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">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</script><title>How to Install Gitea on Ubuntu 18.04 | Linuxize</title><meta content="IE=edge" http-equiv=X-UA-Compatible><meta content="width=device-width,initial-scale=1,shrink-to-fit=no" name=viewport><meta content=Linuxize name=apple-mobile-web-app-title><meta content=Linuxize name=application-name><meta content=#2271ff name=theme-color><meta content=#2271ff name=msapplication-TileColor><meta content="This tutorial explains how to install and configure Gitea on Ubuntu 18.04. Gitea is a self-hosted open source git server written in Go." name=description><meta content=$coil.xrptipbot.com/zcpKbIbXTOOdckFuNg5Pew name=monetization><meta content=unsafe-url name=referrer><link href=https://linuxize.com/post/how-to-install-gitea-on-ubuntu-18-04/ rel=canonical><meta content="index, follow" name=robots><meta content="How to Install Gitea on Ubuntu 18.04" property=og:title><meta content="This tutorial explains how to install and configure Gitea on Ubuntu 18.04. Gitea is a self-hosted open source git server written in Go." property=og:description><meta content=article property=og:type><meta content=/post/how-to-install-gitea-on-ubuntu-18-04/ property=og:url><meta content=https://linuxize.com/post/how-to-install-gitea-on-ubuntu-18-04/featured.jpg property=og:image><meta content="This tutorial explains how to install and configure Gitea on Ubuntu 18.04. Gitea is a self-hosted open source git server written in Go." property=og:image:alt><meta content=2020-01-04T20:14:15+01:00 property=article:published_time><meta content=2020-01-04T20:14:15+01:00 property=article:modified_time><meta content=en property=og:locale><meta content=post property=article:section><meta content=https://www.facebook.com/linuxize property=article:publisher><meta content=ubuntu property=article:tag><meta content=git property=article:tag><meta content=gitea property=article:tag><meta content=ubuntu,git,gitea name=news_keywords><meta content=summary_large_image name=twitter:card><meta content=https://linuxize.com/post/how-to-install-gitea-on-ubuntu-18-04/featured.jpg name=twitter:image><meta content="How to Install Gitea on Ubuntu 18.04" name=twitter:title><meta content="This tutorial explains how to install and configure Gitea on Ubuntu 18.04. Gitea is a self-hosted open source git server written in Go." name=twitter:description><meta content=@linuxize name=twitter:site><link href=/favicons/apple-touch-icon.png rel=apple-touch-icon sizes=180x180><link href=/favicons/favicon-32x32.png rel=icon sizes=32x32 type=image/png><link href=/favicons/favicon-16x16.png rel=icon sizes=16x16 type=image/png><link href=/favicons/safari-pinned-tab.svg rel=mask-icon color=#2271ff><link href=//fonts.gstatic.com rel=preconnect crossorigin=""><link href=//fonts.googleapis.com rel=preconnect crossorigin=""><link href=//www.googletagmanager.com rel=preconnect crossorigin=""><link href=//www.google-analytics.com rel=preconnect crossorigin=""><link href=//pagead2.googlesyndication.com rel=preconnect crossorigin=""><link href=//sdki.truepush.com rel=preconnect crossorigin=""><link href="https://fonts.googleapis.com/css?family=Hind:400,500,600,700|Roboto+Mono:400,400i,700,700i|Roboto:400,400i,500,700,700i&display=swap" rel=stylesheet><script type=application/ld+json>{
  "@context": "http://schema.org",
  "@type": "BlogPosting",
  "headline": "How to Install Gitea on Ubuntu 18.04",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https:\/\/linuxize.com\/post\/how-to-install-gitea-on-ubuntu-18-04\/"
  },"image": {
     "@type": "ImageObject",
     "url": "https:\/\/linuxize.com\/post\/how-to-install-gitea-on-ubuntu-18-04\/featured.jpg",
     "width":  1000 ,
     "height":  530 
    },"keywords": "ubuntu, git, gitea",
  "wordcount":  1297 ,
  "url": "https:\/\/linuxize.com\/post\/how-to-install-gitea-on-ubuntu-18-04\/",
  "datePublished": "2020-01-04T20:14:15+01:00",
  "dateModified": "2020-01-04T20:14:15+01:00",
  "publisher": {
    "@type": "Organization","logo": {
    "@type": "imageObject",
      "url": "https:\/\/linuxize.com\/assets\/linuxize-card.png"
    },"name": "Linuxize"
  },

  "author": {
    "@type": "Person",
    "name": "Linuxize"
  },
  "description": "This tutorial explains how to install and configure Gitea on Ubuntu 18.04. Gitea is a self-hosted open source git server written in Go."
}</script><script src=/js/ads.js async></script><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-P827G6S');</script><script src=https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js async></script><script>(adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-9439755881064125",
          enable_page_level_ads: true
     });</script><script src=https://sdki.truepush.com/sdk/v2.0.2/app.js async></script><script>var truepush = window.truepush || [];
truepush.push(function(){
    truepush.Init({
        id: "5df40b77a46c3c43f5357dd5"
        }, function(error){
          if(error) console.error(error);
        })
    })</script><meta content=#2271ff name=theme-color><link href=/manifest.128dc4ca8d47b9db75ffbc72b588021a.json rel=manifest><link href=/css/app.4ae77aedfd5393611a77.css rel=stylesheet><link rel='canonical' href='https://linuxize.com/post/how-to-install-gitea-on-ubuntu-18-04/' />

<script data-ezscrex="false" data-cfasync="false" type="text/javascript">window.google_analytics_uacct = "UA-124335151-13";</script>
<script data-ezscrex="false" data-cfasync="false" type="text/javascript">
var _gaq = _gaq || [];
_gaq.push(['e._setAccount', 'UA-124335151-13']);
_gaq.push(['f._setAccount', 'UA-38339005-1']);
_gaq.push(['e._setDomainName', 'linuxize.com']);
_gaq.push(['f._setDomainName', 'linuxize.com']);
_gaq.push(['e._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['e._setCustomVar',2,'t','126',3]);
_gaq.push(['e._setCustomVar',3,'rid','0',2]);
_gaq.push(['e._setCustomVar',4,'bra','mod36-c',3]);
_gaq.push(['e._setAllowAnchor',true]);
_gaq.push(['e._setSiteSpeedSampleRate', 10]);
_gaq.push(['f._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['f._setCustomVar',2,'domain','linuxize.com',3]);
_gaq.push(['f._setSiteSpeedSampleRate', 20]);
_gaq.push(['e._trackPageview']);
_gaq.push(['f._trackPageview']);


(function() {
 var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
 ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
 var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
})();
</script>
<script type="text/javascript">var ezouid = "1";</script><base href="https://linuxize.com/post/how-to-install-gitea-on-ubuntu-18-04/"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 93605;
var ezdomain = 'linuxize.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":93605,"engaged_time_visit":0,"ezcache_level":1,"forensiq_score":-1,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"990ff81b-ed72-4a00-6567-faf1bab7be9a","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_time_orig":7,"serverid":"3.83.146.42:18841","state":"VA","t_epoch":1578289869,"template_id":126,"time_on_site_visit":0,"url":"https://linuxize.com/post/how-to-install-gitea-on-ubuntu-18-04/","user_id":0,"word_count":1575,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script><script data-ezscrex='false' data-cfasync='false' type="text/javascript" src="/detroitchicago/rochester.js?cb=188-0&v=8" async></script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl() {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_93605=" + new Date().getTime() + "|990ff81b-ed72-4a00-6567-faf1bab7be9a; " + expires, 3);
}
function attach_ezolpl() {
    if(window.attachEvent) {
        window.attachEvent('onload', create_ezolpl);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl();
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl;
        }
    }
}
attach_ezolpl();
</script></head><body class="font-sans kind-page leading-normal section-post type-post"><div class="flex flex-col min-h-screen main-wrap"><header class="w-full dark:border-gray-900 border-b border-gray-400 fixed header linuxize-shadow px-6 z-50" id=header><nav class="w-full mx-auto flex items-center h-12 justify-start md:h-16"><a href=/ class="flex items-center block dark:text-gray-200 flex-shrink-0 logo mr-6 no-underline text-black" aria-label=Linuxize.com><svg aria-hidden=true class="h-6 w-6 fill-current md:h-8 md:w-8 mr-2" role=img><use xlink:href=/svg/sprite.svg#logo></use></svg> <span class="font-medium hidden md:block text-md tracking-tight">Linuxize</span></a><div class="flex -mb-px flex-1 min-w-0 text-sm"><a href=/tags/ubuntu/ class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 hidden md:block mr-4 no-underline text-gray-800"><span class="py-3 font-bold inline-block md:py-4 md:py-6">Ubuntu </span></a><a href=/tags/centos/ class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 hidden md:block mr-4 no-underline text-gray-800"><span class="py-3 font-bold inline-block md:py-4 md:py-6">Centos </span></a><a href=/tags/debian/ class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 hidden md:block mr-4 no-underline text-gray-800"><span class="py-3 font-bold inline-block md:py-4 md:py-6">Debian </span></a><a href=/tags/terminal/ class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 hidden md:block mr-4 no-underline text-gray-800"><span class="py-3 font-bold inline-block md:py-4 md:py-6">Commands </span></a><a href=/series/ class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 hidden md:block mr-4 no-underline text-gray-800"><span class="py-3 font-bold inline-block md:py-4 md:py-6">Series </span></a><a href=https://www.buymeacoffee.com/8swZOSU6I class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 hidden md:block mr-4 no-underline text-gray-800 mr-0"><span class="py-3 font-bold inline-block md:py-4 md:py-6">Donate</span></a></div><div class="flex justify-end"><button class="block h-6" id=btn-search aria-label=Search><svg aria-hidden=true class="dark:text-gray-300 inline-block fill-current h-6 w-6 text-gray-900" role=img><use xlink:href=/svg/sprite.svg#search></use></svg></button> <button class="ml-2 mode-toggle" id=mode-toggle><div class=mode-toggle-icons><svg aria-hidden=true class="dark:text-gray-300 inline-block fill-current h-6 w-6 text-gray-900" role=img><use xlink:href=/svg/sprite.svg#moon></use></svg> <svg aria-hidden=true class="dark:text-gray-300 inline-block fill-current h-6 w-6 text-gray-900" role=img><use xlink:href=/svg/sprite.svg#sun></use></svg></div></button></div></nav></header><main class="w-full flex-grow flex-shrink-0 pb-8 pt-16 sm:pt-24 main"><article class="relative single-post"><div class="w-full mx-auto px-6 post-width"><div class="relative mb-4 post-header xl:mb-8 z-40"><h1 class="font-semibold leading-none lg:text-3xl mb-2 text-2xl xxl:text-4xl">How to Install Gitea on Ubuntu 18.04</h1><div class="flex flex-col dark:text-gray-300 font-medium md:flex-row text-gray-700 text-xs"><div class="inline-flex flex-row"><p class="font-medium text-xs leading-normal rounded-sm"><span>Posted </span><time class="" datetime=2020-01-04T20:14:15+01:00>Jan 4, 2020</time></p><span class="mx-2 inline-block">•</span><p>7 min read</p></div></div></div><div class=lg:flex><div class="w-full lg:max-h-full lg:overflow-visible lg:static min-h-screen"><div class=flex><div class="w-full pb-8"><div class="flex flex-col xl:flex-relative xl:flex-row"><aside class="w-full block hidden sidebar2 xxl:block" id=sidebar2><div class="w-full flex justify-center content-center"><div class="w-full relative"><ins class="hidden adsbygoogle mx-auto sidebar2-as xl:block" data-ad-client=ca-pub-9439755881064125 data-ad-format=horizontal,rectangle data-ad-slot=4501323511 data-full-width-responsive=true style=display:block></ins></div></div><div class="w-full -mt-12 flex-col hidden justify-between pb-4 pt-12 sticky top-16 xl:flex"><div class="bg-gray-200 dark:bg-gray-900 mb-6 p-4 pb-2 overflow-auto table-of-contents toc"><p class="font-medium text-xs mb-3 mb-3 text-gray-800 tracking-tight uppercase xxl:text-sm dark:text-gray-200">Contents</p><div class="relative overflow-hidden"><div class="lg:max-h-toc overflow-y-auto scrollbar-thumb-gray scrollbar-thumb-rounded scrollbar-track-gray-lighter scrollbar-w-2 scrolling-touch"><nav id=TableOfContents><ul><li><a href=#prerequisites>Prerequisites</a></li><li><a href=#installing-gitea>Installing Gitea</a><ul><li><a href=#install-git>Install Git</a></li><li><a href=#create-a-git-user>Create a Git user</a></li><li><a href=#download-gitea-binary>Download Gitea binary</a></li><li><a href=#create-a-systemd-unit-file>Create a Systemd Unit File</a></li><li><a href=#configure-gitea>Configure Gitea</a></li></ul></li><li><a href=#configuring-nginx-as-ssl-termination-proxy>Configuring Nginx as SSL Termination Proxy</a></li><li><a href=#configuring-email-notifications>Configuring Email Notifications</a></li><li><a href=#upgrading-gitea>Upgrading Gitea</a></li><li><a href=#conclusion>Conclusion</a></li></ul></nav></div></div><div class="flex border-gray-400 border-t dark:border-gray-900 items-center justify-content mb-3 mr-2 pt-4 tracking-tight"><p class="font-medium text-xs mr-4 uppercase xxl:text-sm">Share:</p><section class="w-full mx-auto"><nav class="flex flex-wrap"><a href="https://twitter.com/share?text=How%20to%20Install%20Gitea%20on%20Ubuntu%2018.04&url=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-install-gitea-on-ubuntu-18-04%2f" class="h-6 w-6 mr-3" rel=noopener target=_blank><svg aria-hidden=true class="dark:text-gray-300 inline-block fill-current h-6 w-6 hover:text-blue-600 text-gray-600" role=img><use xlink:href=/svg/sprite.svg#twitter></use></svg> </a><a href="https://www.facebook.com/sharer/sharer.php?caption=How%20to%20Install%20Gitea%20on%20Ubuntu%2018.04&u=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-install-gitea-on-ubuntu-18-04%2f" class="h-6 w-6 mr-3" rel=noopener target=_blank><svg aria-hidden=true class="dark:text-gray-300 inline-block fill-current h-6 w-6 hover:text-blue-600 text-gray-600" role=img><use xlink:href=/svg/sprite.svg#facebook></use></svg> </a><a href="https://pinterest.com/pin/create/button/?url=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-install-gitea-on-ubuntu-18-04%2f&media=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-install-gitea-on-ubuntu-18-04%2ffeatured.jpg&description=How%20to%20Install%20Gitea%20on%20Ubuntu%2018.04" class="h-6 w-6 mr-3" rel=noopener target=_blank><svg aria-hidden=true class="dark:text-gray-300 inline-block fill-current h-6 w-6 hover:text-blue-600 text-gray-600" role=img><use xlink:href=/svg/sprite.svg#pinterest></use></svg> </a><a href="mailto:?subject=How%20to%20Install%20Gitea%20on%20Ubuntu%2018.04&body=Check%20out%20this%20article:%0A%0Ahttps%3a%2f%2flinuxize.com%2fpost%2fhow-to-install-gitea-on-ubuntu-18-04%2f" class="h-6 w-6" rel=noopener target=_blank><svg aria-hidden=true class="dark:text-gray-300 inline-block fill-current h-6 w-6 hover:text-blue-600 text-gray-600" role=img><use xlink:href=/svg/sprite.svg#email></use></svg></a></nav></section></div></div></div></aside><section class="w-full mx-auto lg:ml-0 lg:mr-auto lg:pr-6 min-w-0 xl:mx-0 xl:w-full xxl:px-6"><figure class="relative -mx-6 lg:mx-0 mb-6"><div class="w-full mx-auto my-0 block relative"><div class=block style=padding-bottom:53%></div><div class="w-full h-full absolute inset-0 m-auto overflow-hidden bg-gray-200"><img alt="" class="w-full h-full absolute inset-0 m-auto lazy lazyload" src="data:image/gif;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAYAAAAfFcSJAAAADUlEQVR42mP8+PXHfwAJnAPfCuZXlQAAAABJRU5ErkJggg==" data-sizes=auto data-src=/post/how-to-install-gitea-on-ubuntu-18-04/featured_hu1bb10650272de842f93c68a3c7255b5c_21127_600x0_resize_q95_box.jpg data-srcset="
              /post/how-to-install-gitea-on-ubuntu-18-04/featured_hu1bb10650272de842f93c68a3c7255b5c_21127_600x0_resize_q95_box.jpg 600w,
              /post/how-to-install-gitea-on-ubuntu-18-04/featured.jpg 1000w
            "><noscript><img alt="" class="w-full h-full absolute inset-0 m-auto" src=/post/how-to-install-gitea-on-ubuntu-18-04/featured.jpg></noscript></div></div></figure><div class=markdown><p>Gitea is a self-hosted open source git server written in Go. It is a fork of <a href=https://linuxize.com/post/how-to-install-and-configure-gogs-on-ubuntu-18-04/ >Gogs</a>. Gitea includes a repository file editor, project issue tracking, users managements, notifications, built-in wiki, and much more.</p><p><a href=https://gitea.io/ >Gitea</a> is a lightweight application and can be installed on low-powered systems. If you are searching for an alternative to Gitlab with a much smaller memory footprint and you don't need all the bells and whistles that <a href=https://linuxize.com/post/how-to-install-and-configure-gitlab-on-ubuntu-18-04/ >Gitlab</a> offers, then you should definitely try Gitea.</p><p>This tutorial explains how to install and configure Gitea on Ubuntu 18.04. The same instructions apply for Ubuntu 16.04 and any other Debian-based distribution.</p><h2 id=prerequisites>Prerequisites <a href=#prerequisites class=headline-link aria-hidden=true>#</a></h2><p>Gitea supports SQLite, <a href=https://linuxize.com/post/how-to-install-postgresql-on-ubuntu-18-04/ >PostgreSQL</a>, and <a href=https://linuxize.com/post/how-to-install-mysql-on-ubuntu-18-04/ >MySQL</a>/<a href=https://linuxize.com/post/how-to-install-mariadb-on-ubuntu-18-04/ >MariaDB</a> as database backends.</p><p>We'll use SQLite as the database for Gitea. If SQLite is not installed on your Ubuntu system you can install it by entering the following commands as <a href=https://linuxize.com/post/how-to-create-a-sudo-user-on-ubuntu/ >sudo user</a>:</p><pre class=terminal><code class=terminal-line prefix=$>sudo apt update</code><code class=terminal-line prefix=$>sudo apt install sqlite3</code></pre><h2 id=installing-gitea>Installing Gitea <a href=#installing-gitea class=headline-link aria-hidden=true>#</a></h2><p>Gitea provides Docker images and can be installed from source, binary, and as a package.</p><p>We'll install Gitea from binary. Complete the following steps to install Gitea on Ubuntu.</p><h3 id=install-git>Install Git <a href=#install-git class=headline-link aria-hidden=true>#</a></h3><p>The first step is to <a href=https://linuxize.com/post/how-to-install-git-on-ubuntu-18-04/ >install Git</a> on your server:</p><pre class=terminal><code class=terminal-line prefix=$>sudo apt update</code><code class=terminal-line prefix=$>sudo apt install git</code></pre><p>Verify the installation by displaying the Git version:</p><pre class=terminal><code class=terminal-line prefix=$>git --version</code></pre><pre><code class=language-output data-lang=output>git version 2.17.1
</code></pre><h3 id=create-a-git-user>Create a Git user <a href=#create-a-git-user class=headline-link aria-hidden=true>#</a></h3><p><a href=https://linuxize.com/post/how-to-add-and-delete-users-on-ubuntu-18-04/ >Create a new system user</a> which will run the Gitea application by typing:</p><pre class=terminal><code class=terminal-line prefix=$>sudo adduser --system --group --disabled-password --shell /bin/bash --home /home/git --gecos 'Git Version Control' git</code></pre><p>The command will create a new user and group named <code>git</code>, and set the home directory to <code>/home/git</code>. The output will look something like below:</p><pre><code class=language-output data-lang=output>Adding system user `git' (UID 111) ...
Adding new group `git' (GID 116) ...
Adding new user `git' (UID 111) with group `git' ...
Creating home directory `/home/git' ...
</code></pre><h3 id=download-gitea-binary>Download Gitea binary <a href=#download-gitea-binary class=headline-link aria-hidden=true>#</a></h3><p>Visit the <a href=https://dl.gitea.io/gitea/ >Gitea Download page</a> and download the latest binary for your architecture. At the time of writing, the latest version is 1.10.2. If there is a new version available, change the <code>VERSION</code> variable in the command below.</p><p>Download the Gitea binary in the <code>/tmp</code> directory using the following <a href=https://linuxize.com/post/wget-command-examples/ ><code>wget</code></a> command:</p><pre class=terminal><code class=terminal-line prefix=$>VERSION=1.10.2</code><code class=terminal-line prefix=$>sudo wget -O /tmp/gitea https://dl.gitea.io/gitea/${VERSION}/gitea-${VERSION}-linux-amd64</code></pre><p>The <code>gitea</code> binary can run from any location. We'll follow the convention and move the binary to the <code>/usr/local/bin</code> directory:</p><pre class=terminal><code class=terminal-line prefix=$>sudo mv /tmp/gitea /usr/local/bin</code></pre><p>Make the binary executable:</p><pre class=terminal><code class=terminal-line prefix=$>sudo chmod +x /usr/local/bin/gitea</code></pre><p>Run the commands below to create the directories and set the required permissions and <a href=https://linuxize.com/post/linux-chown-command/ >ownership</a>:</p><pre class=terminal><code class=terminal-line prefix=$>sudo mkdir -p /var/lib/gitea/{custom,data,indexers,public,log}</code><code class=terminal-line prefix=$>sudo chown git: /var/lib/gitea/{data,indexers,log}</code><code class=terminal-line prefix=$>sudo chmod 750 /var/lib/gitea/{data,indexers,log}</code><code class=terminal-line prefix=$>sudo mkdir /etc/gitea</code><code class=terminal-line prefix=$>sudo chown root:git /etc/gitea</code><code class=terminal-line prefix=$>sudo chmod 770 /etc/gitea</code></pre><p>The directory structure above is recommended by the official Gitea documentation.</p><p>The permissions of the <code>/etc/gitea</code> directory are set to <code>770</code> so that the installation wizard can create the configuration file. Once the installation is complete, we'll set more restrictive permissions.</p><h3 id=create-a-systemd-unit-file>Create a Systemd Unit File <a href=#create-a-systemd-unit-file class=headline-link aria-hidden=true>#</a></h3><p>Gitea provides a Systemd unit file that is already configured to match our setup.</p><p>Download the file to the <code>/etc/systemd/system/</code> directory by typing:</p><pre class=terminal><code class=terminal-line prefix=$>sudo wget https://raw.githubusercontent.com/go-gitea/gitea/master/contrib/systemd/gitea.service -P /etc/systemd/system/</code></pre><p>Once done, enable and start the Gitea service:</p><pre class=terminal><code class=terminal-line prefix=$>sudo systemctl daemon-reload</code><code class=terminal-line prefix=$>sudo systemctl enable --now gitea</code></pre><p>Verify that the service is started successfully:</p><pre><code class=language-output data-lang=output>● gitea.service - Gitea (Git with a cup of tea)
   Loaded: loaded (/etc/systemd/system/gitea.service; enabled; vendor preset: enabled)
   Active: active (running) since Sat 2020-01-04 21:27:23 UTC; 3s ago
 Main PID: 14804 (gitea)
    Tasks: 9 (limit: 1152)
   CGroup: /system.slice/gitea.service
           └─14804 /usr/local/bin/gitea web --config /etc/gitea/app.ini
...
</code></pre><h3 id=configure-gitea>Configure Gitea <a href=#configure-gitea class=headline-link aria-hidden=true>#</a></h3><p>Now that Gitea is downloaded and running, it is time to finalize the installation through the web interface.</p><p>By default, Gitea listens for connections on port <code>3000</code> on all network interfaces.</p><p>If you have a <a href=https://linuxize.com/post/how-to-setup-a-firewall-with-ufw-on-ubuntu-18-04/ >UFW firewall</a> running on your server, you'll need to open the Gitea port:</p><p>To allow traffic on port <code>3000</code>, enter the following command:</p><pre class=terminal><code class=terminal-line prefix=$>sudo ufw allow 3000/tcp</code></pre><p>Open your browser, type <code>http://YOUR_DOMAIN_IR_IP:3000</code>, and a screen similar to the following will appear:</p><figure class=relative><div class="w-full mx-auto my-0 block relative"><div class=block style=padding-bottom:110.50295857988165%></div><div class="w-full h-full absolute inset-0 m-auto overflow-hidden text-center"><img alt="" class=lazyload src="data:image/gif;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAYAAAAfFcSJAAAADUlEQVR42mP8+PXHfwAJnAPfCuZXlQAAAABJRU5ErkJggg==" data-sizes=auto data-src=/post/how-to-install-gitea-on-ubuntu-18-04/gitea-install_hu0fef48a1a4fc23c829fe9e7f27f3c37c_115259_600x0_resize_q75_box.jpg data-srcset="
              /post/how-to-install-gitea-on-ubuntu-18-04/gitea-install_hu0fef48a1a4fc23c829fe9e7f27f3c37c_115259_600x0_resize_q75_box.jpg 600w,
              /post/how-to-install-gitea-on-ubuntu-18-04/gitea-install.jpg 1352w
            " data-action=zoom><noscript><img alt="" class="w-full h-full absolute inset-0 m-auto" src=/post/how-to-install-gitea-on-ubuntu-18-04/gitea-install.jpg></noscript></div></div></figure><p>Database Settings:</p><ul><li>Database Type: SQLite3</li><li>Path: Use an absolute path, <code>/var/lib/gitea/data/gitea.db</code></li></ul><p>Application General Settings:</p><ul><li>Site Title: Enter your organization name.</li><li>Repository Root Path: Leave the default <code>/home/git/gitea-repositories</code>.</li><li>Git LFS Root Path: Leave the default <code>/var/lib/gitea/data/lfs</code>.</li><li>Run As Username: git</li><li>SSH Server Domain: Enter your domain or server IP address.</li><li>SSH Port: 22, change it if SSH is <a href=https://linuxize.com/post/check-listening-ports-linux/ >listening on other Port</a></li><li>Gitea HTTP Listen Port: 3000</li><li>Gitea Base URL: Use http and your domain or server IP address.</li><li>Log Path: Leave the default <code>/var/lib/gitea/log</code></li></ul><div class="my-6 bg-yellow-100 border-l-4 border-yellow-400 dark:bg-gray-800 dark:border-0 dark:text-yellow-200 note p-6"><div class=flex><div class="w-full text-sm font-sans">You can change the settings at any time by editing the Gitea configuration file.</div></div></div><p>Once done, hit the “Install Gitea” button. The installation is instant. When completed you will be redirected to the login page.</p><p>Click on the “Sign up now” link. The first registered user is automatically added to the Admin group.</p><p>Change the <a href=https://linuxize.com/post/chmod-command-in-linux/ >permissions</a> of the Gitea configuration file to read-only using:</p><pre class=terminal><code class=terminal-line prefix=$>sudo chmod 750 /etc/gitea</code><code class=terminal-line prefix=$>sudo chmod 640 /etc/gitea/app.ini</code></pre><p>That's it. Gitea has been installed on your Ubuntu machine.</p><h2 id=configuring-nginx-as-ssl-termination-proxy>Configuring Nginx as SSL Termination Proxy <a href=#configuring-nginx-as-ssl-termination-proxy class=headline-link aria-hidden=true>#</a></h2><p>This step is optional, but it is highly recommended. To use <a href=https://linuxize.com/post/nginx-reverse-proxy/ >Nginx as a reverse proxy</a> you need to have a domain or subdomain pointing to your server public IP. In this tutorial, we will use <code>git.example.com</code>.</p><p>First, install Nginx and generate a free Let's Encrypt SSL certificate using the guides below:</p><ul><li><a href=https://linuxize.com/post/how-to-install-nginx-on-ubuntu-18-04/ >How To Install Nginx on Ubuntu 18.04</a></li><li><a href=https://linuxize.com/post/secure-nginx-with-let-s-encrypt-on-ubuntu-18-04/ >Secure Nginx with Let's Encrypt on Ubuntu 18.04</a></li></ul><p>Once done, open your text editor and edit the domain <a href=https://linuxize.com/post/how-to-set-up-nginx-server-blocks-on-ubuntu-18-04/ >server block</a> file:</p><pre class=terminal><code class=terminal-line prefix=$>sudo nano /etc/nginx/sites-enabled/git.example.com</code></pre><div class=code-label>/etc/nginx/sites-enabled/git.example.com</div><div class=highlight><pre class=chroma><code class=language-nginx data-lang=nginx><span class=k>server</span> <span class=p>{</span>
    <span class=kn>listen</span> <span class=mi>80</span><span class=p>;</span>
    <span class=kn>server_name</span> <span class=s>git.example.com</span><span class=p>;</span>

    <span class=kn>include</span> <span class=s>snippets/letsencrypt</span><span class=s>.conf</span><span class=p>;</span>
    <span class=kn>return</span> <span class=mi>301</span> <span class=s>https://git.example.com</span><span class=nv>$request_uri</span><span class=p>;</span>
<span class=p>}</span>

<span class=k>server</span> <span class=p>{</span>
    <span class=kn>listen</span> <span class=mi>443</span> <span class=s>ssl</span> <span class=s>http2</span><span class=p>;</span>
    <span class=kn>server_name</span> <span class=s>git.example.com</span><span class=p>;</span>

    <span class=kn>proxy_read_timeout</span> <span class=s>720s</span><span class=p>;</span>
    <span class=kn>proxy_connect_timeout</span> <span class=s>720s</span><span class=p>;</span>
    <span class=kn>proxy_send_timeout</span> <span class=s>720s</span><span class=p>;</span>

    <span class=kn>client_max_body_size</span> <span class=mi>50m</span><span class=p>;</span>

    <span class=c1># Proxy headers
</span><span class=c1></span>    <span class=kn>proxy_set_header</span> <span class=s>X-Forwarded-Host</span> <span class=nv>$host</span><span class=p>;</span>
    <span class=kn>proxy_set_header</span> <span class=s>X-Forwarded-For</span> <span class=nv>$proxy_add_x_forwarded_for</span><span class=p>;</span>
    <span class=kn>proxy_set_header</span> <span class=s>X-Forwarded-Proto</span> <span class=nv>$scheme</span><span class=p>;</span>
    <span class=kn>proxy_set_header</span> <span class=s>X-Real-IP</span> <span class=nv>$remote_addr</span><span class=p>;</span>

    <span class=c1># SSL parameters
</span><span class=c1></span>    <span class=kn>ssl_certificate</span> <span class=s>/etc/letsencrypt/live/git.example.com/fullchain.pem</span><span class=p>;</span>
    <span class=kn>ssl_certificate_key</span> <span class=s>/etc/letsencrypt/live/git.example.com/privkey.pem</span><span class=p>;</span>
    <span class=kn>ssl_trusted_certificate</span> <span class=s>/etc/letsencrypt/live/git.example.com/chain.pem</span><span class=p>;</span>
    <span class=kn>include</span> <span class=s>snippets/letsencrypt</span><span class=s>.conf</span><span class=p>;</span>
    <span class=kn>include</span> <span class=s>snippets/ssl</span><span class=s>.conf</span><span class=p>;</span>

    <span class=c1># log files
</span><span class=c1></span>    <span class=kn>access_log</span> <span class=s>/var/log/nginx/git.example.com.access.log</span><span class=p>;</span>
    <span class=kn>error_log</span> <span class=s>/var/log/nginx/git.example.com.error.log</span><span class=p>;</span>

    <span class=c1># Handle / requests
</span><span class=c1></span>    <span class=kn>location</span> <span class=s>/</span> <span class=p>{</span>
       <span class=kn>proxy_redirect</span> <span class=no>off</span><span class=p>;</span>
       <span class=kn>proxy_pass</span> <span class=s>http://127.0.0.1:3000</span><span class=p>;</span>
    <span class=p>}</span>
<span class=p>}</span>
</code></pre></div><p>Don’t forget to replace git.example.com with your Gitea domain and set the correct path to the SSL certificate files. The <a href=https://linuxize.com/post/redirect-http-to-https-in-nginx/ >HTTP traffic is redirected to HTTPS</a></p><p><a href=https://linuxize.com/post/nginx-commands-you-should-know/ >Restart the Nginx service</a> for changes to take effect:</p><pre class=terminal><code class=terminal-line prefix=$>sudo systemctl restart nginx</code></pre><p>Next, change the Gitea domain and root url. To do so, open the configuration file and edit the following lines:</p><pre class=terminal><code class=terminal-line prefix=$>sudo nano /etc/gitea/app.ini</code></pre><div class=code-label>/etc/gitea/app.ini</div><div class=highlight><pre class=chroma><code class=language-ini data-lang=ini><span class=k>[server]</span>
<span class=na>DOMAIN</span>           <span class=o>=</span> <span class=s>git.example.com</span>
<span class=na>ROOT_URL</span>         <span class=o>=</span> <span class=s>https://git.example.com/</span>
</code></pre></div><p>Restart the Gitea service by typing:</p><pre class=terminal><code class=terminal-line prefix=$>sudo systemctl restart gitea</code></pre><p>At this point, Gitea proxy is configured, and you can access it at: <code>https://git.example.com</code></p><h2 id=configuring-email-notifications>Configuring Email Notifications <a href=#configuring-email-notifications class=headline-link aria-hidden=true>#</a></h2><p>In order for Gitea to be able to send notification emails, you can either install Postfix or use some transactional mail service such as SendGrid, MailChimp, MailGun, or SES.</p><p>To enable email notifications, open the configuration file and edit the following lines:</p><pre class=terminal><code class=terminal-line prefix=$>sudo nano /etc/gitea/app.ini</code></pre><div class=code-label>/etc/gitea/app.ini</div><div class=highlight><pre class=chroma><code class=language-ini data-lang=ini><span class=k>[mailer]</span>
<span class=na>ENABLED</span> <span class=o>=</span> <span class=s>true</span>
<span class=na>HOST</span>    <span class=o>=</span> <span class=s>SMTP_SERVER:SMTP_PORT</span>
<span class=na>FROM</span>    <span class=o>=</span> <span class=s>SENDER_EMAIL</span>
<span class=na>USER</span>    <span class=o>=</span> <span class=s>SMTP_USER</span>
<span class=na>PASSWD</span>  <span class=o>=</span> <span class=s>YOUR_SMTP_PASSWORD</span>
</code></pre></div><p>Make sure you put the correct SMTP server information.</p><p>Restart the Gitea service for changes to take effect:</p><pre class=terminal><code class=terminal-line prefix=$>sudo systemctl restart gitea</code></pre><p>To verify the settings and send a test email, log in to Gitea, and go to: Site Administration > Configuration > SMTP Mailer Configuration.</p><p>Gitea also allows you to connect to Slack by creating a <a href=https://docs.gitea.io/en-us/webhooks/ >web webhook</a> and send notifications to your <a href=https://linuxize.com/post/how-to-install-slack-on-ubuntu-18-04/ >Slack channels</a>.</p><h2 id=upgrading-gitea>Upgrading Gitea <a href=#upgrading-gitea class=headline-link aria-hidden=true>#</a></h2><p>To upgrade to the latest Gitea version, simply download and replace the binary.</p><ol><li><p>Stop the Gitea service:</p><pre class=terminal><code class=terminal-line prefix=$>sudo systemctl stop gitea</code></pre></li><li><p>Download the latest Gitea version and move it to the <code>/home/git</code> directory:</p><pre class=terminal><code class=terminal-line prefix=$>VERSION=&lt;THE_LATEST_GITEA_VERSION></code><code class=terminal-line prefix=$>wget -O /tmp/gitea https://dl.gitea.io/gitea/${VERSION}/gitea-${VERSION}-linux-amd64</code><code class=terminal-line prefix=$>sudo mv /tmp/gitea /usr/local/bin</code></pre></li><li><p>Make the binary executable:</p><pre class=terminal><code class=terminal-line prefix=$>sudo chmod +x /usr/local/bin/gitea</code></pre></li><li><p>Start the Gitea service:</p><pre class=terminal><code class=terminal-line prefix=$>sudo systemctl restart gitea</code></pre></li></ol><p>That's it.</p><h2 id=conclusion>Conclusion <a href=#conclusion class=headline-link aria-hidden=true>#</a></h2><p>This tutorial walked you through the installation of Gitea on Ubuntu 18.04.</p><p>You should now visit the <a href=https://docs.gitea.io/en-us/ >Gitea documentation page</a> and learn how to configure your Gitea instance and create your first project.</p><p>If you have questions, feel free to leave a comment below.</p><div class="flex flex-wrap my-6"><a href=/tags/ubuntu/ class="font-medium text-sm bg-indigo-700 hover:bg-indigo-800 mr-2 mt-2 px-4 py-2 rounded text-white tracking-wide">ubuntu</a> <a href=/tags/git/ class="font-medium text-sm bg-indigo-700 hover:bg-indigo-800 mr-2 mt-2 px-4 py-2 rounded text-white tracking-wide">git</a> <a href=/tags/gitea/ class="font-medium text-sm bg-indigo-700 hover:bg-indigo-800 mr-2 mt-2 px-4 py-2 rounded text-white tracking-wide">gitea</a></div></div></section></div></div></div></div><div class="w-full absolute hidden -mb-16 flex-grow lg:-mb-0 lg:block lg:pt-0 lg:static sidebar top-16 z-40" id=sidebar><div class=sideblock><div class="w-full flex justify-center content-center"><div class="w-full relative"><ins class="hidden adsbygoogle mx-auto lg:block" data-ad-client=ca-pub-9439755881064125 data-ad-format=auto data-ad-slot=9558702194 data-full-width-responsive=true style=display:block></ins></div></div></div><div class="bg-gray-200 dark:bg-gray-900 mb-6 p-4 pb-2 related-content"><p class="dark:text-gray-300 font-medium text-gray-800 mb-3 mb-3 text-xs tracking-tight uppercase xxl:text-sm">Related Tutorials</p><ul class="border-gray-400 dark:border-gray-800 border-t mb-0 mt-4 pt-3"><li class="flex border-gray-400 border-b dark:border-gray-800 mb-2 pb-2"><a href=https://linuxize.com/post/how-to-install-and-configure-gogs-on-ubuntu-18-04/ class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 font-medium text-gray-700 text-sm">How To Install and Configure Gogs on Ubuntu 18.04</a></li><li class="flex border-gray-400 border-b dark:border-gray-800 mb-2 pb-2"><a href=https://linuxize.com/post/how-to-install-git-on-ubuntu-18-04/ class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 font-medium text-gray-700 text-sm">How To Install Git on Ubuntu 18.04</a></li><li class="flex border-gray-400 border-b dark:border-gray-800 mb-2 pb-2"><a href=https://linuxize.com/post/how-to-install-and-configure-gitlab-on-ubuntu-18-04/ class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 font-medium text-gray-700 text-sm">How To Install and Configure GitLab on Ubuntu 18.04</a></li><li class="flex border-gray-400 border-b dark:border-gray-800 mb-2 pb-2"><a href=https://linuxize.com/post/how-to-install-python-3-8-on-ubuntu-18-04/ class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 font-medium text-gray-700 text-sm">How to Install Python 3.8 on Ubuntu 18.04</a></li><li class="flex border-gray-400 border-b dark:border-gray-800 mb-2 pb-2"><a href=https://linuxize.com/post/how-to-change-git-remote-url/ class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 font-medium text-gray-700 text-sm">How to Change a Git Remote's URL</a></li><li class="flex border-gray-400 border-b dark:border-gray-800 mb-2 pb-2"><a href=https://linuxize.com/post/gitignore-ignoring-files-in-git/ class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 font-medium text-gray-700 text-sm">Ignoring Files and Directories in Git (.gitignore)</a></li><li class="flex border-gray-400 border-b dark:border-gray-800 mb-2 pb-2"><a href=https://linuxize.com/post/how-to-install-odoo-13-on-ubuntu-18-04/ class="dark:text-gray-300 dark-hover:text-gray-100 hover:text-gray-900 font-medium text-gray-700 text-sm">How to Install Odoo 13 on Ubuntu 18.04</a></li></ul></div><div class="flex flex-col -mt-12 lg:block lg:relative lg:sticky lg:top-16 pt-12"><div class=sideblock><div class="hidden affiliate"><a href="https://www.vultr.com/?ref=7780547-4F" class=vultr rel=noopener target=_blank></a></div><div class="w-full flex justify-center content-center"><div class="w-full relative"><ins class="adsbygoogle mx-auto" data-ad-client=ca-pub-9439755881064125 data-ad-format=auto data-ad-slot=7027266996 data-full-width-responsive=true style=display:block></ins></div></div></div></div></div></div></div></article><div class=px-6><section class="w-full mx-auto border-gray-200 border-t dark:border-gray-900 mt-8 pt-8 max-w-article"><div class="p-8 dark:bg-gray-900 sm:py-8 bg-orange-100"><p class="dark:text-gray-300 lg:text-base max-w-md mx-auto my-0 sm:text-base text-center text-orange-800 text-sm">If you like our content, please consider buying us a coffee.<br>Thank you for your support!</p><div class="w-full mx-auto flex items-center flex-col max-w-sm sm:flex-row justify-center mt-6"><a href=https://www.buymeacoffee.com/8swZOSU6I class="font-medium px-4 py-2 rounded bg-orange-500 hover:bg-orange-600 inline-flex items-center text-orange-100" rel=noopener target=_blank><svg aria-hidden=true class="h-6 w-6 fill-current inline-block text-gray-900" role=img><use xlink:href=/svg/sprite.svg#bmc></use></svg> <span class="font-medium text-xs ml-2 uppercase">Buy me a coffee</span></a></div></div></section><section class="w-full mx-auto border-gray-200 border-t dark:border-gray-900 mt-8 pt-8 max-w-article"><div class="bg-gray-200 dark:bg-gray-900 p-8 sm:py-8"><p class="lg:text-base max-w-md mx-auto my-0 sm:text-base text-center text-sm">Sign up to our newsletter and get our latest tutorials and news straight to your mailbox.</p><form action="https://linuxize.us17.list-manage.com/subscribe/post?u=35cd4cd9d021c25c3dd7cabfd&id=9cfa4c89de" class=pt-8 id=mc-embedded-subscribe-form method=post name=mc-embedded-subscribe-form novalidate><div class="w-full mx-auto flex items-center flex-col max-w-sm sm:flex-row justify-between mb-2"><input class="w-full block bg-white appearance-none border hover:border-gray-700 mb-3 px-4 py-3 rounded sm:mb-0 text-gray-800" name=EMAIL aria-label=email placeholder="Your email..." type=email> <input class=hidden name=b_35cd4cd9d021c25c3dd7cabfd_9cfa4c89de tabindex=-1> <button class="w-full px-4 py-3 rounded bg-indigo-700 hover:bg-indigo-800 sm:ml-4 sm:w-auto text-white tracking-wide" name=subscribe type=submit><span class=text-center>Subscribe</span></button></div><p class="w-full mx-auto my-0 max-w-sm text-sm">We’ll never share your email address or spam you.</p></form></div></section><section class="w-full mx-auto border-gray-200 border-t dark:border-gray-900 mt-8 pt-8 max-w-5xl"><div class="flex flex-wrap -mx-4"><a href=https://linuxize.com/post/how-to-install-and-configure-gogs-on-ubuntu-18-04/ class="w-full flex md:mb-0 md:w-1/3 overflow-hidden px-4 mb-8"><div class="w-full h-full flex flex-col"><p class="dark:text-gray-300 text-xs text-gray-700 font-normal uppercase">Apr 25, 2019</p><h2 class="dark:text-gray-300 font-medium text-gray-800 flex-grow mb-2 md:mb-4 text-lg">How To Install and Configure Gogs on Ubuntu 18.04</h2><div><figure class=relative><div class="w-full mx-auto my-0 block relative"><div class=block style=padding-bottom:53%></div><div class="w-full h-full absolute inset-0 m-auto overflow-hidden bg-gray-200"><img alt="" class="w-full h-full absolute inset-0 m-auto lazy lazyload" src="data:image/gif;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAYAAAAfFcSJAAAADUlEQVR42mP8+PXHfwAJnAPfCuZXlQAAAABJRU5ErkJggg==" data-sizes=auto data-src=/post/how-to-install-and-configure-gogs-on-ubuntu-18-04/featured_huebd91d24c597c7faf76d78c71932a47d_29825_600x0_resize_q95_box.jpg data-srcset="
              /post/how-to-install-and-configure-gogs-on-ubuntu-18-04/featured_huebd91d24c597c7faf76d78c71932a47d_29825_600x0_resize_q95_box.jpg 600w,
              /post/how-to-install-and-configure-gogs-on-ubuntu-18-04/featured.jpg 1000w
            "><noscript><img alt="" class="w-full h-full absolute inset-0 m-auto" src=/post/how-to-install-and-configure-gogs-on-ubuntu-18-04/featured.jpg></noscript></div></div></figure></div></div></a><a href=https://linuxize.com/post/how-to-install-git-on-ubuntu-18-04/ class="w-full flex md:mb-0 md:w-1/3 overflow-hidden px-4 mb-8"><div class="w-full h-full flex flex-col"><p class="dark:text-gray-300 text-xs text-gray-700 font-normal uppercase">Jul 5, 2018</p><h2 class="dark:text-gray-300 font-medium text-gray-800 flex-grow mb-2 md:mb-4 text-lg">How To Install Git on Ubuntu 18.04</h2><div><figure class=relative><div class="w-full mx-auto my-0 block relative"><div class=block style=padding-bottom:53%></div><div class="w-full h-full absolute inset-0 m-auto overflow-hidden bg-gray-200"><img alt="" class="w-full h-full absolute inset-0 m-auto lazy lazyload" src="data:image/gif;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAYAAAAfFcSJAAAADUlEQVR42mP8+PXHfwAJnAPfCuZXlQAAAABJRU5ErkJggg==" data-sizes=auto data-src=/post/how-to-install-git-on-ubuntu-18-04/featured_hu25aff9f72d513faca953928880eaab82_60807_600x0_resize_q95_box.jpg data-srcset="
              /post/how-to-install-git-on-ubuntu-18-04/featured_hu25aff9f72d513faca953928880eaab82_60807_600x0_resize_q95_box.jpg 600w,
              /post/how-to-install-git-on-ubuntu-18-04/featured.jpg 1000w
            "><noscript><img alt="" class="w-full h-full absolute inset-0 m-auto" src=/post/how-to-install-git-on-ubuntu-18-04/featured.jpg></noscript></div></div></figure></div></div></a><a href=https://linuxize.com/post/how-to-install-and-configure-gitlab-on-ubuntu-18-04/ class="w-full flex md:mb-0 md:w-1/3 overflow-hidden px-4 mb-0"><div class="w-full h-full flex flex-col"><p class="dark:text-gray-300 text-xs text-gray-700 font-normal uppercase">Jun 8, 2018</p><h2 class="dark:text-gray-300 font-medium text-gray-800 flex-grow mb-2 md:mb-4 text-lg">How To Install and Configure GitLab on Ubuntu 18.04</h2><div><figure class=relative><div class="w-full mx-auto my-0 block relative"><div class=block style=padding-bottom:53%></div><div class="w-full h-full absolute inset-0 m-auto overflow-hidden bg-gray-200"><img alt="" class="w-full h-full absolute inset-0 m-auto lazy lazyload" src="data:image/gif;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAYAAAAfFcSJAAAADUlEQVR42mP8+PXHfwAJnAPfCuZXlQAAAABJRU5ErkJggg==" data-sizes=auto data-src=/post/how-to-install-and-configure-gitlab-on-ubuntu-18-04/featured_huab0f9dab6d72eb7a9d02fc1b41b459e4_18548_600x0_resize_q95_box.jpg data-srcset="
              /post/how-to-install-and-configure-gitlab-on-ubuntu-18-04/featured_huab0f9dab6d72eb7a9d02fc1b41b459e4_18548_600x0_resize_q95_box.jpg 600w,
              /post/how-to-install-and-configure-gitlab-on-ubuntu-18-04/featured.jpg 1000w
            "><noscript><img alt="" class="w-full h-full absolute inset-0 m-auto" src=/post/how-to-install-and-configure-gitlab-on-ubuntu-18-04/featured.jpg></noscript></div></div></figure></div></div></a></div></section><section class="w-full mx-auto relative border-gray-200 border-t dark:border-gray-900 max-w-3xl mt-8 pt-16 py-8"><a href=https://linuxize.com/post/how-to-install-gitea-on-ubuntu-18-04/#disqus_thread class="w-full block bg-gray-200 dark:bg-gray-900 disqus-comment-count disqus-load md:py-8 py-4 text-center" title="Show comments for post">Write a comment</a><div id=disqus_thread></div><noscript>Please enable JavaScript to view the <a href=https://disqus.com/?ref_noscript>comments powered by Disqus.</a></noscript></section></div></main><section class="w-full absolute inset-0 bg-white block h-screen hidden search z-100" id=search-box><div class="flex flex-col min-h-screen"><header class="w-full mx-auto flex items-center h-12 justify-end px-6 sm:h-16 z-10"><a href=# class="block h-6 sm:h-8" id=btn-search-close><svg aria-hidden=true class="h-6 w-6 fill-current inline-block text-gray-900 sm:h-8 sm:w-8" role=img><use xlink:href=/svg/sprite.svg#close></use></svg> <small class="block text-center sm:w-8 w-6">ESC</small></a></header><div class="w-full px-6 flex-grow flex-shrink-0 pb-8 pt-16 sm:pt-24"><div class="flex flex-col mx-auto max-w-screen-xl mb-4 mb-8"><div class=searchbox-container id=searchbox></div><div class=search-results id=search-results></div><div id=hits></div><div id=stats></div><footer class=mt-6><a href=https://www.algolia.com/doc/ rel="noopener noreferrer" target=_blank tabindex=-1><svg aria-hidden=true class="search-algolia-logo fill-current inline-block text-gray-700" role=img><use xlink:href=/svg/sprite.svg#search-by-algolia></use></svg></a></footer></div></div></div></section><footer class="w-full px-6 bg-gray-100 dark:bg-gray-900"><div class="w-full mx-auto flex items-center justify-center flex-wrap lg:justify-between lg:text-left max-w-screen-xl py-8 text-center"><div class="w-full text-sm lg:mb-0 lg:w-1/2 mb-2"><div class="w-full block lg:flex lg:items-center lg:w-auto"><div class=lg:flex-grow><span class="dark:text-gray-300 text-gray-800 mb-2 block lg:inline-block lg:mb-0 lg:mr-8">© 2020 Linuxize.com</span> <a href=/privacy-policy/ class="dark:text-gray-300 dark-hover:text-gray-100 no-underline mr-4 footer-menu-item hover:text-gray-800 inline-block lg:mt-0 text-gray-900">Privacy Policy </a><a href=/contact/ class="dark:text-gray-300 dark-hover:text-gray-100 no-underline footer-menu-item hover:text-gray-800 inline-block lg:mt-0 text-gray-900 mr-0">Contact</a></div></div></div><div class="w-full flex justify-center lg:justify-end lg:w-1/2"><a href=https://twitter.com/linuxize class="block h-6 mr-2" aria-label=Twitter><svg aria-hidden=true class="dark:text-gray-300 inline-block fill-current h-6 w-6 text-gray-900" role=img><use xlink:href=/svg/sprite.svg#twitter></use></svg> </a><a href=https://www.facebook.com/linuxize/ class="block h-6 mr-2" aria-label=Facebook><svg aria-hidden=true class="dark:text-gray-300 inline-block fill-current h-6 w-6 text-gray-900" role=img><use xlink:href=/svg/sprite.svg#facebook></use></svg> </a><a href=/index.xml class="block h-6" aria-label=RSS><svg aria-hidden=true class="dark:text-gray-300 inline-block fill-current h-6 w-6 text-gray-900" role=img><use xlink:href=/svg/sprite.svg#rss></use></svg></a></div></div></footer></div><script src=https://cdn.jsdelivr.net/npm/algoliasearch@3.35.1/dist/algoliasearchLite.min.js crossorigin=anonymous integrity="sha256-5rOQwvvJdM9oDYQYCGzaJuuTy6SUALjma3OtzEGyJM0="></script><script src=https://cdn.jsdelivr.net/npm/instantsearch.js@4.0.0/dist/instantsearch.production.min.js crossorigin=anonymous integrity="sha256-6S7q0JJs/Kx4kb/fv0oMjS855QTz5Rc2hh9AkIUjUsk="></script><script src=/js/1.eaacd7b1f9a6464a752e.js></script><script src=/js/app.4ae77aedfd5393611a77.js></script><script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('edmonton.php', '/detroitchicago/edmonton.webp?a=a&cb=0&shcb=32', true, [], true, false, false, false);
__ez.queue.addFile('jellyfish.php', '/porpoiseant/jellyfish.webp?a=a&cb=0&shcb=32', false, [], true, false, false, false);
</script>

<script>var _audins_dom="linuxize_com",_audins_did=93605;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=188-0");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.linuxize_com,DomainId.93605" border="0" height="1" width="1" alt="Quantcast"/></div></noscript><noscript><img src="https://sb.scorecardresearch.com/p?c1=2&c2=20015427&cv=2.0&cj=1"/></noscript>
<script type='text/javascript' data-cfasync='false'>(function(){function b(e,c){for(var d=0;d<c.length;d++){var f=c[d];if(0==f.complete||"undefined"!=typeof f.readyState&&4>f.readyState){var g=f.getAttribute("src")||f.currentSrc;"undefined"!=typeof f.readyState&&0==f.readyState?f.addEventListener("loadstart",function(h){var k=h.getAttribute("src")||h.currentSrc;window.ezorqs(h,k)}):(g=f.getAttribute("src")||f.currentSrc,window.ezorqs(f,g));f.addEventListener("load",function(h){var k=h.currentTarget.getAttribute("src")||h.srcElement.currentSrc;window.ezorqe(h,
	k)});f.addEventListener("loadeddata",function(h){var k=h.currentTarget.getAttribute("src")||h.srcElement.currentSrc;window.ezorqe(h,k)});f.addEventListener("error",function(h){var k=h.currentTarget.getAttribute("src")||h.srcElement.currentSrc;window.ezorqe(h,k)})}}}function a(e){for(var c=0;c<document.styleSheets.length;c++)if(document.styleSheets[c].href==e)return!0;return!1}b("img",document.querySelectorAll("img"));b("video",document.querySelectorAll("video"));b("audio",document.querySelectorAll("audio"));
	(function(e){for(var c=0;c<e.length;c++){var d=e[c];if(("preload"==d.getAttribute("rel")||"stylesheet"==d.getAttribute("rel"))&&null!=d.getAttribute("href")&&a(d.getAttribute("href"))){window.ezorqs(d,d.getAttribute("href"));var f=document.createElement("img");f.onerror=function(g){"undefined"!=typeof g.path&&"undefined"!=typeof g.path[0].currentSrc?window.ezorqe(d,g.path[0].currentSrc):"undefined"!=typeof g.srcElement&&"undefined"!=typeof g.srcElement.href&&window.ezorqe(d,g.srcElement.href)};f.src=
	d.getAttribute("href")}}})(document.querySelectorAll("link"));"undefined"!=typeof window.__ez.ssaf&&-1<window.__ez.ssaf.indexOf(16)&&"undefined"!==typeof window.__ez.sshsdef&&!1===window.__ez.sshsdef&&Element.prototype.addEventListener&&("function"==typeof window.onload&&(window.addEventListener("load",window.onload),window.onload=null),"function"==typeof document.onload&&(document.addEventListener.addEventListener("load",document.onload),document.onload=null))})();</script></body></html>