<!doctype html><html class=no-js lang=en-us><head><title>How to install WordPress with Nginx on CentOS 7 | Linuxize</title><meta charset=utf-8><meta content="IE=edge" http-equiv=X-UA-Compatible><meta content="width=device-width,initial-scale=1,shrink-to-fit=no" name=viewport><meta content=Linuxize name=apple-mobile-web-app-title><meta content=Linuxize name=application-name><meta content=#2271ff name=theme-color><meta content=#2271ff name=msapplication-TileColor><meta content="In this tutorial we will show you how to install WordPress on an CentOS 7 machine. WordPress is by far the most popular open source blogging and CMS platform worldwide." name=description><meta content=unsafe-url name=referrer><link href=https://linuxize.com/post/how-to-install-wordpress-with-nginx-on-centos-7/ rel=canonical><meta content="index, follow" name=robots><meta content="Hugo 0.51" name=generator><meta content="How to install WordPress with Nginx on CentOS 7" property=og:title><meta content="In this tutorial we will show you how to install WordPress on an CentOS 7 machine. WordPress is by far the most popular open source blogging and CMS platform worldwide." property=og:description><meta content=article property=og:type><meta content=/post/how-to-install-wordpress-with-nginx-on-centos-7/ property=og:url><meta content=https://linuxize.com/post/how-to-install-wordpress-with-nginx-on-centos-7/featured.jpg property=og:image><meta content="In this tutorial we will show you how to install WordPress on an CentOS 7 machine. WordPress is by far the most popular open source blogging and CMS platform worldwide." property=og:image:alt><meta content=2018-11-27T21:24:10+01:00 property=article:published_time><meta content=2018-11-27T21:24:10+01:00 property=article:modified_time><meta content=en property=og:locale><meta content=post property=article:section><meta content=https://www.facebook.com/linuxize property=article:publisher><meta content=centos property=article:tag><meta content=wordpress property=article:tag><meta content=mysql property=article:tag><meta content=mariadb property=article:tag><meta content=cms property=article:tag><meta content=nginx property=article:tag><meta content=centos,wordpress,mysql,mariadb,cms,nginx name=news_keywords><meta content=summary_large_image name=twitter:card><meta content=https://linuxize.com/post/how-to-install-wordpress-with-nginx-on-centos-7/featured.jpg name=twitter:image><meta content="How to install WordPress with Nginx on CentOS 7" name=twitter:title><meta content="In this tutorial we will show you how to install WordPress on an CentOS 7 machine. WordPress is by far the most popular open source blogging and CMS platform worldwide." name=twitter:description><meta content=@linuxize name=twitter:site><link href=/favicons/apple-touch-icon.png rel=apple-touch-icon sizes=180x180><link href=/favicons/favicon-32x32.png rel=icon sizes=32x32 type=image/png><link href=/favicons/favicon-16x16.png rel=icon sizes=16x16 type=image/png><link href=/favicons/safari-pinned-tab.svg rel=mask-icon color=#2271ff><script type=application/ld+json>{
  "@context": "http://schema.org",
  "@type": "BlogPosting",
  "headline": "How to install WordPress with Nginx on CentOS 7",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://linuxize.com/post/how-to-install-wordpress-with-nginx-on-centos-7/"
  },"image": {
     "@type": "ImageObject",
     "url": "https://linuxize.com/post/how-to-install-wordpress-with-nginx-on-centos-7/featured.jpg",
     "width": 1000,
     "height": 530
    },"keywords": "centos, wordpress, mysql, mariadb, cms, nginx",
  "wordcount": 1144,
  "url": "https://linuxize.com/post/how-to-install-wordpress-with-nginx-on-centos-7/",
  "datePublished": "2018-11-27T21:24:10+01:00",
  "dateModified": "2018-11-27T21:24:10+01:00",
  "publisher": {
    "@type": "Organization","logo": {
    "@type": "imageObject",
      "url": "https://linuxize.com/assets/linuxize-card.png"
    },"name": "Linuxize"
  },

  "author": {
    "@type": "Person",
    "name": "Linuxize"
  },
  "description": "In this tutorial we will show you how to install WordPress on an CentOS 7 machine. WordPress is by far the most popular open source blogging and CMS platform worldwide."
}</script><script src=/js/ads.js></script><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-P827G6S');</script><script src=https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js async></script><script>(adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-9439755881064125",
          enable_page_level_ads: true
     });</script><meta content=#2271ff name=theme-color><link href=/manifest.79f739767e479131c04f7216cce1c084.json rel=manifest><link href="https://fonts.googleapis.com/css?family=IBM+Plex+Sans:300,400,400i,500,700%7CIBM+Plex+Serif:300,400,400i,600,600i" rel=stylesheet><link href=/css/app.b7053e1607f74b413ca7.css rel=stylesheet></head><body class="font-sans kind-page leading-normal section-post text-black type-post"><div class="flex flex-col min-h-screen main-wrap"><header class="w-full px-6 z-10 bg-white border-b border-grey-light fixed linuxize-shadow" id=header><nav class="w-full mx-auto flex items-center h-12 sm:h-16 justify-start"><a href=/ class="flex items-center block flex-no-shrink mr-6 no-underline text-black" aria-label=Linuxize.com><svg aria-hidden=true class="h-6 w-6 fill-current sm:h-8 sm:w-8 mr-2"><use xlink:href=#logo></use><title>Linuxize</title></svg> <span class="font-medium text-xl hidden sm:block tracking-tight">Linuxize</span></a><div class="flex -mb-px flex-1 min-w-0 text-sm"><a href=/tags/ubuntu/ class="hover:text-grey-darkest hidden mr-4 no-underline sm:block text-grey-darker"><span class="inline-block font-bold md:py-6 py-3 sm:py-4">Ubuntu </span></a><a href=/tags/centos/ class="hover:text-grey-darkest hidden mr-4 no-underline sm:block text-grey-darker"><span class="inline-block font-bold md:py-6 py-3 sm:py-4">Centos </span></a><a href=/tags/debian/ class="hover:text-grey-darkest hidden mr-4 no-underline sm:block text-grey-darker"><span class="inline-block font-bold md:py-6 py-3 sm:py-4">Debian </span></a><a href=/tags/terminal/ class="hover:text-grey-darkest hidden mr-4 no-underline sm:block text-grey-darker"><span class="inline-block font-bold md:py-6 py-3 sm:py-4">Linux Commands </span></a><a href=/series/ class="hover:text-grey-darkest hidden mr-4 no-underline sm:block text-grey-darker mr-0"><span class="inline-block font-bold md:py-6 py-3 sm:py-4">Series</span></a></div><div class="flex justify-end"><button class="block h-6 sm:h-8" aria-label=Search id=btn-search><svg aria-hidden=true class="h-6 w-6 fill-current inline-block text-grey-darkest sm:h-8 sm:w-8"><use xlink:href=#search></use><title>Search</title></svg></button></div></nav></header><main class="w-full px-6 flex-grow flex-no-shrink pb-8 pt-16 sm:pt-24 main"><article class="relative single-post"><div class="w-full mx-auto max-w-screen-2xl"><div class=lg:flex><div class="w-full lg:static lg:max-h-full lg:overflow-visible min-h-screen"><div class=flex><div class="w-full pb-8"><div class="mb-6 mx-auto lg:ml-0 lg:mr-auto lg:pr-6 max-w-lg xl:max-w-full xl:mx-0 xl:pr-8"><div class="flex mb-2 flex-col font-medium md:flex-row text-xs uppercase"><div class=inline-flex><time class="" datetime=2018-11-27T21:24:10+01:00>November 27, 2018 </time><span class=mx-2>•</span><p>Read in 6 minutes</p></div><span class="hidden md:block mx-2">|</span><p class="font-medium leading-normal rounded-sm text-xs uppercase">last updated  <time class="" datetime=2018-11-27T21:24:10+01:00>November 27, 2018</time></p></div><div class=post-header><h1 class="mb-4 font-bold leading-none lg:text-3xl text-2xl text-black xl:mb-8 xxl:text-4xl">How to install WordPress with Nginx on CentOS 7</h1></div></div><div class="flex flex-col xl:flex-relative xl:flex-row"><aside class="w-full lg:hidden block xl:block" id=sidebar2><div class="w-full flex justify-center content-center"><div class="w-full relative"><ins class="hidden adsbygoogle mx-auto mb-6 sidebar2-as xl:block" data-ad-client=ca-pub-9439755881064125 data-ad-format=horizontal,rectangle data-ad-slot=4501323511 style=display:block data-full-width-responsive=true></ins></div></div><div class="hidden flex-col justify-between xl:flex distro-versions"><div class="mb-6 p-4 pb-2 toc bg-blue"><p class="font-medium text-white text-xs xxl:text-sm mb-3 tracking-tight uppercase">This tutorial is also available for</p><div class="w-full distro-versions flex-wrap inline-flex items-center mb-4"><a href=/post/how-to-install-wordpress-with-nginx-on-ubuntu-18-04/ class="w-full text-center bg-blue-dark capitalize font-medium hover:bg-blue-darkest leading-normal mb-2 px-3 py-1 rounded-sm text-white text-xs xxl:mr-2 xxl:text-sm">ubuntu 18.04</a></div></div></div><div class="hidden flex-col justify-between xl:flex -mt-12 pb-4 pt-12 sticky top-16"><div class="mb-6 p-4 pb-2 toc bg-grey-lighter table-of-contents"><p class="font-medium mb-3 mb-3 text-xs tracking-tight uppercase xxl:text-sm text-grey-darker">Contents</p><nav id=TableOfContents><ul><li><ul><li><a href=#prerequisites>Prerequisites</a></li><li><a href=#creating-mysql-database>Creating MySQL database</a></li><li><a href=#installing-php-7-2>Installing PHP 7.2</a></li><li><a href=#downloading-wordpress>Downloading Wordpress</a></li><li><a href=#configuring-nginx>Configuring Nginx</a></li><li><a href=#completing-the-wordpress-installation>Completing the WordPress Installation</a></li><li><a href=#conclusion>Conclusion</a></li></ul></li></ul></nav><p class="font-medium mb-3 mb-3 text-xs tracking-tight uppercase xxl:text-sm border-grey-light border-t mt-4 pt-4">Share</p><section class="w-full mx-auto"><nav class="flex flex-wrap"><a href="https://twitter.com/share?text=How%20to%20install%20WordPress%20with%20Nginx%20on%20CentOS%207&url=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-install-wordpress-with-nginx-on-centos-7%2f" class="h-6 w-6 mb-4 mr-3" rel=noopener target=_blank><svg aria-hidden=true class="h-6 w-6 fill-current inline-block hover:text-blue text-gray-light"><use xlink:href=#twitter></use><title>Share on Twitter</title></svg> </a><a href="https://www.facebook.com/sharer/sharer.php?caption=How%20to%20install%20WordPress%20with%20Nginx%20on%20CentOS%207&u=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-install-wordpress-with-nginx-on-centos-7%2f" class="h-6 w-6 mb-4 mr-3" rel=noopener target=_blank><svg aria-hidden=true class="h-6 w-6 fill-current inline-block hover:text-blue text-gray-light"><use xlink:href=#facebook></use><title>Share on Facebook</title></svg> </a><a href="https://pinterest.com/pin/create/button/?url=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-install-wordpress-with-nginx-on-centos-7%2f&media=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-install-wordpress-with-nginx-on-centos-7%2ffeatured.jpg&description=How%20to%20install%20WordPress%20with%20Nginx%20on%20CentOS%207" class="h-6 w-6 mb-4 mr-3" rel=noopener target=_blank><svg aria-hidden=true class="h-6 w-6 fill-current inline-block hover:text-blue text-gray-light"><use xlink:href=#pinterest></use><title>Share on Pinterest</title></svg> </a><a href="https://plus.google.com/share?url=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-install-wordpress-with-nginx-on-centos-7%2f" class="h-6 w-6 mb-4 mr-3" rel=noopener target=_blank><svg aria-hidden=true class="h-6 w-6 fill-current inline-block hover:text-blue text-gray-light"><use xlink:href=#gplus></use><title>Share on Google Plus</title></svg> </a><a href="https://news.ycombinator.com/submitlink?t=How%20to%20install%20WordPress%20with%20Nginx%20on%20CentOS%207&u=https%3a%2f%2flinuxize.com%2fpost%2fhow-to-install-wordpress-with-nginx-on-centos-7%2f" class="h-6 w-6 mb-4 mr-3" rel=noopener target=_blank><svg aria-hidden=true class="h-6 w-6 fill-current inline-block hover:text-blue text-gray-light"><use xlink:href=#hacker-news></use><title>Submit to Hacker News</title></svg> </a><a href="/cdn-cgi/l/email-protection#09367a7c6b636c6a7d3441667e2c3b397d662c3b3960677a7d6865652c3b395e667b6d597b6c7a7a2c3b397e607d612c3b39476e6067712c3b3966672c3b394a6c677d465a2c3b393e2f6b666d70344a616c6a622c3b39667c7d2c3b397d61607a2c3b39687b7d606a656c332c39482c3948617d7d797a2c3a682c3b6f2c3b6f6560677c7160736c276a66642c3b6f79667a7d2c3b6f61667e247d662460677a7d686565247e667b6d797b6c7a7a247e607d6124676e606771246667246a6c677d667a243e2c3b6f" class="h-6 w-6 mb-4" rel=noopener target=_blank><svg aria-hidden=true class="h-6 w-6 fill-current inline-block hover:text-blue text-gray-light"><use xlink:href=#email></use><title>Share with Email</title></svg></a></nav></section></div></div></aside><section class="w-full mx-auto lg:ml-0 lg:mr-auto lg:pr-6 min-w-0 xl:mx-0 xl:px-8 xl:w-full"><figure class="relative -mx-6 lg:mx-0 mb-6"><div class="bg-center bg-cover" style=background-image:url(/post/how-to-install-wordpress-with-nginx-on-centos-7/featured.jpg);padding-top:46.7%></div></figure><div class=markdown><p>WordPress is the most popular open source blogging and CMS platform worldwide, powering a quarter of all websites on the Internet today. It is based on PHP and MySQL and packs a ton of features that can be extended with free and premium plugins and themes. WordPress is the simplest way to create your online store, website, or blog.</p><p>This tutorial describes how to install WordPress on CentOS 7. It is a fairly simple process that takes less than ten minutes to complete.</p><p>We’ll be using a <a href=/series/install-lemp-stack-on-centos-7/ >LEMP stack</a> with Nginx as a web server, SSL certificate, the latest PHP 7.2 and MySQL/MariaDB as a database server.</p><h2 id=prerequisites>Prerequisites</h2><p>Ensure the following prerequisites are met before continuing with this tutorial:</p><ul><li>Have a domain name pointed to your server public IP address. In this tutorial we will use <code>example.com</code>.</li><li>Logged in as a <a href=/post/create-a-sudo-user-on-centos/ >user with sudo privileges</a>.</li><li>Nginx installed by following <a href=/post/how-to-install-nginx-on-centos-7/ >these instructions</a>.</li><li>You have a SSL certificate installed for your domain. You can generate a free Let’s Encrypt SSL certificate by following <a href=/post/secure-nginx-with-let-s-encrypt-on-centos-7/ >these instructions</a> .</li></ul><h2 id=creating-mysql-database>Creating MySQL database</h2><p>WordPress stores its data and configuration in a MySQL database. The first step is to create a MySQL database, <a href=/post/how-to-create-mysql-user-accounts-and-grant-privileges/ >MySQL user account and grant access to the database</a>.</p><p>If you already don’t have MySQL or MariaDB installed on your Ubuntu server you can install by following one of the instructions below:</p><ul><li><a href=/post/install-mysql-on-centos-7/ >Install MySQL on CentOS 7</a>.</li><li><a href=/post/install-mariadb-on-centos-7/ >Install MariaDB on CentOS 7</a>.<br></li></ul><p>Login to the MySQL shell by executing the following command:</p><div class=highlight><pre class=chroma><code class=language-console-bash data-lang=console-bash>mysql -u root -p</code></pre></div><p>From inside the mysql console, run the following SQL statements to <a href=/post/how-to-create-a-mysql-database/ >create a database</a> named <code>wordpress</code>, user named <code>wordpressuser</code> and to grant all necessary permissions to the user:</p><div class=highlight><pre class=chroma><code class=language-console-mysql data-lang=console-mysql>CREATE DATABASE wordpress CHARACTER SET utf8mb4 COLLATE utf8mb4_general_ci;
GRANT ALL ON wordpress.* TO 'wordpressuser'@'localhost' IDENTIFIED BY 'change-with-strong-password';
FLUSH PRIVILEGES;
EXIT;</code></pre></div><h2 id=installing-php-7-2>Installing PHP 7.2</h2><p>CentOS 7 ships with PHP version 5.4. The recommended PHP version for WordPress is PHP 7.2.</p><p>To install PHP 7.2 on your server you can either follow <a href=/post/install-php-7-on-centos-7/ >this tutorial</a> or install PHP 7.2 and all required PHP extensions with the following commands:</p><div class=highlight><pre class=chroma><code class=language-console-bash data-lang=console-bash>sudo yum install epel-release yum-utils
sudo yum install http://rpms.remirepo.net/enterprise/remi-release-7.rpm
sudo yum-config-manager --enable remi-php72
sudo yum install php-cli php-fpm php-mysql php-json php-opcache php-mbstring php-xml php-gd php-curl</code></pre></div><p>We installed PHP FPM because we will be using Nginx as a web server.</p><p>By default PHP FPM will run as user <code>apache</code> on port 9000. We’ll change the user to <code>nginx</code> and switch from TCP socket to Unix socket. To do so open the <code>/etc/php-fpm.d/www.conf</code> file edit the lines highlighted in yellow:</p><div class=code-label>/etc/php-fpm.d/www.conf</div><div class=highlight><pre class=chroma><code class=language-config data-lang=config>...
<span class=hl>user = nginx
</span>...
<span class=hl>group = nginx
</span>...
<span class=hl>listen = /run/php-fpm/www.sock
</span>...
<span class=hl>listen.owner = nginx
</span><span class=hl>listen.group = nginx</span></code></pre></div><p>Make sure the <code>/var/lib/php</code> directory has the correct permissions:</p><div class=highlight><pre class=chroma><code class=language-console-bash data-lang=console-bash>chown -R root:nginx /var/lib/php</code></pre></div><p>Once you made the changes, enable and start the PHP FPM service:</p><div class=highlight><pre class=chroma><code class=language-console-bash data-lang=console-bash>sudo systemctl enable php-fpm
sudo systemctl start php-fpm</code></pre></div><h2 id=downloading-wordpress>Downloading Wordpress</h2><p>Before downloading the Wordpress archive, first create a directory in which we will place the WordPress files:</p><div class=highlight><pre class=chroma><code class=language-console-bash data-lang=console-bash>sudo mkdir -p /var/www/html/example.com</code></pre></div><p>The next step is to download the latest version of WordPress from the <a href=https://wordpress.org/download/ >WordPress download page</a> using the following <a href=/post/wget-command-examples/ >wget command</a>:</p><div class=highlight><pre class=chroma><code class=language-console-bash data-lang=console-bash>cd /tmp
wget https://wordpress.org/latest.tar.gz</code></pre></div><p>When the download is complete, <a href=/post/how-to-create-and-extract-archives-using-the-tar-command-in-linux/ >extract the WordPress archive</a> and move the entire contents into the domain’s document root directory:</p><div class=highlight><pre class=chroma><code class=language-console-bash data-lang=console-bash>tar xf latest.tar.gz
sudo mv /tmp/wordpress/* /var/www/html/example.com/</code></pre></div><p>Set the correct permissions so that the web server can have full access to the site’s files and directories:</p><div class=highlight><pre class=chroma><code class=language-output data-lang=output>sudo chown -R nginx: /var/www/html/example.com</code></pre></div><h2 id=configuring-nginx>Configuring Nginx</h2><p>By now, you should already have Nginx with SSL certificate installed on your system, if not check the prerequisites for this tutorial.</p><p>To create a new server block for our WordPress instance we will use the <a href=https://www.nginx.com/resources/wiki/start/topics/recipes/wordpress/ >Nginx recipe</a> from the official Nginx site.</p><p>Open your text editor and create a new <a href=/post/how-to-set-up-nginx-server-blocks-on-centos-7/ >nginx server block</a>:</p><div class=highlight><pre class=chroma><code class=language-console-bash data-lang=console-bash>sudo nano /etc/nginx/conf.d/example.com.conf</code></pre></div><p>Add the following lines:</p><div class=code-label>/etc/nginx/conf.d/example.com.conf</div><div class=highlight><pre class=chroma><code class=language-nginx data-lang=nginx><span class=c1># Redirect HTTP -> HTTPS
</span><span class=c1></span><span class=k>server</span> <span class=p>{</span>
    <span class=kn>listen</span> <span class=mi>80</span><span class=p>;</span>
    <span class=kn>server_name</span> <span class=s>www.example.com</span> <span class=s>example.com</span><span class=p>;</span>

    <span class=kn>include</span> <span class=s>snippets/letsencrypt.conf</span><span class=p>;</span>
    <span class=kn>return</span> <span class=mi>301</span> <span class=s>https://example.com</span><span class=nv>$request_uri</span><span class=p>;</span>
<span class=p>}</span>

<span class=c1># Redirect WWW -> NON WWW
</span><span class=c1></span><span class=k>server</span> <span class=p>{</span>
    <span class=kn>listen</span> <span class=mi>443</span> <span class=s>ssl</span> <span class=s>http2</span><span class=p>;</span>
    <span class=kn>server_name</span> <span class=s>www.example.com</span><span class=p>;</span>

    <span class=kn>ssl_certificate</span> <span class=s>/etc/letsencrypt/live/example.com/fullchain.pem</span><span class=p>;</span>
    <span class=kn>ssl_certificate_key</span> <span class=s>/etc/letsencrypt/live/example.com/privkey.pem</span><span class=p>;</span>
    <span class=kn>ssl_trusted_certificate</span> <span class=s>/etc/letsencrypt/live/example.com/chain.pem</span><span class=p>;</span>
    <span class=kn>include</span> <span class=s>snippets/ssl.conf</span><span class=p>;</span>

    <span class=kn>return</span> <span class=mi>301</span> <span class=s>https://example.com</span><span class=nv>$request_uri</span><span class=p>;</span>
<span class=p>}</span>

<span class=k>server</span> <span class=p>{</span>
    <span class=kn>listen</span> <span class=mi>443</span> <span class=s>ssl</span> <span class=s>http2</span><span class=p>;</span>
    <span class=kn>server_name</span> <span class=s>example.com</span><span class=p>;</span>

    <span class=kn>root</span> <span class=s>/var/www/html/example.com</span><span class=p>;</span>
    <span class=kn>index</span> <span class=s>index.php</span><span class=p>;</span>

    <span class=c1># SSL parameters
</span><span class=c1></span>    <span class=kn>ssl_certificate</span> <span class=s>/etc/letsencrypt/live/example.com/fullchain.pem</span><span class=p>;</span>
    <span class=kn>ssl_certificate_key</span> <span class=s>/etc/letsencrypt/live/example.com/privkey.pem</span><span class=p>;</span>
    <span class=kn>ssl_trusted_certificate</span> <span class=s>/etc/letsencrypt/live/example.com/chain.pem</span><span class=p>;</span>
    <span class=kn>include</span> <span class=s>snippets/ssl.conf</span><span class=p>;</span>
    <span class=kn>include</span> <span class=s>snippets/letsencrypt.conf</span><span class=p>;</span>

    <span class=c1># log files
</span><span class=c1></span>    <span class=kn>access_log</span> <span class=s>/var/log/nginx/example.com.access.log</span><span class=p>;</span>
    <span class=kn>error_log</span> <span class=s>/var/log/nginx/example.com.error.log</span><span class=p>;</span>

    <span class=kn>location</span> <span class=p>=</span> <span class=s>/favicon.ico</span> <span class=p>{</span>
        <span class=kn>log_not_found</span> <span class=no>off</span><span class=p>;</span>
        <span class=kn>access_log</span> <span class=no>off</span><span class=p>;</span>
    <span class=p>}</span>

    <span class=kn>location</span> <span class=p>=</span> <span class=s>/robots.txt</span> <span class=p>{</span>
        <span class=kn>allow</span> <span class=s>all</span><span class=p>;</span>
        <span class=kn>log_not_found</span> <span class=no>off</span><span class=p>;</span>
        <span class=kn>access_log</span> <span class=no>off</span><span class=p>;</span>
    <span class=p>}</span>

    <span class=kn>location</span> <span class=s>/</span> <span class=p>{</span>
        <span class=kn>try_files</span> <span class=nv>$uri</span> <span class=nv>$uri/</span> <span class=s>/index.php?</span><span class=nv>$args</span><span class=p>;</span>
    <span class=p>}</span>

    <span class=kn>location</span> <span class=p>~</span> <span class=sr>\.php$</span> <span class=p>{</span>
        <span class=kn>try_files</span> <span class=nv>$uri</span> <span class=p>=</span><span class=mi>404</span><span class=p>;</span>
        <span class=kn>fastcgi_pass</span> <span class=s>unix:/run/php-fpm/www.sock</span><span class=p>;</span>
        <span class=kn>fastcgi_index</span>   <span class=s>index.php</span><span class=p>;</span>
        <span class=kn>fastcgi_param</span> <span class=s>SCRIPT_FILENAME</span> <span class=nv>$document_root$fastcgi_script_name</span><span class=p>;</span>
        <span class=kn>include</span> <span class=s>fastcgi_params</span><span class=p>;</span>
    <span class=p>}</span>

    <span class=kn>location</span> <span class=p>~</span><span class=sr>*</span> <span class=s>\.(js|css|png|jpg|jpeg|gif|ico|svg)</span>$ <span class=p>{</span>
        <span class=kn>expires</span> <span class=s>max</span><span class=p>;</span>
        <span class=kn>log_not_found</span> <span class=no>off</span><span class=p>;</span>
    <span class=p>}</span>

<span class=p>}</span></code></pre></div><div class="my-6 bg-yellow-lightest border-l-4 border-yellow-light note p-6 text-yellow-darkest"><div class=flex><div class="w-full text-sm font-sans"><p>Don’t forget to replace example.com with your Wordpress domain and set the correct path to the SSL certificate files. The snippets used in this configuration are created in <a href=/post/secure-nginx-with-let-s-encrypt-on-centos-7/ >this guide</a> .</p></div></div></div><p>Before restarting the Nginx service test the configuration to be sure that there are no syntax errors:</p><div class=highlight><pre class=chroma><code class=language-console-bash data-lang=console-bash>sudo nginx -t</code></pre></div><p>If there are no errors the output should look like this:</p><div class=highlight><pre class=chroma><code class=language-output data-lang=output>nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
nginx: configuration file /etc/nginx/nginx.conf test is successful</code></pre></div><p>and we can restart Nginx by typing:</p><div class=highlight><pre class=chroma><code class=language-console-bash data-lang=console-bash>sudo systemctl restart nginx</code></pre></div><div class="w-full flex justify-center content-center"><div class="w-full relative"><ins class=adsbygoogle data-ad-client=ca-pub-9439755881064125 data-ad-format=fluid data-ad-slot=5120214995 style=display:block data-ad-layout=in-article></ins></div></div><h2 id=completing-the-wordpress-installation>Completing the WordPress Installation</h2><p>Now that Wordpress is downloaded and the server configuration is complete, you can finish the installation through the web interface.</p><p>Open your browser, type your domain and a screen similar to the following will appear:</p><figure class=relative><div class="w-full mx-auto my-0 block relative"><div class=block style=padding-bottom:66.66666666666667%></div><div class="w-full text-center absolute h-full m-auto overflow-hidden pin"><img alt="" class="" data-action=zoom src=/post/how-to-install-wordpress-with-nginx-on-centos-7/install-wordpress-language-selector.jpg></div></div></figure><p>Select the language you would like to use and click on the <code>Continue</code> button.</p><p>Next, you will see the following information page, click on the <code>Let's go!</code> button.</p><figure class=relative><div class="w-full mx-auto my-0 block relative"><div class=block style=padding-bottom:66.66666666666667%></div><div class="w-full text-center absolute h-full m-auto overflow-hidden pin"><img alt="" class="" data-action=zoom src=/post/how-to-install-wordpress-with-nginx-on-centos-7/install-wordpress-information.jpg></div></div></figure><p>On the next screen the setup wizard will ask you to enter your database connection details. Enter the MySQL user and database details you previously created.</p><figure class=relative><div class="w-full mx-auto my-0 block relative"><div class=block style=padding-bottom:66.66666666666667%></div><div class="w-full text-center absolute h-full m-auto overflow-hidden pin"><img alt="" class="" data-action=zoom src=/post/how-to-install-wordpress-with-nginx-on-centos-7/install-wordpress-database-information.jpg></div></div></figure><p>Start the WordPress installation by clicking on the <code>Run the Installation</code> button.</p><figure class=relative><div class="w-full mx-auto my-0 block relative"><div class=block style=padding-bottom:36.22222222222222%></div><div class="w-full text-center absolute h-full m-auto overflow-hidden pin"><img alt="" class="" data-action=zoom src=/post/how-to-install-wordpress-with-nginx-on-centos-7/install-wordpress-run-installation.jpg></div></div></figure><p>On the next step you’ll need to enter a name for your WordPress site and choose a username (for security purposes do not use “admin” ).</p><p>The installer will automatically generate a strong password for you. Do not forget to save this password. You can also set the password by yourself.</p><p>Enter your email address and select whether you want to discourage search engines from indexing the site (not recommended).</p><figure class=relative><div class="w-full mx-auto my-0 block relative"><div class=block style=padding-bottom:94.22222222222223%></div><div class="w-full text-center absolute h-full m-auto overflow-hidden pin"><img alt="" class="" data-action=zoom src=/post/how-to-install-wordpress-with-nginx-on-centos-7/install-wordpress-welcome.jpg></div></div></figure><p>Click <code>Install WordPress</code> and once the installation is completed you will be taken to a page informing you that WordPress has been installed.</p><p>To access your WordPress login page click on the <code>Log in</code> button.</p><figure class=relative><div class="w-full mx-auto my-0 block relative"><div class=block style=padding-bottom:52.888888888888886%></div><div class="w-full text-center absolute h-full m-auto overflow-hidden pin"><img alt="" class="" data-action=zoom src=/post/how-to-install-wordpress-with-nginx-on-centos-7/install-wordpress-completed.jpg></div></div></figure><p>Enter your username and password.</p><figure class=relative><div class="w-full mx-auto my-0 block relative"><div class=block style=padding-bottom:57.77777777777778%></div><div class="w-full text-center absolute h-full m-auto overflow-hidden pin"><img alt="" class="" data-action=zoom src=/post/how-to-install-wordpress-with-nginx-on-centos-7/wordpress-login-form.jpg></div></div></figure><p>You will be redirected to the WordPress administration dashboard.</p><figure class=relative><div class="w-full mx-auto my-0 block relative"><div class=block style=padding-bottom:71.60262417994377%></div><div class="w-full text-center absolute h-full m-auto overflow-hidden pin"><img alt="" class="" data-action=zoom src=/post/how-to-install-wordpress-with-nginx-on-centos-7/wordpress-dashboard.jpg></div></div></figure><p>From here your can start customizing your WordPress installation by installing new themes and plugins.</p><h2 id=conclusion>Conclusion</h2><p>Congratulations, you have successfully installed WordPress with Nginx on your CentOS 7 server. <a href=https://codex.wordpress.org/Getting_Started_with_WordPress>First Steps With WordPress</a> is a good starting place to learn more about how to make your new WordPress site your own.</p><p>If you have questions feel free to leave a comment below.</p><div class="flex flex-wrap my-6"><a href=/tags/centos class="font-medium text-sm bg-indigo-dark hover:bg-indigo-darker mr-2 mt-2 px-4 py-2 rounded text-white tracking-wide">centos</a> <a href=/tags/wordpress class="font-medium text-sm bg-indigo-dark hover:bg-indigo-darker mr-2 mt-2 px-4 py-2 rounded text-white tracking-wide">wordpress</a> <a href=/tags/mysql class="font-medium text-sm bg-indigo-dark hover:bg-indigo-darker mr-2 mt-2 px-4 py-2 rounded text-white tracking-wide">mysql</a> <a href=/tags/mariadb class="font-medium text-sm bg-indigo-dark hover:bg-indigo-darker mr-2 mt-2 px-4 py-2 rounded text-white tracking-wide">mariadb</a> <a href=/tags/cms class="font-medium text-sm bg-indigo-dark hover:bg-indigo-darker mr-2 mt-2 px-4 py-2 rounded text-white tracking-wide">cms</a> <a href=/tags/nginx class="font-medium text-sm bg-indigo-dark hover:bg-indigo-darker mr-2 mt-2 px-4 py-2 rounded text-white tracking-wide">nginx</a></div></div></section></div></div></div></div><div class="w-full absolute -mb-16 flex-grow hidden lg:-mb-0 lg:block lg:pt-0 lg:static top-16 z-90" id=sidebar><div class=sideblock><div class="w-full flex justify-center content-center"><div class="w-full relative"><ins class="hidden adsbygoogle mx-auto lg:block" data-ad-client=ca-pub-9439755881064125 data-ad-format=auto data-ad-slot=9558702194 style=display:block data-full-width-responsive=true></ins></div></div></div><div class="bg-grey-lighter p-4 pb-2 my-6 related-content"><p class="font-medium mb-3 mb-3 text-xs tracking-tight uppercase xxl:text-sm text-grey-darker">Related Tutorials</p><ul class="border-grey-light border-t list-reset mb-0 mt-4 pt-3"><li class="flex mb-2 border-b border-grey-light pb-2"><a href=https://linuxize.com/post/how-to-install-wordpress-with-nginx-on-ubuntu-18-04/ class="font-medium text-sm hover:text-grey-darkest text-grey-dark truncate">How to install WordPress with Nginx on Ubuntu 18.04</a></li><li class="flex mb-2 border-b border-grey-light pb-2"><a href=https://linuxize.com/post/how-to-install-phpmyadmin-with-nginx-on-centos-7/ class="font-medium text-sm hover:text-grey-darkest text-grey-dark truncate">How to Install phpMyAdmin with Nginx on CentOS 7</a></li><li class="flex mb-2 border-b border-grey-light pb-2"><a href=https://linuxize.com/post/how-to-install-drupal-on-ubuntu-18-04/ class="font-medium text-sm hover:text-grey-darkest text-grey-dark truncate">How to install Drupal on Ubuntu 18.04</a></li><li class="flex mb-2 border-b border-grey-light pb-2"><a href=https://linuxize.com/post/how-to-install-phpmyadmin-with-nginx-on-ubuntu-18-04/ class="font-medium text-sm hover:text-grey-darkest text-grey-dark truncate">How to Install phpMyAdmin with Nginx on Ubuntu 18.04</a></li><li class="flex mb-2 border-b border-grey-light pb-2"><a href=https://linuxize.com/post/how-to-install-and-secure-phpmyadmin-with-apache-on-centos-7/ class="font-medium text-sm hover:text-grey-darkest text-grey-dark truncate">How to Install and Secure phpMyAdmin with Apache on CentOS 7</a></li><li class="flex mb-2 border-b border-grey-light pb-2"><a href=https://linuxize.com/post/install-mariadb-on-centos-7/ class="font-medium text-sm hover:text-grey-darkest text-grey-dark truncate">Install MariaDB on CentOS 7</a></li><li class="flex mb-2 border-b border-grey-light pb-2"><a href=https://linuxize.com/post/how-to-install-and-secure-phpmyadmin-with-apache-on-debian-9/ class="font-medium text-sm hover:text-grey-darkest text-grey-dark truncate">How to Install and Secure phpMyAdmin with Apache on Debian 9</a></li><li class="flex mb-2 border-b border-grey-light pb-2"><a href=https://linuxize.com/post/how-to-create-mysql-user-accounts-and-grant-privileges/ class="font-medium text-sm hover:text-grey-darkest text-grey-dark truncate">How to Create MySQL Users Accounts and Grant Privileges</a></li><li class="flex mb-2 border-b border-grey-light pb-2"><a href=https://linuxize.com/post/how-to-set-up-nginx-server-blocks-on-centos-7/ class="font-medium text-sm hover:text-grey-darkest text-grey-dark truncate">How To Set Up Nginx Server Blocks on CentOS 7</a></li><li class="flex mb-2 border-b border-grey-light pb-2"><a href=https://linuxize.com/post/how-to-install-mariadb-on-debian-9/ class="font-medium text-sm hover:text-grey-darkest text-grey-dark truncate">How to Install MariaDB on Debian 9</a></li></ul></div><div class="flex flex-col -mt-12 lg:block lg:relative lg:sticky lg:top-16 pt-12"><div class=sideblock><div class="hidden affiliate"><a href="https://www.vultr.com/?ref=7602414" class=vultr rel=noopener target=_blank></a> <a href="https://shareasale.com/r.cfm?b=1133389&u=1755182&m=75038&urllink=&afftrack=" class="cloudways mt-8" rel=noopener target=_blank></a></div><div class="w-full flex justify-center content-center"><div class="w-full relative"><ins class="adsbygoogle mx-auto" data-ad-client=ca-pub-9439755881064125 data-ad-format=auto data-ad-slot=7027266996 style=display:block data-full-width-responsive=true></ins></div></div></div></div></div></div></div></article><section class="w-full mx-auto border-grey-lighter border-t mt-8 pt-8 max-w-article"><div class="bg-grey-lighter p-8 sm:py-8"><p class="lg:text-2xl max-w-md mx-auto my-0 sm:text-xl text-center text-lg">Sign up to our newsletter and get our latest tutorials and news straight to your mailbox.</p><form action="https://linuxize.us17.list-manage.com/subscribe/post?u=35cd4cd9d021c25c3dd7cabfd&id=9cfa4c89de" class=pt-8 id=mc-embedded-subscribe-form method=post name=mc-embedded-subscribe-form novalidate><div class="w-full mx-auto flex items-center flex-col justify-between max-w-sm mb-2 sm:flex-row"><input class="w-full bg-white block appearance-none border hover:border-grey-dark mb-3 px-4 py-3 rounded sm:mb-0 text-grey-darker" name=EMAIL aria-label=email placeholder="Your email..." type=email> <input class=hidden name=b_35cd4cd9d021c25c3dd7cabfd_9cfa4c89de tabindex=-1> <button class="w-full text-white bg-indigo-dark hover:bg-indigo-darker px-4 py-3 rounded sm:ml-4 sm:w-auto tracking-wide" name=subscribe type=submit><span class=text-center>Subscribe</span></button></div><p class="w-full mx-auto my-0 max-w-sm text-sm">We’ll never share your email address or spam you.</p></form></div></section><section class="w-full mx-auto border-grey-lighter border-t mt-8 pt-8 max-w-xl"><div class="flex flex-wrap -mx-4"><div class="w-full flex justify-center content-center"><div class="w-full relative"><ins class=adsbygoogle data-ad-client=ca-pub-9439755881064125 data-ad-format=autorelaxed data-ad-slot=8589924088 style=display:block></ins></div></div></div></section><section class="w-full mx-auto relative border-grey-lighter border-t max-w-lg mt-8 pt-16 py-8"><a href=https://linuxize.com/post/how-to-install-wordpress-with-nginx-on-centos-7/#disqus_thread class="w-full text-center bg-grey-lighter block disqus-comment-count disqus-load md:py-8 py-4" title="Show comments for post">Write a comment</a><div id=disqus_thread></div><noscript>Please enable JavaScript to view the <a href=https://disqus.com/?ref_noscript>comments powered by Disqus.</a></noscript></section></main><section class="w-full absolute pin bg-white block h-screen invisible search z-50" hidden id=search-box><div class="flex flex-col min-h-screen"><header class="w-full mx-auto flex items-center h-12 sm:h-16 justify-end px-6 z-10"><a href=# class="block h-6 sm:h-8" id=btn-search-close><svg aria-hidden=true class="h-6 w-6 fill-current inline-block text-grey-darkest sm:h-8 sm:w-8 -mb-2"><use xlink:href=#close></use><title>Close search form</title></svg> <small class="block text-center sm:w-8 w-6">ESC</small></a></header><div class="w-full px-6 flex-grow flex-no-shrink pb-8 pt-16 sm:pt-24"><div class="flex flex-col mx-auto max-w-xl mb-4 mb-8"><input class="w-full appearance-none bg-transparent focus:outline-0 font-medium md:text-3xl placeholder-grey-dark search-input sm:text-2xl text-grey-darkest text-xl" placeholder="Type to search" autocomplete=off id=search-input><div class=search-results id=search-results></div><div id=hits></div><div id=stats></div><footer class=mt-6><a href=https://algolia.com rel="noopener noreferrer" target=_blank tabindex=-1><svg aria-hidden=true class="inline-block fill-current search-algolia-logo text-grey-dark"><use xlink:href=#search-by-algolia></use><title>Search by Algolia</title></svg></a></footer></div></div></div></section><footer class="w-full px-6 bg-grey-lightest"><div class="w-full mx-auto flex items-center flex-wrap justify-center max-w-xl md:justify-between md:text-left py-8 text-center"><div class="w-full text-sm mb-2 md:mb-0 md:w-1/2"><div class="w-full md:flex block md:items-center md:w-auto"><div class=md:flex-grow><span class="block text-grey-darker mb-2 md:inline-block md:mb-0 md:mr-8">© 2018 Linuxize.com</span> <a href=/privacy-policy/ class="inline-block text-grey-darkest footer-menu-item hover:text-grey-darker md:mt-0 no-underline mr-4">Privacy Policy </a><a href=/contact/ class="inline-block text-grey-darkest footer-menu-item hover:text-grey-darker md:mt-0 no-underline mr-0">Contact</a></div></div></div><div class="w-full flex justify-center md:justify-end md:w-1/2"><a href=https://twitter.com/linuxize class="block h-6 mr-2" aria-label=Twitter><svg aria-hidden=true class="h-6 w-6 fill-current inline-block text-grey-darkest"><use xlink:href=#twitter></use><title>Twitter</title></svg> </a><a href=https://www.facebook.com/linuxize/ class="block h-6 mr-2" aria-label=Facebook><svg aria-hidden=true class="h-6 w-6 fill-current inline-block text-grey-darkest"><use xlink:href=#facebook></use><title>Facebook</title></svg> </a><a href=/index.xml class="block h-6" aria-label=RSS><svg aria-hidden=true class="h-6 w-6 fill-current inline-block text-grey-darkest"><use xlink:href=#rss></use><title>RSS</title></svg></a></div></div></footer></div><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script src=https://cdnjs.cloudflare.com/ajax/libs/instantsearch.js/2.7.4/instantsearch.min.js></script><script src=/js/1.0779b5aaf9cf6f3138ca.js></script><script src=/js/app.b7053e1607f74b413ca7.js></script></body></html>